[Support] binhex - Sonarr


Recommended Posts

I moved to v3 recently - I'm finding Sonarr is having issues with the Wanted | Manual Import feature.  Can't see anything in the debug logs that would indicate a problem.

 

Sonarr is able to import files from the same location via its normal download processing (so I'm quite sure this isn't a permissions issue), it's just the Manual Import function that seems to be broken.  Anyone else able to confirm this?

 

Never mind, I think Sonarr was just busy with other background tasks.

Edited by ConnectivIT
Link to comment
21 hours ago, yanksno1 said:

It's Queued, but not seeding anymore. Looking at the logs, don't see any obvious errors. Anything I should look for? Here's the Permissions I have "set", which I just left default. Your help is much appreciated.  

 

1077478868_ScreenShot2021-01-10at19_45_17PM.thumb.png.9d01e580f22c7e737a038590e8ae5497.png

I forgot to ask also - are you using the 'label' plugin? And what is your label in Sonarr in your Indexer settings?

Link to comment
25 minutes ago, Rick_Sanchez said:

I forgot to ask also - are you using the 'label' plugin? And what is your label in Sonarr in your Indexer settings?

Yup, as shown there. In deluge on the torrents the Label is "tv-sonarr", so that's working correctly I think. Looked in the Indexer settings and didn't see anywhere to specify them. Anything else I should try? 

Screen Shot 2021-01-12 at 7.31.35 PM.png

Link to comment
  • 3 weeks later...
  • 2 weeks later...
On 1/30/2021 at 11:50 PM, yanksno1 said:

Further observation: It does seem like Sonarr or Deluge (don't know who) deletes the lower profile version if a new one downloads for the higher profile one. So obviously something's working right there. 

Interesting - any changes? Are the higher profile getting deleted or is it still persisting in Deluge?

Link to comment

Hi everyone!

 

I'm getting this error in Sonarr when selecting a specific episode to download:
1053140711_Schermafbeelding2021-02-19om12_51_13.png.2f45274c724b694d9a4d969b8785b610.png

 

BlacklistSpecification: Operations that change non-concurrent collections must have exclusive access. A concurrent update was performed on this collection and corrupted its state. The collection's state is no longer correct.

 

Thanks!

Link to comment
1 hour ago, JNCK said:

Hi everyone!

 

I'm getting this error in Sonarr when selecting a specific episode to download:
1053140711_Schermafbeelding2021-02-19om12_51_13.png.2f45274c724b694d9a4d969b8785b610.png

 


BlacklistSpecification: Operations that change non-concurrent collections must have exclusive access. A concurrent update was performed on this collection and corrupted its state. The collection's state is no longer correct.

 

Thanks!

https://www.google.com/search?q=BlacklistSpecification%3A+Operations+that+change+non-concurrent+collections

Link to comment

Hey peeps,

 

I am having some issues with permissions in sonarr, I have been having general issues with SMB and not giving me access even when I have windows credentials set as a user defined in unraid.

 

My quick fix was to set sonarr to change the file/folder permissions to 776 so that even a public user should be able to access the files.

857471803_Sonarrpermissions.png.186ad4dab4e92a4eb042fa285ace1328.png

 

My issue is that it sets the file permissions correctly when importing but the folder does not get set correctly, it carries over the folder permissions that I guess deluge had set which is drwxrwx--- but it also then sets each higher level folder to the same, ie. the show folder as well as the root TV Shows folder which then gives me the "You do not have permission to access....." error due to the SMB issue when trying to get into my top level TV Shows folder.

1075429674_permissionsissue.png.7501a4df0daad26d1fbefe3cbdfa758d.png

 

Also, yes I am using Sonarr V3.

Does anyone know of a reason why Sonarr is not setting the folder permission correctly?

 

I would appreciate any help with this.

Link to comment

Last night I updated my dockers.  I'm not really sure what caused the issue but all indexers in sonarr and radarr were failed this morning.  Deluge-VPN appears to be working ok.  After some troubleshooting I disabled the proxy on sonarr to stop routing searches through privoxy and now all my indexers work again.  Any idea what happened to privoxy working?

Link to comment
44 minutes ago, Gragorg said:

Last night I updated my dockers.  I'm not really sure what caused the issue but all indexers in sonarr and radarr were failed this morning.  Deluge-VPN appears to be working ok.  After some troubleshooting I disabled the proxy on sonarr to stop routing searches through privoxy and now all my indexers work again.  Any idea what happened to privoxy working?

@binhex pushed an update to his delugevpn docker which created problems for some people. If you are using a bridge network you can probably fix this issue by setting the docker IP for your proxy settings-

https://forums.unraid.net/topic/75539-support-binhex-qbittorrentvpn/?do=findComment&comment=952116

You will probably need to repeat this change with any indexers using the proxy too.

  • Thanks 1
Link to comment
1 hour ago, wgstarks said:

@binhex pushed an update to his delugevpn docker which created problems for some people. If you are using a bridge network you can probably fix this issue by setting the docker IP for your proxy settings-

https://forums.unraid.net/topic/75539-support-binhex-qbittorrentvpn/?do=findComment&comment=952116

You will probably need to repeat this change with any indexers using the proxy too.

I have been investigating this further, a better solution ive come up with (in my opinion) is to set a bypass for local networks, see Q26:- https://github.com/binhex/documentation/blob/master/docker/faq/vpn.md

Link to comment
1 minute ago, wgstarks said:

I have always used Jackett so didn’t run into that issue but I may go ahead and set the ignore anyway.

if you have always only used jackett as your index site (no other index sites defined) then there is no requirement for a proxy for sonarr etc though, right?

Link to comment

I have always used jackett and prior to today, I never had a bypass set up. But now, as has been posted, jackett, radarr, and sonarr are now failing. Is this a permanent change that I will need to fix, or is this an error that will be fixed in a future update?

Link to comment

I followed the instructions on Q24 and Q25 in the FAQ, and I am still not able to successfully test any of the indexers. I am working on this one docker at a time, starting with jackett. I have added all the necessary ports in delugevpn, and listed all the ports needed in additional ports, separated by a comma, restarted the container. I am able to pull up the DelugeVPN webui. I then change the network type back to "none" for jackett, add the extra parameter as instructed, "--net=container:binhex-delugevpn". The web interface loads for jackett when I use local IP:9117, and all indexers fail testing. What am I missing?

 

EDIT:

After looking at a few other comments, I removed all settings for proxy in jackett, and now it is passing tests on all indexers. I will move on to sonarr from here.

Edited by Pks6601
ack
Link to comment
1 hour ago, binhex said:

if you have always only used jackett as your index site (no other index sites defined) then there is no requirement for a proxy for sonarr etc though, right?

Sonarr/Radarr probably don’t need the proxy (I really haven’t investigated this) but I had it set anyway so I had also updated those settings. Just because they are there more than anything else. And my own ignorance of course.😁

Link to comment
16 minutes ago, Pks6601 said:

I followed the instructions on Q24 and Q25 in the FAQ, and I am still not able to successfully test any of the indexers. I am working on this one docker at a time, starting with jackett. I have added all the necessary ports in delugevpn, and listed all the ports needed in additional ports, separated by a comma, restarted the container. I am able to pull up the DelugeVPN webui. I then change the network type back to "none" for jackett, add the extra parameter as instructed, "--net=container:binhex-delugevpn". The web interface loads for jackett when I use local IP:9117, and all indexers fail testing. What am I missing?

Just to be sure, did you also read Q26? If you are only using the proxy server (and not creating a separate vpn network) then some of these changes aren’t needed.

Edited by wgstarks
  • Like 1
Link to comment

I am using a separate vpn, PIA using WireGuard, and using privoxy to route my jackett, sonarr, and radarr containers through. Jackett is passing all tests now, but I am still failing at sonarr. I have made changes to the proxy settings in sonarr, but the tests are all still failing.

Screenshot 2021-02-26 122212.png

 

EDIT:

I read through Q26. Since I am routing the containers through delugevpn, I tried to remove the proxy setting completely and it is failing as well. I am having terrible luck with this and am beginning to suspect I am missing something really simple.

Edited by Pks6601
Tried another recommendation
Link to comment
12 minutes ago, wgstarks said:

Did you also edit the Jackett IP in all your indexers in Sonarr? I know I missed those on my first try.

 

Just a guess.

The jackett IP didn't change. Can you tell me what you are referring to? Did you change the indexer settings to localhost or something else?

This is what they are now:

 

Screenshot 2021-02-26 124149.png

 

EDIT:

After thinking about what I typed, I went into the indexer and changed the URL from http://192.168.1.10:9117/... to http://localhost:9117/... and the indexers started passing tests. I was then able to follow the same process on the downloader and it passed. It appears that I now have sonarr fixed and I will be moving to radarr. Thanks for the assistance! I will update this if I have issues, or one final time to indicate success.

Edited by Pks6601
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.