[Support] binhex - Sonarr


Recommended Posts

15 hours ago, jortan said:

 

Settings | Profiles | Release Profiles.

 

"Must not contain"

 

A blank "tags" field will make it apply to all series.

Thanks very much for this ..... I have added it to my Sonar.

 

Cheers

toolmanz

Link to comment

Looks like my Sonarr updated last night and now can't connect to any indexers, but Radarr seems fine. Anyone seen this?

 

21-4-6 08:27:54.6|Error|X509CertificateValidationService|Certificate validation for https://*REMOVED* failed. RemoteCertificateChainErrors

 

Link to comment
20 hours ago, flyize said:

Looks like my Sonarr updated last night and now can't connect to any indexers, but Radarr seems fine. Anyone seen this?

 


21-4-6 08:27:54.6|Error|X509CertificateValidationService|Certificate validation for https://*REMOVED* failed. RemoteCertificateChainErrors

 

 

Same issue here. Just updated and no longer can connect to deluge or jackett. Testing deluge in sonarr kicks back an error on the top of the test page that says Unknown exception: The operation has timed out.: 'http://192.168.1.69:8112/json'

Link to comment

@binhex any idea on the above issue? Here is what the log says:

 

[v3.0.6.1196] System.Net.WebException: The operation has timed out.: 'http://192.168.1.69:8112/json' ---> System.Net.WebException: The operation has timed out. at System.Net.HttpWebRequest.RunWithTimeoutWorker[T] (System.Threading.Tasks.Task`1[TResult] workerTask, System.Int32 timeout, System.Action abort, System.Func`1[TResult] aborted, System.Threading.CancellationTokenSource cts) [0x000e8] in /build/mono/src/mono/mcs/class/System/System.Net/HttpWebRequest.cs:956 at System.Net.HttpWebRequest.GetResponse () [0x0000f] in /build/mono/src/mono/mcs/class/System/System.Net/HttpWebRequest.cs:1218 at NzbDrone.Common.Http.Dispatchers.ManagedHttpDispatcher.GetResponse (NzbDrone.Common.Http.HttpRequest request, System.Net.CookieContainer cookies) [0x00123] in M:\BuildAgent\work\63739567f01dbcc2\src\NzbDrone.Common\Http\Dispatchers\ManagedHttpDispatcher.cs:81 --- End of inner exception stack trace --- at NzbDrone.Common.Http.Dispatchers.ManagedHttpDispatcher.GetResponse (NzbDrone.Common.Http.HttpRequest request, System.Net.CookieContainer cookies) [0x001bb] in M:\BuildAgent\work\63739567f01dbcc2\src\NzbDrone.Common\Http\Dispatchers\ManagedHttpDispatcher.cs:107 at NzbDrone.Common.Http.HttpClient.ExecuteRequest (NzbDrone.Common.Http.HttpRequest request, System.Net.CookieContainer cookieContainer) [0x00086] in M:\BuildAgent\work\63739567f01dbcc2\src\NzbDrone.Common\Http\HttpClient.cs:126 at NzbDrone.Common.Http.HttpClient.Execute (NzbDrone.Common.Http.HttpRequest request) [0x00008] in M:\BuildAgent\work\63739567f01dbcc2\src\NzbDrone.Common\Http\HttpClient.cs:59 at NzbDrone.Core.Download.Clients.Deluge.DelugeProxy.AuthenticateClient (NzbDrone.Common.Http.JsonRpcRequestBuilder requestBuilder, NzbDrone.Core.Download.Clients.Deluge.DelugeSettings settings, System.Boolean reauthenticate) [0x0005b] in M:\BuildAgent\work\63739567f01dbcc2\src\NzbDrone.Core\Download\Clients\Deluge\DelugeProxy.cs:295 at NzbDrone.Core.Download.Clients.Deluge.DelugeProxy.BuildRequest (NzbDrone.Core.Download.Clients.Deluge.DelugeSettings settings) [0x0006d] in M:\BuildAgent\work\63739567f01dbcc2\src\NzbDrone.Core\Download\Clients\Deluge\DelugeProxy.cs:203 at NzbDrone.Core.Download.Clients.Deluge.DelugeProxy.ProcessRequest[TResult] (NzbDrone.Core.Download.Clients.Deluge.DelugeSettings settings, System.String method, System.Object[] arguments) [0x00000] in M:\BuildAgent\work\63739567f01dbcc2\src\NzbDrone.Core\Download\Clients\Deluge\DelugeProxy.cs:210 at NzbDrone.Core.Download.Clients.Deluge.DelugeProxy.GetVersion (NzbDrone.Core.Download.Clients.Deluge.DelugeSettings settings) [0x00000] in M:\BuildAgent\work\63739567f01dbcc2\src\NzbDrone.Core\Download\Clients\Deluge\DelugeProxy.cs:53 at NzbDrone.Core.Download.Clients.Deluge.Deluge.TestConnection () [0x00000] in M:\BuildAgent\work\63739567f01dbcc2\src\NzbDrone.Core\Download\Clients\Deluge\Deluge.cs:228 21-4-8 17:56:38.3|Warn|SonarrErrorPipeline|Invalid request Validation failed: -- : Unknown exception: The operation has timed out.: 'http://192.168.1.69:8112/json'

Link to comment
  • 2 weeks later...

Pretty bad when my server has epic fail right in the log file. Where can i find my database so i can try to recover it?

 

output:
[Error] MigrationLogger: System.Data.SQLite.SQLiteException (0x80004005): database disk image is malformed
2021-04-19 01:35:16,590 DEBG 'sonarr' stdout output:

 

2021-04-19 01:35:16,612 DEBG 'sonarr' stdout output:
[Fatal] ConsoleApp: EPIC FAIL!

[v3.0.6.1196] NzbDrone.Core.Datastore.CorruptDatabaseException:

Edited by sentein
Link to comment

So V2 was configured correctly for me.  I ended up deleting it as I didn't care to preserve anything, and it was spinning up my disks needlessly (I actually left it off so long that it stopped working ultimately, so that's why I deleted it).

 

However, what's happening now is that whenever I try to add a show I get an "Invalid Path" error.  This didn't happen with V2, and I think it's an issue with the container paths.

 

369168134_Screenshot2021-04-20135730.png.936aaa516d2c5bcaf69c7ad876e554b9.png

 

I assume the issue is with the /data path.  Is this where it downloads files, or is it where it searches for existing media?  I assumed this was the /media path.

 

What am I doing wrong?

 

Thanks!

Edited by aidenpryde
Link to comment
20 hours ago, aidenpryde said:

So V2 was configured correctly for me.  I ended up deleting it as I didn't care to preserve anything, and it was spinning up my disks needlessly (I actually left it off so long that it stopped working ultimately, so that's why I deleted it).

 

However, what's happening now is that whenever I try to add a show I get an "Invalid Path" error.  This didn't happen with V2, and I think it's an issue with the container paths.

 

369168134_Screenshot2021-04-20135730.png.936aaa516d2c5bcaf69c7ad876e554b9.png

 

I assume the issue is with the /data path.  Is this where it downloads files, or is it where it searches for existing media?  I assumed this was the /media path.

 

What am I doing wrong?

 

Thanks!

Yes, /data is where Sonarr handles the downloaded files from your download client. This path should ideally be the same in your download client container. /media is where your existing media is located.

 

I just created a share called "downloads" to handle all my downloads from both qBit and sabNZBd. So my Host Path 2 is /mnt/user/downloads/ (same in binhex-qbittorrentvpn and binhex-sabnzbd).

Link to comment
On 3/2/2021 at 2:26 PM, binhex said:

So I'm back again. :) Gave up on the issue back in march but now I'm trying to solve it again. I've read through the Github issue thread, but I can't find VPN_OUTPUT_PORTS in the binhex-qbittorrentvpn container? Its on :latest and updated. I've also read your VPN Docker FAQ on Github but having problem seeing my solution.

 

EDIT Sorry pressed send too early. 

I tried to add the PMS port 32400 to ADDITIONAL_PORTS also but with no luck. I'm not confident at all here so bare with me. My situation is that my PMS isn't on my unRAID machine, ie it has a different IP then my unRAID. My knowledge in networking is rather slim so maybe I'm missing something obvious here?

 

IP for unRAID server: 192.168.1.4

binhex-qbittorrentvpn working (Container Variable: LAN_NETWORK 192.168.1.0/24)

binhex-sonarr working over --net=container:binhex-qbittorrentvpn

Plex Media Server on my iMac. IP:192.168.1.7 Port:32400

 

Edited by kim_sv
pressed send too early
Link to comment

HI

I have errors with the :latest tag. Works fine with 3.0.6.1196-1-01
Any ideas ?

2021-04-23 09:36:24,179 DEBG fd 8 closed, stopped monitoring <POutputDispatcher at 23245932586512 for <Subprocess at 23245932587280 with name sonarr in state STARTING> (stdout)>
2021-04-23 09:36:24,179 DEBG fd 10 closed, stopped monitoring <POutputDispatcher at 23245932747264 for <Subprocess at 23245932587280 with name sonarr in state STARTING> (stderr)>
2021-04-23 09:36:24,180 INFO exited: sonarr (exit status 2; not expected)
2021-04-23 09:36:24,180 DEBG received SIGCHLD indicating a child quit
2021-04-23 09:36:27,185 INFO spawned: 'sonarr' with pid 76
2021-04-23 09:36:27,206 DEBG 'sonarr' stderr output:
Cannot open assembly '/usr/lib/sonarr/NzbDrone.exe': No such file or directory.

2021-04-23 09:36:27,214 DEBG fd 8 closed, stopped monitoring <POutputDispatcher at 23245932586992 for <Subprocess at 23245932587280 with name sonarr in state STARTING> (stdout)>
2021-04-23 09:36:27,214 DEBG fd 10 closed, stopped monitoring <POutputDispatcher at 23245932150208 for <Subprocess at 23245932587280 with name sonarr in state STARTING> (stderr)>
2021-04-23 09:36:27,215 INFO exited: sonarr (exit status 2; not expected)
2021-04-23 09:36:27,215 DEBG received SIGCHLD indicating a child quit
2021-04-23 09:36:28,217 INFO gave up: sonarr entered FATAL state, too many start retries too quickly

 

Link to comment
43 minutes ago, deadnote said:

HI

I have errors with the :latest tag. Works fine with 3.0.6.1196-1-01

you cannot be running latest, as i am running latest myself with no issue, please go to unraid web ui/docker tag, toggle 'advanced view' on and then click on 'force update' for the sonarr container, this will force a pull down of latest.

Link to comment
55 minutes ago, deadnote said:

Thanks for your quick answer.
I have another problem : Read-only file system

I ordered a new usb stick, I will try to force update with the new usb key

 

read-only filesystem is often just caused by an unclean shutdown.  If you shutdown your server and put the USB stick in a Windows machine it should offer to repair the filesystem.

 

edit: backup the unraid files before you do a repair

Edited by jortan
Link to comment

I feel like I'm missing something basic.  New to Unraid and Docker, but not SABNzb and Sonarr (used them on Windows machines previously).  Sonarr is not seeing/copying/moving downloaded files.  Help please?  Thanks in advance!

 

Container basics:

image.thumb.png.7ae53e76761e0549fca54215639678cc.png

 

Sonarr config

image.thumb.png.12d0e362a1ed90729228caf4597fe88c.png

 

SABNzb config

image.png.48d904c80ce5bf53f5a953d12022f707.png

Link to comment
On 4/27/2021 at 7:57 PM, Graber said:

I feel like I'm missing something basic.  New to Unraid and Docker, but not SABNzb and Sonarr (used them on Windows machines previously).  Sonarr is not seeing/copying/moving downloaded files.  Help please?  Thanks in advance!

 

Container basics:

image.thumb.png.7ae53e76761e0549fca54215639678cc.png

 

Sonarr config

image.thumb.png.12d0e362a1ed90729228caf4597fe88c.png

 

SABNzb config

image.png.48d904c80ce5bf53f5a953d12022f707.png

I would first create a separate share for Downloads (with "complete" and "incomplete" folders) and then map /data to that share (/Downloads) on both SABnzbds and Sonarrs containers. Right now your downloads will go into you appdata folder. 

Then you point /media in Sonarr to the folder on unRAID where you have your TV shows.

 

Regarding your Sonarr config I don't use Remote Path Mappings so I can't give you answers there. But I don't think that is needed if you configure the rest correct? 

 

Link to comment

Hello, I have an issue with my sonarr installation. 

It finds and downloads my episodes just fine, but it never move the files to the correct folder, I took a printscreen of something I think looked wrong , the file path it's looking for the files in don't makes sense to me, any suggestions ? 

 

Plex.jpg

Link to comment
  • 2 weeks later...

I have been using Sonarr for a while and has been working great. The other day I was unable to login to the WebUI. it displays this message

"Hmmm… can't reach this page

xxx.xxx.x.xxx refused to connect.

Try:

Checking the connection

Checking the proxy and the firewall

ERR_CONNECTION_REFUSED"

 

I've tried reinstalling docker, it's fully updated, I've tried changing port numbers, tried from multiple computers\browsers. Also my other dockers are working including SAB,Plex,Radarr, Krusader.

 

Any ideas of what else to look at to fix this?

 

 

Link to comment
1 hour ago, Bill leeder said:

I have been using Sonarr for a while and has been working great. The other day I was unable to login to the WebUI. it displays this message

"Hmmm… can't reach this page

xxx.xxx.x.xxx refused to connect.

Try:

Checking the connection

Checking the proxy and the firewall

ERR_CONNECTION_REFUSED"

 

I've tried reinstalling docker, it's fully updated, I've tried changing port numbers, tried from multiple computers\browsers. Also my other dockers are working including SAB,Plex,Radarr, Krusader.

 

Any ideas of what else to look at to fix this?

 

 

check the log file, attach /config/supervisord.log

Link to comment

Here is the log you mentioned as well as the Sonarr log 

 

 

 

 

I have been using Sonarr for a while and has been working great. The other day I was unable to login to the WebUI. it displays this message

"Hmmm… can't reach this page

xxx.xxx.x.xxx refused to connect.

Try:

Checking the connection

Checking the proxy and the firewall

ERR_CONNECTION_REFUSED"

 

I've tried reinstalling docker, it's fully updated, I've tried changing port numbers, tried from multiple computers\browsers. Also my other dockers are working including SAB,Plex,Radarr, Krusader.

 

Any ideas of what else to look at to fix this?

 

 

Bill Leeder Sonarr log.txt supervisord.log

Link to comment
10 minutes ago, Bill leeder said:

Here is the log you mentioned as well as the Sonarr log 

 

 

 

 

I have been using Sonarr for a while and has been working great. The other day I was unable to login to the WebUI. it displays this message

"Hmmm… can't reach this page

xxx.xxx.x.xxx refused to connect.

Try:

Checking the connection

Checking the proxy and the firewall

ERR_CONNECTION_REFUSED"

 

I've tried reinstalling docker, it's fully updated, I've tried changing port numbers, tried from multiple computers\browsers. Also my other dockers are working including SAB,Plex,Radarr, Krusader.

 

Any ideas of what else to look at to fix this?

 

 

Bill Leeder Sonarr log.txt 83.05 kB · 0 downloads supervisord.log 5.24 MB · 0 downloads

the attached supervisord.log file is for krusader not sonarr.

Link to comment
On 4/28/2021 at 7:23 PM, kim_sv said:

I would first create a separate share for Downloads (with "complete" and "incomplete" folders) and then map /data to that share (/Downloads) on both SABnzbds and Sonarrs containers. Right now your downloads will go into you appdata folder. 

Then you point /media in Sonarr to the folder on unRAID where you have your TV shows.

 

Regarding your Sonarr config I don't use Remote Path Mappings so I can't give you answers there. But I don't think that is needed if you configure the rest correct? 

 

That did the trick!  Thanks.

Link to comment
14 hours ago, Bill leeder said:

crap...sorry here is the sonarr one

supervisord.log.1 10 MB · 0 downloads

as i suspected, you have a corrupt database, from your log:-

database disk image is malformed

 

you need to restore your configuration using 'Appdata Backup/Restore v2' plugin (if you dont have this installed then i highly recommend it), if you dont have a backup of your appdata then your only course of action is to delete the existing corrupt db and let it re-create a blank one, then reconfigure, to delete the db do the following:-

 

1. stop container

2. delete files /config/logs*

3. delete files /config/sonarr*

4. start container and reconfigure.

Link to comment
1 hour ago, antonio3427 said:

I am having issues with a number of dockers showing refused to connect:

 

image.thumb.png.f546f47055c3eaac81d29b496ed7d505.png

 

Below are the dockers I have so far:

image.thumb.png.e004d941f88dc99d05dcce665b9c6f86.png

 

Plex, NZBgetm and radarr have no issues. 

 

Lidarr and Sonarr refuse to connect 

 

I am running a bond interface:

image.png.f64c07b1d18d2d923e1670aa93f7f4e6.png

 

 

I have deleted the dockers, deleted their folders in my appdata folder and re-installed

unraid-diagnostics-20210512-1055.zip 77.99 kB · 0 downloads

check the log file, attach /config/supervisord.log

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.