[Support] Linuxserver.io - Mylar


201 posts in this topic Last Reply

Recommended Posts

On 1/22/2018 at 4:19 PM, CHBMB said:

 

@dstanley Remind him in a couple of days, because I can guarantee I'll forget. ;)

Unlike you, I do not have the memory of a goldfish   :D

 

It also happens on Duplicati.  Unfortunately, I ran out of containers with Updates available for them to continue testing.  Best guess is to edit the template and remove the TemplateURL line from it (and then ignore the complaint that FCP will give)  But, it is a hair weird as this doesn't seem to affect everything, and it's not the TemplateURL entry being present that causes it because then it would affect every container across the board. 

 

 

Link to post
  • Replies 200
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Since there is a mylar3 image from linuxserver.io here ; https://fleet.linuxserver.io/image?name=linuxserver/mylar3 Will there be an update so it is in community applications? And will there be a

It'll get updated on Friday same as it does every week, the reason you think it's back to late April is because they just merged a ton from development branch into master.  It was rebuilt three days a

This is slightly strange, I wonder if @Squid might be able to shed some light on it.  I suspect it's something to do with updating XMLs automatically.

Posted Images

I can't seem to determine what triggers the template to remove my '/mylar' added onto the WebUI address - it will work for a bit and then somehow revert to the original template address.

Tried several things like removing the webui address - then adding it back in after a save - to editing the template file on the boot usb - nothing 'sticks' with the webui changed from:

http://[IP]:[PORT:8090]/

to

http://[IP]:[PORT:8090]/mylar

as it always reverts (somehow/someway) to:

http://[IP]:[PORT:8090]/

 

This is happening with these dockers on my system:

Mylar

Headphones

Plexpy

 

I cannot access these dockers locally through the Unraid webui as the trailing folder is being removed.

 

I have the webui changed to make these dockers work with Let's Encrypt easiest and I do have them all working through that interface:

http://(MyServer).com/mylar

http://(MyServer).com/headphones

http://(MyServer).com/plexpy

 

Not a 'life-threatening' situation but a perplexing one ...

 

Dwight

Link to post

I'm new to unraid and docker, but not to mylar and Sabnzbd (used windows versions).  I have Sabnzbd set up and working flawlessly with Sonarr and Radarr.  The problem I am having with Mylar is simple (I hope).  Following post processing I get a couple of errors.  One is with Sabnzbd, after running the script, says post processing aborted.  The Mylar log looks good with no errors, until it attempts to move the file form mylar/cache to the final comic directory.  When I check the folders in the cache directory they are all read only (even thought the cache directory has full r-w for nobody.

 

I'm stuck at this point because I cannot figure out how to stop Mylar for making these protected folders inside the cache while processing.  I posted on the Mylar forum too (still waiting for a review of the logs).  Hoping somebody here might have had similar issue?

 

Thanks for the help

 

Dave

Link to post

My setup:

 

Intel NUC mini PC kit NUC7i7BNH, 3 Hard Drives (one internal and 2 external)

  • Unraid 6.4.0

Docker Containers:

  • Mylar - master git build 053626a96bd1a8601b2ca87066261408e8c1cd30
  • SABnzbd
  • Radarr (no errors)
  • Sonarr (no errors)


Synology DS2413+

  • All media storage - with read/write permissions for all directories and files
  • Used Unassigned Devices plugin

Mylar and SABnzbd work together with no errors to grab and download the comic.  The folder is created and the file is renamed then moved to the respective folder on the synology.  The error happens when it tries to clean things up...delete the cache from the mylar directory and delte the file from sabnzbd completed folder.

 

I've attached the Mylar verbose log, the run command for Mylar and  Sabnzbd

 

Mylar Run Command:

 

root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name="mylar" --net="bridge" -e TZ="America/Regina" -e HOST_OS="unRAID" -e "PUID"="99" -e "PGID"="100" -p 8090:8090/tcp -v "/mnt/disks/172.16.1.79_downloads/complete/":"/downloads":rw,slave -v "/mnt/disks/172.16.1.79_Comics/Comics/":"/comics":rw,slave -v "/mnt/cache/appdata/mylar":"/config":rw linuxserver/mylar
5557aa49c9de7ac3ef83e8aa682b2713e585df3b726ff821d67e22f75e0c7912

 

 

SABnzbd Run Command:

 

root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name="sabnzbd" --net="bridge" -e TZ="America/Regina" -e HOST_OS="unRAID" -e "PUID"="99" -e "PGID"="100" -p 8080:8080/tcp -p 9090:9090/tcp -v "/mnt/disks/172.16.1.79_downloads/complete/":"/downloads":rw,slave -v "/mnt/disks/172.16.1.79_downloads/incomplete/":"/incomplete-downloads":rw,slave -v "/mnt/cache/appdata/sabnzbd/scripts/":"/scripts":rw -v "/mnt/disks/172.16.1.79_eBooks/Calibre Library/":"/books":rw,slave -v "/mnt/disks/172.16.1.79_Comics/Comics/":"/comics":rw,slave -v "/mnt/cache/appdata/sabnzbd/":"/config":rw linuxserver/sabnzbd
54f56f61f391b25b4296f7d734c860dc0039082f9d61b63c076f61509d4b8314

 

Thanks for the help

 

Dave

 

Mylar Run Command.txt

Mylar Verbose Log.txt

SABNzbd Run Command.txt

Edited by summerside1967
Link to post

Can someone help me with my problem? I posted here over a week ago. I can't seem to get mylar to load a comic or download one. Sonarr and radarr work fine. I'm not sure what else to do. I've looked for help elsewhere, but to no avail. I've gone through the mylar settings multiple times to try to get it work. 

 

Any tips on what I do? Why am I having this problem? How do you guys setup your mylar? I will provide whatever details you need to narrow down this problem just let me know what to do.

Other than the traceback call errors I get this error every time I attempt to add a comic from the 'This week' tab. I have searched this error and how to fix it, but I still get the error and no comics meta data loads.

2018-01-30 20:29:15	WARNING	Error trying to validate/create directory. Aborting this process at this time.
2018-01-30 20:29:15	WARNING	[DIRECTORY-CHECK] Could not create directory: /Comics/Image+ (2016)[[Errno 13] Permission denied: '/Comics']. Aborting.
2018-01-30 20:29:15	INFO	[DIRECTORY-CHECK] Creating comic directory (0777) : /Comics/Image+ (2016)
2018-01-30 20:29:15	WARNING	[DIRECTORY-CHECK] Could not find comic directory: /Comics/Image+ (2016)
2018-01-30 20:29:15	INFO	Previous version detected as None - seeing if update required
2018-01-30 20:29:15	INFO	Sucessfully retrieved details for Image+
2018-01-30 20:29:15	INFO	Now adding/updating: Image+
2018-01-30 20:29:13	INFO	Attempting to add directly by ComicVineID: 89936

 

Link to post
5 hours ago, frankthetank said:

Can someone help me with my problem? I posted here over a week ago. I can't seem to get mylar to load a comic or download one. Sonarr and radarr work fine. I'm not sure what else to do. I've looked for help elsewhere, but to no avail. I've gone through the mylar settings multiple times to try to get it work. 

 

Any tips on what I do? Why am I having this problem? How do you guys setup your mylar? I will provide whatever details you need to narrow down this problem just let me know what to do.

Other than the traceback call errors I get this error every time I attempt to add a comic from the 'This week' tab. I have searched this error and how to fix it, but I still get the error and no comics meta data loads.


2018-01-30 20:29:15	WARNING	Error trying to validate/create directory. Aborting this process at this time.
2018-01-30 20:29:15	WARNING	[DIRECTORY-CHECK] Could not create directory: /Comics/Image+ (2016)[[Errno 13] Permission denied: '/Comics']. Aborting.
2018-01-30 20:29:15	INFO	[DIRECTORY-CHECK] Creating comic directory (0777) : /Comics/Image+ (2016)
2018-01-30 20:29:15	WARNING	[DIRECTORY-CHECK] Could not find comic directory: /Comics/Image+ (2016)
2018-01-30 20:29:15	INFO	Previous version detected as None - seeing if update required
2018-01-30 20:29:15	INFO	Sucessfully retrieved details for Image+
2018-01-30 20:29:15	INFO	Now adding/updating: Image+
2018-01-30 20:29:13	INFO	Attempting to add directly by ComicVineID: 89936

 

 

/Comics is not the same as /comics in linux

you need to use /comics

Link to post

I changed it to /comics and it seemed to fix my issue. It let me in to see get metadata and it downloaded a comic to test. Thanks for your help.

 

Mylar downloaded the issue fine. Then, I had to tweak my categories setting in SABnzbd, because I had it set up wrong. It moved comics to an incorrect folder. I ended up manually deleting the test comic issue it downloaded previously, so I could start fresh. I made sure the recycle bin is empty. In mylar, I went to the issue I test downloaded, the Manage Failed Downloads, and any other settings I could fine to remove or set it back like I never owned it. Now when I check my logs it's spamming me with this a few hundred times a second, and I can't seem to get of it. 

 

2018-01-31 10:18:30	INFO	no file found where it should be @ /data/Media/Comics - is there another script that moves things after completion ?
2018-01-31 10:18:30	INFO	found matching completed item in history. Job has a status of Completed
2018-01-31 10:18:30	INFO	no file found where it should be @ /data/Media/Comics - is there another script that moves things after completion ?
2018-01-31 10:18:30	INFO	found matching completed item in history. Job has a status of Completed
2018-01-31 10:18:30	INFO	no file found where it should be @ /data/Media/Comics - is there another script that moves things after completion ?
2018-01-31 10:18:30	INFO	found matching completed item in history. Job has a status of Completed

 

Link to post
On 1/30/2018 at 6:18 PM, summerside1967 said:

My setup:

 

Intel NUC mini PC kit NUC7i7BNH, 3 Hard Drives (one internal and 2 external)

  • Unraid 6.4.0

Docker Containers:

  • Mylar - master git build 053626a96bd1a8601b2ca87066261408e8c1cd30
  • SABnzbd
  • Radarr (no errors)
  • Sonarr (no errors)


Synology DS2413+

  • All media storage - with read/write permissions for all directories and files
  • Used Unassigned Devices plugin

Mylar and SABnzbd work together with no errors to grab and download the comic.  The folder is created and the file is renamed then moved to the respective folder on the synology.  The error happens when it tries to clean things up...delete the cache from the mylar directory and delte the file from sabnzbd completed folder.

 

I've attached the Mylar verbose log, the run command for Mylar and  Sabnzbd

 

Mylar Run Command:

 

root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name="mylar" --net="bridge" -e TZ="America/Regina" -e HOST_OS="unRAID" -e "PUID"="99" -e "PGID"="100" -p 8090:8090/tcp -v "/mnt/disks/172.16.1.79_downloads/complete/":"/downloads":rw,slave -v "/mnt/disks/172.16.1.79_Comics/Comics/":"/comics":rw,slave -v "/mnt/cache/appdata/mylar":"/config":rw linuxserver/mylar
5557aa49c9de7ac3ef83e8aa682b2713e585df3b726ff821d67e22f75e0c7912

 

 

SABnzbd Run Command:

 

root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name="sabnzbd" --net="bridge" -e TZ="America/Regina" -e HOST_OS="unRAID" -e "PUID"="99" -e "PGID"="100" -p 8080:8080/tcp -p 9090:9090/tcp -v "/mnt/disks/172.16.1.79_downloads/complete/":"/downloads":rw,slave -v "/mnt/disks/172.16.1.79_downloads/incomplete/":"/incomplete-downloads":rw,slave -v "/mnt/cache/appdata/sabnzbd/scripts/":"/scripts":rw -v "/mnt/disks/172.16.1.79_eBooks/Calibre Library/":"/books":rw,slave -v "/mnt/disks/172.16.1.79_Comics/Comics/":"/comics":rw,slave -v "/mnt/cache/appdata/sabnzbd/":"/config":rw linuxserver/sabnzbd
54f56f61f391b25b4296f7d734c860dc0039082f9d61b63c076f61509d4b8314

 

Thanks for the help

 

Dave

 

Mylar Run Command.txt

Mylar Verbose Log.txt

SABNzbd Run Command.txt

Anyone have any thoughts or ideas?   This is the only issue with the install and I can't figure it out....thanks again

Link to post

In SAB I get this error while trying to use a script. I'm not sure why it doesn't have permission. Does anyone know why?

ERROR a few seconds ago Python script "/data/Media/sabscripts/ComicRN.py" does not have execute (+x) permission set

Also, I in mylar my logs keep getting spammed with this hundreds of times per second. I have to clear my logs after it reaches a couple million lines. Is there some way I can stop this? rebooting/restarting doesn't seem to work. Thanks

2018-02-01 15:16:33	INFO	found matching completed item in history. Job has a status of Completed
2018-02-01 15:16:33	INFO	no file found where it should be @ /data/Media/Comics - is there another script that moves things after completion ?

 

Link to post
23 minutes ago, CHBMB said:

Because it doesn't have execute permissions set?


 


docker exec -it mylar bash

chmod +x /data/Media/sabscripts/ComicRN.py

 

Thanks. That worked to clear the error. I did have to change the path because it had nothing existing there. Now, in Sabnzbd it is telling me this.

/usr/bin/env: ‘python\r’: No such file or directory

 

Link to post

Thanks.  I did look at the logs.  Everything is set up witt appropriate permissions.  Mylar does exactly what it should (based on  the settings I defined), but for some reason when it creates comic (inisde the cache directory) it makes it read only and will not delete (or clean up) after processing.

 

There are not errors until the very end...I'm not sure why the folders inside the cache are being created with different permissions

 

2018-02-01 19:18:09 WARNING [POST-PROCESSING] Post-Processing ABORTED
2018-02-01 19:18:09 WARNING

[POST-PROCESSING] Failed to move /config/mylar/cache/mylar_kp9ceY/All-New Wolverine 012 (2016) (Digital) (BlackManta-Empire).cbz - check directories and manually re-run.

 

 

Edited by summerside1967
Link to post
Thanks.  I did look at the logs.  Everything is set up witt appropriate permissions.  Mylar does exactly what it should (based on  the settings I defined), but for some reason when it creates comic (inisde the cache directory) it makes it read only and will not delete (or clean up) after processing.
 
There are not errors until the very end...I'm not sure why the folders inside the cache are being created with different permissions
 
2018-02-01 19:18:09 WARNING [post-PROCESSING] Post-Processing ABORTED
2018-02-01 19:18:09 WARNING [post-PROCESSING] Failed to move /config/mylar/cache/mylar_kp9ceY/All-New Wolverine 012 (2016) (Digital) (BlackManta-Empire).cbz - check directories and manually re-run.
 
 
You have mylar set up incorrectly sabnzbd has no access to mylar's /config directory.

Sent from my LG-H815 using Tapatalk

Link to post
8 minutes ago, CHBMB said:

You don't, you setup Mylar so stuff isn't put into /config, instead put into /downloads

Sent from my LG-H815 using Tapatalk
 

I was told in the mylar forum that Mylar does the renaming and metadata in temporary folders in the cache, then deletes the files after it moves.  

Link to post
So how would I config Mylar from not using the cache?
I don't know I don't use Mylar, might even be sabnzbd that needs configuring, but something is telling something to put files in /config and the other container consequently can't find it.



Sent from my LG-H815 using Tapatalk

Link to post
7 minutes ago, CHBMB said:

I don't know I don't use Mylar, might even be sabnzbd that needs configuring, but something is telling something to put files in /config and the other container consequently can't find it.



Sent from my LG-H815 using Tapatalk

Sabnzbd finds it.  Mylar for some reason changes permissions of the temporary files it creates in the cache (Mylar cache folder has the correct permissions)   if you don't use Mylar then how can you answer questions under the Mylar topic? 

Link to post
Sabnzbd finds it.  Mylar for some reason changes permissions of the temporary files it creates in the cache (Mylar cache folder has the correct permissions)   if you don't use Mylar then how can you answer questions under the Mylar topic? 
Well, in general docker problems are 99% caused by issues with the end user configuration, and I can see that is your issue from the info and logs posted so far, I use Linux on my server and desktop, and I use docker a lot, and I'm a member of the group that publishes this container, so I'm pretty knowledgeable on those counts, and nobody else was offering any help, but you're right I can only point you to the probable issues not spoon feed you the solution, so if my help isn't valued, I'll refrain from answering.

Sent from my LG-H815 using Tapatalk

Link to post

@CHBMB Please let that comment go and ignore it - your presence here and your guidance has been invaluable to me over the past year or so - I would NOT have got my system to the point it is now without reading your posts and benefiting from your generosity.

 

@summerside1967 I suggest you approach your request for aid with a little more patience and respect - I have both Sabnzbd and Mylar running perfectly on my system and I will help you if I can.

Enclosed are screen shots of my docker configurations for both - please study these and see if they help - the /downloads location MUST be identical in both container settings

 

sabnzbd_docker.JPG

mylar_docker.JPG

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.