Jump to content
linuxserver.io

[Support] Linuxserver.io - Jackett

154 posts in this topic Last Reply

Recommended Posts

This still periodically enters a state where it tries to start itself (when its already running) over and over again, causing 100% load on one cpu. (mono is seen in top at 100%)

 

Any ideas why this might be happening?

Share this post


Link to post
This still periodically enters a state where it tries to start itself (when its already running) over and over again, causing 100% load on one cpu. (mono is seen in top at 100%)
 
Any ideas why this might be happening?


I had this happen to me yesterday. Have you ticked the 'disable automatic update' in settings.
If the selection doesn't stick, you'll have to stop the container and edit the settings in the app data manually. Change the setting in a text editor to 'true'.

Hope this is clear

Regards Clint


Sent from my iPhone using Tapatalk

Share this post


Link to post
8 hours ago, BillClinton said:

 


I had this happen to me yesterday. Have you ticked the 'disable automatic update' in settings.
If the selection doesn't stick, you'll have to stop the container and edit the settings in the app data manually. Change the setting in a text editor to 'true'.

Hope this is clear

Regards Clint


Sent from my iPhone using Tapatalk

 

Thanks for that.

Share this post


Link to post

Still keeps stopping working every couple of days, since ticking disable updates its stopped causing 100% cpu on one core, but now it just doesn't return results.

 

Testing it via sonarr fails, once its restarted it works fine again, I don't really have any in-depth logs to post here.

Share this post


Link to post
1 hour ago, brandur said:

Just a heads up, if someone else is having issues with latest Docker build.

Error: "Self referencing loop detected"

https://github.com/Jackett/Jackett/issues/1532

 

Thanks please post if/when its fixed too. I'm having other server problems and need to take Jackett offline to eliminate any issues I can so would be nice to know if/.when fixed

Share this post


Link to post

Trying to use a proxy for my connections out and I have found the "--ProxyConnection=10.0.0.xx:xxxx" argument but when I add it to the extra params line the container fails to start. Any ideas?

Share this post


Link to post
On 17/07/2017 at 0:02 AM, Kash76 said:

Trying to use a proxy for my connections out and I have found the "--ProxyConnection=10.0.0.xx:xxxx" argument but when I add it to the extra params line the container fails to start. Any ideas?

I posted this in spaceinvader/gridrunner's Privoxy video, but I'll repost here now too where its more searchable :)

 

In unRaid, go to Jackett docker... Edit
Switch Docker template to Advanced view (top right).
Add to the following to Extra Parameters: -e "RUN_OPTS"="--ProxyConnection=192.168.0.100:8118"
* update IP to match your server *
 

Now I tested it by making changes to Jackett first, running tracker test, then failing (due to Privoxy not enabled).
Now enable Privoxy in DelugeVPN, retest tracker test in Jackett, should pass this time :)

Share this post


Link to post
2 hours ago, tjb_altf4 said:

I posted this in spaceinvader/gridrunner's Privoxy video, but I'll repost here now too where its more searchable :)

 

In unRaid, go to Jackett docker... Edit
Switch Docker template to Advanced view (top right).
Add to the following to Extra Parameters: -e "RUN_OPTS"="--ProxyConnection=192.168.0.100:8118"
* update IP to match your server *
 

Now I tested it by making changes to Jackett first, running tracker test, then failing (due to Privoxy not enabled).
Now enable Privoxy in DelugeVPN, retest tracker test in Jackett, should pass this time :)

 

Failed for me..but I already had --cpuset-cpus=0-3,14-17 in my Extra Params...  Should it be -e "RUN_OPTS"="--ProxyConnection=192.168.0.100:8118 --cpuset-cpus=0-3,14-17" for me then?

Share this post


Link to post
On 4/8/2017 at 7:07 PM, methanoid said:

but this icon works fine with both light AND dark themes...

@methanoid

Not sure that's true. I can't see it at all.

 

SafariScreenSnapz038.jpg.17eb57b7c51e1d989d9e2ddaa302f831.jpg

Share this post


Link to post
50 minutes ago, wgstarks said:

@methanoid

Not sure that's true. I can't see it at all.

 

SafariScreenSnapz038.jpg.17eb57b7c51e1d989d9e2ddaa302f831.jpg

 

lol, its about as good as the default is for the Dark theme.. I''ll need to fix it... just needs thicker outline for the Jackett

Share this post


Link to post
8 hours ago, tjb_altf4 said:

I posted this in spaceinvader/gridrunner's Privoxy video, but I'll repost here now too where its more searchable :)

 

In unRaid, go to Jackett docker... Edit
Switch Docker template to Advanced view (top right).
Add to the following to Extra Parameters: -e "RUN_OPTS"="--ProxyConnection=192.168.0.100:8118"
* update IP to match your server *
 

Now I tested it by making changes to Jackett first, running tracker test, then failing (due to Privoxy not enabled).
Now enable Privoxy in DelugeVPN, retest tracker test in Jackett, should pass this time :)

 

Thanks a lot, been looking for an option for proxy in Jackett for awhile. 

Works fine with the extra parameter string towards privoxy.

Share this post


Link to post
2 hours ago, kamhighway said:

Wanted to add my thanks for this application. 

That's very kind of you to say... :)

Share this post


Link to post
8 hours ago, kamhighway said:

Does anyone have IPT working with this Docker?

Yes.

If memory servers me right, you need to get a couple of the session ID from your web cookies and add that to Jackett.

Share this post


Link to post

Thank you tjb_altf4 and wgstarks. The instructions that wgstarks linked to were a little confusing so while its fresh in my mind, I'd like to write down how to enable IPT.

 

First, it was not clear that to see the cookies in Chrome you have to go to "More Tools" and turn on "Developer Tools". The cookie is found under the tab "Application".

 

There are three parts:  PHPSESSID, pass, and uid.  Copy the three pieces to a text editor and put it together like this:  PHPSESSID=[insert long number]; pass=[insert second number]; uid=[insert third number]

 

Now the question is how to get this cookie into Jackett?  In Jackett, if you hit the "+ Add Indexer" you will find IPTorrent listed. Select it and it will come up with the default ip as https://iptorrents.com. Change https to http and click "OK". Now you should see a box to paste the cookie. Click OK.  It will fail, but now you can change the link from http back to https.  Now click OK and it should succeed.

 

 

 

 

Edited by kamhighway

Share this post


Link to post

I'm using Jackett with Deluge, Sonarr and Radarr. I have one path in the docker template that I'm not sure is correct. What should /download be? The github page says it's the path to "torrent black hole". Not sure what that means. I've set it to /mnt/disks/deluge/incomplete since this is what I'm guessing just from the path name. Not really sure why Jackett needs a downloads folder.

Share this post


Link to post

Black hole is a fallback way of adding a torrent file to a deluge. It’s where you put .torrent files if you grab one manually. The downloader will see it and start the download. It’s also a way of getting apps like Sonarr to talk to downloaders that can’t handle the api calls etc.

 

 

Sent from my iPad using Tapatalk

 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.