Preclear runs (via plugin) but no disk activity?


Recommended Posts

I just bought an Unraid licence, a new SSD and HDD and decided it wouldnt hurt to do a preclear.  :D


So.. yesterday i installed the Preclear plugin and the script. I started it via the webinterface on a SSD and a HDD, and the Main page shows the activity. However, after a few hours i came back and found that the GUI is no longer updating.


12 hours later, still no change:

  • The preclear menu page does not show any unassigned disks. (this is OK, i think?)
  • The Main page does show two disks preclearing, but its still not updating. One preclear was at 9% and the other at 26%, in different stages but not quite sure which. They also show a MB/s and ETA time, which also are frozen.
  • The Stats shows 35% sustained CPU usage but no (!) disk activity. (screenshot attached)
  • The `top` command shows two processes `dd` with 100% cpu usage each.
  • Both disks where spun down.


Hoping this would help, i just stopped the array, and started it again. Nothing changed, except that the drives are no longer listed on the Main page or Dashboard page. The Tools > Devices also no longer show them as a SCSI device.


I only ran one preclear cycle, and i expected the 500GB SSD to be done by now. The 6TB HDD wil take longer ofcourse. The machine is a i7 920 (4 core).



[*]Is there any way to see the actual preclear progress? I'd like to know the % or ETA.


pkill -USR1 -n -x dd

outputs nothing.

[*]Should i just cancel the preclear, and try it again? How?

Or just reboot? I'd like to get on and use this SSD to replace my cache..

[*]Could the (new) PCIe controller that these disks are on be to blame?


Link to comment

I got a reply on this in another thread:


I've started a preclear via the plugin, but after a few hours i cant see any progress.



command shows two


processes at 100% each, but there is no disk activity..


I descided to start a new subject to not hijack this thread.


I'm using a fairly virgin Unraid system, which makes me think this is a bug.


One quick thing.  Double checked that you do not have an ad blocker running or some other software/browser-setting to prevent pop-ups.  You may have to whitelist your unRAID server.


I just double checked, no ad is blocked..


But where in Unraid would a new window pop up? Should i leave the webinterface open or something? (which i didnt)

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.