[Support] Linuxserver.io - Plex Requests


159 posts in this topic Last Reply

Recommended Posts

Okay, i changed to 3001 and its still not working. So it must have something to do with this docker not talking to remote.


Has anyone here be able to access this docker from outside? I tried bridge and Host. I cant test br0 because google wifi doesnt recignize the new ip, (i guess) because its not talking on net. If i dont see the host in my app, i cant add port forwardning.. xD (fugg Google wifi)


Also. I setup a port redirect for TS3/PLEX, working perfect, also as "Host". So i dont think its at my end.

 

Can anyone help? 


Edit: seems like unraid is incompatible with google wifi.

Edited by nuhll
Link to post
  • Replies 158
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Looks like there is something going on with this docker right now and request errors. Here is an open Github issue discussing it:   https://github.com/lokenx/plexrequests-meteor/issues/492

This image has been updated now. A manual update was pushed by @sparklyballs.   Our images are updated every friday at 11pm GMT and the update that fixed this bug was released after that.

Can't say based on that why it's not working, but I thought you were security conscious?  Why are you opening random ports to the WAN when the more secure approach would be to reverse proxy this with

Posted Images

Well that's a completely different subnet. I have no idea about your network topology, but I'm assuming you have a VLAN or something.

I'm guessing it would be accessible from 192.168.0.0/24

Sent from my LG-H815 using Tapatalk

Link to post
  • 3 weeks later...
3 hours ago, hilljd00 said:

I wish this thread had a search function. 

 

I'm receiving 'ERR_CONNECTION_REFUSED' error.

 

There is a search icon in the top of the page you can use to search this thread. Choose this thread to the left of the search field.

 

As for the error you probably need to supply more info. Docker run command would be nice and the logs.

Link to post
  • 3 weeks later...

After upgrading to 6.4.0 I had to recreate docker.img and now PleyRequests is giving me error: ERR_CONNECTION_REFUSED

I reinstalled PlexRequests using same appdata as on 6.3.5. I reinstalled PR again and used backup appdata (couple different backups) and nothing worked. I always got same error.

I removed PR and deleted it's appdata and installed PR again and it is working (but no setting and saved requests...). I stopped PR container and replaced appdata from backup and got the same error as first time - ERR_CONNECTION_REFUSED

Any advice how to get PR working or maybe how can I access PR's database so I can extract data and manually import it to new PR instance?

Link to post
15 minutes ago, Vaseer said:

After upgrading to 6.4.0 I had to recreate docker.img and now PleyRequests is giving me error: ERR_CONNECTION_REFUSED

I reinstalled PlexRequests using same appdata as on 6.3.5. I reinstalled PR again and used backup appdata (couple different backups) and nothing worked. I always got same error.

I removed PR and deleted it's appdata and installed PR again and it is working (but no setting and saved requests...). I stopped PR container and replaced appdata from backup and got the same error as first time - ERR_CONNECTION_REFUSED

Any advice how to get PR working or maybe how can I access PR's database so I can extract data and manually import it to new PR instance?

 

Tried clearing your browser cache or using a different browser?

Link to post

Only thing I can suggest is try editing the template and putting a tag to pull an earlier version of the container.

 

If that doesn't work then I'm out of ideas,

 

Edit the template so it reads linuxserver/plexrequests:100

 

Which will pull an older version of the plex requests container,

Link to post
9 minutes ago, Vaseer said:

Edited template to linuxserver/plexrequests:100. It pulled different version but I get the same error as before.

Any advice how can I access PR's database? What/where is db file? 

 

To be brutally honest, if you can't manage to find the file, is you retrieving usable data from it a realistic proposition?

 

But iirc it uses mongodb and it will be located in /config

Edited by CHBMB
Link to post
1 hour ago, CHBMB said:

 

To be brutally honest, if you can't manage to find the file, is you retrieving usable data from it a realistic proposition?

 

But iirc it uses mongodb and it will be located in /config

Thank you to be brutally honest :) (I really miss it sometimes), but I am always ready to learn something new.

From PR template: /config --> /mnt/cache/docker/appdata/plexrequests

To double check it I connected to PR container (bash) and access /config. It contains the same data as /appdata/plexrequests

 

This is where I got lost. Is database one single file or mongodb uses/creates multiple files for db? I have zero experiences with mongo but some with redis and sql so I have some knowledge about databases, but still much to learn.

What I would like to try is use "working" appdata and replace only database to check if it will work.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.