Jump to content

help with Logitech webcam and PCI-E USB 3.0 card on Windows 10 VM


Rexxer

Recommended Posts

Hi everyone,

 

I am new to unRAID and could use some assistance. I am running the latest version of unRAID 6. I got pretty much everything working perfectly on my Windows 10 VM except my logitech C525 USB webcam and Inateck PCI-E USB 3.0 card don't show up.

My motherboard is an ASUS Rampage VIII Hero with an Intel Skylake Core i7-6700k

 

I'll start with the webcam.  I have tried passing it through to my Windows 10 VM in a few different ways. I plugged it into all of the USB ports on my motherboard (both the onboard Intel and ASMedia controller ports) and it shows up under the USB Devices menu but doesn't show up at all in Windows. I bought an Inateck PCI-E USB 3.0 card to see if that would work (also to get USB hotplugging for flash drives) and there are issues there too. I tried following 2 different guides, the one from LinusTechTips and the one on here from archedraft to no avail.

 

Here are the results from SSH'ing into my unRAID

 

This is the output of lspci | grep USB

 

00:14.0 USB controller: Intel Corporation Sunrise Point-H USB 3.0 xHCI Controller (rev 31)

04:00.0 USB controller: ASMedia Technology Inc. Device 1242

05:00.0 USB controller: Fresco Logic Device 1100 (rev 10)

 

The Fresco Logic Device must be the Inateck card because it wasn't there before I installed the card and that is the only change I made.

 

lsusb shows this

 

Bus 006 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub

Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub

Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub

Bus 001 Device 003: ID 046d:c32b Logitech, Inc.

Bus 001 Device 002: ID 046d:0a17 Logitech, Inc. G330 Headset

Bus 001 Device 004: ID 13fe:3e00 Kingston Technology Company Inc. Flash Drive

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

 

The Kingston Technology Company Inc. Flash Drive is my unRAID flash drive

 

Logitech Inc. is my G910 keyboard and Logitech Inc. G330 Headset is a USB sound card since onboard sound apparently doesn't work with Skylake

 

I have no idea what the Linux Foundation 3.0 or 2.0 root hubs are

 

My Logitech webcam doesn't show up even though it is plugged into the Inateck card and I also have another flash drive plugged into the Inateck card that doesn't show up.

 

Both the flash drive and webcam show up if I plug them into an onboard USB port.

 

Any advice would be greatly appreciated.

tower-diagnostics-20160224-2355.zip

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...