Jump to content

Problem running MYSQL service on Windows 10 with network data folder


theone

Recommended Posts

Hello,

 

I have been running MySQL as a service on my Windows 7 VM (Virtualbox) for some years without issues.

MySQL is configured to use a network folder on my cache drive.

datadir="//TOWER/cache/unRAID_Apps/XBMC/XBMC_Database/data"

 

I have created another VM with Windows 10 in order to start migrating functionality to it and remove my Windows 7 VM.

I installed MySQL (tried v5.6 and v5.7) and configured it using the same MySQL "my.ini" file that I use on Windows 7.

This time the service refuses to start - starts and doesn't complete to reach run state.

 

I then tried to run MySQL not as a service but as a console (CMD window always running in background) and !! it works !!

C:\PortableApps\mysql-5.6.29-winx64\bin\mysqld.exe --defaults-file="C:\PortableApps\mysql-5.6.29-winx64\my.ini" --console

 

I tried to also run it as a service from the command line but get the same problem as before - won't start.

C:\PortableApps\mysql-5.6.29-winx64\bin\mysqld.exe --install MYSQL56 --defaults-file="C:\PortableApps\mysql-5.6.29-winx64\my.ini"

 

This get's me to believing that the service runs with different credetials and maybe doesn't have permissions to the network location.

 

So for now I am running it as a console and not service.

 

Keep in mind that the same setups is working on my Windows 7 VM.

Can anyone provide any pointers?

 

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...