[Support] Linuxserver.io - Rutorrent


Recommended Posts

My scheduler does not appear to be working. Here is a screenshot of my ruTorrent. None of these torrents have the "Ignore Scheduler" option ticked either. Note the time is 19:13 in the screenshot and clearly all the boxes past midday are white. Any ideas?

 

2018-01-17_19-14-09.png

Edited by hittingray
Link to comment
5 hours ago, hittingray said:

My scheduler does not appear to be working. Here is a screenshot of my ruTorrent. None of these torrents have the "Ignore Scheduler" option ticked either. Note the time is 19:13 in the screenshot and clearly all the boxes past midday are white. Any ideas?

 

Make sure your Timezone is correctly set. Use this website and find your appropriate TZ, which should be formatted like

Country/City

 

Screen Shot 2018-01-17 at 09.31.026 PM.png

Link to comment
On 18/01/2018 at 12:32 AM, bamtan said:

 

Make sure your Timezone is correctly set. Use this website and find your appropriate TZ, which should be formatted like


Country/City

 

Screen Shot 2018-01-17 at 09.31.026 PM.png

I gave that a try, and now the scheduler seems to operate, but not properly... My torrents seem to randomly be set to "Finished" not at the appropriate times, and it never changes them back to "Seeding". It also changes the DL/UL limit to 1 KiB/s but never back to unlimited...

 

I turned off the scheduler for a couple days and I never encountered the above issues. Any ideas?

 

Edit: Decided to screw around with Binhex's rTorrent docker and the functionality works exactly as I expect it to. If possible, I'd prefer to just get this working, but I'll just swap to Binhex's if I have to.

Edited by hittingray
Link to comment
On 12/28/2017 at 2:27 PM, Quiks said:

New question.

image.png.0201914beb5ba8861255a5a85d9d1571.png

The CPU indicator is showing 100% usage, but my processor is running at ~50%. I docker exec'd into the container and it doesn't seem to be showing high usage either.

Is this indicator not accurate or is there some underlying problem that needs to be addressed.

image.thumb.png.63ce010fa4b14b1e9b7b1ca06eeb17c1.png

image.png.e29d7cfa3fa10ccf572f3c63828a04e4.png

Docker stats doesn't show too much either

image.thumb.png.e317715a9732996818a962d125fad1d0.png

 

Any help is greatly appreciated

 

Thanks!

 

 

Did we ever find a solution to this because I don't think it was ever address. More or less, I am experiencing the same issue. 

Link to comment
4 hours ago, Bisu said:

 

Did we ever find a solution to this because I don't think it was ever address. More or less, I am experiencing the same issue. 

I ended up migrating rutorrent off of my unraid box onto a hyper-v docker server I have. No issues there with a nice low 0-2% CPU usage. It might have been an unraid issue. I noticed VM performance increase after upgrading to 6.4. Did you upgrade to the latest version to see if your docker container's performance also increased?

 

Sorry I can't be of help since I ditched the platform in this case :(.

Edited by Quiks
Link to comment
  • 4 weeks later...
1 hour ago, memphisto said:

I have a problem with bandwidth limiting. I want to set aprox. 400mbit (409600 Kib/s) but it will change to me unlimited. Maxiumum what I managed to set is 319.9mbit (327622 Kib/s). Its bug?


I've noticed you have to change most of the settings in the config file if you want them to stick. Otherwise they keep reverting. Shut down the docker and change the config file.

Link to comment
On 8/8/2017 at 11:27 PM, alowishes said:

Hello, 

 

Thank you for creating this docker. 

 

I just wanted to add some steps for other laymen that were trying to get http authentication working. 

 

I'm new to docker and Linux so found this with trial and error while reading this thread

 

Modify the nginx.conf file by SSHing into UNRAID and executing


 nano /mnt/user/appdata/rutorrent/nginx/nginx.conf

 

add following under location / { 


			auth_basic "Restricted";
			auth_basic_user_file /config/rutorrent/.htpasswd;

It should look something like this when you are done. 


		location / {
			auth_basic "Restricted";
			auth_basic_user_file /config/rutorrent/.htpasswd;
			access_log /config/log/nginx/rutorrent.access.log;
			error_log /config/log/nginx/rutorrent.error.log;
			location ~ .php$ {
				fastcgi_split_path_info ^(.+\.php)(.*)$;
				fastcgi_pass    backendrutorrent;
				fastcgi_index   index.php;
				.....
			}
		}

Create a .htpasswd file in the location specified above. This can be done multiple ways, i used http://www.htaccesstools.com/htpasswd-generator/ after Googling. 

 


nano /mnt/user/appdata/rutorrent/rutorrent/.htpasswd

Paste in the output from the above htpasswd generator site eg. 

 

abc:$apr1$pQPv3Rnv$8c9JMYANl.rO0cgaa931F0

 

Save the file. You may or may not need to restart the rutorrent docker. 

 

Just a note that my server isn't externally accessible so i felt this was sufficient for my needs. I'm not sure what is involved in getting SSL working...

 

 

Thank you so much for posting this!!

 

I followed it as written and it worked first try.   I hated having rutorrent exposed to the world.   I'm not sure why the developers don't put in a password from the get go

Link to comment
On 24/02/2018 at 8:35 AM, go69cars said:

 

 

Thank you so much for posting this!!

 

I followed it as written and it worked first try.   I hated having rutorrent exposed to the world.   I'm not sure why the developers don't put in a password from the get go

 

Glad it was of some use to you :)

 

I having an issue with a fork of this container and am not sure where to ask. Since updating to Unraid 6.4.1 irssi is unable to communicate outside the container. Everything else in the docker works as usual. I've tried adding ports 6667 to the docker but i still have the same issue. 

 

The fork i'm using is https://hub.docker.com/r/horjulf/rutorrent-autodl/

 

Is anyone able to point me in the right direction? 

 

Link to comment
On 1/17/2018 at 2:19 AM, hittingray said:

My scheduler does not appear to be working. Here is a screenshot of my ruTorrent. None of these torrents have the "Ignore Scheduler" option ticked either. Note the time is 19:13 in the screenshot and clearly all the boxes past midday are white. Any ideas?

 

2018-01-17_19-14-09.png

I am having the exact same issue. Time is correct for my timezone (ran date inside the docker, it returned proper timezone/time), but yet the scheduler is borked. It looks like it thinks limited2 is unlimited, unlimited is limited1, and limited1 is....? I am not sure exactly how to fix this.

Link to comment
On 08/03/2018 at 5:47 PM, d2dyno said:

I am having the exact same issue. Time is correct for my timezone (ran date inside the docker, it returned proper timezone/time), but yet the scheduler is borked. It looks like it thinks limited2 is unlimited, unlimited is limited1, and limited1 is....? I am not sure exactly how to fix this.

 

Only got a notification for this just now... Anyway, I ended up trying BinHex's rTorrent docker, and the scheduler worked properly in that, so I just moved to that. It's not too hard to transfer everything over.

Link to comment

So, let me start with this is my very first post on the forums.  I'm am 100% brand new to unraid.  Literally just popped my unraid cherry a couple of hours ago.  I'm trying to copy my current plex set up on my main gaming pc to my new unraid box. 

My current setup is, I use Ombi + Radarr + Sonarr (W/ jackett) for all of my requests and auto show updates.  They all use utorrent as my client.  I have utorrent set up to automatically move completed files from my download folder to completed folder, and it is set up to automatically run winrar to extract any zipped files (that way Sonarr can move the files over to my Plex library). 

Now I have Plex set up on unraid, with it's correct folders, etc... that part was super easy.  I installed this docker, but i'm now lost.  Sorry if I'm asking what is probably super simple to figure out, but once again I'm new.  WIth the rutorrent docker installed... how do I pull up the utorrent UI so I can configure it (IE set where to download files to, move them once complete, set up winrar to auto extract, etc..).  I know utorrent offers a web ui feature, as I use it on my main windows pc, but I have no idea how to enable that so I can configure it to see the standard utorrent UI.

Any good guides that really dumb it down for us newbs?  Or just any advice at all?  I am still learning.  I'm not even sure if I should have my network type as bridge or host or what.  All I know is unraid uses port  80 so I had to change that to some random port.  Outside of that, I don't know what I'm doing.

Thanks for any (future) help.  I do appreciate it.

Link to comment

This isn't utorrent, it is rtorrent/rutorrent but they are similar to utorrent.  rtorrent is the back end rtorrent application and rutorrent is the web-based UI for rtorrent. 

 

You should be able to get to the UI by going to the unRAID Dashboard and then click on Rutorrent and WebUI.  Then you configure everything through the browser - generally through settings which you access via the Gear icon on the Web UI.  Google "rutorrent" and you should find more.  You set the download file location in settings/Downloads. You can use Autotools to specify where files should get moved when downloads are completed.

Link to comment

rutorrent is really only similar to utorrent in name and somewhat in the UI. They are completely different under the hood. There really is no option to continue using utorrent on unraid. There is a linux client of utorrent but for one, I don't think there is a docker for unraid, and two, even if you happen to find/make one, the linux client is 3 years old and receives no attention from devs. utorrent frequently get banned by trackers anyway. You can still use utorrent in your setup if you want, just not in unraid.

Edited by bobbintb
Link to comment

This is more of an rutorrent specific question instead of a docker question but I've never had success in getting the rutorrent dev to respond to any issues. My automove only seems to work about half of the time and I could never figure out why. They are supposed to move from /downloads to /complete. I ended up just turning off automove because it creates more of an organizational mess when it is supposed to reduce it. Anyone else have that issue or know how to resolve it?

Link to comment

So there is even a third developer.  How does Autotools work?  Does it just add a line to the rtorrent.rc file or something like that?  What I am getting at is that maybe there is an issue with the underlying rtorrent process for moving files upon completion of the torrent.  Or maybe something changes and AutoTools was never updated to reflect the change.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.