[Support] Linuxserver.io - Rutorrent

Recommended Posts

Hey Guys... 


Super easy install thanks for that and all your guys hard work... 


I wanted to give the rutorrent a custom ip address

i went through the setup and changed network mode to bridge and it works fine, gives me an ip out of my range in my network though... see below images





When I change the network to custom br:0 and give it an ip like it does not load the GUI and does not work?




any thoughts?

Link to comment
On 9/8/2019 at 5:32 PM, dkerlee said:

Trying to get some settings to save in ruTorrent GUI, the default save directory. Seems to get in there for only a few minutes, then is overwritten minutes later. Where can I stick settings that will persist between restarts and for longer than xx minutes? thanks!



You have to edit the values in the rtorrent.rc file in your appdata/rutorrent/rtorrent folder

  • Thanks 1
Link to comment

I recently updated this docker and now when I try to go to the web UI I get a 404/Not found error - nginx/1.16.1


I am using bridge mode (br0) mode with an IP of


To try to fix it I temporarily tried host mode and tried to change the Host Port 1 to 9980.  I have since changed it back but this seems to have screwed up my docker start command.


Here is the docker start command: (notice the  'TCP_PORT_9980'='80'  command


root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name='rutorrent' --net='br0' --ip='' -e TZ="America/New_York" -e HOST_OS="unRAID" -e 'TCP_PORT_9980'='80' -e 'TCP_PORT_51413'='51413' -e 'UDP_PORT_6881'='6881' -e 'PUID'='99' -e 'PGID'='100' -v '/mnt/user/media/downloads':'/downloads':'rw' -v '/mnt/user/appdata/rutorrent':'/config':'rw' 'linuxserver/rutorrent'



edit - I "fixed" this by deleting the docker, deleting the appdata folder and reinstalling.

Edited by wayner
Link to comment
  • 5 weeks later...

I hope this it the right thread to ask but I've been trying to create a script to change the throttle speeds of my upload. Does anyone have any experience with this? Right now after some investigating the only way I managed to get this to work is to change the lines for download_rate and upload_rate in rtorrent.rc and restarting the docker container. The end goal is when people are streaming remotely on my plex server I want it to dynamically adjust the upload rate in my rutorrent and adjust it back when nobody is streaming on my plex server. I've tried to follow this guide to adjust it through the throttle.php plugin but it doesn't seem to change in the WebUI. https://www.seedhost.eu/whmcs/knowledgebase/245/rTorrentorruTorrent-limit-uploadordownload-speed.html

Link to comment
On 8/25/2019 at 6:58 AM, J89eu said:

I still can't get unpacking to work automatically on this docker.. I have it all ticked to do so in the settings but it never works. If I rightclick the torrent and hit "unpack" it works....

Mine works intermittently. If I have 2 files downloading with the same label, it will unpack the first one but not the second one. No mention of anything wrong in any logs that I've checked so I must be missing the right on. As with you, if I manually select and run Unpack it works fine.

Link to comment
  • 1 month later...
On 3/8/2016 at 1:30 PM, linuxserver.io said:

**Attention - Latest Update - Image Rewrite** 11/12/2018

We have rewrite to our newest image, so much more lightweight, supports theme folders, fixes a known shutdown bug.



Anyone know how to use the "theme folders"?


I have been trying to add 3rd party themes from here: https://github.com/artyuum/ruTorrent-Themes but I cannot figure out how to add them persistently to this docker container.


Thanks in advance

Link to comment
  • 4 weeks later...
On 6/17/2019 at 3:37 PM, deusxanime said:

You might want to review all your settings if you are still using those old parameters. They were depreciated for quite a long time actually and finally had support completely removed for them months back. I had the same problem with some other settings as well (must have used an old guide to set it up originally so I was using many of the older deprecated parameters) and went back through and realized I had to redo quite a bunch of them to get things working properly again. Don't remember what version that happened in, but it just kind of stopped working all at once because of that.

The "old" parameters are still in the default config for this container. Are there any plans to update the rtorrent.rc file to remove the depreciated settings?




EDIT: "new" parameters aren't working, specifically max upload and download speed set to 0

Edited by surfshack66
Link to comment


Thanks for this container, i was wondering if there's anyway to prevent rutorrent client from creating the folders /incoming /watched /completed ?

Even though i've set my download folder to be /downloads/ it creates these 3 sub directories. I don't want to use any of them but ive dug around and i can't find how to disable rutorrent from creating them in the first place.

Link to comment

Can anyone maybe take a look at my settings for rutorrent to get my reverse proxy working?  I've got it working for everything else, I just get a 502 bad gateway error on rutorrent for some reason.  I'm sure it's something simple I have set wrong.  I get this error in my nginx log:


2019/12/29 15:55:20 [error] 442#442: *2565 connect() failed (111: Connection refused) while connecting to upstream, client:, server: rutorrent.*, request: "GET / HTTP/1.1", upstream: "", host: "rutorrent.xxxxxxxx.xxx"


And I'm not sure where that IP address is coming from.  Just noticed that, it's not mine.


This is my .conf file:


# make sure that your dns has a cname set for rutorrent

server {
    listen 443 ssl;
    listen [::]:443 ssl;

    server_name rutorrent.*;

    include /config/nginx/ssl.conf;

    client_max_body_size 0;

    # enable for ldap auth, fill in ldap details in ldap.conf
    #include /config/nginx/ldap.conf;

    location / {
        # enable the next two lines for http auth
        #auth_basic "Restricted";
        #auth_basic_user_file /config/nginx/.htpasswd;

        # enable the next two lines for ldap auth
        #auth_request /auth;
        #error_page 401 =200 /login;

        include /config/nginx/proxy.conf;
        resolver valid=30s;
        set $upstream_rutorrent binhex-rtorrentvpn;
        proxy_pass http://$upstream_rutorrent:80;

    location /RPC2 {
        include /config/nginx/proxy.conf;
        resolver valid=30s;
        set $upstream_rutorrent binhex-rtorrentvpn;
        proxy_pass http://$upstream_rutorrent:80;


Edited by EC28
Link to comment

I've finally solved my issue with the rutorrent process being deadlocked in IOWAIT.

If this is your problem you will see all of the below symptoms:

  • rutorrent will load, but you will get an error 500, 504, or 502 on getplugins.php and the queue will not load
  • when the queue does load you will rarely get updates and "the request to rtorrent timed out" will be your most common response.
  • torrents will get stuck in checking status
  • torrents that are downloading/seeding will get abysmal performance.
  • all of the above will be intermittent and will usually occur after adding new, large torrents, or several smaller torrents
  • Checking "iotop" when the above is occuring will have the rtorrent process listed at the top, with 99.99% IOWAIT and very low read/write speed.

I had previously attempted many things to fix this problem:

  • changing nginx scgi buffer size.
  • increasing rtorrent memory allocation
  • changing php-fpm workers and memory allocations
  • changing php-fpm and nginx timeout to allow rtorrent more time to respond to requests.

The final nail in the coffin was switching IO Schedulers. I swapped from mq-deadline to BFQ and the problem has entirely gone away. Not entirely sure why internally this was the fix - but immediately upon switching to BFQ the problem is completely gone and I can actually watch checking progress on a 200gb torrent while data is moving on the other torrents in the queue.

  • Thanks 1
Link to comment

Anyone having the same as me, that as soon that i'm starting a torrent to download, my ruTorrent webclient just goes time-out and will not load.

The download speed stays at like 10-60kb/s for a few hours, now and then it jumps up to my normal max speed (500/500mbits) and im able to load the webgui again... 

After some times it goes back to time-out and 10-60kb/s..

As soon the torrent is done downloading everything works as usual again..


Help pls?

Link to comment
  • 2 weeks later...
  • 2 weeks later...
  • 2 weeks later...
  • 2 weeks later...
On 1/5/2020 at 12:44 AM, AndreasLindroth said:

Anyone having the same as me, that as soon that i'm starting a torrent to download, my ruTorrent webclient just goes time-out and will not load.

The download speed stays at like 10-60kb/s for a few hours, now and then it jumps up to my normal max speed (500/500mbits) and im able to load the webgui again... 

After some times it goes back to time-out and 10-60kb/s..

As soon the torrent is done downloading everything works as usual again..


Help pls?

Anyone? It is still the same and i feel like ripping my hair out :/

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.