[Support] Linuxserver.io - Rutorrent


686 posts in this topic Last Reply

Recommended Posts

  • Replies 685
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Application Name: Rutorrent Application Site: https://github.com/Novik/ruTorrent/ Docker Hub: https://hub.docker.com/r/linuxserver/rutorrent/ Github: https://github.com/linuxserver/dock

Just added note to the first post on how to resolve this.  

@xthursdayx It is actually much easier than that. Simply copy the contents of your "/mnt/user/appdata/rutorrent/rtorrent/rtorrent_sess" into the following folder : "/mnt/user/appdata/binhex-rtorrentvp

Posted Images

is there anyway to add an additional path. I understand the download path but heres my dilemma. i want to be able to have download be a share on unraid which is on the cache and then move to a seperate share called complete so that way it goes onto the array. The cache mover cant move completed torrents while the docker is running. i tried adding -v /complete but that didnt seem to work.

 

Just add an extra path in the docker webui on Unraid.  Edit the container config and do it there.

 

unfortunately even when i do add the path when trying to edit autotools to use this folder its stuck in the download folder?

 

any changes made in the webui are not permanent and only apply to that session, ie until the docker is restarted.

 

this is a limitation of the apps themselves

 

https://github.com/Novik/ruTorrent/wiki#some-non-obvious-points

 

any permanent changes need to be made to the rtorrrent.rc file

 

/config/rtorrent/rtorrent.rc

 

Weird because my changes three main settings i can think of seem to stick. I restarted my docker about an hour again and these settings were retained:

 

feed interval

watch folder

unpack

 

Or are those ruTorrent config settings and not rTorrent??

Link to post

So two things:

 

1) now that I've updated, sure enough making changes to things like my connection port in the webgui do not stick on docker restart. So behaving as described

 

2) I copied over my entire session folder from my old appdata structure into the new appdate structure and all of my old torrents came over, connected to my private tracker, and started seeding as hoped for. So nuking the docker and appdata from orbit is not as much of a complete startover as I had worried.

 

Thanks guys!!!

Link to post

So two things:

 

1) now that I've updated, sure enough making changes to things like my connection port in the webgui do not stick on docker restart. So behaving as described

 

2) I copied over my entire session folder from my old appdata structure into the new appdate structure and all of my old torrents came over, connected to my private tracker, and started seeding as hoped for. So nuking the docker and appdata from orbit is not as much of a complete startover as I had worried.

 

Thanks guys!!!

 

No worries.

Link to post

Quick question because I don't know how to check it myself, can you please confirm that within the docker container this is the correct path to PHP

 

/usr/bin/php7

 

I ask because autotool for autowatch is not working and what I'm reading says the first thing to check is the path to php in the config.php file. The above is what I found.

 

EDIT: also can you confirm, or not, if

"register_argc_argv" enabled for the php-cli.ini

sorry if that is opaque, I'm trying to track down the issue with autowatch. that is another one of the "things to check" from here http://forums.rutorrent.org/index.php?PHPSESSID=557b64757da258035d65eb80f2a4ad26&topic=645.msg4895#msg4895
Link to post

Quick question because I don't know how to check it myself, can you please confirm that within the docker container this is the correct path to PHP

 

/usr/bin/php7

 

I ask because autotool for autowatch is not working and what I'm reading says the first thing to check is the path to php in the config.php file. The above is what I found.

 

EDIT: also can you confirm, or not, if

"register_argc_argv" enabled for the php-cli.ini

sorry if that is opaque, I'm trying to track down the issue with autowatch. that is another one of the "things to check" from here http://forums.rutorrent.org/index.php?PHPSESSID=557b64757da258035d65eb80f2a4ad26&topic=645.msg4895#msg4895

 

the file in question for php.ini is

 

/etc/php7/php.ini

 

currently "register_argc_argv = Off" is the setting.

 

and /usr/bin/php7 is the correct path.

 

if you can confirm that setting

 

register_argc_argv = On enables autotools, i'll sed it in to the dockerfile or one of the startup init files.

Link to post

Ok so if I understand you, and please bare with me,

 

php.ini is in "/etc/php7/" and right now is set to register_argc_argv = Off

 

So as for you asking me to confirm that register_argc_argv = On enables autotools, all I can say is that is what I'm seeing on the intertubes but I can't confirm. Is there a comment I can execute to make the change on my system to test?

 

I'm also seeing some notes that this fails using unix sockets. I assume that is as opposed to the option to use an scgi port?

 

I'm getting some of this also from here http://forums.rutorrent.org/index.php?topic=57.0

 

Mind you I've also tried setting a watch folder in rtorrent.rc and that isn't working either. when trying one or the other I've made sure to disable one as well so they don't compete; then restart the docker.  no luck with either and I don't care which I get working. my rtorrent.rc config line is

schedule = watch_directory_1,5,5,"load.start=~/downloads/watch/*.torrent"

Link to post

So I tried to manually add the torrent in question and this popped in the error log

 

2016/08/07 12:56:50 [crit] 235#0: *1 open() "/var/lib/nginx/tmp/client_body/0000000001" failed (13: Permission denied), client: 10.0.0.6, server: _, request: "POST /php/addtorrent.php?torrents_start_stopped=1& HTTP/1.1", host: "10.0.0.4:8081", referrer: "http://10.0.0.4:8081/"
2016/08/07 12:57:10 [crit] 235#0: *55 open() "/var/lib/nginx/tmp/client_body/0000000002" failed (13: Permission denied), client: 10.0.0.6, server: _, request: "POST /php/addtorrent.php?torrents_start_stopped=1& HTTP/1.1", host: "10.0.0.4:8081", referrer: "http://10.0.0.4:8081/"

 

I've always been able to manually add torrents, so um ... now what? What other log should I send?

Link to post

So I tried to manually add the torrent in question and this popped in the error log

 

2016/08/07 12:56:50 [crit] 235#0: *1 open() "/var/lib/nginx/tmp/client_body/0000000001" failed (13: Permission denied), client: 10.0.0.6, server: _, request: "POST /php/addtorrent.php?torrents_start_stopped=1& HTTP/1.1", host: "10.0.0.4:8081", referrer: "http://10.0.0.4:8081/"
2016/08/07 12:57:10 [crit] 235#0: *55 open() "/var/lib/nginx/tmp/client_body/0000000002" failed (13: Permission denied), client: 10.0.0.6, server: _, request: "POST /php/addtorrent.php?torrents_start_stopped=1& HTTP/1.1", host: "10.0.0.4:8081", referrer: "http://10.0.0.4:8081/"

 

I've always been able to manually add torrents, so um ... now what? What other log should I send?

 

let's deal with this one first, it's the easiest, lol.

 

seems there's a file size limit beyond which it writes to the tmp folder for nginx, i guess the torrents i was testing with were below the file limit.

I'm adding a perms fix to that folder.

Link to post

I'm down with fixing the easy stuff first :) Also kinda makes the whole docker useless without  it :o

 

I await patiently. As always, thanks. And because I want to learn, at any time feel free to tell me to do more research with a bit of a hint where to start. Pieces are falling into place with this most recent comment, the php stuff, and my now trolling through your docker git :)

Link to post

Ok so if I understand you, and please bare with me,

 

php.ini is in "/etc/php7/" and right now is set to register_argc_argv = Off

 

So as for you asking me to confirm that register_argc_argv = On enables autotools, all I can say is that is what I'm seeing on the intertubes but I can't confirm. Is there a comment I can execute to make the change on my system to test?

 

I'm also seeing some notes that this fails using unix sockets. I assume that is as opposed to the option to use an scgi port?

 

I'm getting some of this also from here http://forums.rutorrent.org/index.php?topic=57.0

 

Mind you I've also tried setting a watch folder in rtorrent.rc and that isn't working either. when trying one or the other I've made sure to disable one as well so they don't compete; then restart the docker.  no luck with either and I don't care which I get working. my rtorrent.rc config line is

schedule = watch_directory_1,5,5,"load.start=~/downloads/watch/*.torrent"

 

take the tilde "~" out and it's watched

schedule = watch_directory_1,5,5,"load.start=/downloads/watched/*.torrent"

Link to post

Quick question because I don't know how to check it myself, can you please confirm that within the docker container this is the correct path to PHP

 

/usr/bin/php7

 

I ask because autotool for autowatch is not working and what I'm reading says the first thing to check is the path to php in the config.php file. The above is what I found.

 

EDIT: also can you confirm, or not, if

"register_argc_argv" enabled for the php-cli.ini

sorry if that is opaque, I'm trying to track down the issue with autowatch. that is another one of the "things to check" from here http://forums.rutorrent.org/index.php?PHPSESSID=557b64757da258035d65eb80f2a4ad26&topic=645.msg4895#msg4895

 

changing the config in question to on and placing a torrent for ubuntu server iso in the watched folder and waiting about 10 minutes or so it started downloading.

Link to post

Ok so if I understand you, and please bare with me,

 

php.ini is in "/etc/php7/" and right now is set to register_argc_argv = Off

 

So as for you asking me to confirm that register_argc_argv = On enables autotools, all I can say is that is what I'm seeing on the intertubes but I can't confirm. Is there a comment I can execute to make the change on my system to test?

 

I'm also seeing some notes that this fails using unix sockets. I assume that is as opposed to the option to use an scgi port?

 

I'm getting some of this also from here http://forums.rutorrent.org/index.php?topic=57.0

 

Mind you I've also tried setting a watch folder in rtorrent.rc and that isn't working either. when trying one or the other I've made sure to disable one as well so they don't compete; then restart the docker.  no luck with either and I don't care which I get working. my rtorrent.rc config line is

schedule = watch_directory_1,5,5,"load.start=~/downloads/watch/*.torrent"

 

take the tilde "~" out and it's watched

schedule = watch_directory_1,5,5,"load.start=/downloads/watched/*.torrent"

 

I suppose I understand the tilde, but why "watched"? I specifically created a folder called watch.

 

that said, removed the ~ but left it at "watch" and  :o HOT DAMN :o it worked. [sigh] ... now I need to get it to remove the torrent file, but that is my problem to deal with :)

 

Have you made the permission change? Should I kill and download the docker image / container? The autowatch tools are indeed easier to deal with from the GUI of course :)

Link to post

Ok so if I understand you, and please bare with me,

 

php.ini is in "/etc/php7/" and right now is set to register_argc_argv = Off

 

So as for you asking me to confirm that register_argc_argv = On enables autotools, all I can say is that is what I'm seeing on the intertubes but I can't confirm. Is there a comment I can execute to make the change on my system to test?

 

I'm also seeing some notes that this fails using unix sockets. I assume that is as opposed to the option to use an scgi port?

 

I'm getting some of this also from here http://forums.rutorrent.org/index.php?topic=57.0

 

Mind you I've also tried setting a watch folder in rtorrent.rc and that isn't working either. when trying one or the other I've made sure to disable one as well so they don't compete; then restart the docker.  no luck with either and I don't care which I get working. my rtorrent.rc config line is

schedule = watch_directory_1,5,5,"load.start=~/downloads/watch/*.torrent"

 

take the tilde "~" out and it's watched

schedule = watch_directory_1,5,5,"load.start=/downloads/watched/*.torrent"

 

I suppose I understand the tilde, but why "watched"? I specifically created a folder called watch.

 

that said, made the change and  :o HOT DAMN :o it worked. [sigh] ... now I need to get it to remove the torrent file, but that is my problem to deal with :)

 

Have you made the permission change? Should I kill and download the docker image / container? The autowatch tools are indeed easier to deal with from the GUI of course :)

 

I'm building a test copy on my VM at the moment, takes a little while as have to compile one of the dependencies from source.

Link to post

uggg while waiting I tried adding an rss feed and it will not load. "Error loading RSS feed" it is a feed I've used before and the url loads in my browser just fine.

 

First google link is: http://forums.rutorrent.org/index.php?topic=65.0

 

make sure plugins/rss/cache is read/write to the webuser
if that helps

 

Another similar issue http://forums.rutorrent.org/index.php?PHPSESSID=462ee4f8afb81093d2c735f62a52fe61&topic=288.msg1729#msg1729

Link to post

uggg while waiting I tried adding an rss feed and it will not load. "Error loading RSS feed" it is a feed I've used before and the url loads in my browser just fine.

 

First google link is: http://forums.rutorrent.org/index.php?topic=65.0

 

make sure plugins/rss/cache is read/write to the webuser
if that helps

 

Another similar issue http://forums.rutorrent.org/index.php?PHPSESSID=462ee4f8afb81093d2c735f62a52fe61&topic=288.msg1729#msg1729

 

i had no issue with rss feeds in testing, there is no folder plugins/rss/cache

 

problem with most information for this "lovely" software, it's woefully out of date, lol.

Link to post

But but but ... it really is lovely. Does what I need and plays well with my trackers. Neither Transmission nor Deluge have I ever been able to get setup right. :(

 

Maybe your permission change will help [shrug], but to be clear you're telling me you were able to click on the feed icon, enter in a feed url in the form of

https://revolutiontt.me/rss.php?feed=dl&bookmarks=on&passkey=xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

and it worked? Because I get exactly

 Error loading feed. (https://revolutiontt.me/rss.php?feed=dl&bookmarks=on&passkey=xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx)

 

re: your image ... uggg ... I don't have even an idea where to start with my config that might make me so special. maybe I'll try another completely pristine docker, no session shenanigans, and see what happens

Link to post

K, autotools loading torrents watched folder is working now.

 

fixed the perms on the nginx tmp folder

 

made the php.ini file user-editable in /config/php

 

 

gonna push the PR to the main repo now. i'll let you know when the build is pushed to the hub.

 

also put a commented out line in the rtorrent.rc for watch folder enabling.

Link to post

You rock man. I was gonna suggest that last bit about the commented line too hahaha

 

So ... another rss feed loads fine. So many it is just the first tracker rejecting for some reason despite it loading in my browser and working on the old rutorrent ... coincidence I guess. but it is my problem to solve now, not yours.

 

Thanks so much!!!

Link to post

OK very weird.

 

This rss feed has always worked as entered. I played around and removed the bookmark portion and it loaded, but of course with a butt load of torrents that I don't care about. I put back the bookmark bit and it failed again.

 

Of note is that right now I have no torrents to download because there is nothing new so my bookmarks list is empty.

 

Next I manually added a bookmark at the tracker site and BAM ruTorrent saved the feed and shows only that single bookmark as expected.

 

Soooo like I've said a few times now, this is my problem to deal with now not yours, but I'm adding this for any others that might have a similar problem.

 

In fact it is known: https://github.com/Novik/ruTorrent/issues/1068 it is also in theory fixed, but I wonder if a regression was introduced

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.