Correct way reinstall unraid6

Recommended Posts

Hi guys,

I  a happy owner of unraid from 2 years ago. I played a lot with my server and install things that i shouldn't installed.

this cause that now I see some errors related to plugins and VM-KVM web ui doesn't work i can't create VM.

So I want to reinstall unraid but I don't want to lose data and shares. all the apps are dockerized so it's not a big deal to "reinstall the dockers"

I don't care if I need to regenerate parity data, 1 month ago last parity check.


Guys how I should do it?

-I don't want lose data

-I don't want lose shares

-I don't want lose unraid Licence



Link to comment

And if you also copy config/super.dat, you'll keep your drive assignments including parity.  Copying config/disk.cfg should also be safe, has disk settings.

If you copy config/share.cfg and the config/shares folder, you'll keep all your share settings.

If you copy config/ident.cfg and config/network.cfg, you'll keep your network settings.

Link to comment
  • 8 months later...

It is a pretty old thread but can i just


-Screenshot the the main tab in unraid and then set the same disks (serial number) for parity and disks.


-Use the key link to download the license file again.


EDIT: It worked! I just reinstalled it, selected the same disks for parity and disks (make sure that "parity is already valid" is activated), used the key file link to install the license again and everything works!


It probably has nothing to do with reinstalling it but my SSH didn't work anymore. This fix worked:

Link to comment
  • 6 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.