[Support] binhex - rTorrentVPN


Recommended Posts

5 minutes ago, binhex said:

what problem is that?, your log looks fine to me, no sign of the plugins issue.

When I load the web interface the log looks like this:

Spoiler

 

12.03.2021 12:16:44] WebUI started.

[12.03.2021 12:16:45] _cloudflare: Plugin will not work. rTorrent user can't access external program (python).

[12.03.2021 12:16:45] _task: Plugin will not work. rTorrent user can't access external program (php).

[12.03.2021 12:16:45] autotools: Plugin will not work. rTorrent user can't access external program (php).

[12.03.2021 12:16:45] create: Plugin will not work. rTorrent user can't access external program (php).

[12.03.2021 12:16:45] datadir: Plugin will not work. rTorrent user can't access external program (php).

[12.03.2021 12:16:45] history: Plugin will not work. rTorrent user can't access external program (php).

[12.03.2021 12:16:45] loginmgr: Some functionality will be unavailable. rTorrent user can't access external program (php).

[12.03.2021 12:16:45] ratio: Some functionality will be unavailable. rTorrent user can't access external program (php).

[12.03.2021 12:16:45] retrackers: Plugin will not work. rTorrent user can't access external program (php).

[12.03.2021 12:16:45] rss: Plugin will not work. rTorrent user can't access external program (php).

[12.03.2021 12:16:45] rutracker_check: Plugin will not work. rTorrent user can't access external program (php).

[12.03.2021 12:16:45] scheduler: Plugin will not work. rTorrent user can't access external program (php).

[12.03.2021 12:16:45] trafic: Plugin will not work. rTorrent user can't access external program (php).

[12.03.2021 12:16:45] unpack: Plugin will not work. rTorrent user can't access external program (php).

[12.03.2021 12:16:45] xmpp: Plugin will not work. rTorrent user can't access external program (php).

[12.03.2021 12:16:45] _task: Plugin will not work. rTorrent user can't access external program (pgrep).

[12.03.2021 12:16:45] mediainfo: Plugin will not work. rTorrent user can't access external program (mediainfo).

[12.03.2021 12:16:45] rss: Some functionality will be unavailable. rTorrent user can't access external program (curl).

[12.03.2021 12:16:45] screenshots: Plugin will not work. rTorrent user can't access external program (ffmpeg).

[12.03.2021 12:16:45] spectrogram: Plugin will not work. rTorrent user can't access external program (sox).

 

 

Link to comment

Started fresh after the security issue with rtorrentvpn,
also switched to wireguard.
When i use my old rtorrent.rc and start rtorrentvpn it connects and i can access the webgui.

but when i move my sessions to the new install and start rtorrentvpn i can't access the webgui and get a error,

then i tried to rename my rtorrent.rc so it creates a new one, and then i still get the same error.


supervisord.log

Link to comment

Hi - I just unpinned my Rtorrent version to pull latest, from

image: binhex/arch-rtorrentvpn:rtorrent-ps-1.1.r54.ga787dd9-1-28

I'm having a bit of trouble understanding the changes needed in questions 25 and 26. I'm using Sonarr, Radarr and Jackett. Sonarr and Radarr are configured to use Jackett as a provider, but I also had an HTTPS proxy configured for Sonarr and Radarr. I'm using Ubuntu with docker compose. I'm only accessing the web ui for these apps via a VPN (wireguard hosted on this server). My main issue is that torrents from Jackett are not downloading once added to rtorrent

 

Do I need to change or add values?

VPN_OUTPUT_PORTS

VPN_INPUT_PORTS

- LAN_NETWORK=192.168.55.0/24,10.6.0.0/24 (LAN, Wireguard home vpn subnets)

 

I'll try reading the instructions again.

I'm also using 9443 for the web port instead of 9080  from the issues a few weeks ago.

 

Since I'm  using docker compose, do I need to add networks to my config? I don't have that set up. I can see all of the UIs for the apps, but now no torrents will download.

 

 

EDIT:

 

I did a little more research and when I download the .torrent directly from Jackett and add it myself to rtorrent, the downloads start in rtorrent, when sonarr adds the torrent to jackett, they don't.

Edited by bumperjeep
Link to comment
On 3/10/2021 at 10:22 PM, Trevo525 said:

Me too. I rolled it back but I saw that Binhex was actively fixed some other issues so I tried updating to  the latest again just to see if it was fixed but it still is broken for me. It's seeding and all but the plugins are broken for me.

Ive now managed to solve my plugin issues by running the docker in priviliged mode.

Link to comment

This isn't an important issue but I was curious if there was a way to upload icons for more specific labels? I just prefer using, for example, the word "movies" which doesn't trigger an icon over "movie" (which does). I also have other words I'd like icons on. In other seedbox installs of ruTorrent I managed to find the folder that contained these icon files and it was as simple as copy/pasting the movie.png file and renaming it to movies.png. I couldn't find that folder in this docker, though. Best I could find is this folder that does contain all those icons: https://github.com/Novik/ruTorrent/tree/master/plugins/tracklabels/labels. So at least I have the files I could download and rename but I'm just not sure where to put them. Anyone know? Thanks!

Link to comment

I have a script that runs 10 minutes after CA auto update. This scripts add icons to labels I use and to trackers that dont have and icons/banner. It copies files from "trackers" and "labels" to the same directory inside the container. I have to run it after every update or it will reset.

 

#!/bin/bash
docker cp "/mnt/user/various/unRaid/icons/rutorrent/." binhex-rtorrentvpn:"/usr/share/webapps/rutorrent/plugins/tracklabels/"

 

  • Like 1
Link to comment
51 minutes ago, ProphetSe7en said:

I have a script that runs 10 minutes after CA auto update. This scripts add icons to labels I use and to trackers that dont have and icons/banner. It copies files from "trackers" and "labels" to the same directory inside the container. I have to run it after every update or it will reset.

 


#!/bin/bash
docker cp "/mnt/user/various/unRaid/icons/rutorrent/." binhex-rtorrentvpn:"/usr/share/webapps/rutorrent/plugins/tracklabels/"

 

 

I ended up making this folder: appdata\binhex-rtorrentvpn\rutorrent\user-plugins\tracklabels\labels which didn't exist before. And did what I outlined before and after restarting ruTorrent it works! I made a backup in case a docker update breaks it, as you mentioned. If so then I can copy that script. Thanks for the help!

Link to comment

Why is it a /user-plugins folder rather than a plugins /folder?  When I look up docs on rutorrent it talks about a plugins folder.  I initially created a plugins folder and added tracklabels.  That worked and I saw icons for stuff like movies, except the plugins folder got wiped when the docker restarted.  Then I tried adding the tracklabels to the user-plugins folder and the icons disappeared.  Weird.

Link to comment

So I finally got it working with wireguard, but no the web-ui wont load anymore. 

 

This is the same issue I had when updating the container so I had to use and older version.

 

To day i started over with a new install but stil no web ui :/

 

I found one error in the log, not sure if it is related. 

 

ERROR: could not load module /lib/modules/iptable_mangle.ko: No such file or directory

 

Edited by ProphetSe7en
Link to comment

I'm having trouble getting the torrent control firefox addon working. Every time I try to add a torrent from a magnet link I get the following error:

[error] 2296#2296: *1102 FastCGI sent in stderr: "PHP message: PHP Warning:  move_uploaded_file(/usr/share/webapps/rutorrent/share/torrents/temp.torrent): Failed to open stream: Permission denied in /usr/share/webapps/rutorrent/php/addtorrent.php on line 57
PHP message: PHP Warning:  move_uploaded_file(): Unable to move "/tmp/phpgJaY10" to "/usr/share/webapps/rutorrent/share/torrents/temp.torrent" in /usr/share/webapps/rutorrent/php/addtorrent.php on line 57" while reading response header from upstream, client: 192.168.1.194, server: localhost, request: "POST /php/addtorrent.php?json=1 HTTP/1.1", upstream: "fastcgi://127.0.0.1:7777", host: "192.168.1.221:9443"

 

I would greatly appreciate some help with this.

Edited by optibot
Link to comment
On 3/18/2021 at 8:24 PM, ProphetSe7en said:

So I finally got it working with wireguard, but no the web-ui wont load anymore. 

 

This is the same issue I had when updating the container so I had to use and older version.

 

To day i started over with a new install but stil no web ui :/

 

I found one error in the log, not sure if it is related. 

 


ERROR: could not load module /lib/modules/iptable_mangle.ko: No such file or directory

 

see the recommended post at the top of this screen.

Link to comment

Any reason why this seems incompatible with Nginx Proxy Manager?

 

Basically I have this running with the following port and IP settings:

 

1644036142_Screenshot_2021-03-23TowerUpdateContainer.thumb.png.01fa4f89ced510713913f1d0cd69512b.png

 

This means it runs on 192.168.1.50 which is the same local IP that my Unraid control panel is accessible by.

 

The problem is that Nginx Proxy Manager really seems to like it more when each container has its own IP address and the interface for each container is my br0 adapter. Eg. Hedgedoc @ 192.168.1.60, Ubooquity @ 192.168.1.61 etc.

 

When I try to use any other network interface for this container, the webui won't even load through its local IP. The webpage just stays loading forever. Though the log shows that the container is definitely running in the background.

 

The thing is, when using bridge Nginx Proxy Manager throws all sorts of errors. Firstly, it can't even determine the status of the container and secondly throws internal errors:

 

185055844_Screenshot_2021-03-23NginxProxyManager.png.12057f95e7e7b2c5d1a42a9fc446f49d.png

 

54028711_Screenshot_2021-03-23NginxProxyManager(1).thumb.png.fdc02c0c4e4d0477a0d93eef5e79eb42.png

 

I'm using the Pivoxy function if that matters. Nothing changes either if I choose to try and port forward 9080 or 9443 either. Even with the CNAME set up properly and all my other services/containers working via reverse proxy. For this container the page just doesn't load no matter what.

 

Here's my port forwarding setup:

 

415881654_Screenshot_2021-03-23ASUSWirelessRouterRT-AX88U-VirtualServerPortForwarding.png.6960d651d287493036bbddbaad7e6d18.png

 

Does anyone have any idea what seems to be the problem?

Link to comment

Hey I recently have been unable to run the WebUI for the docker and in checking the logs I'm getting the following errors:
 

2021-03-24 15:20:33 DEPRECATED OPTION: --cipher set to 'aes-128-cbc' but missing in --data-ciphers (AES-256-GCM:AES-128-GCM). Future OpenVPN version will ignore --cipher for cipher negotiations. Add 'aes-128-cbc' to --data-ciphers or change --cipher 'aes-128-cbc' to --data-ciphers-fallback 'aes-128-cbc' to silence this warning.

2021-03-24 15:20:33,395 DEBG 'start-script' stdout output:
2021-03-24 15:20:33 WARNING: file 'credentials.conf' is group or others accessible

 

There was another post talking about this one and theirs was fixed by a docker update, but mine is still having the issue. I'm using PIA and haven't had any issues for a while so not sure what's going on there.

Link to comment

 

1 hour ago, m0lle said:

Its a plugin. So maybe your plugins arent loading. What does the log inside rutorrent say?

I thought it was part of the core functionality.

[25.03.2021 19:02:07] WebUI started.
[25.03.2021 19:02:30] _cloudflare: Plugin will not work. rTorrent user can't access external program (python).
[25.03.2021 19:02:30] _task: Plugin will not work. rTorrent user can't access external program (php).
[25.03.2021 19:02:30] autotools: Plugin will not work. rTorrent user can't access external program (php).
[25.03.2021 19:02:30] create: Plugin will not work. rTorrent user can't access external program (php).
[25.03.2021 19:02:30] datadir: Plugin will not work. rTorrent user can't access external program (php).
[25.03.2021 19:02:30] history: Plugin will not work. rTorrent user can't access external program (php).
[25.03.2021 19:02:30] loginmgr: Some functionality will be unavailable. rTorrent user can't access external program (php).
[25.03.2021 19:02:30] ratio: Some functionality will be unavailable. rTorrent user can't access external program (php).
[25.03.2021 19:02:30] retrackers: Plugin will not work. rTorrent user can't access external program (php).
[25.03.2021 19:02:30] rss: Plugin will not work. rTorrent user can't access external program (php).
[25.03.2021 19:02:30] rutracker_check: Plugin will not work. rTorrent user can't access external program (php).
[25.03.2021 19:02:30] scheduler: Plugin will not work. rTorrent user can't access external program (php).
[25.03.2021 19:02:30] trafic: Plugin will not work. rTorrent user can't access external program (php).
[25.03.2021 19:02:30] unpack: Plugin will not work. rTorrent user can't access external program (php).
[25.03.2021 19:02:30] xmpp: Plugin will not work. rTorrent user can't access external program (php).
[25.03.2021 19:02:30] _task: Plugin will not work. rTorrent user can't access external program (pgrep).
[25.03.2021 19:02:30] mediainfo: Plugin will not work. rTorrent user can't access external program (mediainfo).
[25.03.2021 19:02:30] rss: Some functionality will be unavailable. rTorrent user can't access external program (curl).
[25.03.2021 19:02:30] screenshots: Plugin will not work. rTorrent user can't access external program (ffmpeg).
[25.03.2021 19:02:30] spectrogram: Plugin will not work. rTorrent user can't access external program (sox).

 

Is this related to it?

On 3/17/2021 at 5:19 PM, wayner said:

Why is it a /user-plugins folder rather than a plugins /folder?  When I look up docs on rutorrent it talks about a plugins folder.  I initially created a plugins folder and added tracklabels.  That worked and I saw icons for stuff like movies, except the plugins folder got wiped when the docker restarted.  Then I tried adding the tracklabels to the user-plugins folder and the icons disappeared.  Weird.

Link to comment

Sorry if this is a stupid question but I'm trying to get the scheduler to run properly in Rutorrent and have been having some problems with the start time. I did some searching and found out I needed to set the timezone to my area. I edited the php.ini and got it to work for a day but the setting is not sticking. I did some further searching and found this.

 

"If you do not define the PHP timezone you may see issues with the ruTorrent Scheduler plugin, please make sure you set the PHP timezone by specifying this using the environment variable PHP_TZ. Valid timezone values can be found here, http://php.net/manual/en/timezones.php"

 

Do I set the environment variable PHP_TZ.America/Chicago using the console command on the docker instead of the php.ini file? Seems simple enough but wanted to check to make sure I was doing it correctly.

Link to comment
1 hour ago, eman31 said:

Sorry if this is a stupid question but I'm trying to get the scheduler to run properly in Rutorrent and have been having some problems with the start time. I did some searching and found out I needed to set the timezone to my area. I edited the php.ini and got it to work for a day but the setting is not sticking. I did some further searching and found this.

 

"If you do not define the PHP timezone you may see issues with the ruTorrent Scheduler plugin, please make sure you set the PHP timezone by specifying this using the environment variable PHP_TZ. Valid timezone values can be found here, http://php.net/manual/en/timezones.php"

 

Do I set the environment variable PHP_TZ.America/Chicago using the console command on the docker instead of the php.ini file? Seems simple enough but wanted to check to make sure I was doing it correctly.

 

Edit the docker and set the timezone for the Key (mine is Key 20): Container Variable: PHP_TZ

Link to comment
1 hour ago, dh0llyw00d said:

 

Edit the docker and set the timezone for the Key (mine is Key 20): Container Variable: PHP_TZ

 

Thanks! It's been so long since I edited anything, it wasn't clicking in my brain. The environmental variable threw me off.

Edited by eman31
Link to comment
5 hours ago, Cull2ArcaHeresy said:

 

I thought it was part of the core functionality.


[25.03.2021 19:02:07] WebUI started.
[25.03.2021 19:02:30] _cloudflare: Plugin will not work. rTorrent user can't access external program (python).
[25.03.2021 19:02:30] _task: Plugin will not work. rTorrent user can't access external program (php).
[25.03.2021 19:02:30] autotools: Plugin will not work. rTorrent user can't access external program (php).
[25.03.2021 19:02:30] create: Plugin will not work. rTorrent user can't access external program (php).
[25.03.2021 19:02:30] datadir: Plugin will not work. rTorrent user can't access external program (php).
[25.03.2021 19:02:30] history: Plugin will not work. rTorrent user can't access external program (php).
[25.03.2021 19:02:30] loginmgr: Some functionality will be unavailable. rTorrent user can't access external program (php).
[25.03.2021 19:02:30] ratio: Some functionality will be unavailable. rTorrent user can't access external program (php).
[25.03.2021 19:02:30] retrackers: Plugin will not work. rTorrent user can't access external program (php).
[25.03.2021 19:02:30] rss: Plugin will not work. rTorrent user can't access external program (php).
[25.03.2021 19:02:30] rutracker_check: Plugin will not work. rTorrent user can't access external program (php).
[25.03.2021 19:02:30] scheduler: Plugin will not work. rTorrent user can't access external program (php).
[25.03.2021 19:02:30] trafic: Plugin will not work. rTorrent user can't access external program (php).
[25.03.2021 19:02:30] unpack: Plugin will not work. rTorrent user can't access external program (php).
[25.03.2021 19:02:30] xmpp: Plugin will not work. rTorrent user can't access external program (php).
[25.03.2021 19:02:30] _task: Plugin will not work. rTorrent user can't access external program (pgrep).
[25.03.2021 19:02:30] mediainfo: Plugin will not work. rTorrent user can't access external program (mediainfo).
[25.03.2021 19:02:30] rss: Some functionality will be unavailable. rTorrent user can't access external program (curl).
[25.03.2021 19:02:30] screenshots: Plugin will not work. rTorrent user can't access external program (ffmpeg).
[25.03.2021 19:02:30] spectrogram: Plugin will not work. rTorrent user can't access external program (sox).

 

Is this related to it?

Try running the docker in privileged mode.

  • Thanks 1
Link to comment
On 1/4/2021 at 1:34 PM, JackPo said:

actually, looked in my log and saw a bunch of issues around rtorrent listening to new IP after VPN reconnects, seems like it can't access rtxmlrpc.


[info] rTorrent listening interface IP 10.16.112.9 and VPN provider IP 10.26.112.111 different, marking for reconfigure




2021-01-04 14:33:45,124 DEBG 'watchdog-script' stdout output:


[info] rTorrent incoming port 45817 and VPN incoming port 50542 different, marking for reconfigure




2021-01-04 14:33:45,125 DEBG 'watchdog-script' stderr output:


/home/nobody/rtorrent.sh: line 13: rtxmlrpc: command not found




2021-01-04 14:33:45,125 DEBG 'watchdog-script' stderr output:


/home/nobody/rtorrent.sh: line 19: rtxmlrpc: command not found




2021-01-04 14:33:45,126 DEBG 'watchdog-script' stderr output:


/home/nobody/rtorrent.sh: line 24: rtxmlrpc: command not found



 

Did you ever resolve this? My Rtorrentvpn log shows this same thing over and over. 

 

It randomly happens and it will be down for hours/days. Sometimes it will fix itself after a certain period of time.

 

Any help would be appreciated!

Link to comment
On 3/24/2021 at 3:34 PM, cyriouslydylan said:

Hey I recently have been unable to run the WebUI for the docker and in checking the logs I'm getting the following errors:
 


2021-03-24 15:20:33 DEPRECATED OPTION: --cipher set to 'aes-128-cbc' but missing in --data-ciphers (AES-256-GCM:AES-128-GCM). Future OpenVPN version will ignore --cipher for cipher negotiations. Add 'aes-128-cbc' to --data-ciphers or change --cipher 'aes-128-cbc' to --data-ciphers-fallback 'aes-128-cbc' to silence this warning.

2021-03-24 15:20:33,395 DEBG 'start-script' stdout output:
2021-03-24 15:20:33 WARNING: file 'credentials.conf' is group or others accessible

 

There was another post talking about this one and theirs was fixed by a docker update, but mine is still having the issue. I'm using PIA and haven't had any issues for a while so not sure what's going on there.

I'm on latest, and I still can't access the webUI. Any help would be greatly appreciated. It's just refusing the connection:
"

Unable to connect

Firefox can’t establish a connection to the server at 192.168.x.xx:xxxx."

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.