[Support] binhex - rTorrentVPN


Recommended Posts

I'm not sure when exactly but all of a sudden the docker is no longer working. I didn't change anything but it updated to the latest version and I'm running unraid v6.8.2. Any ideas where to start?

 

image.thumb.png.91d774fd51a62a063986265e2a4fbf36.png

image.thumb.png.3dc4df68b6c36857f87049963f731111.png

2021-08-27 14:36:35 Socket Buffers: R=[212992->212992] S=[212992->212992]
2021-08-27 14:36:35 UDP link local: (not bound)
2021-08-27 14:36:35 UDP link remote: [AF_INET]50.7.136.139:8292

2021-08-27 14:37:35,524 DEBG 'start-script' stdout output:
2021-08-27 14:37:35 [UNDEF] Inactivity timeout (--ping-restart), restarting

2021-08-27 14:37:35,524 DEBG 'start-script' stdout output:
2021-08-27 14:37:35 SIGHUP[soft,ping-restart] received, process restarting

2021-08-27 14:37:35,524 DEBG 'start-script' stdout output:
2021-08-27 14:37:35 WARNING: Compression for receiving enabled. Compression has been used in the past to break encryption. Sent packets are not compressed unless "allow-compression yes" is also set.

2021-08-27 14:37:35 DEPRECATED OPTION: --max-routes option ignored.The number of routes is unlimited as of OpenVPN 2.4. This option will be removed in a future version, please remove it from your configuration.


2021-08-27 14:37:35,524 DEBG 'start-script' stdout output:
2021-08-27 14:37:35 DEPRECATED OPTION: --cipher set to 'AES-256-CBC' but missing in --data-ciphers (AES-256-GCM:AES-128-GCM). Future OpenVPN version will ignore --cipher for cipher negotiations. Add 'AES-256-CBC' to --data-ciphers or change --cipher 'AES-256-CBC' to --data-ciphers-fallback 'AES-256-CBC' to silence this warning.

2021-08-27 14:37:35 WARNING: file 'credentials.conf' is group or others accessible

2021-08-27 14:37:35 OpenVPN 2.5.0 [git:makepkg/a73072d8f780e888+] x86_64-pc-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [PKCS11] [MH/PKTINFO] [AEAD] built on Nov 6 2020
2021-08-27 14:37:35 library versions: OpenSSL 1.1.1j 16 Feb 2021, LZO 2.10
2021-08-27 14:37:35 Restart pause, 5 second(s)

2021-08-27 14:37:40,525 DEBG 'start-script' stdout output:
2021-08-27 14:37:40 WARNING: --ns-cert-type is DEPRECATED. Use --remote-cert-tls instead.

2021-08-27 14:37:40 NOTE: the current --script-security setting may allow this configuration to call user-defined scripts

2021-08-27 14:37:40,525 DEBG 'start-script' stdout output:
2021-08-27 14:37:40 Outgoing Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication
2021-08-27 14:37:40 Incoming Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication
2021-08-27 14:37:40 TCP/UDP: Preserving recently used remote address: [AF_INET]50.7.136.139:8292
2021-08-27 14:37:40 Socket Buffers: R=[212992->212992] S=[212992->212992]
2021-08-27 14:37:40 UDP link local: (not bound)
2021-08-27 14:37:40 UDP link remote: [AF_INET]50.7.136.139:8292

 

 

 

 

 

Edited by puncho
Link to comment
I'm not sure when exactly but all of a sudden the docker is no longer working. I didn't change anything but it updated to the latest version and I'm running unraid v6.8.2. Any ideas where to start?
 
image.thumb.png.91d774fd51a62a063986265e2a4fbf36.png
image.thumb.png.3dc4df68b6c36857f87049963f731111.png
2021-08-27 14:36:35 Socket Buffers: R=[212992->212992] S=[212992->212992]2021-08-27 14:36:35 UDP link local: (not bound)2021-08-27 14:36:35 UDP link remote: [AF_INET]50.7.136.139:82922021-08-27 14:37:35,524 DEBG 'start-script' stdout output:2021-08-27 14:37:35 [uNDEF] Inactivity timeout (--ping-restart), restarting2021-08-27 14:37:35,524 DEBG 'start-script' stdout output:2021-08-27 14:37:35 SIGHUP[soft,ping-restart] received, process restarting2021-08-27 14:37:35,524 DEBG 'start-script' stdout output:2021-08-27 14:37:35 WARNING: Compression for receiving enabled. Compression has been used in the past to break encryption. Sent packets are not compressed unless "allow-compression yes" is also set.2021-08-27 14:37:35 DEPRECATED OPTION: --max-routes option ignored.The number of routes is unlimited as of OpenVPN 2.4. This option will be removed in a future version, please remove it from your configuration.2021-08-27 14:37:35,524 DEBG 'start-script' stdout output:2021-08-27 14:37:35 DEPRECATED OPTION: --cipher set to 'AES-256-CBC' but missing in --data-ciphers (AES-256-GCM:AES-128-GCM). Future OpenVPN version will ignore --cipher for cipher negotiations. Add 'AES-256-CBC' to --data-ciphers or change --cipher 'AES-256-CBC' to --data-ciphers-fallback 'AES-256-CBC' to silence this warning.2021-08-27 14:37:35 WARNING: file 'credentials.conf' is group or others accessible2021-08-27 14:37:35 OpenVPN 2.5.0 [git:makepkg/a73072d8f780e888+] x86_64-pc-linux-gnu [sSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [PKCS11] [MH/PKTINFO] [AEAD] built on Nov 6 20202021-08-27 14:37:35 library versions: OpenSSL 1.1.1j 16 Feb 2021, LZO 2.102021-08-27 14:37:35 Restart pause, 5 second(s)2021-08-27 14:37:40,525 DEBG 'start-script' stdout output:2021-08-27 14:37:40 WARNING: --ns-cert-type is DEPRECATED. Use --remote-cert-tls instead.2021-08-27 14:37:40 NOTE: the current --script-security setting may allow this configuration to call user-defined scripts2021-08-27 14:37:40,525 DEBG 'start-script' stdout output:2021-08-27 14:37:40 Outgoing Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication2021-08-27 14:37:40 Incoming Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication2021-08-27 14:37:40 TCP/UDP: Preserving recently used remote address: [AF_INET]50.7.136.139:82922021-08-27 14:37:40 Socket Buffers: R=[212992->212992] S=[212992->212992]2021-08-27 14:37:40 UDP link local: (not bound)2021-08-27 14:37:40 UDP link remote: [AF_INET]50.7.136.139:8292

 
 
 
 
 

This sounds to me like a classic case of out of date VPN configuration file please go to your VPN provider and re-download the latest ovpn/wireguard configuration file

Sent from my CLT-L09 using Tapatalk

Link to comment
On 8/28/2021 at 12:59 AM, binhex said:

This sounds to me like a classic case of out of date VPN configuration file please go to your VPN provider and re-download the latest ovpn/wireguard configuration file

Sent from my CLT-L09 using Tapatalk
 

Thanks, that worked!

Link to comment

Hello, I just wanted to confirm is there's any special configuration needed when the VPN is disabled? I am able to access the webUI and download torrents but notice that I am not able to seed. I'm also having issues adding any RSS feeds. Only error I'm seeing is that port 6881 is closed. I appreciate the help.

 

Edit: I ended up switching to the qbittorrentvpn image instead, everything appears to be working out of the box.

Edited by ReadAmp
Link to comment

Just had to reimage my server and I'm trying to get rtorrent setup and its hanging at this step any idea? Running centos 8 

 


2021-09-03 14:40:52,276 DEBG 'watchdog-script' stdout output:,
[debug] DNS operational, we can resolve name 'www.google.com' to address '142.250.69.196',
[debug] Waiting for iptables chain policies to be in place...

Link to comment
On 9/3/2021 at 2:45 PM, waffles1702 said:

Just had to reimage my server and I'm trying to get rtorrent setup and its hanging at this step any idea? Running centos 8 

 


2021-09-03 14:40:52,276 DEBG 'watchdog-script' stdout output:,
[debug] DNS operational, we can resolve name 'www.google.com' to address '142.250.69.196',
[debug] Waiting for iptables chain policies to be in place...

 

Went digging and found below error from /tmp/getiptables any help is greatly appreciated. Tried doing a pacman update but didnt help any. 

 

modprobe: FATAL: Module ip_tables not found in directory /lib/modules/4.18.0-338.el8.x86_64
iptables v1.8.7 (legacy): can't initialize iptables table `filter': Table does not exist (do you need to insmod?)
Perhaps iptables or your kernel needs to be upgraded. 

Link to comment
7 hours ago, binhex said:

you need the above iptables table to be loaded in your hosts kernel, without this you cannot use this image.

It was actually much easier. Not sure if its a Centos 8 thing but just did a chmod 777 /lib/modules/4.18.0-338.el8.x86_64 and it booted as expected. 

  • Like 1
Link to comment

I'd search this topic but for some reason the search function is not working for me at the very moment.  So I'll just ask, is there a way to fix the date/time drift I get using this?  I'll notice the date/time of the download sometimes displays as some point in the future.  Restarting the container fixes it.  So there is some drift going on and I'm not sure the best way to go about fixing it.

Link to comment
43 minutes ago, Cat_Seeder said:

 

 

ah i see. sorry i totally missed that post. do you know the name of the default user if i want to use the command to change the password via that command; is it "root"? or do you recommend setting up a completely separate user and leaving the default as is?

 

docker exec -it rtorrent /home/nobody/createuser.sh <username to create> <password for the user>

docker exec -it rtorrent /home/nobody/deluser.sh <username to delete>

 

Edited by Linguafoeda
Link to comment
6 minutes ago, Linguafoeda said:

ah i see. sorry i totally missed that post. do you know the name of the default user if i want to use the `-docker exec -it <container name> /home/nobody/deluser.sh <username to delete>` command to change the password via that command? or do you recommend setting up a completely separate user and leaving the default as is?

It's whatever you have set with the env variables. Just delete it, recreate it with a new password and later remove the env variables (or not, leave them as a distraction to anyone trying to hack into your container).

Edited by Cat_Seeder
Link to comment
9 minutes ago, Cat_Seeder said:

It's whatever you have set with the env variables. Just delete it, recreate it with a new password and later edit the env variables (or not, leave them as a distraction go anyone trying to hack into your container).

 

do you know the command to change username's password, i see "createuser.sh" and "deluser.sh"

Link to comment
On 9/6/2021 at 1:28 AM, binhex said:

you need the above iptables table to be loaded in your hosts kernel, without this you cannot use this image.

This issue came back with no changes to the os. Any idea what the cause can be on the latest centos 8. i can run this ( iptables -t filter -L ) command with no issues and get a print out on the host so not sure where to go with this.

 

 

 Container says this. 

modprobe: FATAL: Module ip_tables not found in directory /lib/modules/4.18.0-338.el8.x86_64
iptables v1.8.7 (legacy): can't initialize iptables table `filter': Table does not exist (do you need to insmod?)
Perhaps iptables or your kernel needs to be upgraded.  

Edited by waffles1702
miss spelled
Link to comment

Hi

 

Don't know what is going on with ruTorrent, suddenly there were no torrents downloading so I restarted it hoping that would fix it and now no torrents are even showing up and the WebUI skin has reverted back to the standard. It's like it's a new install. Can someone help me get all my torrents back please, not sure what I need to supply to assist. 

 

Edit - No worries just updated my vpn credentials and that fixed it.

 

Edit - Now I have (received status code 400) and (This site can’t be reached). The only thing I can think of is that I recently replaced my modem/router, not sure what to do.

Edited by azmaril
Link to comment

Hi,

 

As of last night my Rtorrent docker has not been able to connect to my wireguard vpn. It has worked fine before. After restarting the docker the logs reads: 

 

2021-09-21 12:31:51.574285 [info] Host is running unRAID
2021-09-21 12:31:51.593068 [info] System information Linux 207c0e46b1fe 5.10.28-Unraid #1 SMP Wed Apr 7 08:23:18 PDT 2021 x86_64 GNU/Linux
2021-09-21 12:31:51.616380 [info] OS_ARCH defined as 'x86-64'
2021-09-21 12:31:51.636952 [info] PUID defined as '99'
2021-09-21 12:31:51.659593 [info] PGID defined as '100'
2021-09-21 12:31:52.039318 [info] UMASK defined as '000'
2021-09-21 12:31:52.059801 [info] Permissions already set for volume mappings
2021-09-21 12:31:52.080852 [info] Deleting files in /tmp (non recursive)...
2021-09-21 12:31:52.105172 [info] VPN_ENABLED defined as 'yes'
2021-09-21 12:31:52.126454 [info] VPN_CLIENT defined as 'wireguard'
2021-09-21 12:31:52.146945 [info] VPN_PROV defined as 'custom'
2021-09-21 12:31:52.171915 [info] WireGuard config file (conf extension) is located at /config/wireguard/wg0.conf
2021-09-21 12:31:52.200537 [info] VPN_REMOTE_SERVER defined as 'xxx.xxx.xxx.xx'
2021-09-21 12:31:52.221321 [info] VPN_REMOTE_PORT defined as '51820'
2021-09-21 12:31:52.239716 [info] VPN_DEVICE_TYPE defined as 'wg0'
2021-09-21 12:31:52.258146 [info] VPN_REMOTE_PROTOCOL defined as 'udp'
2021-09-21 12:31:52.279023 [info] LAN_NETWORK defined as '192.168.1.0/24'
2021-09-21 12:31:52.299862 [info] NAME_SERVERS defined as '209.222.18.222,84.200.69.80,37.235.1.174,1.1.1.1,209.222.18.218,37.235.1.177,84.200.70.40,1.0.0.1'
2021-09-21 12:31:52.320676 [info] VPN_USER defined as 'vpn username'
2021-09-21 12:31:52.341422 [info] VPN_PASS defined as 'vpn password'
2021-09-21 12:31:52.362140 [info] ENABLE_PRIVOXY defined as 'no'
2021-09-21 12:31:52.384918 [info] VPN_INPUT_PORTS not defined (via -e VPN_INPUT_PORTS), skipping allow for custom incoming ports
2021-09-21 12:31:52.405474 [info] VPN_OUTPUT_PORTS not defined (via -e VPN_OUTPUT_PORTS), skipping allow for custom outgoing ports
2021-09-21 12:31:52.426109 [info] ENABLE_AUTODL_IRSSI defined as 'no'
2021-09-21 12:31:52.446703 [info] ENABLE_RPC2 defined as 'yes'
2021-09-21 12:31:52.467442 [info] ENABLE_RPC2_AUTH defined as 'yes'
2021-09-21 12:31:52.488001 [info] RPC2_USER defined as 'admin'
2021-09-21 12:31:52.508560 [info] RPC2_PASS defined as 'xxxxxx'
2021-09-21 12:31:52.530006 [info] ENABLE_WEBUI_AUTH defined as 'yes'
2021-09-21 12:31:52.550776 [info] WEBUI_USER defined as 'admin'
2021-09-21 12:31:52.571678 [info] WEBUI_PASS defined as 'xxxxxx'
2021-09-21 12:31:52.592350 [info] Starting Supervisor...
2021-09-21 12:31:52,721 INFO Included extra file "/etc/supervisor/conf.d/rtorrent.conf" during parsing
2021-09-21 12:31:52,721 INFO Set uid to user 0 succeeded
2021-09-21 12:31:52,723 INFO supervisord started with pid 7
2021-09-21 12:31:53,725 INFO spawned: 'logrotate-script' with pid 184
2021-09-21 12:31:53,726 INFO spawned: 'pyrocore-script' with pid 185
2021-09-21 12:31:53,728 INFO spawned: 'rutorrent-script' with pid 186
2021-09-21 12:31:53,730 INFO spawned: 'shutdown-script' with pid 187
2021-09-21 12:31:53,731 INFO spawned: 'start-script' with pid 188
2021-09-21 12:31:53,733 INFO spawned: 'watchdog-script' with pid 192
2021-09-21 12:31:53,734 INFO reaped unknown pid 8 (exit status 0)
2021-09-21 12:31:53,746 DEBG 'start-script' stdout output:
[info] VPN is enabled, beginning configuration of VPN

2021-09-21 12:31:53,746 INFO success: logrotate-script entered RUNNING state, process has stayed up for > than 0 seconds (startsecs)
2021-09-21 12:31:53,746 INFO success: pyrocore-script entered RUNNING state, process has stayed up for > than 0 seconds (startsecs)
2021-09-21 12:31:53,746 INFO success: rutorrent-script entered RUNNING state, process has stayed up for > than 0 seconds (startsecs)
2021-09-21 12:31:53,747 INFO success: shutdown-script entered RUNNING state, process has stayed up for > than 0 seconds (startsecs)
2021-09-21 12:31:53,747 INFO success: start-script entered RUNNING state, process has stayed up for > than 0 seconds (startsecs)
2021-09-21 12:31:53,747 INFO success: watchdog-script entered RUNNING state, process has stayed up for > than 0 seconds (startsecs)
2021-09-21 12:31:53,749 DEBG 'start-script' stdout output:
[info] Adding 209.222.18.222 to /etc/resolv.conf

2021-09-21 12:31:53,750 DEBG 'watchdog-script' stdout output:
[info] rTorrent config file already exists, skipping copy

2021-09-21 12:31:53,753 DEBG 'start-script' stdout output:
[info] Adding 84.200.69.80 to /etc/resolv.conf

2021-09-21 12:31:53,756 DEBG 'start-script' stdout output:
[info] Adding 37.235.1.174 to /etc/resolv.conf

2021-09-21 12:31:53,760 DEBG 'start-script' stdout output:
[info] Adding 1.1.1.1 to /etc/resolv.conf

2021-09-21 12:31:53,764 DEBG 'start-script' stdout output:
[info] Adding 209.222.18.218 to /etc/resolv.conf

2021-09-21 12:31:53,767 DEBG 'start-script' stdout output:
[info] Adding 37.235.1.177 to /etc/resolv.conf

2021-09-21 12:31:53,770 DEBG 'start-script' stdout output:
[info] Adding 84.200.70.40 to /etc/resolv.conf

2021-09-21 12:31:53,773 DEBG 'start-script' stdout output:
[info] Adding 1.0.0.1 to /etc/resolv.conf

2021-09-21 12:31:53,777 DEBG 'start-script' stdout output:
185.195.233.68

2021-09-21 12:31:53,801 DEBG 'start-script' stdout output:
[info] Default route for container is 192.168.1.1

2021-09-21 12:31:53,811 DEBG 'start-script' stdout output:
[info] Docker network defined as 192.168.1.0/24

2021-09-21 12:31:53,814 DEBG 'start-script' stdout output:
[info] Adding 192.168.1.0/24 as route via docker eth0

2021-09-21 12:31:53,815 DEBG 'start-script' stderr output:
RTNETLINK answers: File exists

2021-09-21 12:31:53,815 DEBG 'start-script' stdout output:
[info] ip route defined as follows...
--------------------

2021-09-21 12:31:53,816 DEBG 'start-script' stdout output:
default via 192.168.1.1 dev eth0
192.168.1.0/24 dev eth0 proto kernel scope link src 192.168.1.96

2021-09-21 12:31:53,816 DEBG 'start-script' stdout output:
broadcast 127.0.0.0 dev lo table local proto kernel scope link src 127.0.0.1
local 127.0.0.0/8 dev lo table local proto kernel scope host src 127.0.0.1
local 127.0.0.1 dev lo table local proto kernel scope host src 127.0.0.1
broadcast 127.255.255.255 dev lo table local proto kernel scope link src 127.0.0.1
broadcast 192.168.1.0 dev eth0 table local proto kernel scope link src 192.168.1.96
local 192.168.1.96 dev eth0 table local proto kernel scope host src 192.168.1.96
broadcast 192.168.1.255 dev eth0 table local proto kernel scope link src 192.168.1.96
--------------------

2021-09-21 12:31:53,819 DEBG 'start-script' stdout output:
iptable_mangle 16384 0
ip_tables 28672 4 iptable_filter,iptable_raw,iptable_nat,iptable_mangle
x_tables 28672 14 ip6table_filter,xt_conntrack,iptable_filter,xt_tcpudp,xt_addrtype,xt_nat,xt_comment,ip6_tables,xt_connmark,iptable_raw,ip_tables,xt_MASQUERADE,iptable_mangle,xt_mark

2021-09-21 12:31:53,819 DEBG 'start-script' stdout output:
[info] iptable_mangle support detected, adding fwmark for tables

2021-09-21 12:31:53,860 DEBG 'start-script' stdout output:
[info] iptables defined as follows...
--------------------

2021-09-21 12:31:53,862 DEBG 'start-script' stdout output:
-P INPUT DROP
-P FORWARD DROP
-P OUTPUT DROP
-A INPUT -s 192.168.1.0/24 -d 192.168.1.0/24 -j ACCEPT
-A INPUT -s xxx.xxx.xxx.xx/32 -i eth0 -j ACCEPT
-A INPUT -i eth0 -p tcp -m tcp --dport 9080 -j ACCEPT
-A INPUT -i eth0 -p udp -m udp --dport 9080 -j ACCEPT
-A INPUT -i eth0 -p tcp -m tcp --dport 9443 -j ACCEPT
-A INPUT -i eth0 -p udp -m udp --dport 9443 -j ACCEPT
-A INPUT -s 192.168.1.0/24 -d 192.168.1.0/24 -i eth0 -p tcp -m tcp --dport 5000 -j ACCEPT
-A INPUT -p icmp -m icmp --icmp-type 0 -j ACCEPT
-A INPUT -i lo -j ACCEPT
-A INPUT -i wg0 -j ACCEPT
-A OUTPUT -s 192.168.1.0/24 -d 192.168.1.0/24 -j ACCEPT
-A OUTPUT -d xxx.xxx.xxx.xx/32 -o eth0 -j ACCEPT
-A OUTPUT -o eth0 -p tcp -m tcp --sport 9080 -j ACCEPT
-A OUTPUT -o eth0 -p udp -m udp --sport 9080 -j ACCEPT
-A OUTPUT -o eth0 -p tcp -m tcp --sport 9443 -j ACCEPT
-A OUTPUT -o eth0 -p udp -m udp --sport 9443 -j ACCEPT
-A OUTPUT -s 192.168.1.0/24 -d 192.168.1.0/24 -o eth0 -p tcp -m tcp --sport 5000 -j ACCEPT
-A OUTPUT -p icmp -m icmp --icmp-type 8 -j ACCEPT
-A OUTPUT -o lo -j ACCEPT
-A OUTPUT -o wg0 -j ACCEPT

2021-09-21 12:31:53,863 DEBG 'start-script' stdout output:
--------------------

2021-09-21 12:31:53,865 DEBG 'start-script' stdout output:
[info] Attempting to bring WireGuard interface 'up'...

2021-09-21 12:31:53,871 DEBG 'start-script' stderr output:
Warning: `/config/wireguard/wg0.conf' is world accessible


2021-09-21 12:31:53,876 DEBG 'start-script' stderr output:
[#] ip link add wg0 type wireguard

2021-09-21 12:31:53,877 DEBG 'start-script' stderr output:
[#] wg setconf wg0 /dev/fd/63

2021-09-21 12:31:53,883 DEBG 'start-script' stderr output:
[#] ip -4 address add xx.xx.xx.1xx/32 dev wg0

2021-09-21 12:31:53,887 DEBG 'start-script' stderr output:
[#] ip link set mtu 1420 up dev wg0

2021-09-21 12:31:53,894 DEBG fd 11 closed, stopped monitoring <POutputDispatcher at 22986149568368 for <Subprocess at 22986149567696 with name pyrocore-script in state RUNNING> (stdout)>
2021-09-21 12:31:53,894 DEBG fd 15 closed, stopped monitoring <POutputDispatcher at 22986149055024 for <Subprocess at 22986149567696 with name pyrocore-script in state RUNNING> (stderr)>
2021-09-21 12:31:53,895 INFO exited: pyrocore-script (exit status 0; expected)
2021-09-21 12:31:53,895 DEBG received SIGCHLD indicating a child quit
2021-09-21 12:31:53,896 DEBG 'start-script' stderr output:
[#] resolvconf -a wg0 -m 0 -x

2021-09-21 12:31:53,908 DEBG 'start-script' stderr output:
[#] wg set wg0 fwmark 51820

2021-09-21 12:31:53,908 DEBG 'start-script' stderr output:
[#] ip -4 route add 0.0.0.0/0 dev wg0 table 51820

2021-09-21 12:31:53,909 DEBG 'start-script' stderr output:
[#] ip -4 rule add not fwmark 51820 table 51820

2021-09-21 12:31:53,910 DEBG 'start-script' stderr output:
[#] ip -4 rule add table main suppress_prefixlength 0

2021-09-21 12:31:53,912 DEBG 'start-script' stderr output:
[#] sysctl -q net.ipv4.conf.all.src_valid_mark=1

2021-09-21 12:31:53,913 DEBG 'start-script' stderr output:
[#] iptables-restore -n

2021-09-21 12:31:53,915 DEBG 'start-script' stderr output:
[#] '/root/wireguardup.sh'

It hangs at the last line. What could cause this?

PS. I censored some bits with xxx. Okay this is gonna sound really dumb but the vpn subscription had ended. Renewed and fixed.

Edited by Wieuwzak
Link to comment

Does anyone know how to make use of autotools inside the docker?  I have it creating a symbolic link to the file when its done which works fine.  The issue is, that symbolic link doesnt work outside the docker since it points to a location inside the docker.  ie. /data/complete  
 

Is there a way I can make the symbolic link use a different path like: /mnt/disks/unassigned/torrent/complete so that I can run my scripts outside of the docker to sort out where to permanently store the files?

 

It seems like I can do it in the rtorrent.rc file but the scripting is not clear to me on how it works.

 

There is a line that is kind of what I need but I wanted to change it to a symbolic link and hardcode the path /mnt/disks/unassigned/torrent/complete instead of /data/completed/ but then it isnt able to save the link since /mnt/disks/unassigned/torrent/complete doesnt exist in the docker.

 

system.method.set_key = event.download.finished,move_complete,"execute=mv,-u,$d.get_base_path=,/data/completed/;d.set_directory=/data/completed/"

 

Any ideas or help?

 

Edit: I just made a bash script to do it instead of fighting with rtorrent cryptic syntax.  The download finished event simply triggers a bash script to create the symlink.

Edited by RAINMAN
Link to comment

I have tried everything so i want to resort here for a question that hopefully somebody can answer (thanks in advance for the kind soul haha).

 

I setup a subnet for my unraid server. It is 10.0.20.0/24 for the unraid network. My main LAN is 10.0.0.0/24. I have rtorrentvpn running on the unraid network and I fixed the IP to 10.0.20.20. I put the variable LAN_Network = 10.0.20.0/24.

 

What am I doing wrong? I can go to the 10.0.20.20 address in chrome and put in my username + password. It resolves fine! However, when I use sonarr, radarr and all of the other ARR apps, I cannot connect to rtorrent. I have tried putting the name of the container for the host. I have also tried putting the IP itself i.e. 10.0.20.20. The port number is 9080 so I know thats not the issue.

 

I am out of ideas as i have tried a lot of different things. One thing i should mention is that when my unraid server was on my main lan (10.0.0.0/24), I didnt have any issues. I set the IP address fixed for rtorrentVPN to 10.0.0.20 and everything worked perfectly fine. It seems now that it is on a subet of 10.0.20.0/24, the ARR apps cannot communicate with rtorrentvpn anymore.....All of the ARR apps are on the same subnet and they all communicate with each other no problem. Only rtorrentvpn is having issues...

 

Any ideas are appreciated.

Edited by ritty
Link to comment

I have the default download directory set in rtorrent.rc as /data/downloads/ but torrents coming from Sonarr are getting added with the wrong directory specifically:  /downloads/label/filename instead of the intended /data/downloads/label/filename.  Torrents coming from Radarr, on the other hand, are added correctly (/data/downloads/label/filename)  

 

All three containers have /data/ mapped to the same share directory /usr/share/Plex

 

Normally I would think this is a Sonarr problem but the research I have done suggests that the download directory is set by the downloader and all sonarr/radarr does is pass the torrent file to the download client. Any idea how I can fix this so that the torrents coming from Sonarr get added to the default download directory?

Link to comment
9 minutes ago, doctapeppa said:

...

Normally I would think this is a Sonarr problem but the research I have done suggests that the download directory is set by the downloader and all sonarr/radarr does is pass the torrent file to the download client.

 

Not true. Go to the Sonarr download clients settings page, enable advanced settings, and you'll be able to set the download directory that Sonarr tells rTorrent to use. This might be mismatched.

Additionally, you may have some setting differences with the category tag that is causing rTorrent to behave differently.

Edited by Imanoob
Additional info
Link to comment
27 minutes ago, Imanoob said:

 

Not true. Go to the Sonarr download clients settings page, enable advanced settings, and you'll be able to set the download directory that Sonarr tells rTorrent to use. This might be mismatched.

Additionally, you may have some setting differences with the category tag that is causing rTorrent to behave differently.

You are the man!! I had checked and triple checked all the settings in the download client settings in Sonarr but I had no idea that enabling  "show advanced" would show extra options inside the download settings as well as outside.  What a terrible design! Thank you kind sir. 

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.