[Support] binhex - rTorrentVPN


2554 posts in this topic Last Reply

Recommended Posts

 
Ah thanks for the update. should have checked. cheers
 
Is there any EU server that ppl would recommend now? from what i can see swedish server has best throughput?
Don't worry about closest, go with fastest

Sent from my SM-G935F using Tapatalk

Link to post
  • Replies 2.6k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

OK guys, multi remote endpoint support is now in for this image please pull down the new image (this change will be rolled out to all my vpn images shortly).   What this means is that the im

its very possible that there was an issue with autodl-irssi at the time of the build (pulls from master branch), and this issue has now been resolved, so subsequent builds are ok, i will create a new

Just updated it. That fixed it. Thank you very much

Posted Images

9 hours ago, binhex said:

Switch to an Endpoint that supports port forwarding or set strict port forwarding to no (not recommended).

Sent from my SM-G935F using Tapatalk
 

Yes, change from Holland to Sweden in /mnt/user/appdata/binhex-rtorrentvpn/openvpn works.

Link to post

I'm not trying to be bothersome, but I'm still having issues and if there's anything else I can do or any other kind of information you need please let me know. I've went through a complete reinstall of unraid plus all of my docker containers and stuff. I started from fresh settings too (as in, I renamed the old folder so that the docker would start with brand new downloaded files), the only thing I carried over was my array data. I do appreciate your time

 

This line shows up, I'll look into it but maybe it's helpful for you

2018-08-22 17:35:21,321 DEBG 'rutorrent-script' stderr output:
[NOTICE] [pool www] 'user' directive is ignored when FPM is not running as root
[NOTICE] [pool www] 'group' directive is ignored when FPM is not running as root


 

Edited by destrugter
Link to post

hi

   cannot  any  one  help us  with  this issue

 

for  some  reason   rctorrent.rc  file  I  change to limit  the  upload  speed  does not  change anything

 

I manually  change it  in the program  it self  put  each days  it  resets it self

 

 

thanks

 

 

backupking

Link to post

Hi

 

Just wanna start of with saying thank you for an awesome container! I've been running separate solutions for a long while trying to find that 1 container which has all components in it. Unfortunately I'm facing some issues with rtorrent process stopping, VPN, autodl etc is still working but not rtorrent.

Checking the supervisord log I can't find anything obvious, are there any other logs I should check? 
This happens once or several times per day, I'm guessing it occurs when it loads torrent automatically but I cant reproduce the error myself by adding torrents in my watch folders. 

I Updated to version 0.9.7-1-09 2 weeks ago. Ubuntu 18 as the host, I hope thats OK even though this is the unraid forum! 

Added some info via hastebin to not make this post to long

Supervisord.loghttps://hastebin.com/qerewuvona.coffeescript

One error i find that is present every time is: (URL is changed "my.url.com)
 

Quote

 

2018-08-30 08:11:12,656 DEBG 'rutorrent-script' stderr output:
2018/08/30 08:11:12 [error] 2414#2414: *3 open() "/usr/share/webapps/rutorrent/plugins/autodl-irssi/lang/sv.js" failed (2: No such file or directory), client: 172.17.0.1, server: localhost, request: "GET /plugins/autodl-irssi/lang/sv.js HTTP/1.1", host: "my.url.com", referrer: "https://my.url.com/"


2018-08-30 08:26:37,807 DEBG 'rutorrent-script' stderr output:
2018/08/30 08:26:37 [error] 2414#2414: *1392 open() "/usr/share/webapps/rutorrent/plugins/autodl-irssi/lang/sv.js" failed (2: No such file or directory), client: 172.17.0.1, server: localhost, request: "GET /plugins/autodl-irssi/lang/sv.js HTTP/1.1", host: "my.url.com", referrer: "https://my.url.com/"

 

 

 

 

My cert file for the vpnhttps://hastebin.com/mahomukeci.coffeescript

 

rtorrent.rc https://hastebin.com/ixasugayig.shell

Only special thing I have here is 

Quote

schedule2 = watch_directory_1,5,5,"load.start=./data/Movies/*.torrent,d.directory.set=/data/Movies/"


 




 

Edited by martikainen
Link to post

This docker has suddenly stopped working for me. Latest version of the docker/latest version of Unraid

 

It Starts ok, but the log floods with the following:

 

2018-08-31 10:22:45,960 DEBG 'start-script' stdout output:
[warn] Response code 000 from curl != 2xx
[warn] Exit code 7 from curl != 0
[info] 1 retries left
[info] Retrying in 10 secs...
 

I can't connect to the UI

 

Any ideas?

Link to post
On 8/31/2018 at 3:25 PM, newoski said:

This docker has suddenly stopped working for me. Latest version of the docker/latest version of Unraid

 

It Starts ok, but the log floods with the following:

 

2018-08-31 10:22:45,960 DEBG 'start-script' stdout output:
[warn] Response code 000 from curl != 2xx
[warn] Exit code 7 from curl != 0
[info] 1 retries left
[info] Retrying in 10 secs...
 

I can't connect to the UI

 

Any ideas?

see second post in this thread.

Link to post
2 minutes ago, newoski said:

Is there an alternativr Netherlands VPN option that remains compatible?

 


Sent from my Pixel 2 using Tapatalk
 

 

its all detailed in that second post there is a link to all endpoints that support port forwarding (which is what netherlands used to support).

Link to post

Sorry, I meant a different VPN provider that has Netherlands endpoints compatible with your docker?

 

its all detailed in that second post there is a link to all endpoints that support port forwarding (which is what netherlands used to support).

 

Sent from my Pixel 2 using Tapatalk

 

 

 

Link to post
  • 2 weeks later...

I seem to have a problem tunning both rutorrent and flood. Am I alone with this?

Running both I get this after a while: 

 

Quote

111: Connection refused) while connecting to upstream, client: , server: localhost, request: "POST /RPC2 HTTP/1.1", upstream: "scgi://127.0.0.1:5000",

 

And then the download speeds goes down to 0. Disabled flood now, and the problem doesn’t occur. 

 

Edit: Seems that I get that error no matter what. 

Edited by Ritt
Link to post
PIA now supports AES GCM. Is it possible to make that the default cypher? It's less than half the CPU cost, or double the bandwidth if you're maxing out one core.
 
Thanks.
In that case you should simply download the newer ovpn config file that includes the new encryption type and replace the one in /config/openvpn/

Sent from my SM-G935F using Tapatalk

Link to post
On 9/15/2018 at 12:30 PM, Ritt said:

I seem to have a problem tunning both rutorrent and flood. Am I alone with this?

Running both I get this after a while:

 

 

And then the download speeds goes down to 0. Disabled flood now, and the problem doesn’t occur.

 

Edit: Seems that I get that error no matter what.

Im having a similar issue. Its like I have to restart this Docker daily or I will find that I get connection refused errors on it and the torrents are no longer seeding. One time, it had been WEEKS that this thing was unresponsive. I dont know why this is happening now, been using this Docker since the very beginning and never had this problem.

 

Maybe I should give the Docker its on IP?

Link to post

Trying to get rtorrent to execute a script sitting after it's done downloading, is there any reason

method.set_key=event.download.finished,filebot,"execute={/home/rtorrent-postprocess.sh,$d.base_path=,$d.name=,$d.custom1=}"

doesn't seem to work? I gave the script all permissions and the first thing it does is echo into a file so I'm pretty sure it's not being called.

 

On a separate note I found an interesting (although unfortunately really old) thread on some forums about having deluge handle downloading and then having it pass the download off to rtorrent after it's done. 

In order to do something like that I would have to be able to, through the docker, point it at a torrent file to import and tell it where to find it. Is something like this currently possible? 

Edited by FireFtw
update
Link to post
The UI is empty and unresponsive 90% of the time for me. I have about 20 complete torrents total. No errors in log. Restarting docker doesn't fix it.
"The request to rTorrent has timed out."
Are you by any chance using mirrored cache drives. or have /config pointing at host path /mnt/user/....

Sent from my SM-G935F using Tapatalk

Link to post

Hi!

 

The docker was working perfectly for a long time >1 month but I found today that my ratio groups and scheduler settings have been lost.

I have backups of my appdata folder and tried to copy it back but this didnt fix it.

 

Where are those settings stored?

I think this happened after the last update.

 

Thank you!

Edited by karateo
Link to post
[mention=11148]binhex[/mention] For some reason the docker doesn't have the rutorrent Screenshot Plugin I tried downloading it from github and adding it into
 
appdata/binhex-rtorrentvpn/rutorrent/user-plugins/
 
but it doesn't look like it's installed after restarting the docker... Would be very grateful for any help. Thanks
Done, please pull down new image

Sent from my SM-G935F using Tapatalk

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.