Jump to content
binhex

[Support] binhex - rTorrentVPN

1630 posts in this topic Last Reply

Recommended Posts

I have fixed the auto transferring with sonarr

 

I had mapped the /mnt/downloads (host) to /dowloads  (in sonarr container) 

it should reallt be /mnt/downloads : /data  

 

Things are working rather nicely  Kudos to the Rutorrwent vpn integration 

 

I struggled with building a nord VPN  container and trying to link rutorrent container too it  (i'll need much more docker experience) 

Share this post


Link to post
1 hour ago, nikko-wolf said:

I had mapped the /mnt/downloads (host)

If you typed that accurately, you will quickly fill up RAM. Can you post a screenshot of the docker settings for this container please?

Share this post


Link to post

Has Flood stopped working with the new update for anyone else? Rutorrent works fine, but flood isnt. Im seeing 
 



2019-01-06 00:01:11,964 DEBG fd 17 closed, stopped monitoring <POutputDispatcher at 22911187286784 for <Subprocess at 22911187284840 with name flood-script in state RUNNING> (stdout)>
2019-01-06 00:01:11,964 DEBG fd 21 closed, stopped monitoring <POutputDispatcher at 22911187287072 for <Subprocess at 22911187284840 with name flood-script in state RUNNING> (stderr)>
2019-01-06 00:01:11,964 INFO exited: flood-script (exit status 0; expected)

In the logs. 

Share this post


Link to post
Posted (edited)

Hello, I just installed rtorrentvpn and got it all setup. I'm trying to use autodl-irssi however it isn't connecting to ANY irc servers. I've done it on other rtorrent's with no problem. Any ideas on what would be causing this? I use PIA as my vpn and rtorrent is running just fine. No errors on autodl or rtorrent. Just doesn't try to connect to irc servers I set.

 

Thanks for the container and any help!

 

EDIT: I fixed the issue, it's not irssi, it's the irc server has banned VPN access. So to fix this, A workaround is use rtorrent and irssi to download ONLY watch files with VPN disabled. Then use Binhex's deluge or Qbittorrent docker to pick up said watch files and have VPN turned on with them.

Edited by Turbo123

Share this post


Link to post
Posted (edited)

Hi,

I have a problem.

 

ruTorrent isn't displaying the full path of a torrent in the ‘Save As’ field of the ‘General’ tab for a selected torrent. Regardless of what the full path is it only displays the ‘Save to’ location (for me: ‘/media/downloads/torrent/completed’). This is making it impossible for me to copy a path or filename for a torrent within ruTorrent.

 

Example - same torrent:

This docker: https://i.imgur.com/WxutTCm.png

linuxserver docker: https://i.imgur.com/0f2jU7r.png

 

How to fix this?

 

PS: I have it like that from start.

Edited by bonk1990

Share this post


Link to post
On 1/6/2019 at 5:07 AM, wisemanofhyrule said:

Has Flood stopped working with the new update for anyone else? Rutorrent works fine, but flood isnt. Im seeing 
 




2019-01-06 00:01:11,964 DEBG fd 17 closed, stopped monitoring <POutputDispatcher at 22911187286784 for <Subprocess at 22911187284840 with name flood-script in state RUNNING> (stdout)>
2019-01-06 00:01:11,964 DEBG fd 21 closed, stopped monitoring <POutputDispatcher at 22911187287072 for <Subprocess at 22911187284840 with name flood-script in state RUNNING> (stderr)>
2019-01-06 00:01:11,964 INFO exited: flood-script (exit status 0; expected)

In the logs. 

yep flood is currently broken, basically the last release is now so old it no longer builds, thus i was forced to switch to the latest master commit, which is quite different in the procedure for building, so short story is im aware of it being broken and its on my todo list.

Share this post


Link to post
4 hours ago, bonk1990 said:

Hi,

I have a problem.

 

ruTorrent isn't displaying the full path of a torrent in the ‘Save As’ field of the ‘General’ tab for a selected torrent. Regardless of what the full path is it only displays the ‘Save to’ location (for me: ‘/media/downloads/torrent/completed’). This is making it impossible for me to copy a path or filename for a torrent within ruTorrent.

 

Example - same torrent:

This docker: https://i.imgur.com/WxutTCm.png

linuxserver docker: https://i.imgur.com/0f2jU7r.png

 

How to fix this?

 

PS: I have it like that from start.

 

I think I know how to fix your issue,

 

https://prnt.sc/m41qls - in your rutorrent settings you need to go to autotools and select the two check boxes "Add torrent's label to path" & "Add torrent's name to path"

 

After doing so only new torrents will show the full path. 

 

Example: https://prnt.sc/m41tei

Share this post


Link to post
Posted (edited)
On 1/5/2019 at 11:07 PM, wisemanofhyrule said:

Has Flood stopped working with the new update for anyone else? Rutorrent works fine, but flood isnt. Im seeing 
 




2019-01-06 00:01:11,964 DEBG fd 17 closed, stopped monitoring <POutputDispatcher at 22911187286784 for <Subprocess at 22911187284840 with name flood-script in state RUNNING> (stdout)>
2019-01-06 00:01:11,964 DEBG fd 21 closed, stopped monitoring <POutputDispatcher at 22911187287072 for <Subprocess at 22911187284840 with name flood-script in state RUNNING> (stderr)>
2019-01-06 00:01:11,964 INFO exited: flood-script (exit status 0; expected)

In the logs. 

Just noticed this as well.

 

Glad to know you are working on it. For now I have switched back to the main rutorrent interface.

Edited by weirdcrap

Share this post


Link to post

Maybe a silly question, does this come with the frontend despite being called rtorrent?

Share this post


Link to post
On 1/7/2019 at 8:05 PM, weirdcrap said:

Just noticed this as well.

 

Glad to know you are working on it. For now I have switched back to the main rutorrent interface.

new image created, please pull down, should have flood working again (works for me).

Share this post


Link to post
2 minutes ago, Spies said:

Maybe a silly question, does this come with the frontend despite being called rtorrent?

yes, in fact it comes with two, flood and rutorrent

Share this post


Link to post

Great, could I just copy the configuration files from Linux | Server.io's in yours?

Share this post


Link to post
2 minutes ago, Spies said:

Great, could I just copy the configuration files from Linux | Server.io's in yours?

probably :-), depends on how far ahead they are from latest release, as i know they go bleeding edge latest commit, you can try, make sure the volume mappings are the same.

Share this post


Link to post

Any plans to add NordVPN/ExpressVPN support? I know custom is an option but was curious since it will simplify the setup if its baked in.  @binhex

Edited by jrdnlc

Share this post


Link to post
3 hours ago, jrdnlc said:

I know custom is an option but was curious since it will simplify the setup if its baked in

simplify it in what way?, you mean the end user wouldnt need to download the ovpn file and certs?, if thats what you are talking about then im afraid this wont happen, ive been down that road before and all that happens is it means more frequent rebuilds of the image due to ever changing ovpn config files.

Share this post


Link to post

Managed to move the config and even the session files over to your docker :)

Edited by Spies

Share this post


Link to post

Do you still have to write watch and download folders to the .rtorrent.rc file like

 

schedule = watch_tv_series, 5, 5, "load.start=/home/torrent/watch_tv_series/*.torrent,d.set_directory="/Media/TVSERIES/"

 

Or is there some GUI way to do it nowdays? Migrating from an old server I set up like 4 years ago ( rtorrent+rutorrent+autodl-irssi)

 

How do I acess IRSSI in this docker? From the Terminal? Is it run in an screen session or something?

 

What does the "Account" options like write your name/pass for certain torrent websites do? Does it auto-login according to rule set to avoid being locked out for activity?

Share this post


Link to post

When using PIA, the incoming port is grabbed and reconfigured on connection, I have my torrent client set to 51413 but in the log I see the line:

 

2019-01-12 16:39:55,968 DEBG 'watchdog-script' stdout output:
[info] rTorrent incoming port 49160 and VPN incoming port 26572 different, marking for reconfigure

 

and the client is showing as un-connectable, where do I need to change this so that it matches?

 

Worked it out, I had un-commented the line #network.port_range.set so I could forward the relevant port from the router but this broke the auto reconfigure in your script, re-commented the line and its working :)

Edited by Spies

Share this post


Link to post
2 hours ago, Spies said:

Worked it out, I had un-commented the line #network.port_range.set so I could forward the relevant port from the router but this broke the auto reconfigure in your script, re-commented the line and its working

If you are indeed connected through VPN, your router ports have nothing to do with your connection.

Share this post


Link to post
Just now, jonathanm said:

If you are indeed connected through VPN, your router ports have nothing to do with your connection.

I was using it without the VPN function initially.

Share this post


Link to post

Seem to have an issue with rtorrent randomly crashing, do I just need to enable debug in the docker settings to figure out whats going on?

Share this post


Link to post
On 6/4/2018 at 2:30 PM, Heciruam said:

Hello,

 

I have a question regarding the ratio groups.

Now that I set up sonarr and radarr, I had to set up some ratio rules. And everything works great.

My problem is that the ratio groups are set to default after the docker gets restarted (within rutorrent). I checked the config file if I can change it there so my ratiogroups survive a restart. 

What am I doing wrong? Or where can I make my ratio settings permanent?

 

Thanks in advance.

 

p.s. thanks binhex for your great dockers

Did you ever get this solved? I tried to use ratio groups for the first time today and even though I edit the group options, they always seem to go back to default. How can I make these settings permanent? Thank you.

Share this post


Link to post
1 minute ago, theGrok said:

Did you ever get this solved? I tried to use ratio groups for the first time today and even though I edit the group options, they always seem to go back to default. How can I make these settings permanent? Thank you.

At some point it just stopped resetting itself. Not sure why. At the time I just told myself to not restart or update the docker until I also have time to re-enter everything.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.