Jump to content
binhex

[Support] binhex - rTorrentVPN

1707 posts in this topic Last Reply

Recommended Posts

Posted (edited)

Looks like rakshasa pushed rtorrent .98! Thanks for your continued efforts, Binhex, this container is great work.

Edited by Rinzler

Share this post


Link to post
Posted (edited)

Hi all, after hours and hours of trying to get this to work, I just can't come up with a solution.

 

Here's the Docker Log:

Created by...
___.   .__       .__                   
\_ |__ |__| ____ |  |__   ____ ___  ___
 | __ \|  |/    \|  |  \_/ __ \\  \/  /
 | \_\ \  |   |  \   Y  \  ___/ >    < 
 |___  /__|___|  /___|  /\___  >__/\_ \
     \/        \/     \/     \/      \/
   https://hub.docker.com/u/binhex/

2019-07-30 18:41:53.745237 [info] System information Linux 7735e3bda776 3.10.105 #24922 SMP Fri May 10 02:50:17 CST 2019 x86_64 GNU/Linux
2019-07-30 18:41:53.835332 [info] PUID defined as '1029'
2019-07-30 18:41:53.949178 [info] PGID defined as '100'
2019-07-30 18:41:54.137843 [info] UMASK defined as '000'
2019-07-30 18:41:54.213429 [info] Setting permissions recursively on volume mappings...
2019-07-30 18:42:19.628876 [info] VPN_ENABLED defined as 'yes'
2019-07-30 18:42:19.717958 [info] OpenVPN config file (ovpn extension) is located at /config/openvpn/US Chicago.ovpn
dos2unix: converting file /config/openvpn/US Chicago.ovpn to Unix format...
2019-07-30 18:42:19.825343 [info] VPN remote line defined as 'remote us-chicago.privateinternetaccess.com 1198'
2019-07-30 18:42:19.901669 [info] VPN_REMOTE defined as 'us-chicago.privateinternetaccess.com'
2019-07-30 18:42:19.979236 [info] VPN_PORT defined as '1198'
2019-07-30 18:42:20.062734 [info] VPN_PROTOCOL defined as 'udp'
2019-07-30 18:42:20.146279 [info] VPN_DEVICE_TYPE defined as 'tun0'
2019-07-30 18:42:20.226590 [info] VPN_PROV defined as 'pia'
2019-07-30 18:42:20.303082 [info] LAN_NETWORK defined as '192.168.1.0/32'
2019-07-30 18:42:20.380506 [info] NAME_SERVERS defined as '209.222.18.222,84.200.69.80,37.235.1.174,1.1.1.1,209.222.18.218,37.235.1.177,84.200.70.40,1.0.0.1'
2019-07-30 18:42:20.460691 [info] VPN_USER defined as 'x'
2019-07-30 18:42:20.538588 [info] VPN_PASS defined as 'x'
2019-07-30 18:42:20.616200 [info] VPN_OPTIONS not defined (via -e VPN_OPTIONS)
2019-07-30 18:42:20.693079 [info] STRICT_PORT_FORWARD defined as 'no'
2019-07-30 18:42:20.770943 [info] ENABLE_PRIVOXY defined as 'yes'
2019-07-30 18:42:20.849542 [info] ENABLE_AUTODL_IRSSI defined as 'yes'
2019-07-30 18:42:20.926153 [info] ENABLE_RPC2 defined as 'yes'
2019-07-30 18:42:21.005588 [info] ENABLE_RPC2_AUTH defined as 'yes'
2019-07-30 18:42:21.090083 [info] Starting Supervisor...
2019-07-30 18:42:21,611 INFO Included extra file "/etc/supervisor/conf.d/rtorrent.conf" during parsing
2019-07-30 18:42:21,611 INFO Set uid to user 0 succeeded
2019-07-30 18:42:21,620 INFO supervisord started with pid 6
2019-07-30 18:42:22,624 INFO spawned: 'irssi-script' with pid 154
2019-07-30 18:42:22,628 INFO spawned: 'logrotate-script' with pid 155
2019-07-30 18:42:22,632 INFO spawned: 'pyrocore-script' with pid 156
2019-07-30 18:42:22,636 INFO spawned: 'rutorrent-script' with pid 157
2019-07-30 18:42:22,641 INFO spawned: 'start-script' with pid 158
2019-07-30 18:42:22,645 INFO spawned: 'watchdog-script' with pid 159
2019-07-30 18:42:22,646 INFO reaped unknown pid 7
2019-07-30 18:42:22,658 DEBG 'irssi-script' stdout output:
Script started, file is /home/nobody/typescript

2019-07-30 18:42:22,659 INFO success: irssi-script entered RUNNING state, process has stayed up for > than 0 seconds (startsecs)
2019-07-30 18:42:22,659 INFO success: logrotate-script entered RUNNING state, process has stayed up for > than 0 seconds (startsecs)
2019-07-30 18:42:22,659 INFO success: pyrocore-script entered RUNNING state, process has stayed up for > than 0 seconds (startsecs)
2019-07-30 18:42:22,659 INFO success: rutorrent-script entered RUNNING state, process has stayed up for > than 0 seconds (startsecs)
2019-07-30 18:42:22,659 INFO success: start-script entered RUNNING state, process has stayed up for > than 0 seconds (startsecs)
2019-07-30 18:42:22,666 INFO success: watchdog-script entered RUNNING state, process has stayed up for > than 0 seconds (startsecs)
2019-07-30 18:42:22,678 DEBG 'start-script' stdout output:
[info] VPN is enabled, beginning configuration of VPN

2019-07-30 18:42:22,695 DEBG 'watchdog-script' stdout output:
[info] rTorrent config file already exists, skipping copy

2019-07-30 18:42:22,725 DEBG 'irssi-script' stdout output:
Script done, file is /home/nobody/typescript

2019-07-30 18:42:22,748 DEBG fd 9 closed, stopped monitoring <POutputDispatcher at 139790209245928 for <Subprocess at 139790209246376 with name irssi-script in state RUNNING> (stdout)>
2019-07-30 18:42:22,749 DEBG fd 11 closed, stopped monitoring <POutputDispatcher at 139790208691112 for <Subprocess at 139790209246376 with name irssi-script in state RUNNING> (stderr)>
2019-07-30 18:42:22,750 INFO exited: irssi-script (exit status 0; expected)
2019-07-30 18:42:22,751 DEBG received SIGCHLD indicating a child quit
2019-07-30 18:42:22,777 DEBG 'watchdog-script' stderr output:
dos2unix: 
2019-07-30 18:42:22,778 DEBG 'watchdog-script' stderr output:
converting file /config/rtorrent/config/rtorrent.rc to Unix format...

2019-07-30 18:42:22,947 DEBG 'start-script' stdout output:
[info] Default route for container is 172.17.0.1

2019-07-30 18:42:22,979 DEBG 'start-script' stdout output:
[info] Adding 209.222.18.222 to /etc/resolv.conf

2019-07-30 18:42:22,990 DEBG 'start-script' stdout output:
[info] Adding 84.200.69.80 to /etc/resolv.conf

2019-07-30 18:42:23,011 DEBG 'start-script' stdout output:
[info] Adding 37.235.1.174 to /etc/resolv.conf

2019-07-30 18:42:23,071 DEBG 'start-script' stdout output:
[info] Adding 1.1.1.1 to /etc/resolv.conf

2019-07-30 18:42:23,149 DEBG 'start-script' stdout output:
[info] Adding 209.222.18.218 to /etc/resolv.conf

2019-07-30 18:42:23,174 DEBG 'start-script' stdout output:
[info] Adding 37.235.1.177 to /etc/resolv.conf

2019-07-30 18:42:23,184 DEBG 'start-script' stdout output:
[info] Adding 84.200.70.40 to /etc/resolv.conf

2019-07-30 18:42:23,197 DEBG 'start-script' stdout output:
[info] Adding 1.0.0.1 to /etc/resolv.conf

2019-07-30 18:42:23,438 DEBG 'start-script' stdout output:
[info] Attempting to load iptable_mangle module...

2019-07-30 18:42:23,439 DEBG fd 17 closed, stopped monitoring <POutputDispatcher at 139790208691784 for <Subprocess at 139790208652680 with name pyrocore-script in state RUNNING> (stdout)>
2019-07-30 18:42:23,439 DEBG fd 21 closed, stopped monitoring <POutputDispatcher at 139790208691952 for <Subprocess at 139790208652680 with name pyrocore-script in state RUNNING> (stderr)>
2019-07-30 18:42:23,440 INFO exited: pyrocore-script (exit status 0; expected)
2019-07-30 18:42:23,440 DEBG received SIGCHLD indicating a child quit
2019-07-30 18:42:23,444 DEBG 'start-script' stderr output:
modprobe: FATAL: Module iptable_mangle not found in directory /lib/modules/3.10.105

2019-07-30 18:42:23,444 DEBG 'start-script' stdout output:
[warn] Unable to load iptable_mangle module using modprobe, trying insmod...

2019-07-30 18:42:23,447 DEBG 'start-script' stderr output:
insmod: ERROR: could not load module /lib/modules/iptable_mangle.ko: No such file or directory

2019-07-30 18:42:23,447 DEBG 'start-script' stdout output:
[warn] Unable to load iptable_mangle module, you will not be able to connect to the applications Web UI or Privoxy outside of your LAN
[info] unRAID/Ubuntu users: Please attempt to load the module by executing the following on your host: '/sbin/modprobe iptable_mangle'
[info] Synology users: Please attempt to load the module by executing the following on your host: 'insmod /lib/modules/iptable_mangle.ko'

2019-07-30 18:42:23,495 DEBG 'start-script' stdout output:
[info] Docker network defined as    172.17.0.0/16

2019-07-30 18:42:23,503 DEBG 'start-script' stdout output:
[info] Adding 192.168.1.0/32 as route via docker eth0

2019-07-30 18:42:23,506 DEBG 'start-script' stdout output:
[info] ip route defined as follows...
--------------------

2019-07-30 18:42:23,509 DEBG 'start-script' stdout output:
default via 172.17.0.1 dev eth0 
172.17.0.0/16 dev eth0 proto kernel scope link src 172.17.0.3 
192.168.1.0 via 172.17.0.1 dev eth0 

2019-07-30 18:42:23,509 DEBG 'start-script' stdout output:
--------------------

2019-07-30 18:42:23,626 DEBG 'start-script' stdout output:
[info] iptables defined as follows...
--------------------

2019-07-30 18:42:23,629 DEBG 'start-script' stdout output:
-P INPUT DROP
-P FORWARD DROP
-P OUTPUT DROP
-A INPUT -s 172.17.0.0/16 -d 172.17.0.0/16 -j ACCEPT
-A INPUT -i eth0 -p udp -m udp --sport 1198 -j ACCEPT
-A INPUT -i eth0 -p tcp -m tcp --dport 9080 -j ACCEPT
-A INPUT -i eth0 -p tcp -m tcp --sport 9080 -j ACCEPT
-A INPUT -i eth0 -p tcp -m tcp --dport 9443 -j ACCEPT
-A INPUT -i eth0 -p tcp -m tcp --sport 9443 -j ACCEPT
-A INPUT -s 192.168.1.0/32 -i eth0 -p tcp -m tcp --dport 5000 -j ACCEPT
-A INPUT -s 192.168.1.0/32 -d 172.17.0.0/16 -i eth0 -p tcp -j ACCEPT
-A INPUT -p icmp -m icmp --icmp-type 0 -j ACCEPT
-A INPUT -i lo -j ACCEPT
-A INPUT -i tun0 -j ACCEPT
-A OUTPUT -s 172.17.0.0/16 -d 172.17.0.0/16 -j ACCEPT
-A OUTPUT -o eth0 -p udp -m udp --dport 1198 -j ACCEPT
-A OUTPUT -o eth0 -p tcp -m tcp --dport 9080 -j ACCEPT
-A OUTPUT -o eth0 -p tcp -m tcp --sport 9080 -j ACCEPT
-A OUTPUT -o eth0 -p tcp -m tcp --dport 9443 -j ACCEPT
-A OUTPUT -o eth0 -p tcp -m tcp --sport 9443 -j ACCEPT
-A OUTPUT -d 192.168.1.0/32 -o eth0 -p tcp -m tcp --sport 5000 -j ACCEPT
-A OUTPUT -s 172.17.0.0/16 -d 192.168.1.0/32 -o eth0 -p tcp -j ACCEPT
-A OUTPUT -p icmp -m icmp --icmp-type 8 -j ACCEPT
-A OUTPUT -o lo -j ACCEPT
-A OUTPUT -o tun0 -j ACCEPT

2019-07-30 18:42:23,632 DEBG 'start-script' stdout output:
--------------------

2019-07-30 18:42:23,634 DEBG 'start-script' stdout output:
[info] Starting OpenVPN...

2019-07-30 18:42:23,651 DEBG 'start-script' stdout output:
Tue Jul 30 18:42:23 2019 WARNING: file 'credentials.conf' is group or others accessible
Tue Jul 30 18:42:23 2019 OpenVPN 2.4.7 [git:makepkg/2b8aec62d5db2c17+] x86_64-pc-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [PKCS11] [MH/PKTINFO] [AEAD] built on Feb 19 2019
Tue Jul 30 18:42:23 2019 library versions: OpenSSL 1.1.1c  28 May 2019, LZO 2.10

2019-07-30 18:42:23,653 DEBG 'start-script' stdout output:
[info] OpenVPN started

2019-07-30 18:42:23,662 DEBG 'start-script' stdout output:
Tue Jul 30 18:42:23 2019 NOTE: the current --script-security setting may allow this configuration to call user-defined scripts

2019-07-30 18:42:23,663 DEBG 'start-script' stdout output:
Tue Jul 30 18:42:23 2019 TCP/UDP: Preserving recently used remote address: [AF_INET]199.116.115.145:1198
Tue Jul 30 18:42:23 2019 UDP link local: (not bound)

2019-07-30 18:42:23,663 DEBG 'start-script' stdout output:
Tue Jul 30 18:42:23 2019 UDP link remote: [AF_INET]199.116.115.145:1198

2019-07-30 18:42:23,793 DEBG 'start-script' stdout output:
Tue Jul 30 18:42:23 2019 [d72a43a57f0a1a6ff12e16c66188297e] Peer Connection Initiated with [AF_INET]199.116.115.145:1198

2019-07-30 18:42:25,008 DEBG 'start-script' stdout output:
Tue Jul 30 18:42:25 2019 TUN/TAP device tun0 opened
Tue Jul 30 18:42:25 2019 /usr/bin/ip link set dev tun0 up mtu 1500

2019-07-30 18:42:25,012 DEBG 'start-script' stdout output:
Tue Jul 30 18:42:25 2019 /usr/bin/ip addr add dev tun0 local 10.17.18.6 peer 10.17.18.5

2019-07-30 18:42:25,015 DEBG 'start-script' stdout output:
Tue Jul 30 18:42:25 2019 /root/openvpnup.sh tun0 1500 1558 10.17.18.6 10.17.18.5 init

2019-07-30 18:42:25,032 DEBG 'start-script' stdout output:
Tue Jul 30 18:42:25 2019 Initialization Sequence Completed

2019-07-30 18:42:25,158 DEBG 'start-script' stdout output:
[info] Port forwarding is not enabled

2019-07-30 18:42:25,160 DEBG 'start-script' stdout output:
[info] Checking we can resolve name 'www.google.com' to address...

2019-07-30 18:42:25,190 DEBG 'start-script' stdout output:
[info] DNS operational, we can resolve name 'www.google.com' to address '172.217.4.196'

2019-07-30 18:42:25,193 DEBG 'start-script' stdout output:
[info] Attempting to get external IP using Name Server 'ns1.google.com'...

2019-07-30 18:42:25,397 DEBG 'start-script' stdout output:
[info] Successfully retrieved external IP address 199.116.115.145

2019-07-30 18:42:26,121 DEBG 'watchdog-script' stdout output:
172.217.4.196

2019-07-30 18:42:26,148 DEBG 'watchdog-script' stdout output:
[info] rTorrent listening interface IP 0.0.0.0 and VPN provider IP 10.17.18.6 different, marking for reconfigure

2019-07-30 18:42:26,159 DEBG 'watchdog-script' stdout output:
[info] rTorrent not running

2019-07-30 18:42:26,169 DEBG 'watchdog-script' stdout output:
[info] Privoxy not running
[info] Removing any rTorrent session lock files left over from the previous run...

2019-07-30 18:42:26,172 DEBG 'watchdog-script' stdout output:
[info] Attempting to start rTorrent...

2019-07-30 18:42:26,176 DEBG 'watchdog-script' stdout output:
Script started, file is /home/nobody/typescript

2019-07-30 18:42:26,207 DEBG 'watchdog-script' stdout output:
Script done, file is /home/nobody/typescript

2019-07-30 18:42:26,449 DEBG 'rutorrent-script' stdout output:
[info] rtorrent started, setting up rutorrent...

2019-07-30 18:42:26,451 DEBG 'rutorrent-script' stdout output:
[info] Setting PHP timezone to UTC...

2019-07-30 18:42:26,459 DEBG 'rutorrent-script' stdout output:
[info] nginx cert files already exists, skipping copy

2019-07-30 18:42:26,460 DEBG 'rutorrent-script' stdout output:
[info] nginx security file already exists, skipping copy
[info] nginx config file already exists, skipping copy

2019-07-30 18:42:26,462 DEBG 'rutorrent-script' stdout output:
[info] rutorrent conf folder already exists, skipping copy

2019-07-30 18:42:26,469 DEBG 'rutorrent-script' stdout output:
                "python"        => '/usr/bin/python',           // Something like /usr/bin/python. If empty, will be found in PATH.

2019-07-30 18:42:26,488 DEBG 'rutorrent-script' stdout output:
[info] running rsync to copy rutorrent user plugins to the plugins folder inside the container...

2019-07-30 18:42:26,494 DEBG 'rutorrent-script' stdout output:
sending incremental file list

2019-07-30 18:42:26,496 DEBG 'rutorrent-script' stdout output:
README.txt

2019-07-30 18:42:26,496 DEBG 'rutorrent-script' stdout output:
theme/themes/README.txt

2019-07-30 18:42:26,498 DEBG 'rutorrent-script' stdout output:


2019-07-30 18:42:26,498 DEBG 'rutorrent-script' stdout output:
sent 430 bytes  received 60 bytes  980.00 bytes/sec
total size is 237  speedup is 0.48

2019-07-30 18:42:26,499 DEBG 'rutorrent-script' stdout output:
[info] rutorrent share folder already exists, skipping copy

2019-07-30 18:42:26,501 DEBG 'rutorrent-script' stdout output:
[info] nginx /rpc2 location enabled

2019-07-30 18:42:26,513 DEBG 'rutorrent-script' stdout output:
[info] starting php-fpm...

2019-07-30 18:42:26,558 DEBG 'rutorrent-script' stderr output:
[NOTICE] [pool www] 'user' directive is ignored when FPM is not running as root
[NOTICE] [pool www] 'group' directive is ignored when FPM is not running as root

2019-07-30 18:42:26,566 DEBG 'rutorrent-script' stdout output:
[info] starting nginx...

2019-07-30 18:42:26,597 DEBG 'rutorrent-script' stderr output:
2019/07/30 18:42:26 [emerg] 790#790: open() "/etc/nginx/nginx.conf" failed (13: Permission denied)

2019-07-30 18:42:26,598 DEBG fd 22 closed, stopped monitoring <POutputDispatcher at 139790208692176 for <Subprocess at 139790208690944 with name rutorrent-script in state RUNNING> (stdout)>
2019-07-30 18:42:26,599 DEBG fd 26 closed, stopped monitoring <POutputDispatcher at 139790208774328 for <Subprocess at 139790208690944 with name rutorrent-script in state RUNNING> (stderr)>
2019-07-30 18:42:26,599 INFO exited: rutorrent-script (exit status 1; not expected)
2019-07-30 18:42:26,599 DEBG received SIGCHLD indicating a child quit
2019-07-30 18:42:27,229 DEBG 'watchdog-script' stdout output:
[info] rTorrent process started
[info] Waiting for rTorrent process to start listening on port 5000...

2019-07-30 18:42:27,240 DEBG 'watchdog-script' stdout output:
[info] rTorrent process listening on port 5000

2019-07-30 18:42:27,249 DEBG 'watchdog-script' stdout output:
[info] Initialising ruTorrent plugins (checking rTorrent is running)...

2019-07-30 18:42:27,258 DEBG 'watchdog-script' stdout output:
[info] rTorrent running
[info] Initialising ruTorrent plugins (checking nginx is running)...

 

And here are my settings:

docker run -d \
    --cap-add=NET_ADMIN \
    -p 9080:9080 \
    -p 9443:9443 \
    -p 8118:8118 \
    --name=rtorrentvpn \
    -v /volume1/"Ollie Network Drive"/Server/Downloads:/data \
    -v /volume1/docker/rutorrent:/config \
    -v /etc/localtime:/etc/localtime:ro \
    -e VPN_ENABLED=yes \
    -e VPN_USER=USER \
    -e VPN_PASS=PASS \
    -e VPN_PROV=pia \
    -e STRICT_PORT_FORWARD=no \
    -e ENABLE_PRIVOXY=yes \
    -e ENABLE_AUTODL_IRSSI=yes \
    -e ENABLE_RPC2=yes \
    -e ENABLE_RPC2_AUTH=yes \
    -e LAN_NETWORK=192.168.1.0/24 \
    -e NAME_SERVERS=us-midwest.privateinternetaccess.com,1.0.0.1 \
    -e DEBUG=false \
    -e PHP_TZ=UTC \
    -e UMASK=000 \
    -e PUID=1029 \
    -e PGID=100 \
    binhex/arch-rtorrentvpn

 

After a lot of tinkering, I was able to get it to this point, which makes it seem like it's working ("rTorrent running"). I can't access the webUI, though (192.168.1.17:9080, 9443, 8118). Any insight? Am I way off the mark on something? Through my router I've forwarded those ports. FYI this is on a Synology Diskstation. 

 

Edited by Ollie

Share this post


Link to post
Posted (edited)
On 7/30/2019 at 6:26 PM, Ollie said:

After a lot of tinkering, I was able to get it to this point, which makes it seem like it's working ("rTorrent running"). I can't access the webUI, though (192.168.1.17:9080, 9443, 8118). Any insight? Am I way off the mark on something? Through my router I've forwarded those ports. FYI this is on a Synology Diskstation. 

 

This is a forum for UnRAID so I'm not sure if anyone will be able to help with Synology.  You should try the Synology forums.

Edited by bobbintb

Share this post


Link to post
Posted (edited)
Quote

2019/07/30 18:42:26 [emerg] 790#790: open() "/etc/nginx/nginx.conf" failed (13: Permission denied) 2019-07-30 18:42:26,598 DEBG fd 22 closed, stopped monitoring <POutputDispatcher at 139790208692176 for <Subprocess at 139790208690944 with name rutorrent-script in state RUNNING> (stdout)> 2019-07-30 18:42:26,599 DEBG fd 26 closed, stopped monitoring <POutputDispatcher at 139790208774328 for <Subprocess at 139790208690944 with name rutorrent-script in state RUNNING> (stderr)> 2019-07-30 18:42:26,599 INFO exited: rutorrent-script (exit status 1; not expected) 2019-07-30 18:42:26,599 DEBG received SIGCHLD indicating a child quit 2019-07-30 18:42:27,229 DEBG 'watchdog-script' stdout output:

Based on these lines, I kind of suspect it can't read /etc/nginx/nginx.conf ... not sure if this is the only problem you have but "[emerg]" doesn't sound great. If I'm right, rTorrent can't connect to ruTorrent which runs on that failed nginx server.

 

A gut suspicion is likely due settings on your NAS versus your run parameters with : -e UMASK=000 \     -e PUID=1029 \     -e PGID=100 \

 

You could try as terminal on nas:

cd /volume1/docker/rutorrent/nginx/config

ls -l

to see permissions group id, and owner of the nginx.conf file. It should match your arguments, and if it doesn't you can change its owner like so:

 

sudo chown 1029:100 nginx.conf

 

then maybe try expand it's permissions, to something less secure but more flexible 755

sudo chmod 755 nginx.conf

 

Good luck.

 

Edited by Rinzler

Share this post


Link to post
On 7/31/2019 at 1:26 AM, Ollie said:

[emerg] 790#790: open() "/etc/nginx/nginx.conf" failed (13: Permission denied)

i have seen this before, a LONG time ago, bit of trawling and i came across the same error by another synology user, the issue is apparmor on synology is a little overly keen and is causing the issue, at the time the only way to fix this is to turn off apparmor on your synology box (dont ask me how to do this), this will 'fix' the issue but obviously isnt ideal.

 

fyi here is the link to guy getting the problem @hammsandwich 

https://forums.unraid.net/topic/46127-support-binhex-rtorrentvpn/?do=findComment&comment=460006

 

Share this post


Link to post
On 2/18/2019 at 1:07 PM, IndianaJoe1216 said:

Hello, just want to start by saying that this is by far the best torrent docker that I have come across and has been a life-saver. I am having an issue that I was hoping to get some support on or see if anyone else is having the same problem.

 

 

I use a combination of Autotools, the unpack feature and Ratio Groups to automatically label new torrents, move them to a folder once the download is complete and then remove them after a certain period of time. When a torrent is added by either Sonarr or Radarr it gets a label of either TV or Movie. Pretty standard stuff. The path to that item is /data/Torrents/Download/TV or /data/Torrents/Download/Movie and once completed I have the auto move set to move the torrent to /data/Torrents/Complete/TV or /data/Torrents/Complete/Movie respectively. Once completed if there is anything that needs to be unpacked that is completed at that time as well. The downloaded item then remains on my server in that folder for 2 weeks and is removed regardless of the seed ratio (this is completed via ratio groups.) When I initially set this up it worked just fine. I tested it multiple times and everything went swimmingly. The problem I am having now is the all of my docker containers are automatically shut down every night for the CA Backup Plugin to run and backup all of my configs. For some reason after that plugin runs all of the features mentioned above stop working and won't start again until I go and stop and restart the container, but everything that should have happened between then doesn't. It will remove old downloads after I restart usually, but anything added after the plugin runs won't get assigned a RatioGroup, Nothing gets auto unpacked or moved to the correct folder when complete. I don't see anything in the logs that would cause this and there shouldn't be anything in the rtorrent.rc file that needs to be edited for this either. Is anyone else having this issue or know of a fix?

 

Want to bump this again to see if anyone else is seeing this. Binhex's docker is by far the best one out there but for some reason I CANNOT get autotools to work consistently. Anyone have any ideas on places to check?

Share this post


Link to post
On 7/23/2019 at 8:48 AM, TRaSH said:

i'm using autodl-irss,
but after a restart of rutorrent or a update i'm getting always the following error.
image.thumb.png.5574d78dab924bc94bd4006489056af5.png

 

I then need to go to the autodl-irss settings and just click on the settings and then i start to work again.
most of the time.
 

 

I am having the same problem. After the container got updated during the night autodl stopped working. Then I have to go to irc-server settings and press ok and it starts to work again.

Share this post


Link to post

I suddenly found that there was no activity on the docker (no uploads or downloads). So I tried restarting the docker, and now I can't get to the WebUI. The browser error message is ERR_CONNECTION_REFUSED. I'm on 6.5.3 and am using PIA. I tried force-updating the docker, but same result.

 

I'm getting these lines in the log, repeating continuously:

2019-08-14 00:20:33,812 DEBG 'start-script' stdout output:
Wed Aug 14 00:20:33 2019 NOTE: the current --script-security setting may allow this configuration to call user-defined scripts

2019-08-14 00:20:33,813 DEBG 'start-script' stdout output:
Wed Aug 14 00:20:33 2019 TCP/UDP: Preserving recently used remote address: [AF_INET]x.x.x.x:x
Wed Aug 14 00:20:33 2019 UDP link local: (not bound)
Wed Aug 14 00:20:33 2019 UDP link remote: [AF_INET]x.x.x.x:x

2019-08-14 00:21:33,688 DEBG 'start-script' stdout output:
Wed Aug 14 00:21:33 2019 [UNDEF] Inactivity timeout (--ping-restart), restarting

2019-08-14 00:21:33,688 DEBG 'start-script' stdout output:
Wed Aug 14 00:21:33 2019 SIGHUP[soft,ping-restart] received, process restarting

2019-08-14 00:21:33,689 DEBG 'start-script' stdout output:
Wed Aug 14 00:21:33 2019 WARNING: file 'credentials.conf' is group or others accessible

Wed Aug 14 00:21:33 2019 OpenVPN 2.4.7 [git:makepkg/2b8aec62d5db2c17+] x86_64-pc-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [PKCS11] [MH/PKTINFO] [AEAD] built on Feb 19 2019
Wed Aug 14 00:21:33 2019 library versions: OpenSSL 1.1.1c 28 May 2019, LZO 2.10

If it's relevant, I recently updated to 6.7.2 but rolled back to 6.5.3.

Share this post


Link to post
Posted (edited)
1 hour ago, sonofdbn said:

...and am using PIA.

Sweden by any chance?  I have no idea why, but it might be down.  Can't connect there from a desktop app.

 

Edit: and now I can

Edited by Cessquill
PIA access restored

Share this post


Link to post
17 hours ago, Cessquill said:

Sweden by any chance?  I have no idea why, but it might be down.  Can't connect there from a desktop app.

 

Edit: and now I can

Yes, that was exactly the problem. Docker humming along nicely again. I did try to see whether PIA has some status page for their gateways, but didn't find anything. Next time I should just test via the desktop app.

Share this post


Link to post
23 minutes ago, sonofdbn said:

Yes, that was exactly the problem. Docker humming along nicely again. I did try to see whether PIA has some status page for their gateways, but didn't find anything. Next time I should just test via the desktop app.

There's a speedtest on their website for each server, and I just got a spinning wheel when trying to access Sweden.  Couldn't find a server status page, but that *might* be just as useful.

Share this post


Link to post

I am sure it is something simple I am missing but updated container, restarted and no matter what, just get the following when trying to access the ui:

 

An error occurred.

Sorry, the page you are looking for is currently unavailable.
Please try again later.

If you are the system administrator of this resource then you should check the error log for details.

Faithfully yours, nginx.

Share this post


Link to post
19 hours ago, crsavage1 said:

I am sure it is something simple I am missing but updated container, restarted and no matter what, just get the following when trying to access the ui:

 

An error occurred.

Sorry, the page you are looking for is currently unavailable.
Please try again later.

If you are the system administrator of this resource then you should check the error log for details.

Faithfully yours, nginx.

follow the procedure in the link:-

https://github.com/binhex/documentation/blob/master/docker/faq/help.md

Share this post


Link to post

Log file attached...it appears to run fine but I have a feeling I have messed up permissions along the way or my file structure is messed up.  Thanks for any help.

supervisord.txt

Share this post


Link to post
34 minutes ago, crsavage1 said:

Log file attached...it appears to run fine but I have a feeling I have messed up permissions along the way or my file structure is messed up.  Thanks for any help.

supervisord.txt 43.09 kB · 0 downloads

this is your issue:-

2019-08-15 08:42:09.985802 [info] UMASK defined as '777'

a umask of 777 = no permissions for anybody for any newly created files or folders, set it to 000 or 002 if you want to restrict.

Share this post


Link to post

Thanks.  I changed and it continues to throw the following when watching the logs:

 

 

2019/08/15 09:42:56 [crit] 2294#2294: *10 open() "/config/nginx/security/auth" failed (13: Permission denied)

 

I added a username to see if that made any difference.  I changed the umask=000 and re-deployed.  Do I need to delete everything out first?  Sorry for the probable dumb questions.

Share this post


Link to post
58 minutes ago, crsavage1 said:

Thanks.  I changed and it continues to throw the following when watching the logs:

 

 

2019/08/15 09:42:56 [crit] 2294#2294: *10 open() "/config/nginx/security/auth" failed (13: Permission denied)

 

I added a username to see if that made any difference.  I changed the umask=000 and re-deployed.  Do I need to delete everything out first?  Sorry for the probable dumb questions.

i got a faq for that, q2:-

https://github.com/binhex/documentation/blob/master/docker/faq/rtorrentvpn.md

Share this post


Link to post
Posted (edited)

I have confirmed that apparmor is torn down and nothing is in enforce mode, and still the same error.  Attached log.

 

storagex1.txt

Edited by crsavage1
Scrubbed log

Share this post


Link to post
7 minutes ago, crsavage1 said:

and still the same error.  Attached log.

not in that log you just attached there isnt, i see no sign of the nginx permission denied message

Share this post


Link to post

 

2019/08/15 11:51:13 [crit] 1093#1093: *1 open() "/config/nginx/security/auth" failed (13: Permission denied), client: 10.1.1.11, server: localhost, request: "GET / HTTP/1.1", host: "10.1.1.200:9080

 

I hadn't tried to hit it when grabbing new logs....

 

I see the above in the logs, and:

 

An error occurred.

Sorry, the page you are looking for is currently unavailable.
Please try again later.

If you are the system administrator of this resource then you should check the error log for details.

Faithfully yours, nginx.

 

After logging into the ui

Share this post


Link to post
27 minutes ago, crsavage1 said:

 

2019/08/15 11:51:13 [crit] 1093#1093: *1 open() "/config/nginx/security/auth" failed (13: Permission denied), client: 10.1.1.11, server: localhost, request: "GET / HTTP/1.1", host: "10.1.1.200:9080

 

I hadn't tried to hit it when grabbing new logs....

 

I see the above in the logs, and:

 

An error occurred.

Sorry, the page you are looking for is currently unavailable.
Please try again later.

If you are the system administrator of this resource then you should check the error log for details.

Faithfully yours, nginx.

 

After logging into the ui

ok in that case i can only assume it has created files with umask 777, and thus no permissions on the existing file, you will need to delete the /config/nginx/security/auth on the host side and then restart, this SHOULD then regenerate the file with the correct permissions (now that umask is correct).

 

alternatively delete everything in /config and restart so it re-creates the whole lot with correct permissions.

Share this post


Link to post

I appreciate your patience, that did the trick.  I deleted the config files and let them recreate.  Many thanks......

Share this post


Link to post
4 minutes ago, crsavage1 said:

I appreciate your patience, that did the trick.  I deleted the config files and let them recreate.  Many thanks......

np :-), i will enhance the FAQ i linked to for cases where the wrong umask has previously been set as well as apparmor trip up.

Share this post


Link to post

Anyone else having an issue with all torrents showing timed out on trackers with the latest update (assuming 1.1.r42.g37c9d4b-1-04)? Just backed down to 1.1.r42.g37c9d4b-1-03 and my torrents no longer show time out.

Share this post


Link to post

rutorrentvpn not working tried to install this one and getting same error

 

Unable to connect

Firefox can’t establish a connection to the server at 192.168.0.102:9080.

    The site could be temporarily unavailable or too busy. Try again in a few moments.
    If you are unable to load any pages, check your computer’s network connection.
    If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the Web.

 

any help?

Edited by erfly7

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.