Jump to content
binhex

[Support] binhex - rTorrentVPN

1754 posts in this topic Last Reply

Recommended Posts

23 minutes ago, erfly7 said:

delugevpn not working tried to install this one and getting same error

 

Unable to connect

Firefox can’t establish a connection to the server at 192.168.0.102:9080.

    The site could be temporarily unavailable or too busy. Try again in a few moments.
    If you are unable to load any pages, check your computer’s network connection.
    If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the Web.

 

any help?

What steps have you done so far? What vpn are you using? Have you added the vpn files to the correct folder? What error do you get in the log? 

Share this post


Link to post
Posted (edited)

using piavpn

 

yes placed files in the openvpn folder under rutorrent in appdata

 

no idea where to find log file?

supervisordfile.odt

Edited by erfly7
EDIT: Seen previous post similar error and to post this file?

Share this post


Link to post

Just got rTorrentVPN installed, and got it setup with the PIA France server, using GCM (as according to the FAQ, but also tried the GCM cfg downloaded straight from my user page on PIA, seeing the same behaviour). Having a problem where starting a download will cause a single core on the server to be pinned at 100%, and rTorrent to become entirely unresponsive...eventually the webui will say it cannot connect. Observing the log in debug mode, I don't see anything that could suggest why.

 

Interestingly, when I first installed the container, and tried an Ubuntu iso torrent, it worked perfectly, seeing about 200mbit down, and 70% load on a single core while doing so. However, when I came back to it (after a server reboot) to test a much larger download, this behaviour has sadly disappeared, leading to what I described. 

 

Downloading and running speedtest-cli from within the container does not cause the same CPU pinning, and gets around 300mbit down through the VPN tunnel, so seems like it's something more closely related to rTorrent?
 

Any ideas?

Share this post


Link to post

Finally got it working, any guide on how to setup with Sonarr and what rutorrent settings should be using?

Share this post


Link to post

Hey all,

What solutions are people using for torrent queueing?

 

I'm looking to swap from qbittorrent and I was surprised to find this wasn't a feature in rtorrent.

 

I've noted that pyrocore is included in the container, and https://pyrocore.readthedocs.io/en/latest/advanced.html?highlight=dry_run#rtorrent-queue-manager suggests this implements the functionality I'm describing (i.e. limiting max simultaneous downloads to <4 or whatever, while allowing a larger number of active torrents to seed). I've changed

 job.queue.active  = True

however, with

job.queue.downloading_max   = 8

and rtorrent is still trying to download 50 torrents at once.

 

Am I doing something wrong?

Share this post


Link to post
On 8/23/2019 at 12:56 AM, erfly7 said:

Finally got it working, any guide on how to setup with Sonarr and what rutorrent settings should be using?

There are some videos here: https://www.youtube.com/channel/UCZDfnUn74N0WeAPvMqTOrtA/videos

 

Versions might be older, but the principles are the same (one from about 2 years ago is the one you're after I think, but there are lots in there that come in handy).

Share this post


Link to post

Probably something i missed as always, but im trying to run the docker on vlan with 192.168.20.xx but i cant acess it from outside of the vlan.

I can acess it from a pc on the vlan but not from lan (192.168.0.x) and had same problem acessing it from openvpn acess lan (192.168.1.x).

Is there a way u can grant acess to the docker from the other lans?

Share this post


Link to post
6 minutes ago, Pirate said:

Probably something i missed as always, but im trying to run the docker on vlan with 192.168.20.xx but i cant acess it from outside of the vlan.

I can acess it from a pc on the vlan but not from lan (192.168.0.x) and had same problem acessing it from openvpn acess lan (192.168.1.x).

Is there a way u can grant acess to the docker from the other lans?

yes you need to add in the additional vlans to the LAN_NETWORK, separate each network with a comma.

Share this post


Link to post
5 minutes ago, binhex said:

yes you need to add in the additional vlans to the LAN_NETWORK, separate each network with a comma.

Ah! That did the trick, thanks Binhex :)

Share this post


Link to post

I am having issues with rtorrent constantly restarting. It is only up for a minute or 2 before it restarts.

Sample from log:

2019-09-11 14:37:31,346 DEBG 'watchdog-script' stdout output:
[info] ruTorrent plugins initialised

2019-09-11 14:39:23,562 DEBG 'start-script' stdout output:
Wed Sep 11 14:39:23 2019 [531bf825779768703299168ed8b30109] Inactivity timeout (--ping-restart), restarting

 

Any ideas what the cause would be? Is it an issue with PIA?

Share this post


Link to post

I have a problem where my settings i set in rutorrent get reset when the docker restarts. It might happen at other times as well because sometimes i have to set my setting over again multiple days in a row.

 

Is there any whay i can hardsave my settings or somehow stop it from reseting my settings?

Share this post


Link to post
11 minutes ago, PetterH said:

I have a problem where my settings i set in rutorrent get reset when the docker restarts. It might happen at other times as well because sometimes i have to set my setting over again multiple days in a row.

 

Is there any whay i can hardsave my settings or somehow stop it from reseting my settings?

Post your docker run command as explained here:

 

https://forums.unraid.net/topic/57181-real-docker-faq/#comment-564345

 

Share this post


Link to post
13 minutes ago, PetterH said:

I have a problem where my settings i set in rutorrent get reset when the docker restarts. It might happen at other times as well because sometimes i have to set my setting over again multiple days in a row.

 

Is there any whay i can hardsave my settings or somehow stop it from reseting my settings?

FAQ #1 https://github.com/binhex/documentation/blob/master/docker/faq/rtorrentvpn.md

Share this post


Link to post
12 hours ago, noski said:

I am having issues with rtorrent constantly restarting. It is only up for a minute or 2 before it restarts.

Sample from log:


2019-09-11 14:37:31,346 DEBG 'watchdog-script' stdout output:
[info] ruTorrent plugins initialised

2019-09-11 14:39:23,562 DEBG 'start-script' stdout output:
Wed Sep 11 14:39:23 2019 [531bf825779768703299168ed8b30109] Inactivity timeout (--ping-restart), restarting

 

Any ideas what the cause would be? Is it an issue with PIA?

hard to say with so little information, just incase you are a qnap user see Q12 from the following link:-

https://github.com/binhex/documentation/blob/master/docker/faq/vpn.md

 

if you arent a qnap user then please follow this procedure to debug further:-

https://github.com/binhex/documentation/blob/master/docker/faq/help.md

 

Share this post


Link to post
4 hours ago, noski said:

Log file attached. Thanks for your help binhex.

supervisord.log 92.57 kB · 0 downloads

hmm nothing obvious in the logs, i can see the restarts, my only thoughts/guesses are:-

 

1. isp instability, is your connection rock solid to isp, im assuming wired connection right?

2. check mem usage, it could be OOM killer killing openvpn.

3. look for any rogue scripts or such that maybe attempting to backup the container.

Share this post


Link to post
13 hours ago, binhex said:

hmm nothing obvious in the logs, i can see the restarts, my only thoughts/guesses are:-

 

1. isp instability, is your connection rock solid to isp, im assuming wired connection right?

2. check mem usage, it could be OOM killer killing openvpn.

3. look for any rogue scripts or such that maybe attempting to backup the container.

I am having very similar issues. Mine happened when I changed VPN providers, but then once I set the DEBUG variable to true, the issues went away for about a day, but then came back.

I don't think it is a connection issue since I'm using Ethernet.

supervisord.log

 

 

EDIT: I've noticed that with htop my RAM usage increases every 30 seconds by about 500MB every time it restarts rtorrent, but I still have like 6GB of RAM available. After stopping the container, everything is completely fine. For a little while the rtorrent process didn't crash, and I was able to load rutorrent, but then all of my torrents had the red button to the left and when I tried to force recheck one, rtorrent crashed again, and then it started the whole crashing/relaunching loop again.

Edited by cjeee
Extra information

Share this post


Link to post
4 hours ago, cjeee said:

I am having very similar issues.

no, from your log rtorrent process is continually restarting, this is not the same as the previous user, his issue is that openvpn process is restarting, this is not the case for you.

 

4 hours ago, cjeee said:

but then once I set the DEBUG variable to true, the issues went away for about a day, but then came back.

 

debug will def not fix anything, this purely logs more info, it doesnt run anything else so this is a coincidence. my guess would be low memory, try shutting down some of your other docker container, then start rtorrentvpn, if it remains stable then OOM killer is probably what is kicking in and killing processes, in this case the process is 'rtorrent'

 

Edited by binhex

Share this post


Link to post
8 hours ago, binhex said:

no, from your log rtorrent process is continually restarting, this is not the same as the previous user, his issue is that openvpn process is restarting, this is not the case for you.

 

 

debug will def not fix anything, this purely logs more info, it doesnt run anything else so this is a coincidence. my guess would be low memory, try shutting down some of your other docker container, then start rtorrentvpn, if it remains stable then OOM killer is probably what is kicking in and killing processes, in this case the process is 'rtorrent'

 

I don't have any other containers running, just a VM. My total memory sits around 9.5GB then spikes to 10GB when the process is restarted. I have a total 16GB of RAM.

 

I restarted the whole system and only have this container running, and I'm still experiencing the same issue

Edited by cjeee

Share this post


Link to post
On 9/13/2019 at 2:28 AM, binhex said:

hmm nothing obvious in the logs, i can see the restarts, my only thoughts/guesses are:-

 

1. isp instability, is your connection rock solid to isp, im assuming wired connection right?

2. check mem usage, it could be OOM killer killing openvpn.

3. look for any rogue scripts or such that maybe attempting to backup the container.

Thanks for the ideas.

1. Yes I'm using a wired connection. My router doesn't indicate any connectivity issues with the ISP.

2. Mem usage looks ok, using ~2GB out of 16GB.

3. I do have the "CA Backup / Restore Appdata" plugin installed by it is not running on a schedule. I'll have a look if I can find anything else but not sure if I'll find anything.

 

Some more info:

- Yes I am an unRaid user and not a QNAP user.

- I also have your other torrent dockers - delgue and qbittorrent. I looked at their logs and they also have the same issue.

 

There are many articles on the internet for "Inactivity timeout (--ping-restart), restarting". I am looking into them.

Share this post


Link to post

For me, I can find "Inactivity timeout" entries in my supervisord logs going back as far as June 2018, possibly further, but the logs have rolled. So this is not a 'new' issue.

It was infrequent in the past, so I guess it went unnoticed. Currently, it is constant.

Edited by noski

Share this post


Link to post

Hi BinHex,

 

Loving your docker container! I keep running into an issue with it though that I hope you or the community might be able to help me with. I get it running with no issues and it downloads and seeds with no problems. However, I notice while letting it run and do it's thing that after a (long) while it goes down and fails to restart. I have posted the log here: https://paste.ee/p/ADI4A

 

My assumption is that the VPN times out due to inactivity (in my case PIA) and the the container then fires a script to try and reconnect again but can't due to this error: "rtorrent: Error in option file: ~/.rtorrent.rc:134: Could not prepare socket for listening: Address already in use"

 

Restarting the container corrects this by the way until of course it happens again. I am hoping you might be able to help me finally correct this so I can set it and forget it :)

Edited by td00

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.