[Support] binhex - rTorrentVPN


2795 posts in this topic Last Reply

Recommended Posts

  • Replies 2.8k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

OK guys, multi remote endpoint support is now in for this image please pull down the new image (this change will be rolled out to all my vpn images shortly).   What this means is that the im

@binhex   Would it be possible to have the script run through a list of .ovpn files after failing to port forward with one? Use case would be, CA-Montreal is having port-forward API issues r

Out of nowhere my container is messing up. I've had it running with no problem for months and now I am getting a bunch of errors.   [01.03.2021 08:56:39] WebUI started. [01.03.2021 08:56:42]

Posted Images

7 hours ago, Ducco said:

Hi, kinda new to this show, but in the docker settings under host path 2, is the path to the download folder?

yes

 

1 hour ago, Ducco said:

hi, i try to get this docker to work, i dont use a vpn so i set no where it says vpn, but not getting any ip in docker, tried to set maual ip, any guide?

just watch this video. Works exactly the same way for rtorrent.

Link to post

I'm having a hard time with Magnet links and this docker. Frequently I get an issue where DHT is unable to connect and download tracker data.

 

Anyone else running into this?

 

I'm using PIA with portforwarding set to "only"

Link to post
12 hours ago, lrx345 said:

I'm having a hard time with Magnet links and this docker. Frequently I get an issue where DHT is unable to connect and download tracker data.

 

Anyone else running into this?

 

I'm using PIA with portforwarding set to "only"

Seeing an issue currently with UDP unable to connect, also using PIA.  It finds a multiple list of peers, but none will connect. 

Link to post
39 minutes ago, lrx345 said:

Can confirm mine is giving UDP errors as well.

Same, but small part of me wants to think it might be linked to PIA's recent bad IP lists which are evident by more Captcha pages, etc. If some of their Port Forwarding servers made it on a blocklist due to some bad apples, it might also be why they re not connecting. I am not seeing the UDP issue on all, but persists on a bunch. 

Link to post
Can confirm mine is giving UDP errors as well.
Change endpoint then, PIA is currently going through a transition to their next-generation network, outages are being experienced.

Sent from my CLT-L09 using Tapatalk

Link to post
5 hours ago, binhex said:

Change endpoint then, PIA is currently going through a transition to their next-generation network, outages are being experienced.

Sent from my CLT-L09 using Tapatalk
 

My VPN passport is stamped all over. I wonder if PIA is going to get themselves sorted out.  Are there any other providers that have the ability to do Port Forwarding? Curious about their Wireguard implementation once they get it figured out but assume we would need to use a separate container and route everything through it.   

 

If it isnt said enough, thank you for the work you do on all of this. 

  

Link to post
On 8/2/2020 at 10:56 AM, dewlite said:

My VPN passport is stamped all over. I wonder if PIA is going to get themselves sorted out.  Are there any other providers that have the ability to do Port Forwarding? Curious about their Wireguard implementation once they get it figured out but assume we would need to use a separate container and route everything through it.   

 

If it isnt said enough, thank you for the work you do on all of this. 

  

The Toronto PIA server seems to be working well for me, right now at least.  I had problems with a bunch of others.

Link to post

I'm getting a lot of rutorrent timeout errors and login issues with my image.  I have about 1100 torrents running currently.  I know stability is an issue with rutorrent historically.  I've even read and attempted some of the fixes on the tuning website:  Performance Tuning

 

I've not been able to find anything that really solves this problem yet.  I saw one person recommend the arch-rtorrentvpn image as being more stable.  Debating about giving that a go.

 

Are there any things you guys or anyone has been able to do to manage a high torrent load and still have rutorrent be functional?  I'd like to go even high in torrent count, but until it's stable I know it will be an issue.  Thanks!

Link to post
2 hours ago, EC28 said:

I'm getting a lot of rutorrent timeout errors and login issues with my image.  I have about 1100 torrents running currently.  I know stability is an issue with rutorrent historically.  I've even read and attempted some of the fixes on the tuning website:  Performance Tuning

 

I've not been able to find anything that really solves this problem yet.  I saw one person recommend the arch-rtorrentvpn image as being more stable.  Debating about giving that a go.

 

Are there any things you guys or anyone has been able to do to manage a high torrent load and still have rutorrent be functional?  I'd like to go even high in torrent count, but until it's stable I know it will be an issue.  Thanks!

I get many "Request to rTorrent has timed out" errors as well, but at least now that I'm on Toronto PIA nothing seems to actually crash..... I haven't been able to figure out whether I should worry about these errors or not. I'm running around 700 torrents currently and it seems to be OK. Would love to know how to tune to max number of torrents and eliminate errors.

Link to post
28 minutes ago, kirk8999 said:

I get many "Request to rTorrent has timed out" errors as well, but at least now that I'm on Toronto PIA nothing seems to actually crash..... I haven't been able to figure out whether I should worry about these errors or not. I'm running around 700 torrents currently and it seems to be OK. Would love to know how to tune to max number of torrents and eliminate errors.

From my understanding, rTorrent itself isn't actually crashing and is running fine behind the scenes.  ruTorrent is the part having issues.  But when you can't see rTorrent, it's a problem.  (I know you can use the actual rTorrent to see things, but ruTorrent is 1000x easier.)

Link to post

PIA (Switzerland) connects and ip confirmed to be there. When rutorrent saying port open does not seem to have an impact on speed, but most the time it has port open. My internet is 200/20, so rtorrent config has bandwith limited to 100 down/10 up (12500/1250). In waves ill have full connections at limits, but most the time up/down is less than 1 MB (50+ active torrents or 2). Seeing stuff about PIA transitioning and udp problems, but i have connections (most the time) just speed is almost always minuscule. In the case that this is a disk IO issue, im planning on adding 2 user shares to the container with 1 being cache only (downloading) and the other being normal both (seeding). Have not started this yet because it seems less likely to be the issue. 

Link to post
On 8/5/2020 at 2:32 PM, EC28 said:

From my understanding, rTorrent itself isn't actually crashing and is running fine behind the scenes.  ruTorrent is the part having issues.  But when you can't see rTorrent, it's a problem.  (I know you can use the actual rTorrent to see things, but ruTorrent is 1000x easier.)

Have had a few issues with seedbox where rutorrent crashes and rtorrent gets stuck, so had to kill and start instead of restart. With this container the few times i have crashed rutorrent it did a similar thing so i had to stop container and then start it again and wait for a longer start time (was like 20 minutes). Monitoring the supervisor log showed that it was working on it tho. Main thing that ive done that has caused crashes so far is dumping too many torrent files into the watch dir at the same time.

Link to post

Regarding the endpoints, is it possible that this is similar to a hostname issue that happened with nyc one a few weeks back?

 

The image was stable until it was restarted, so I'm almost positive it's a DNS issue. If it's a DNS issue, if we knew the european locations IP addresses?, could we modify the config file to use that instead of the hostname? That being said; spain.privateinternetaccess.com for example does resolve to a ping, so maybe it's not that. For now I guess everyone is on Canada.

Link to post

I saw someone else post this same error a few days ago, but not additional messages were related to it.

 

I've been running rTorrentvpn under a docker container for months now with zero problems. I updated earlier this morning to the latest image and restarted and now my ruTorrent web won't open up correctly. I know my rtorrent client is running, I've got 1000+ torrents seeding and I can see them validated on the trackers without problems.

[07.08.2020 13:53:11] WebUI started.

[07.08.2020 13:53:25] JS error: [http://rutorrent:XXXXX@x.x.x.x:9080/ : 5145] Uncaught TypeError: Cannot read property 'flabel_cont' of undefined

 

Log attached.

supervisord rs5050.log

Link to post
Is FLOOD WEbUI still available in this docker?  seems I can't have it running.  Seems to be removed?
Flood was removed about a year ago and unfortunately will not be re added, this is due to constant breakage on install which became a real pita.

Sent from my CLT-L09 using Tapatalk

Link to post

Hey guys, i've been searching this post for pages and pages but i just can't seem to figure out how to set the port range for Rtorrent.


I know that changing the port on the webui won't permanently change the port since it only changes the port for that instance. Everytime i change the port in the webui and restart rutorrent the port reverts back.

 

So i went into the rtorrent.rc file and tried setting the port as follows:

 

#network.port_range.set = 49152-65535
#port_range = 49152-65535
 

i also tried with a space:

 

# network.port_range.set = 49152-65535
# port_range = 49152-65535

 

However this didn't work neither...

So i tried setting port in the docker settings itself with the same variables:

 

NETWORK.PORT_RANGE.SET = 49152-65535

PORT_RANGE = 49152-65535

 

still no success.

What am i doing wrong guys? can anyone help?

I have DHT disabled since my private trackers require me to do so.
I'm also using OPENVPN, not Airvpn.

 

Thanks in advance ❤️

rtorrent port img.jpg

Edited by wookieleader
Link to post
36 minutes ago, wookieleader said:

Hey guys, i've been searching this post for pages and pages but i just can't seem to figure out how to set the port range for Rtorrent.


I know that changing the port on the webui won't permanently change the port since it only changes the port for that instance. Everytime i change the port in the webui and restart rutorrent the port reverts back.

 

So i went into the rtorrent.rc file and tried setting the port as follows:

 

#network.port_range.set = 49152-65535
#port_range = 49152-65535
 

i also tried with a space:

 

# network.port_range.set = 49152-65535
# port_range = 49152-65535

 

However this didn't work neither...

So i tried setting port in the docker settings itself with the same variables:

 

NETWORK.PORT_RANGE.SET = 49152-65535

PORT_RANGE = 49152-65535

 

still no success.

What am i doing wrong guys? can anyone help?

I have DHT disabled since my private trackers require me to do so.
I'm also using OPENVPN, not Airvpn.

 

Thanks in advance ❤️

rtorrent port img.jpg

one thing is that # comments out the line, so if you know that is the right range then remove the #

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.