Jump to content
binhex

[Support] binhex - rTorrentVPN

2501 posts in this topic Last Reply

Recommended Posts

20 minutes ago, cinico said:

I'm having the exact same issue after updating to latest version. I am using privado.io VPN (wlvpn.com?) and I did not change my OVPN file at all which had been working fine. It was single-line, DNS name, being properly resolved according to docker log. 
I have since tried multi-remote too, no change. Using the OVPN client from the provider I can connect from the same location.

Please can you post your ovpn file and also do the following:-

https://github.com/binhex/documentation/blob/master/docker/faq/help.md

 

i know privacy is a big concern but please leave in resolved ip's in the log if possible, just remove any credentials/keys shown in the log.

Share this post


Link to post
18 minutes ago, binhex said:

Please can you post your ovpn file and also do the following:-

https://github.com/binhex/documentation/blob/master/docker/faq/help.md

 

i know privacy is a big concern but please leave in resolved ip's in the log if possible, just remove any credentials/keys shown in the log.

I deleted my post because I realized I had dumped some old ovpn files into the folder while trying to resolve this. I corrected the ovpn files and rolled the container back two versions to rtorrent-ps-1.1.r54.ga787dd9-1-16 and it is connecting now. If you would like me to go back to latest and troubleshoot I am willing to do that. Otherwise I will just try a later version when available. Sorry for wasting your time.

Share this post


Link to post
2 minutes ago, cinico said:

If you would like me to go back to latest and troubleshoot I am willing to do that.

yes please, otherwise you will be stuck on that version.

Share this post


Link to post
2020-09-22 09:39:49,769 DEBG 'start-script' stdout output:
[crit] 'entries' cannot be resolved, possible DNS issues, exiting...
# The hostname/IP and port of the server.
# You can have multiple remote entries
# to load balance between the servers.

I'm using OpenVPN on my own remote server and by default, it includes "proto" and "remote" in the comments of the generated config file. These are being recognized as protocols and remote endpoints.

 

	vpn_remote_line=$(cat "${VPN_CONFIG}" | grep -P -o '(?<=remote\s).*' | paste -s -d, - || true)

I think you need a ^ in your regex for remote, probably the same for proto but I can't look further at the moment.

 

image.thumb.png.1ae77ad366170c81404fa80561281921.png

image.thumb.png.2d9809093792aa9a19df071e4ed19450.png

Edited by psycho_asylum

Share this post


Link to post
22 minutes ago, psycho_asylum said:

2020-09-22 09:39:49,769 DEBG 'start-script' stdout output:
[crit] 'entries' cannot be resolved, possible DNS issues, exiting...

# The hostname/IP and port of the server.
# You can have multiple remote entries
# to load balance between the servers.

Startup is failing because it is recognizing "entires" as a remote endpoint in my config even though it's part of a comment. 

ok i can see the bug, its due to a regex match, for now to get it going please remove the word remote from the comment.

Edited by binhex

Share this post


Link to post
Just now, binhex said:

ok i can see the bug, its due to a regex match, for now to get it going please remove the word remote from the comment.

Thanks. I just updated my comment. It's also recognizing anywhere "proto" is present.  I've got it running now.  

Share this post


Link to post
35 minutes ago, psycho_asylum said:

I think you need a ^ in your regex for remote, probably the same for proto but I can't look further at the moment.

exactly!, just need to double check that lookbehind regex allows for this with grep.

Share this post


Link to post
18 hours ago, psycho_asylum said:

Thanks. I just updated my comment. It's also recognizing anywhere "proto" is present.  I've got it running now.  

changes are in, now anchored both remote and proto, please pull down the latest image in around an hour from this post.

Share this post


Link to post
On 9/18/2020 at 11:23 PM, tooviral said:

All I did was

 

1. Set up the port forward on Mullvad. 

2. Edited the .torrent.rc file and specified the port like this: network.port_range.set = xxxx-xxxx where xxxx is the port number and set "network.port_random.set = no"

 

and worked

This is what I have done, and its not working. I can't see what im missing. My torrent.rc file must be good  as its clearly trying to use the correct port. Did you make any changes to the mulvad openVPN config files. It's the only other place I can see it going wrong.

Share this post


Link to post

didnt make any changes to the files, added user/pass to docker variable and put these files in the openvpn folder

mullvad.png.f3ec03adb46cb52399f553a16e4b6005.png

Share this post


Link to post
47 minutes ago, tooviral said:

didnt make any changes to the files, added user/pass to docker variable and put these files in the openvpn folder

mullvad.png.f3ec03adb46cb52399f553a16e4b6005.png

And when you check the port status in rTorrent’s GUI, it shows the forwarded port as open?  I’m set up exactly the same as you other than I’m using a different VPN location and I get the exclamation mark in the status bar with the message xxxxx: Port is closed. Where xxxxx is the forwarded port. 

Share this post


Link to post

Seems it may have been a fluke as I am now getting the red exclamation mark too.

 

My docker start command is as follows

Quote

root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name='binhex-rtorrentvpn' --net='bridge' --privileged=true -e TZ="America/New_York" -e HOST_OS="Unraid" -e 'VPN_ENABLED'='yes' -e 'VPN_USER'='XXXX' -e 'VPN_PASS'='XXXX' -e 'VPN_REMOTE'='ca-tor-002.mullvad.net' -e 'VPN_PORT'='1198' -e 'VPN_PROTOCOL'='udp' -e 'VPN_INCOMING_PORT'='12528' -e 'VPN_DEVICE_TYPE'='tun' -e 'VPN_PROV'='custom' -e 'VPN_OPTIONS'='' -e 'STRONG_CERTS'='yes' -e 'ENABLE_PRIVOXY'='no' -e 'ENABLE_FLOOD'='no' -e 'LAN_NETWORK'='192.168.1.0/24' -e 'NAME_SERVERS'='192.168.1.1,8.8.8.8,8.8.4.4' -e 'DEBUG'='false' -e 'PHP_TZ'='UTC' -e 'UMASK'='000' -e 'PUID'='99' -e 'PGID'='100' -e 'WEBUI_PASS'='XXXX' -e 'RPC2_PASS'='XXXX' -p '3001:3000/tcp' -p '5000:5000/tcp' -p '9080:9080/tcp' -p '9443:9443/tcp' -p '8119:8118/tcp' -v '/mnt/cache/downloads/':'/data':'rw' -v '/mnt/cache/appdata/binhex-rtorrentvpn':'/config':'rw' --log-opt max-size=50m --log-opt max-file=1 'binhex/arch-rtorrentvpn'

 

Am I doing something wrong?

Edited by tooviral

Share this post


Link to post

So I've noticed in the logs this

 

2020-09-26 08:02:04,415 DEBG 'start-script' stdout output:
[info] Application does not require port forwarding or VPN provider is != pia, skipping incoming port assignment

 

It looks like its not setting the port forward.  Could this be my problem?

Share this post


Link to post
7 hours ago, tooviral said:

So I've noticed in the logs this

 

2020-09-26 08:02:04,415 DEBG 'start-script' stdout output:
[info] Application does not require port forwarding or VPN provider is != pia, skipping incoming port assignment

 

It looks like its not setting the port forward.  Could this be my problem?

it wont set the incoming port for you automatically, the only provider that i support automatic incoming port assignment is PIA, all others you need to manually assign the port using your vpn providers web portal and then set the port in the app.

Share this post


Link to post
8 hours ago, binhex said:

it wont set the incoming port for you automatically, the only provider that i support automatic incoming port assignment is PIA, all others you need to manually assign the port using your vpn providers web portal and then set the port in the app.

Ive done that in rtorrent.rc and added the variable  -e 'VPN_INCOMING_PORT'='12528' and it still shows a closed in rutorrent and https://portchecker.co/

Share this post


Link to post
14 hours ago, tooviral said:

Ive done that in rtorrent.rc and added the variable  -e 'VPN_INCOMING_PORT'='12528' and it still shows a closed in rutorrent and https://portchecker.co/

ok i have seen people report that the built in incoming port checker for rutorrent doesnt work, now it does work perfectly for me, so i can only assume its related to the vpn provider, possibly (and this is a theory at this point) mullvad (and maybe other providers) block incoming ICMP for allocated incoming ports, and therefore the built in check fails (check is done through a website and web scaped for result).

 

try this, look in the supervisord.log file to get your external ip address for the vpn connection (not your isp's external ip), and make a note of the incoming port assigned to you and then plug both of these values into this website:- https://www.yougetsignal.com/tools/open-ports/

 

if it reports open then simply ignore the rutorrent checker and be happy :-), if it reports closed then further investigation is required.

 

Share this post


Link to post

Its reported as closed still.

 

Noticed another container variable  "ADDITIONAL_PORTS" in logs and tried adding the incoming port and still no joy.

Latest start logs attached.

rtorrent.txt

Share this post


Link to post
Just now, tooviral said:

Its reported as closed still.

 

Noticed another container variable  "ADDITIONAL_PORTS" in logs and tried adding the incoming port and still no joy.

Latest start logs attached.

rtorrent.txt 19.42 kB · 0 downloads

Same here after following binhex’s recommendations.  I’m using Mullvad. 

Share this post


Link to post
3 hours ago, binhex said:

Support for multi remote endpoints and PIA 'Next-Gen' networks now complete, see Q19 and Q20 for details:-

https://github.com/binhex/documentation/blob/master/docker/faq/vpn.md

This is working perfectly thanks. The only odd thing for me is I can’t get faster than 30MB/sec using the next gen servers, even one that’s not too far from my location and the port is reporting open by ruTorrent as well. Same torrent without port forwarding working gets at least 82MB/sec on my gigabit connection using Mullvad. I wonder if others with fast connections are seeing similar results. 

Edited by cardo

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.