Mysterious Windows 10 VM network share issues - "Location is not available"

Recommended Posts

Hi! I've got a Win 10 VM set up with unRaid 6.2b20 and most things are working really well. I've got the main OS installed on a 30GB vdisk on my cache drive and it boots up just fine. Then inside the OS I have mapped two network shares for storing games (G:) and data (U:) respectively. I set up these shares in unRaid in the usual way and didn't change any defaults (save for marking the Games one as cache-only).


I installed Steam and had it set up with a games library on the G: drive and have been able to download and run my games through the client that way and everything works great. However, after getting a game from Gog it seems as though it's unable to install itself to that network share for some reason.


What I've seen in both the Gog installer, and a few other installers I've tried to use, is that when the dialog box pops up asking where to install the files, neither one of my two network shares is available as a target. When I try to select one I get an error message saying "Location is unavailable":




The mysterious thing is that this seems to be the only context in which I don't have complete control over the share. I can create folders, delete stuff, etc with no problem, and as I said earlier Steam works fine.


Is there something I didn't set up correctly regarding users and shares, either on the unRaid server or the Windows client? Anyone else seen this behavior?

Link to comment

Just as an addendum to this, I have just tried unsuccessfully to solve the problem by doing this:


  • Added a "windows" user in unRaid
  • Set the SMB security on both shares to "secure"
  • From the Windows VM, disconnected both shares and rebooted
  • Reconnected to the shares from Windows and using the "windows" user and password to connect
  • Verified that I could still write files to the drives
  • Tried the installer again. No dice - same behavior as above.
  • On the unRaid box, did "chown -R windows" on both of the shares, then rebooted Windows and tried again - still no dice.


I'm beginning to wonder if I've run into a weird bug in Inno Setup or something.


Is there any way to just pass a user share into the Windows VM as a virtual disk from unRaid (as I am able to do with Docker images)?

Link to comment

Aha - so after digging around a little more, I realized I can just make a separate vdisk image to pass into Windows, so I did that instead. It's not really as good as using a share since I need to specify the image size manually and then I lose that space out of my cache, but it's good enough for my purposes and once I had mounted the image in Windows and done an NTFS format, I was able to get the installer to use it correctly.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.