[Plugin] Linuxserver.io - Unraid DVB


1690 posts in this topic Last Reply

Recommended Posts

7 hours ago, Institute said:

Hello,

 

I am trying to use LibreELEC 6.4 RC6 but whenever i change from the normal unraid 6.4 RC6 my adaptec asr71605e stops working and if i go to "/lib/modules/4.11.6-unRAID/kernal/drivers/scsi/" directory the aacraid driver is missing but on normal unraid 6.4 RC6 it is there.

 

Was this raid driver removed?

 

Not as far as I'm aware, I don't remove drivers.

 

Pretty sure there's something I haven't quite figured out going on with these LibreELEC releases, just don't have a lot of time at the moment to figure out what.

Link to post
  • 2 weeks later...
  • Replies 1.7k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Yeah, I've been busy, quite ironic though that the day before you came along I started working on it again.....   I uploaded v6.6.6 last night.   There are some caveats, can't get

DEPRECATED

@trurl Please lock this thread.  Due to an unexpected announcement from @limetech about Nvidia, I have since made the decision to do no further development work on Unraid. I'm quitting Unraid work.  A

Posted Images

On 7/7/2017 at 6:56 AM, CHBMB said:

 

Not as far as I'm aware, I don't remove drivers.

 

Pretty sure there's something I haven't quite figured out going on with these LibreELEC releases, just don't have a lot of time at the moment to figure out what.

 

Hey CHBMB, should libreelec-module.sh copy bzmodules from stock/bzmodules-new instead of from /boot/bzmodules?

 

Link to post
On 06/07/2017 at 2:35 PM, Institute said:

Hello,

 

I am trying to use LibreELEC 6.4 RC6 but whenever i change from the normal unraid 6.4 RC6 my adaptec asr71605e stops working and if i go to "/lib/modules/4.11.6-unRAID/kernal/drivers/scsi/" directory the aacraid driver is missing but on normal unraid 6.4 RC6 it is there.

 

Was this raid driver removed?

 

OK, got to the bottom of this one, when I compile these, I start with a base config taken from /usr/src/linux-4.11.6-unRAID/ 

 

This gives the kernel options selected as they were for the base install of Unraid and also applies any patches that are normally applied.

 

For some reason, on RC6 the kernel options in the .config file at that location was not selected.  So maybe @eschultz or @limetech can shed some light on why, but essentially it meant it wasn't included in my build.

Link to post
1 hour ago, CHBMB said:

 

OK, got to the bottom of this one, when I compile these, I start with a base config taken from /usr/src/linux-4.11.6-unRAID/ 

 

This gives the kernel options selected as they were for the base install of Unraid and also applies any patches that are normally applied.

 

For some reason, on RC6 the kernel options in the .config file at that location was not selected.  So maybe @eschultz or @limetech can shed some light on why, but essentially it meant it wasn't included in my build.

 

It's because that driver is one of two out-of-tree drivers we build into the kernel, the other being the rocket raid r750 driver.  We may go back to the in-tree aacraid before 6.4 'stable' is released.

Link to post
17 minutes ago, limetech said:

 

It's because that driver is one of two out-of-tree drivers we build into the kernel, the other being the rocket raid r750 driver.  We may go back to the in-tree aacraid before 6.4 'stable' is released.

 

Ah OK, makes sense.  Any way I can get hold the drivers you're using or keep up to date with this sort of thing?

Edited by CHBMB
Link to post

I upgraded to 6.4RC6 from 6.3.5 and tried to follow your instructions. The settings->unRAIDDVB page keeps fetching images however and never stops loading. 

 

Then I copied all the non-checksum files from http://files.linuxserver.io/unraid-dvb/6-4-0-rc6/libreelec/ to my flash drive, and now I can see (while the page is still loading) that the currently installed build is LibreElec version 1.2.1, but there's no DVB Kernel detected. (So also no devices, and therefore nothing showing up in my TVHeadend container (with device passed through).)

 

I've tried to trace back why the page doesn't finish loading, but all I can see are (nginx) timeouts of exec.php in the plugin directory...

dvbhang.png

Link to post

Can't explain why the DVB kernel isn't showing up, examined LibreElec thoroughly yesterday and was using it on my test system.

Upgrade the plugin and pull the builds again and check.

Sent from my LG-H815 using Tapatalk

Link to post

I tried that, I already had the latest version, but I removed it and installed it again. It still hangs/times-out at pulling the builds.

 

So for the files I pulled manuallly yesterday, I got them from http://files.linuxserver.io/unraid-dvb/6-4-0-rc6/libreelec/ 
Is there any difference between those and those in http://files.linuxserver.io/?dir=unraid-dvb-rc/6-4-0-rc6/libreelec  ?

Link to post

Hmm. Then I have no clue what went wrong with the manual update. 


I'm still trying to install any build via the plugin, this is what I get in the logs:

 

Jul 20 15:42:28 Server nginx: 2017/07/20 15:42:28 [error] 5227#5227: *100072 upstream timed out (110: Connection timed out) while reading response header from upstream, client: [removedclientip], server: , request: "POST /plugins/UnraidDVB/include/exec.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock", host: "server", referrer: "http://server/Settings/UnraidDVB"
 

and this is what I get in chrome:

clientdebug_servertimeout.png

Link to post

I upgraded from 6.3.5 DVB Edition to 6.4RC6 via the official way (with the new plugin). After that I updated all my plugins. (Then the Unraid DVB plugin wouldn't load the images so I tried to copy them in manually. )
 

How can I check whether the images actually start downloading (and maybe that times-out) or whether it hangs before that? 

Here are the contents of my /boot (and /boot/config/plugins) folders, maybe it shows something wrong:
 

bootcontents.png

unraidplugins.png

Edited by tbrasser
added more information
Link to post

I'm going to disable docker (because I'm using the new macvlan br0 stuff), then copy all the images from the "previous" folder back. (Which should get me to 6.3.5), then disabling as many plugins as possible + remove leftover files and folders if there are any, then going official to 6.4RC6 and do your suggestions. I'll let you know when I get any further. Thanks so far!

Link to post
7 hours ago, tbrasser said:

How can I check whether the images actually start downloading (and maybe that times-out) or whether it hangs before that? 

Any chance that you're behind a VPN?  Or some weird network setup?

Edited by Squid
Link to post
1 minute ago, CHBMB said:

I just thought that with the macvlan stuff.....

I've looked at the code again for DVB, and I don't see anyway that the popup wouldn't disappear, even if a fatal error happened in the code.  I can see however that under a weird network situation with the multitude of downloads that DVB has to do (one per each version), each with a timeout of 1 minute that it could take awhile to complete under very strange network circumstances.

 

Another alternative is that the unRaid install currently running is buggered itself with corrupted files / whatnot that's preventing / crashing the javascript code, in which case the manual update to RC6 would fix it.

Link to post
Just now, Squid said:

Any chance that you're behind a VPN?

No, I have a static IP from my ISP and I'm in control of everything except my modem. (Running ddwrt on my gateway/router/wifap, with ip 10.0.0.1), then some static IP's incl my server till 63, then 64 till 127 are for DHCP. On unRAID I have configured the network br0 (which since 6.4 is of type macvlan) for docker, they all have IP's from 10.0.0.128 until (ultimately) 254). I also edited the route masks from 10.0.0.0/24 to 10.0.0.128/25. (Which is working perfectly by the way, I hoped I would also get host connectivity to my docker containers this way since everything below 128 would get routed to my router and everything above it to br0, but no luck)

Link to post

Yeah, I've gone over the code again as there is some conditions in there depending on if you're on V6.3 or V6.4 and to stop the RC builds being accessible if you haven't already upgraded to V6.4 but I agree with Squid, I can't see that the plugin itself is causing this.

 

Only thing I can think of is possibly Cloudflare, but I'm not sure if we're using it on the files server.  Will have to ask j0nnymoe.

Link to post

That gave this within about 15 seconds, (via ssh) so seems to function normally: 
 

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2 Final//EN">
<html>
 <head>
  <title>Index of /unraid-dvb-rc</title>
 <script src="/cdn-cgi/apps/head/SnTkGghPCkY6gCE0hGVDVpppPno.js"></script></head>
 <body>
<h1>Index of /unraid-dvb-rc</h1>
  <table>
   <tr><th valign="top">&nbsp;</th><th><a href="?C=N;O=D">Name</a></th><th><a href="?C=M;O=A">Last modified</a></th><th><a href="?C=S;O=A">Size</a></th><th><a href="?C=D;O=A">Description</a></th></tr>
   <tr><th colspan="5"><hr></th></tr>
<tr><td valign="top">&nbsp;</td><td><a href="/">Parent Directory</a>       </td><td>&nbsp;</td><td align="right">  - </td><td>&nbsp;</td></tr>
<tr><td valign="top">&nbsp;</td><td><a href="6-3-5/">6-3-5/</a>                 </td><td align="right">2017-06-06 16:33  </td><td align="right">  - </td><td>&nbsp;</td></tr>
<tr><td valign="top">&nbsp;</td><td><a href="6-4-0-rc1/">6-4-0-rc1/</a>             </td><td align="right">2017-06-13 10:08  </td><td align="right">  - </td><td>&nbsp;</td></tr>
<tr><td valign="top">&nbsp;</td><td><a href="6-4-0-rc2/">6-4-0-rc2/</a>             </td><td align="right">2017-06-13 10:11  </td><td align="right">  - </td><td>&nbsp;</td></tr>
<tr><td valign="top">&nbsp;</td><td><a href="6-4-0-rc3/">6-4-0-rc3/</a>             </td><td align="right">2017-06-16 11:35  </td><td align="right">  - </td><td>&nbsp;</td></tr>
<tr><td valign="top">&nbsp;</td><td><a href="6-4-0-rc4/">6-4-0-rc4/</a>             </td><td align="right">2017-06-21 22:55  </td><td align="right">  - </td><td>&nbsp;</td></tr>
<tr><td valign="top">&nbsp;</td><td><a href="6-4-0-rc5/">6-4-0-rc5/</a>             </td><td align="right">2017-06-22 21:20  </td><td align="right">  - </td><td>&nbsp;</td></tr>
<tr><td valign="top">&nbsp;</td><td><a href="6-4-0-rc6/">6-4-0-rc6/</a>             </td><td align="right">2017-06-27 21:04  </td><td align="right">  - </td><td>&nbsp;</td></tr>
   <tr><th colspan="5"><hr></th></tr>
</table>
</body></html>

 

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.