[Plugin] Linuxserver.io - Unraid DVB


1690 posts in this topic Last Reply

Recommended Posts

Hi all, apparently I need video4linux to use my USB webcam in OctoPrint (3D printer server), and I was told that this plugin will do that :) A few questions for the experts here:

 

1. Is this plugin the right way to go to get what I need?

2. Is the LibreELEC version of Unraid DVB just the stock Unraid kernel plus some additional drivers?

3. How far is this plugin usually behind the official stable Unraid kernel? A couple of weeks? A month? Two months?

 

Thanks in advance! :)

Edited by Phoenix Down
Link to post
  • Replies 1.7k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Yeah, I've been busy, quite ironic though that the day before you came along I started working on it again.....   I uploaded v6.6.6 last night.   There are some caveats, can't get

DEPRECATED

@trurl Please lock this thread.  Due to an unexpected announcement from @limetech about Nvidia, I have since made the decision to do no further development work on Unraid. I'm quitting Unraid work.  A

Posted Images

On 6/4/2020 at 10:45 PM, Phoenix Down said:

Hi all, apparently I need video4linux to use my USB webcam in OctoPrint (3D printer server), and I was told that this plugin will do that :) A few questions for the experts here:

 

1. Is this plugin the right way to go to get what I need?

2. Is the LibreELEC version of Unraid DVB just the stock Unraid kernel plus some additional drivers?

3. How far is this plugin usually behind the official stable Unraid kernel? A couple of weeks? A month? Two months?

 

Thanks in advance! :)

I think so, but this plugin is there to download a custom bzroot/bzmodules or revert back to stock.

 

Yes.

 

Why should it be behind, it's the same version.

Link to post
1 hour ago, ich777 said:

I think so, but this plugin is there to download a custom bzroot/bzmodules or revert back to stock.

 

Yes.

 

Why should it be behind, it's the same version.

I found out about this plugin from a different thread about OctoPrint. It seems to indicate that there is some amount of lag time between the official latest stable Unraid version vs Unraid DVB's latest version:

 

 

Edited by Phoenix Down
Link to post
On 5/6/2019 at 3:10 AM, CHBMB said:

MTU has been something responsible in the past, other than that, got no idea, never been able to reproduce it.

This fixed my issue with Unraid-Nvidia stuck at "updating available builds".

I had a fresh build with Ver. 6.8.3 and one of the first settings I set before installing the Unraid-Nvidia Plugin was my MTU setting in Unraid.

I had my MTU set to 9000 due to having a 10G NIC.

Changed the MTU to 1500 applied and tried Unraid-Nvidia again. (no reboot)

BAM... All good !!!

 

I troubleshooted all my equipment and BIOS for a day-n a half and it was MTU stopping the plugin !!!!!  :(
 

Thanks @CHBMB and Unraid Community

Link to post
On 6/4/2020 at 9:45 PM, Phoenix Down said:

3. How far is this plugin usually behind the official stable Unraid kernel?

Depends what I have going on in my life at the time.  Last 6-9 months have been pretty full on, last 3 months have been particularly hectic.  New job, new baby and seeing as I work in front line healthcare as a clinician in one of the initially hardest hit areas of my country in terms of Covid, any dev work has kind of taken very much a back seat.

Edited by CHBMB
Link to post
8 hours ago, CHBMB said:

Depends what I have going on in my life at the time.  Last 6-9 months have been pretty full on, last 3 months have been particularly hectic.  New job, new baby and seeing as I work in front line healthcare as a clinician in one of the initially hardest hit areas of my country in terms of Covid, any dev work has kind of taken very much a back seat.

Understood, and props to you! There are definitely more important things in the world right now than hobby project.

Link to post
  • 1 month later...

I can't seem to get this to work right.

When I install Plex with the NVIDIA passthrough, Plex works.  When I go to install this to work with my Hauppauge HVR-2250, the settings show my card, but then the Plex docker is gone.  Then I see that Unraid is no longer on 6.9.0b25.  There doesn't seem to be a compatible DVB driver for that version.  So am I just SOL?  I'm really new to all this.

Link to post
14 minutes ago, hansolo77 said:

I can't seem to get this to work right.

When I install Plex with the NVIDIA passthrough, Plex works.  When I go to install this to work with my Hauppauge HVR-2250, the settings show my card, but then the Plex docker is gone.  Then I see that Unraid is no longer on 6.9.0b25.  There doesn't seem to be a compatible DVB driver for that version.  So am I just SOL?  I'm really new to all this.

You can download prebuilt images on the bottom of the first post that @BRiT linked (I think it's with the latest nVidia driver v450.57 & the LibreELEC DVB drivers v1.4.0) both prebuilt for 6.8.3 (I think I've only built that with the older nVidia driver) and 6.9.0beta25 for your preference. ;)

Link to post
41 minutes ago, hansolo77 said:

After I download a prebuilt how do I install it?

Please read the discription, simply place it on the root of you usb stick (if you are on windows you can connect through WinSCP and place it in the boot directory - equals to the root of your usb stick - to your server and replace the files and reboot or you simply shutdown your server and put the files on the drive - please always backup the existing files on your local computer in case something goes wrong).

 

EDIT: And of course extract it in the first place...

Link to post
  • 1 month later...

 

Hi,

yesterday i updated my Unraid from 6.5 to the 6.8.3 because i need a driver for my zigbee stick....but with this update i broke my tvheadend installation. 
I notices the same problem @natiz  reported: 


[   19.600943] SMI PCIe driver 0000:04:00.0: DVB: registering adapter 0 frontend 0 (Montage Technology M88RS6000)...

[   19.609163] SMI PCIe driver 0000:04:00.0: DVBSky S952 V3 port 0 MAC: 00:18:42:54:55:52

[   19.609440] dvbdev: DVB: registering new adapter (SMI_DVB)

[   19.861771] SMI PCIe driver 0000:04:00.0: DVB: registering adapter 1 frontend 0 (Montage Technology M88RS6000)...

[   19.869952] SMI PCIe driver 0000:04:00.0: DVBSky S952 V3 port 1 MAC: 00:18:32:54:55:53

[   19.870219] Registered IR keymap rc-dvbsky

[   19.870493] rc rc0: IR (DVBSky S952 V3) as /devices/pci0000:00/0000:00:1c.0/0000:04:00.0/rc/rc0

[   19.871525] input: IR (DVBSky S952 V3) as /devices/pci0000:00/0000:00:1c.0/0000:04:00.0/rc/rc0/input5

[ 1540.556607] m88ds3103 2-0069: Direct firmware load for dvb-demod-m88rs6000.fw failed with error -2

[ 1540.556609] m88ds3103 2-0069: firmware file 'dvb-demod-m88rs6000.fw' not found

[ 1540.664806] SMI PCIe driver 0000:04:00.0: DVB: adapter 1 frontend 0 frequency 0 out of range (950000..2150000)

[ 1540.702361] m88ds3103 2-0069: Direct firmware load for dvb-demod-m88rs6000.fw failed with error -2

[ 1540.702363] m88ds3103 2-0069: firmware file 'dvb-demod-m88rs6000.fw' not found

 

The only hint for a solution i found was this:

On 5/15/2020 at 8:10 PM, natiz said:

Thanks for the info, @BRiT.

 

I found a workaround, updated to the TBS OS build, and used mksquashfs to append the missing fw file (dvb-demod-m88rs6000.fw) to bzfirmware and it worked! :)

 

...unfortunately i don't understand what exactly i need to do, can someone please it explain it in more details?

 

Thanks



I solved the Problem by using the  Unraid_Custom_DVB_builtin_v6.8.3.zip that included the missing firmware.
Thanks to @ich777 for that

Edited by f451
Link to post
  • 3 weeks later...

I had a power outage like a month ago and since then (even tho server is connected to UPS and should have shut down gracefully) my Unraid always shows status as in the attachment :| 

 

I've tried reverting to older versions, swapping between LibreElec builds and TBS (also the CrazyCat images) - no result. Card is listed when I use lspci command, but absolutely no joy seeing it in Unraid. Any ideas? Maybe some kind of 'cleanup' is needed?

Messages Image(1830250522).jpg

Link to post
  • 1 month later...

@trurl Please lock this thread.  Due to an unexpected announcement from @limetech about Nvidia, I have since made the decision to do no further development work on Unraid. I'm quitting Unraid work.  Anyone who wants to use DVB on Unraid, you have two options.

 

1.  Ask LimeTech to include it as they should have years ago

2.  Compile it yourselves using the available docker container.  

 

LS.io will no longer be hosting any custom Unraid builds.

Edited by CHBMB
  • Like 3
  • Thanks 3
Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.