Jump to content
linuxserver.io

unRAID DVB Edition

1254 posts in this topic Last Reply

Recommended Posts

ok, back with news...

 

i've setup my test machine with the new TBS-6205 card. unRAID DVB build 6.1.9 TBS installed and when verified via settings it shows:

unRAID Version: 6.1.9

DVB Version: TBS

Driver Version: 160219

DVB Kernel: Detected

DVB Adapter Drivers: Detected

 

for the docker i've choosen saargs "Tvheadend-Unstable-DVB-Tuners" which installed 4.1-2125~g2d15eca

 

so all seems well ;-) but...

in the network-setup wizard i see my tuner (card) identified as TBS 6205 DVBT/T2, so there's no mentioning of DVB-C (it supports both DVB T(2)/C-standards). this is also the only choice i get to choose from the drop-down menus "DVB-T Network". so clearly i can't setup/use it.

 

searching the web brought me to this url:

https://www.linuxtv.org/wiki/index.php/TBS6205

 

there the section "Driver" writes: "A switch between DVB T/T2 and DVB-C requires a recompile."

so it seems that there needs to be made a choice of network-typ support at compile time. this brings me back to you guys and probably more precisly to CHBMB  ;)

 

 

i kindly ask for help. thx. guys.

Share this post


Link to post

OK, didn't realise that, I'll see what I can do..

Share this post


Link to post

OK, didn't realise that, I'll see what I can do..

 

thx. alot mate for your time/effort! ;-)

Share this post


Link to post

OK, didn't realise that, I'll see what I can do..

 

thx. alot mate for your time/effort! ;-)

 

Update the plugin and try the 6.1.9 build I've just uploaded.  Let me know if it does the trick.

Share this post


Link to post

Also s.Oliver, can you test the V6.2 Beta 23 build I'm just uploading as well.  I'll understand if you don't want to.

 

Share this post


Link to post

Ok, there are now V6.1.9 & V6.2 Beta 23 Builds uploaded for both TBS DVB-C and Digital Devices Github.  Be grateful if anyone can test.

 

The new Digital Devices Github build now has ddbridge.conf placed in /config/plugins/UnraidDVB/ enabling you to edit it.  I have kept the default configuration to stop the I2C errors and plugin upgrades shouldn't affect it.  If you remove the plugin however, the file will be deleted.

Share this post


Link to post

Ok, there are now V6.1.9 & V6.2 Beta 23 Builds uploaded for both TBS DVB-C and Digital Devices Github.  Be grateful if anyone can test.

 

The new Digital Devices Github build now has ddbridge.conf placed in /config/plugins/UnraidDVB/ enabling you to edit it.  I have kept the default configuration to stop the I2C errors and plugin upgrades shouldn't affect it.  If you remove the plugin however, the file will be deleted.

 

ok, just had 2 runs and both times the DVB Adapter Drivers didn't get detected.

i went this way:

 

updated the plug-in to 2016.06.19a, then choose the new tbs-build, installed (over my previous install - should i've 1st need to deinstalled or install vanilla build?). rebooted: DVB Adapter Drivers not recognized.

 

then updated to the now newer 2016.06.19b plug-in, installed TBS DVB-C 6.1.9 build, rebooted, same error – not recognizing the DVB Adapter Drivers.

 

btw. i do see a line when booting up, shortly before the end, which writes: "File '/boot/config/plugins/UnraidDVB/ddbridge.conf' already there; not retrieving."

 

want me to try something else?

Share this post


Link to post

Ok, there are now V6.1.9 & V6.2 Beta 23 Builds uploaded for both TBS DVB-C and Digital Devices Github.  Be grateful if anyone can test.

 

The new Digital Devices Github build now has ddbridge.conf placed in /config/plugins/UnraidDVB/ enabling you to edit it.  I have kept the default configuration to stop the I2C errors and plugin upgrades shouldn't affect it.  If you remove the plugin however, the file will be deleted.

 

ok, just had 2 runs and both times the DVB Adapter Drivers didn't get detected.

i went this way:

 

updated the plug-in to 2016.06.19a, then choose the new tbs-build, installed (over my previous install - should i've 1st need to deinstalled or install vanilla build?). rebooted: DVB Adapter Drivers not recognized.

 

then updated to the now newer 2016.06.19b plug-in, installed TBS DVB-C 6.1.9 build, rebooted, same error – not recognizing the DVB Adapter Drivers.

 

btw. i do see a line when booting up, shortly before the end, which writes: "File '/boot/config/plugins/UnraidDVB/ddbridge.conf' already there; not retrieving."

 

want me to try something else?

 

No I spotted the problem will compile another build.

 

Share this post


Link to post

Ok, there are now V6.1.9 & V6.2 Beta 23 Builds uploaded for both TBS DVB-C and Digital Devices Github.  Be grateful if anyone can test.

 

The new Digital Devices Github build now has ddbridge.conf placed in /config/plugins/UnraidDVB/ enabling you to edit it.  I have kept the default configuration to stop the I2C errors and plugin upgrades shouldn't affect it.  If you remove the plugin however, the file will be deleted.

 

ok, just had 2 runs and both times the DVB Adapter Drivers didn't get detected.

i went this way:

 

updated the plug-in to 2016.06.19a, then choose the new tbs-build, installed (over my previous install - should i've 1st need to deinstalled or install vanilla build?). rebooted: DVB Adapter Drivers not recognized.

 

then updated to the now newer 2016.06.19b plug-in, installed TBS DVB-C 6.1.9 build, rebooted, same error – not recognizing the DVB Adapter Drivers.

 

btw. i do see a line when booting up, shortly before the end, which writes: "File '/boot/config/plugins/UnraidDVB/ddbridge.conf' already there; not retrieving."

 

want me to try something else?

New build for you to test.  Overwrite your existing one.

Share this post


Link to post

Ok, there are now V6.1.9 & V6.2 Beta 23 Builds uploaded for both TBS DVB-C and Digital Devices Github.  Be grateful if anyone can test.

 

The new Digital Devices Github build now has ddbridge.conf placed in /config/plugins/UnraidDVB/ enabling you to edit it.  I have kept the default configuration to stop the I2C errors and plugin upgrades shouldn't affect it.  If you remove the plugin however, the file will be deleted.

 

ok, just had 2 runs and both times the DVB Adapter Drivers didn't get detected.

i went this way:

 

updated the plug-in to 2016.06.19a, then choose the new tbs-build, installed (over my previous install - should i've 1st need to deinstalled or install vanilla build?). rebooted: DVB Adapter Drivers not recognized.

 

then updated to the now newer 2016.06.19b plug-in, installed TBS DVB-C 6.1.9 build, rebooted, same error – not recognizing the DVB Adapter Drivers.

 

btw. i do see a line when booting up, shortly before the end, which writes: "File '/boot/config/plugins/UnraidDVB/ddbridge.conf' already there; not retrieving."

 

want me to try something else?

New build for you to test.  Overwrite your existing one.

 

just as a quick reply: installed, tuner got detected as DVB-C and TVHeadend also recognized it

so this looks alreday pretty good! thank you.  :)

 

i probably will go on later today/tonight and will report back then.

 

Share this post


Link to post

just as a quick reply: installed, tuner got detected as DVB-C and TVHeadend also recognized it

so this looks alreday pretty good! thank you.  :)

 

i probably will go on later today/tonight and will report back then.

 

Happy days, should work as expected, sorry about the first build.  Have to say the TBS documentation is a bit lacking on the subject.  Found the problem browsing their forums though...  :D

Share this post


Link to post

Hi CHBMB,

 

DD driver 0.9.23 with Max S8 works very well since days :). The "wrong values" for STR & SNR could be this option in the Makefile (dddvb/frontends/Makefile):

EXTRA_CFLAGS += -DDBVALS

 

Could you create a build without this compiler flag (in dddvb/frontends/Makefile) for testing the STR and SNR values?

#EXTRA_CFLAGS += -DDBVALS

 

Many Thx!

Share this post


Link to post

CHBMB

 

I'm running 6.1.9 with Digital Devices Octopus DVB-S/S2 and DVB-T tuners. TVHeadEnd as the PVR software.

 

Do I need to update and test these? (I'd prefer not as I've just got the whole house TV system working smoothly and I'll be shot if I start disrupting it again, but I can if it would be helpful)

 

Is the ddbridge.conf relevant to me?

 

Thanks

 

 

Share this post


Link to post

CHBMB

 

I'm running 6.1.9 with Digital Devices Octopus DVB-S/S2 and DVB-T tuners. TVHeadEnd as the PVR software.

 

Do I need to update and test these? (I'd prefer not as I've just got the whole house TV system working smoothly and I'll be shot if I start disrupting it again, but I can if it would be helpful)

 

Is the ddbridge.conf relevant to me?

 

Thanks

Well the Digital Devices Experimental is now defunct, so at some point you'll have to switch over.  ddbridge.conf in the new build is the same as in the old build so you shouldn't have to change a thing.

Share this post


Link to post

CHBMB

 

I'm running 6.1.9 with Digital Devices Octopus DVB-S/S2 and DVB-T tuners. TVHeadEnd as the PVR software.

 

Do I need to update and test these? (I'd prefer not as I've just got the whole house TV system working smoothly and I'll be shot if I start disrupting it again, but I can if it would be helpful)

 

Is the ddbridge.conf relevant to me?

 

Thanks

Well the Digital Devices Experimental is now defunct, so at some point you'll have to switch over.  ddbridge.conf in the new build is the same as in the old build so you shouldn't have to change a thing.

 

OK, I'll give it a go maybe next weekend. Will I be able to revert to my current version if I update the plugin? I'm guessing not.

 

 

Share this post


Link to post

Yeah you can, fundamentally nothing changes with my updates, just some formatting for the new builds and a changelog.  Can always downgrade.

Share this post


Link to post

Hi CHBMB,

 

DD driver 0.9.23 with Max S8 works very well since days :). The "wrong values" for STR & SNR could be this option in the Makefile (dddvb/frontends/Makefile):

EXTRA_CFLAGS += -DDBVALS

 

Could you create a build without this compiler flag (in dddvb/frontends/Makefile) for testing the STR and SNR values?

#EXTRA_CFLAGS += -DDBVALS

 

Many Thx!

My only problem with that is what is the effect going to be on others who use this without the Max S8?  Any links to info so I can read a bit.  I am very much against producing yet another build to be honest.

Share this post


Link to post

with DDBVALS - >dB values

without DDBVALS -> linear values

 

Maybe the application needs to change from dB to linear values to show the correct signal strengths.

 

Don't know if DVB-C is affected. But you are right, don't build to much builds.

Share this post


Link to post

with DDBVALS - >dB values

without DDBVALS -> linear values

 

Maybe the application needs to change from dB to linear values to show the correct signal strengths.

 

Don't know if DVB-C is affected. But you are right, don't build to much builds.

I can try...

Share this post


Link to post

with DDBVALS - >dB values

without DDBVALS -> linear values

 

Maybe the application needs to change from dB to linear values to show the correct signal strengths.

 

Don't know if DVB-C is affected. But you are right, don't build to much builds.

 

Try this one.  Extract the tar and copy bzroot, bzimage and bzroot-gui to your flash drive and reboot.  It's V6.2 Beta 23.  I haven't added it to the plugin as it was getting too confusing and I'm worried about other people inadvertently ending up as guinea pigs....

 

You can however use the plugin to change back to a different version afterwards.

 

Share this post


Link to post

Many thanks for your custom build. Did not change the strange signal strength values.

 

femon

status SCVYL | signal  95% | snr   2% | ber 0 | unc 1 | FE_HAS_LOCK

 

How cares, the tuner runs fine (also under bad weather conditions), which is most important  ;D.

 

With your work I can use my card in unRAID. Great work!

Share this post


Link to post

OK, well at least it's nice to satisfy our curiosity.  Glad we got it working and you bought the new Digital Devices Github repo to my attention.  Was wondering what to do with Digital Devices when the mercurial build started throwing errors on compile.  Knew it was a matter of time before it'll stop building on newer kernels.

 

Thanks for all your prompt testing.

Share this post


Link to post

Put the Max S8 now into the production system (6.1.9). Drivers are loaded but ddbridge.conf would not be respected at boot time. After boot i tried "rmmod ddbridge" and "modprobe ddbrige", ddbridge.conf would be respected but the modprobe needs round about 7-10 seconds to load the module and card does not proberly in unicable mode. Then put the card back into the test-system (6.2 beta 23) same thing (worked before, also after 5 reboots) ???. Installed debian 8.5 on the system compiled the driver and everthing works flawless.

 

I'm afraid to ask, but is it possible to upload temporary the image with "options ddbridge fmode=3 msi=0" (without the symbolic link) again? Download link for testing is enough.

 

Many many Thanks.

 

I'm sorry that I nerve  :-[

Share this post


Link to post

Can you try the beta23 version on your production server?  Help me see if there's a problem between different versions.

 

Also are you using a USB2 port to boot from?

Share this post


Link to post

I'll have to compile it again, so give me a day or so.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now