Option to change Boot Keyboard Language


rix

Recommended Posts

As briefly requested in the latest 6.20 beta thread:

 

Please add an option to select the keyboard language used in both the gui and the console boot modes.

 

I am sure a variety of users would benefit from this as typing strong passwords in the gui currently requires an in-depth knowledge of where US-Keys are placed on one's native keyboard.

 

This would resolve my difficulties in reaching the Unraid page from the gui mode, since my server is running on a non-standard port. Typing the colon currently is a real pain from my german layout.. I actually have to go to the Firefox settings page to copy and paste the http:// colon if I intend to use the web-gui.

 

Any solution from simple go script changes to a real setting in the web-gui would suffice.

 

This is not a request to translate the web-gui.

 

Possible duplicate: https://lime-technology.com/forum/index.php?topic=40989.0

 

I have installed nerdpack with kbd-1.15.3-x86_64-2 remotely and will try adding

loadkeys de

to my go script as soon as I am home.

  • Like 1
Link to comment
  • 3 weeks later...

Sadly load keys is not working for me. Seems like deeper changes are required

 

First, you need to install these packages:

 

http://mirrors.slackware.com/slackware/slackware64-current/slackware64/l/glibc-i18n-2.23-x86_64-1.txz

http://mirrors.slackware.com/slackware/slackware64-14.1/slackware64/a/kbd-1.15.3-x86_64-2.txz

 

Then, you should take a look into this: http://docs.slackware.com/slackware:localization

Link to comment

Thanks for your hint gfjardim  ;)

Just a question: Do i need to install glibc or can i simply change the setting in "/etc/profile.d/lang.sh" to "LANG=de_DE.utf8" ?

 

You only have en_US.utf8 installed right now, so you need download all other locales to be able to change between them.

Link to comment

Sadly load keys is not working for me. Seems like deeper changes are required

 

First, you need to install these packages:

 

http://mirrors.slackware.com/slackware/slackware64-current/slackware64/l/glibc-i18n-2.23-x86_64-1.txz

http://mirrors.slackware.com/slackware/slackware64-14.1/slackware64/a/kbd-1.15.3-x86_64-2.txz

 

Then, you should take a look into this: http://docs.slackware.com/slackware:localization

 

Ok - tried this procedure and its not working.

After a reboot, only US is present and changes in /etc/profile.d/lang.sh are back to default US  :o

Did also a locale -av and it gave me only "US".

So... how can i make this persistent?

 

Maybe its the installation...

I put all packages to folder "extra" on my USB-stick - was this maybe wrong?

Link to comment

Store whatever files you downloaded somewhere on your flash drive.

 

Modify /boot/config/go (/config/go on the flash drive) to include the various commands that you entered in to get everything going.

 

That's the only real way to get something to survive a reboot

 

Link to comment

I can't speak for why unraid only shops with us keyboards.

 

But to make the file in /etc survive after you make whatever changes are reuired to it copy it to the flash drive then copy it back within the go file

 

Sent from my LG-D852 using Tapatalk

 

 

Link to comment

After installing all this *.txz files, i saw that i was no longer able to reach my SMB-Shares so i removed all this stuff and did a reboot.

Now all shares are working again - very disappointing  ???

 

Are you using 6.2beta21, right?

 

My signature says 6.1.9  ;)

I never use betas - my sys is a "productive" one

And were can i find the "right" packages for 6.1.9?

Link to comment
  • 6 months later...

I would like to know, how did you solve the issue?

I am using the latest 6.2.2 Unraid.

 

According to slackware wiki I only need enter "setxkbmap de" in the terminal (GUI boot mode) to change the language.

The input language changes properly for the terminal and the browser to german.

 

However I cant get this work with the /boot/config/go

#!/bin/bash
# Start the Management Utility
/usr/local/sbin/emhttp &
# Set German Input Language
setxkbmap de &

 

What am I doing wrong?

Help is very appreciated.

 

Link to comment
  • 1 year later...

I needed Colemak as my keyboard layout for the GUI boot mode interface.

And the following should work for other keyboard languages and layouts as well.

Don't know if this post is effective on an "old" thread and I am happy to start a new one to be of better service to others. (Please, let me know!)

 

So I experimented with putting "setxkbmap us colemak" in the /boot/config/go file,

putting the same line in script in the User Scrips plugin with added custom Cron command @reboot,

and in the 'soft' terminal (the one started from the "terminal" button in the top bar of the webGUI),

but all of those won't stick.

In the "soft" terminal it gives the following error:

Cannot open display "default display"

Couldn't figure that out why it does that. 

 

Then I noticed when I started the terminal from the Lime Technology "start" button, outside Firefox, it did stick/work! 

 

Copied (cp) the /usr/share/X11/xorg.conf.d/90-keyboard-layout-evdev.conf to the /boot/custom folder

and edited it with nano to add "colemak" in the quotes on the -Option "XkbVariant"- line, so it looks like this:

Section "InputClass"
        Identifier "keyboard-all"
        MatchIsKeyboard "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
        Option "XkbLayout" "us"
        Option "XkbVariant" "colemak"
        Option "XkbOptions" "terminate:ctrl_alt_bksp"
EndSection

 

and added the "cp /boot/custom/90-keyboard-layout-evdev.conf /usr/share/X11/xorg.conf.d" line to the /boot/config/go file, shown below:

!/bin/bash
#Set the keyboard layout to US Colemak
cp /boot/custom/90-keyboard-layout-evdev.conf /usr/share/X11/xorg.conf.d
# Start the Management Utility
/usr/local/sbin/emhttp &
cp /boot/custom/docker-shell /usr/local/bin

Not sure if it makes a difference to add it before the "emhttp" commandline. 

 

Now when the boot GUI starts you can immediately use the new keyboard setting in the login and password box!

 

P.S.: Can we call it "bootGui", since that would make it in line with the wording of "webGui"? 

(I'm Dutch and is 3 hours past midnight, so I am not sure how to put this in the proper common English phrase) 

Link to comment
  • 5 months later...

would be good in the Unraid boot menu where you have an option titled like “location, time zone, langrage and keyboard settings” option and then Unraid can detect your time zone, and therefore your language and then your keyboard layout. However, the settings could be changed manually from the location settings using the arrow keys and enter button.

Link to comment
  • 2 years later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.