Jump to content
Sign in to follow this  
StrafeBink

Windows 10 - Can't access \\tower but can access web interface

8 posts in this topic Last Reply

Recommended Posts

Hi,

 

Recently updated to Windows 10 and Unraid worked as it should for around 24 hours. I am guessing since I currently have an up to date Windows 10 somewhere along the line something has been borked with SMB.

 

The web interface currently works perfectly, but whenever I try to access my files I am met with 'Access is denied' when using the correct credentials. My shares are a mix of Public and Private (if that makes a difference).

 

I have tried the following fixes I have found on the forum to no avail.. What else can I try?

 

Adding registry key

 

HKLM\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters\AllowInsecureGuestAuth

 

Enabling in gpedit.msc

 

Also changing 'Computer Configuration - Windows Settings - Security Settings - Local Policies - Security Options - Account: Guest account status' to Enabled.

Share this post


Link to post

Try setting up a local account for windows instead of one tied to a msn account

Share this post


Link to post

Try setting up a local account for windows instead of one tied to a msn account

 

My only account is a Local Account / Administrator. I don't use a Microsoft account.

Share this post


Link to post

And presumably you have the same user & credentials as your windows account set up as a user within unRaid.

 

You can try windows credential manager and clear the credentials

 

Share this post


Link to post

Nah, separate credentials and I have cleared them in the credential manager.

 

Just tried with same credentials and also no joy :(. Thinking I may have to roll back to Windows 8.1...

Share this post


Link to post

What worked for me was disabling SMB 2&3, forcing the connection to SMB v1.

 

Guide from Microsoft.

 

The relevant parts.

 

To disable SMBv2 and SMBv3 on the SMB client, run the following commands:

sc.exe config lanmanworkstation depend= bowser/mrxsmb10/nsi

sc.exe config mrxsmb20 start= disabled

 

And if you wish to reenable SMBv2 and SMBv3 at some point in the future when compatibility issues are worked out you do this:

 

To enable SMBv2 and SMBv3 on the SMB client, run the following commands:

sc.exe config lanmanworkstation depend= bowser/mrxsmb10/mrxsmb20/nsi

sc.exe config mrxsmb20 start= auto

 

Notes

You must run these commands at an elevated command prompt.

You must restart the computer after you make these changes.

 

This might not do it, but it's worked for me and a few other people.

Share this post


Link to post

You are a God amongst men gundamguy!

 

After scratching my head all day and Googling I didn't come across that fix at all. Works perfectly now!

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this