[Support] activ - TransmissionVPN

Recommended Posts

Wheres my downloads?  i  been reading and tought i set my downloads and watch folder ect  ect 

/downloads  /mnt/user/Downloads/Torrents/
/watch  /mnt/user/Downloads/Torrents/Watch
/config  /mnt/user/appdata/activ-transmissionvpn
/data  /mnt/user/Downloads/Torrents/


i see /home/nobody/Downloads when i try to download , it downloads but cant find my files it downloads 

if i set download i get this "Permission denied (/mnt/user/Downloads/Torrents/torrentfile)


i need this to work its first time i see a web ui , and it connected to my vpn , i tryed using filezilla to find the file and nothink:(


help please

Link to comment
11 hours ago, killeriq said:

Hi guys,


I have again problem - drives me nuts :D

Soon as ive finally setup docker,vpn moved torrents etc... I got BAN on one of the Trackers im using. As they are only allowing Transmission 2.04 (if im not misataken)

How to downgrade in Docker?




Sorry, there is no feature in the docker at the moment to specify a version. You would have to create your own version. If I mess with the scripts again I might have a look at implementing that.

Link to comment
Think you need to read up on permission on the docker website. I expect you didn't map the user correctly.

I posted the maps I used in my first post it created the watch folder and download folder has read and write permissions looks like 1 capital letter stumped it

Sent from my Pixel XL using Tapatalk

Link to comment
  • 3 weeks later...

Hi Hope someone can point me in the right direction. I have transmissionVPN and sonarr installed, set up and working with airvpn. I tell sonarr to grap an episode of something. It does and I can see it in transmission downloading. But I check in the downloads folder and there are no files. From what I have read it may be a Volume Mappings problem. It was working fine when I was using Transmission as oposed to TransmissionVPN.


Link to comment
3 hours ago, demon1 said:

From what I have read it may be a Volume Mappings problem.

Yep. Pick either /data or /downloads and change them all to be the same. Since you are changing the app side you will need to hit the edit button on the mapping to change it. After you change the mapping, be sure to change the app itself to look in the correct folder.

Link to comment

Hi jonathanm, thanks for the response. I have done as you said above and changed all the container path's to  /data and host path's to /mnt/user/Downloads/temp creating a temp file in Downloads. Still no sign of any download files in the new directory.



Link to comment

Just verifying, what is your "download-dir" path in your settings.json file?


If its "download-dir": "/downloads" then use "/downloads" as your Host Path.


If your downloads folder is on your cache drive, ex. "/mnt/cache/Downloads" , try using "cache" in the path vs "user"


We'll get this figured out!

Link to comment

If this is any help, from what I can remember I did this to setup:



"download-dir": "/downloads/complete",
"download-queue-enabled": true,


"incomplete-dir": "/downloads/incomplete",
"incomplete-dir-enabled": true,


"umask": 2,


In /mnt/cache/Downloads/ I let Transmission create the "complete" and "incomplete" (torrent.part files) folders.



/downloads --> /mnt/cache/Downloads/



/downloads --> /mnt/user/Downloads/

Link to comment

Hi Andy,

Thanks for your help

the path listing in settings.json was "user/nobody/downloads" or something like that, I have changed it to


 "download-dir": "/downloads/complete",
 "download-queue-enabled": true,
  "incomplete-dir": "/downloads/incomplete",
  "incomplete-dir-enabled": true,


In sonarr and Trasmission I have tried


/data --> /mnt/user/downloads/

/downloads --> /mnt/user/downloads/



I can see in the unraid gui under share's a new share called "downloads", but I cannot see it in windows explorer. I have changed the container path from "data" to "downloads" to no avail. I am not using the cache for this folder, . Its quite frustrating as I know its close to working.

Link to comment

I'm really sorry, I mistyped above with this statement about your JSON file:

If its "download-dir": "/downloads" then use "/downloads" as your Host Path.


I meant "/downloads" should be your Container path, not Host Path!  My bad.


Anyways, if you're using this in Transmission now:

"download-dir": "/downloads/complete",
"download-queue-enabled": true,


"incomplete-dir": "/downloads/incomplete",
"incomplete-dir-enabled": true,


Its looking for a folder "downloads" (with a lower case "d") in the docker container:


/downloads --> /mnt/user/downloads/


If you already have a downloads share created named "Downloads" with a capital "D", then use this for Transmission (you should also have "Downloads" referenced in Sonarr):


/downloads --> /mnt/user/Downloads/


When you set it as this:

/downloads --> /mnt/user/downloads/


It created the share "downloads" with a lower case "d"


Make the changes above to reference "Downloads" with a capital "D" and then delete the "downloads" share with the lower case "d"


If you're using Windows to find the share on the network, I don't think it can distinguish between "Downloads" and "downloads".


I think that should do it!

Link to comment

Hi Again,


            So its now downloading and I can see the file in the incomplete & complete folders. However it is creating an extra folder so my download path looks like data/ _2X68Q~7/complete. All is fine except it breaks the mover service in sonarr which is looking for data/complete/filename for which the automation is half the point!

Link to comment
  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.