Jump to content
Squid

[Plugin] CA Fix Common Problems

1001 posts in this topic Last Reply

Recommended Posts

indeed it does...I can see clearly now, thank you!

the whole ending section is about permissions problems...is there an automated method for making sure *all* files get correct permissions?

 

Share this post


Link to post
36 minutes ago, tillkrueger said:

indeed it does...I can see clearly now, thank you!

the whole ending section is about permissions problems...is there an automated method for making sure *all* files get correct permissions?

 

Tools>docker safe new permissions

You may need to install via CA if you haven’t already.

  • Like 1

Share this post


Link to post

No, I do have it, but I'll wait until a move operation is finished...don't wanna compound the issue.

 

thanks!

 

Share this post


Link to post

finally got a chance to run "docker safe permissions" and it did indeed fix my issues with not being able to move certain files between disk shares...worked like a charm.

Thanks, wgstarks!

 

Share this post


Link to post

Hello there,

 

the plugin is hanging at scanning my system and I can't alter the properties. Does anyone have a clue?

 

2018-11-25 13_55_05-Brainbox Simulator.png

Edited by pappaq

Share this post


Link to post

Due to the nature of unRaid 6.6, on any of the pop-ups that look like that one if the process does not complete in 120 seconds then it will never close automatically.  Close the browser window and then re-open it and the list will probably be populated

  • Upvote 1

Share this post


Link to post
11 minutes ago, Squid said:

Due to the nature of unRaid 6.6, on any of the pop-ups that look like that one if the process does not complete in 120 seconds then it will never close automatically.  Close the browser window and then re-open it and the list will probably be populated

Didn't work, but with another browser I was able to disable the scan for spun down disks. That was all that I wanted. It can scan and notify me in the background now.

 

Thanks anyway.

Share this post


Link to post
1 minute ago, pappaq said:

another browser 

What is the original browser?

Share this post


Link to post
5 minutes ago, Squid said:

What is the original browser?

Maybe I should give you a little bit more background information. The original browser is Chrome and the browser I could make the change with is Opera, but I was only able to change the setting due to the popup not initially showing up. After I changed it the popup appeared and it didn't disappeared like in chrome.

 

Maybe I uninstall the plugin until later releases.

Share this post


Link to post
1 minute ago, pappaq said:

Maybe I uninstall the plugin until later releases.

While changing around how the popup works (to avoid the 120second thing) is on the todo list, it is definitely not a high priority.  It should complete within about 10 seconds tops, unless you've got tons and tons of drives and they are all spun down and the cumulative time to spin them up sequentially exceeds 120 seconds.

 

TLDR: Don't expect an update anytime soon

  • Upvote 1

Share this post


Link to post
28 minutes ago, Squid said:

While changing around how the popup works (to avoid the 120second thing) is on the todo list, it is definitely not a high priority.  It should complete within about 10 seconds tops, unless you've got tons and tons of drives and they are all spun down and the cumulative time to spin them up sequentially exceeds 120 seconds.

 

TLDR: Don't expect an update anytime soon

This is not the case. I don't know what is causing this behaviour and at the moment I am too lazy to get to the bottom of it. I will let the addon run like this for now. The option I wanted to set is now set and the rest works.


It's not that bad that it doesn't have a high priority. I can wait.

 

Many thanks for the quick answers and on a Sunday! Have a nice weekend!

Share this post


Link to post

Overnight I began receiving this error about communicating with github and being unable to download the list of blacklisted plugins.

 

Screenshot_1.thumb.jpg.c9b2c3cf1092136cca8ff33ba0600f87.jpg

I am using the google DNS and I am able to browse github without issue from my browser.  I also tested pinging github and got a response fine, so I'm not sure whats going on.  I've attached diagnostics if its helpful.

tower-diagnostics-20181130-0721.zip

Share this post


Link to post
10 minutes ago, mattekure said:

Overnight I began receiving this error about communicating with github and being unable to download the list of blacklisted plugins.

 

Screenshot_1.thumb.jpg.c9b2c3cf1092136cca8ff33ba0600f87.jpg

I am using the google DNS and I am able to browse github without issue from my browser.  I also tested pinging github and got a response fine, so I'm not sure whats going on.  I've attached diagnostics if its helpful.

tower-diagnostics-20181130-0721.zip

same issue here

Share this post


Link to post
23 minutes ago, mattekure said:

Overnight I began receiving this error about communicating with github and being unable to download the list of blacklisted plugins.

 

Screenshot_1.thumb.jpg.c9b2c3cf1092136cca8ff33ba0600f87.jpg

I am using the google DNS and I am able to browse github without issue from my browser.  I also tested pinging github and got a response fine, so I'm not sure whats going on.  I've attached diagnostics if its helpful.

tower-diagnostics-20181130-0721.zip

 

Same issue here.

 

Also:

- Ping github works

- traceroute github works

- I was able to install a new random app from the community apps tab

Share this post


Link to post

Typo on my part when doing maintenance on CA.  All fixed up now.

Share this post


Link to post

Dear all

 

if I understand correctly the "Docker Safe New Perms" is installed by the plugin "Fix Common Problems", so I post my problem here.

 

I have run Docker Safe New Perms on all disks except for the Cache disk (nothing to be moved).

Then I wanted to use unBalance to move the content of one disk to another disk. During the planning phase unBalance would complain that it found directories with improper permissions and I shall run "Docker Safe New Perms".

So how can this be since I did run "Docker Safe New Perms" in advance.

 

It turns out that unBalance considers existing Set-U-ID oder Set-G-ID bits as problematic, and "Docker Safe New Perms" does not clear out these bits.

 

I do not know whether these bits are actually a real problem for the unBalance procedure.

But if they are, then "Docker Safe New Perms" should remove those bits, e.g. by setting the permissions to 00777. (Note the leading 2 zeroes! Yes this is correct, with just one zero it will NOT clear those bits!)

 

This can be done manually as long as "Docker Safe New Perms" does not do it:

find /mnt/disk?/ -type d -and  -not -perm 0777 -exec chmod 00777 {} \;

 

However, if those bits do not create a problem with the unBalane procedure, the unBalance should not report them as an issue.

if you search like this, you will find the directories where SUID or SGID are set:

find /mnt/disk?/ -type d -and  -not -perm 0777

This is not what we want if we do not want to report those directories. Instead it should be used:

find /mnt/disk?/ -type d -and  -not -perm -0777

Note the "-" (minus) character in front of the 0777. Now additional bits being set will not be reported!

 

It would be great to get feedback from the author of unBalance whether these bits should be cleared or whether the should rather not be reported.

 

In the first case it would be good to get feedback from the author of the plugin "Fix Common Problems" whether clearing of the SUID SGID bit for directories can/will be implemented.

 

I am going to cross-link both postings in both support threads.

unBalance support thread:

 

Edited by jus7incase

Share this post


Link to post

All docker safe new perms is is a wrapper for the stock new perms script (tools - new perms) that runs it against every share except for your appdata share

 

The script itself is

function process {
  list="$1"
  [[ $# -ge 2 ]] && owner=$2 || owner=nobody
  [[ $# -ge 3 ]] && group=$3 || group=users
  ifs=$IFS; IFS='|'
  for dir in $list; do
    echo "$dir"
    if [[ -d $dir ]]; then
      echo processing "$dir"
      echo ... chmod -R u-x,go-rwx,go+u,ugo+X "$dir"
      chmod -R u-x,go-rwx,go+u,ugo+X "$dir"
      echo ... chown -R $owner:$group "$dir"
      chown -R $owner:$group "$dir"
      echo ... sync
      sync
    fi
  done
  IFS=$ifs
}

 

Share this post


Link to post

Running into issues today with FCP -- my error log states that I'm experiencing connection time outs. The only thing I've changed to my system is installing a dockerized version of pihole in the past week. Could this be causing the error?

Dec 21 14:28:47 Tower root: Fix Common Problems Version 2018.12.07
Dec 21 14:30:47 Tower nginx: 2018/12/21 14:30:47 [error] 13756#13756: *21253 upstream timed out (110: Connection timed out) while reading response header from upstream, client: 192.168.1.11, server: , request: "POST /plugins/fix.common.problems/include/fixExec.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock", host: "192.168.1.16", referrer: "http://192.168.1.16/Settings/FixProblems"

Thanks for any insight.

Share this post


Link to post

Hey Squid,

 

I have a conundrum (great 2bit word).  My Backup Server is running on 6.3.5 but can't update.  Reading the posts, I need to install CA-Fix Common Problems to eliminate issues prior to the update.  That requires CA-Community Applications, which could not be updated as the OS was too low, so was removed.  Without Community Applications, I cannot install Fix Common Problems (duh)!  I've searched everywhere for the URL for Fix Common Problems, but everything points back to this thread and Community Applications.  HELP!  I'm Stuck!

 

Dave (Best Wishes for a Happy 2019 New Year)

Share this post


Link to post
24 minutes ago, Archivist said:

I need to install CA-Fix Common Problems to eliminate issues prior to the update.

Do you think you have issues? Have you read the Update Notes?

 

Share this post


Link to post

Yes, I did thanks, but therein lies the problem!  Without your suggested Fix Common Problems first (which I can't find the URL for w/o Community Applications which is not loaded, hence no Apps to Search), I can't clean the system prior to updating to 6.4 or later so the current Community Applications suite will load. 

651461773_ScreenShot2018-12-27at9_13_51PM.png.4b1463abdf4a0cf19bcfb7e02e85dfc3.png928055255_ScreenShot2018-12-27at9_15_05PM.png.f93c1d2bef7765311ee49ca30a58dd58.png1077627478_ScreenShot2018-12-27at9_15_29PM.thumb.png.b2159a2109ea7f037976a60068af3329.png

Share this post


Link to post

Love the plugin. I've used to to identify and fix many issues with my server. The one thing I would like to be able to do is disable the Alerts generated when there is an update to the plug-in. I feel this should be a settable option or at the very least it should be a warning and not an alert. It is super annoying to see that there are 5 alerts on my server and they are all update notifications for this plug-in.

Share this post


Link to post
Posted (edited)

Add to ignore list.

 

And, IMHO if you're using FCP, then it being out of date is an error as you're going to be missing out on fixes, new errors / warnings / etc.

Edited by Squid

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now