[Plugin] CA Fix Common Problems


1371 posts in this topic Last Reply

Recommended Posts

  • Replies 1.4k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

This plugin is designed to find and offer up suggestions to a multitude of configuration errors, outright problems, etc for numerous aspects of your unRaid server.   To install this plugin,

Mainly because my keyboard is worn out from replying "Uninstall Advanced Buttons", today's update features an "Update Assistant" which sits on the Tools Menu (next to Update OS)   This perfo

False positives related to FCP and cache-pools will get fixed.  Sorry...  Didn't even think about FCP's test on that one when I started with beta25

Posted Images

8 minutes ago, trurl said:

I never use disk shares, but I think if you have them enabled, then any disk you are sharing should have security settings you can get to by clicking on the disk in Main.

Nope, that's not it but you got me looking in the right places.

 

Under Shares | Disk | Security.  There's "Public", "Secure" & "Private". Mine look to be set to "Secure".

 

For simplicity, I'll set a disk to "Public", do the clean up then set it back to "Secure".  Once I'm done with this clean up, I'll turn off disk shares anyway, so that should be sufficient.

I decided to play for about 30 seconds and figured out the proper share settings. I've got myself as a user now and have granted myself the proper access.

 

thanks again!

Edited by FreeMan
Link to post
12 minutes ago, FreeMan said:

Under Shares | Disk | Security.

That's right, I remember now, another tab in Shares. I just never use them myself. I always go to Midnight Commander if I want to work with the disks.

Link to post
Just now, trurl said:

That's right, I remember now, another tab in Shares. I just never use them myself. I always go to Midnight Commander if I want to work with the disks.

 

I'm sure there's a setting in MC, but with the lengths of my paths & file names, MC just doesn't show enough for me to be sure I'm working with the right file sometimes.

I need an over/under window split instead of side-by-side. :)

 

Link to post
1 hour ago, FreeMan said:

 

I'm sure there's a setting in MC, but with the lengths of my paths & file names, MC just doesn't show enough for me to be sure I'm working with the right file sometimes.

I need an over/under window split instead of side-by-side. :)

 

Also, you can usually drag the corner of the terminal window to expand it whichever way you want, and the contents will fill the new space instead of expanding the print. I know putty will do that. Combined with changing the layout, I'm pretty confident you should have very few files that would wrap. :D

 

Check out the dupeguru docker as well, it's very versatile when it comes to cleaning up this kind of mess.

Link to post
1 hour ago, jonathanm said:

Also, you can usually drag the corner of the terminal window to expand it whichever way you want, and the contents will fill the new space instead of expanding the print. I know putty will do that

That's genius!

 

hangs head in shame for not having thought of that himself any time in the last... 6 years

 

Edited by FreeMan
Link to post

How can I fix this?

 

 

Share Docker set to cache-only, but files / folders exist on the array You should change the share's settings appropriately  or use the dolphin / krusader docker applications to move the offending files accordingly. Note that there are some valid use cases for a set up like this. In particular: THIS

 

The share is already configure as a cache only but it seems that the files are still in the array. How can I fix it? using "mc" in command line and moving the files, but where?

Link to post
25 minutes ago, L0rdRaiden said:

The share is already configure as a cache only but it seems that the files are still in the array. How can I fix it? using "mc" in command line and moving the files, but where?

You would have to find the array disk the files/folders are on and move them to cache.

 

Alternatively, you could go to Settings - Docker and stop the service, change the Docker share to cache-prefer, run mover, then restart the service.

Link to post

I have docker and VM shares configured as cache only, I have even exclude the disk, and the share show this message "Share is outside the list of designated disk"

then I click on mover time passes but the data is still in the disk.

 

I will try the other method but why the mover doesn't work?

Link to post
1 minute ago, L0rdRaiden said:

I have docker and VM shares configured as cache only, I have even exclude the disk, and the share show this message "Share is outside the list of designated disk"

then I click on mover time passes but the data is still in the disk.

 

I will try the other method but why the mover doesn't work?

If a Share is set as cache only then files will never be moved from the array to the cache.    If you want this to happen then you need cache-prefer to be set.    Turning on the help in the GUI gives more detail on how the different settings work.

Link to post
4 minutes ago, itimpi said:

If a Share is set as cache only then files will never be moved from the array to the cache.    If you want this to happen then you need cache-prefer to be set.    Turning on the help in the GUI gives more detail on how the different settings work.

 

 

Thanks, now is moving files, I was using cache only due to this message, maybe it should be changed.

 

 

Default docker appdata location is not a cache-only share If the appdata share is not set to be cache-only, then the mover program will cause your docker applications to become inoperable when it runs (6.1.x). Under 6.2+, this setting should not affect the operation of the application, but it will definitely impact significantly the performance of the application. Fix it via 

 

Link to post

I seem to be getting a spurious notification about "inotify-tools set to install"!   I cannot find what might be causing that as I do not have any reference to it that I can see in the nerd pack settings.   What is actually checked to cause this message to be output?.

Link to post
4 hours ago, itimpi said:

I seem to be getting a spurious notification about "inotify-tools set to install"!   I cannot find what might be causing that as I do not have any reference to it that I can see in the nerd pack settings.   What is actually checked to cause this message to be output?.

/boot/config/plugins/NerdPack/NerdPack.cfg

 

A line beginning with "inotify-tools" set to be "yes"

 

Probably time to get rid of this test since inotify tools has been in unRaid since 6.3.0-rc6 and NerdPack was updated back then to not give you the option to install it.

Edited by Squid
Link to post
54 minutes ago, Squid said:

/boot/config/plugins/NerdPack/NerdPack.cfg

 

A line beginning with "inotify-tools" set to be "yes"

 

Probably time to get rid of this test since inotify tools has been in unRaid since 6.3.0-rc6 and NerdPack was updated back then to not give you the option to install it.

I actually have no entry at all in that file for inotify-tools, let alone one set to “yes”!   I seem to remember removing it at around the time inotify was built into the standard unRAID release.

Link to post
1 hour ago, itimpi said:

I actually have no entry at all in that file for inotify-tools, let alone one set to “yes”!   I seem to remember removing it at around the time inotify was built into the standard unRAID release.

Looking at the code, I don't see how it can fail.  Does it consistently give you the warning?  Can you post your nerdpack.cfg file?

Link to post
1 hour ago, Squid said:

Looking at the code, I don't see how it can fail.  Does it consistently give you the warning?  Can you post your nerdpack.cfg file?

 

The issue appears to be consistent as far as I can see.  Attached is the requested file.

 

 

NerdPack.cfg

Link to post

Image result for update problems funny

 

Mainly because my keyboard is worn out from replying "Uninstall Advanced Buttons", today's update features an "Update Assistant" which sits on the Tools Menu (next to Update OS)

 

This performs a couple of checks to see if you're going to have problems if you update your OS.  In otherwords, you run it before hitting Update OS

 

Problems it will catch:

  • Plugins up to date
  • Incompatible plugins with the updated unRaid OS
  • At least 4G memory
  • Any disabled disks present (doesn't actually hinder an update, but really something you'd be nuts not to take care of prior to an update)
  • Cache drive partition starts on sector 64 (would catch all those "unmountable" cache drives after updating)
  • Basic RW test to the flash drive
  • Zenstates set up in the go file
  • Any excess parameters on the emhttp line in the go file

Tests are not definitive, there may be valid use cases if there's a failure, but it will at least hopefully save me from buying another keyboard again  :D

 

EDIT: More tests coming...

Edited by Squid
Link to post
3 minutes ago, Squid said:

but it will at least hopefully save me from buying another keyboard again  :D

Wishful thinking.:D

 

I bet you just get a bunch of questions about why the assistant is saying that Advanced Buttons isn’t compatible.:S:)

Link to post
9 minutes ago, wgstarks said:

Wishful thinking.:D

 

I bet you just get a bunch of questions about why the assistant is saying that Advanced Buttons isn’t compatible.:S:)

And preclear plugin of course.

Link to post
4 minutes ago, trurl said:

And preclear plugin of course.

And OpenVM tools, the older libvirt hot plug, etc.  Its not static, dynamically updated whenever you execute the script, and it bases it results not on the version of unRaid you're currently running, but what the version available is.  Will also adjust itself to whether you're on the stable or next branch of the OS.  Tested down to unRaid 6.3.5 as current version, but should work for users running 6.1.9+

Edited by Squid
Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.