[Plugin] CA Fix Common Problems


1371 posts in this topic Last Reply

Recommended Posts

7 minutes ago, bremen1874 said:

What I can't understand is that there are still warnings related to PlexMediaServer and CrashPlanPro. It's still reporting that files exist on cache and I haven't got a cache drive connected.

Docker will create a cache folder that only exists in RAM if there is no physical cache drive attached and the docker template calls out a /mnt/cache location. Check your plex and crashplan docker settings and be sure you only have /mnt/user and no /mnt/cache.

Link to post
  • Replies 1.4k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

This plugin is designed to find and offer up suggestions to a multitude of configuration errors, outright problems, etc for numerous aspects of your unRaid server.   To install this plugin,

Mainly because my keyboard is worn out from replying "Uninstall Advanced Buttons", today's update features an "Update Assistant" which sits on the Tools Menu (next to Update OS)   This perfo

False positives related to FCP and cache-pools will get fixed.  Sorry...  Didn't even think about FCP's test on that one when I started with beta25

Posted Images

I had changed all of the /mnt/cache to /mnt/user.

 

I just realised that unRAID wasn't quite up-to-date. With the update to 6.5.3 installed all of the duplicate errors have gone.

 

I don't know why they survived the previous couple of reboots.

Link to post

Hello, I have two new errors:

Template URL for docker application nginx is missing. The template URL the author specified is https://raw.githubusercontent.com/linuxserver/docker-templates/master/linuxserver.io/nginx.xml. The template can be updated automatically with the correct URL.

 

Same error for radarr, there is a 'apply fix' button next to the two errors, but clicking just pops up with 'ERROR: Missing template.'

I'm not able to edit either of these two dockers, the 'edit' link is not there.

 

Any ideas?

Link to post
4 hours ago, darkangelus said:

I'm not able to edit either of these two dockers, the 'edit' link is not there.

Most likely because for some reason you (inadvertently) deleted /config/plugins/dockerMan/templates-user/nameOfTemplate.xml.  Alternatively, there was an issue with 6.5.1? where if you renamed an application, then the template wound up getting deleted wrongly

Link to post
20 hours ago, Squid said:

Most likely because for some reason you (inadvertently) deleted /config/plugins/dockerMan/templates-user/nameOfTemplate.xml.  Alternatively, there was an issue with 6.5.1? where if you renamed an application, then the template wound up getting deleted wrongly

Hi, thanks for the reply. I've checked the folder and the two xml's are there... however they are both 0kb.

Would I be able to just copy/paste from the github templates or is there a better way?

Link to post

Downloading from GitHub is identical to reinstalling via Apps tab

 

I'd make a note of your paths / ports for the app, then remove the app.  After that, reinstall it via Apps and set your paths/ports identically

Link to post
The author (or moderators of Community Applications) of the plugin template (https://raw.githubusercontent.com/coppit/unraid-mosh/master/mosh.plg) has specified that this plugin is incompatible with your version of unRaid (6.5.3). You should uninstall the plugin here: Maximum OS Version: 6.4.1

I didn't specify any such thing. Tested as working with 6.5.3. How do I get this fixed?

Link to post
55 minutes ago, coppit said:

or moderators of Community Applications

Was based upon reports at the time.  Already been reverted.  (IIRC, the plugin wouldn't even install under 6.5.x)

Edited by Squid
Link to post

@Squid, is it possible to add the hostname of the server to the notifications that Fix Common Problem sends out? I'm using Pushover for unRAID notifications but me having 4 unRAID servers, I have to go to all servers to check which one produced the notification. See attached screenshot.

 

Is it possible for you to add the hostname to the notifications or maybe with a toggle to enable and disable it showing the hostname?

 

Thanks!

IMG_4002.jpg

Link to post
30 minutes ago, ken-ji said:

Go back to your Pushover API page and  make one application for each of your unRAID servers.

then edit the config on each unRAID server to use the the correct application token

kinda like mine is setup

I don't use pushover, but I've got the same issue with email based notifications from FCP. Are you suggesting I should create a separate email account for each different server?

I already use and manage a single email just for all my servers and embedded type devices to use for notifications, so it would be nice if FCP would include the server name in the notification.

Link to post
10 minutes ago, jonathanm said:

it would be nice if FCP would include the server name in the notification

Wouldn’t it be better if all notifications included the server name rather than just FCP? Or is it just FCP notifications that don’t ID the server?

Edited by wgstarks
Link to post

@jonathanm I stopped using email after switching to pushover - was getting too many notices - all my devices email alerted... all my browsers and android devices were doing pushover...

:D But yes, I gave each server an email address.

 

Now I got curious and took a quick look - and I stand corrected.

Its the fault of the plugins/webui as they don't pass the hostname to the notify script (which in hind sight should probably prefix the hostname to the subject anyway)

 

So @Squid and @bonienl please fix the notify call.

Edited by ken-ji
Link to post
7 hours ago, ken-ji said:

Its the fault of the plugins/webui as they don't pass the hostname to the notify script

 

It is up to the initiator of the notification what to include in the message. The notifiy script has several options to construct a notification message.

 

All notifications generated by unRAID itself will have the server name in the subject part of the message.

 

And @Squid just shows how easy it is to add the server name :)

 

Link to post
  • 3 weeks later...

I am getting a fail notice that I don't understand.

 

I just finished a copy-and-shrink-array operation, removed two disk, New config and now rebuilding parity.

This morning I got the email quoted below and the red box notification on the Main page.

But when I got to "Fix Common Problems" plugin page, it says: 

"No errors found"

Can I ignore this?

 

Quote

unRAID Status: Notice [TOWER] - array health report [FAIL]

 

Event: unRAID Status
Subject: Notice [TOWER] - array health report [FAIL]
Description: Array has 10 disks (including parity & cache)
Importance: alert

Parity - HGST_HUH728080ALE600_VKGWSJWX (sdj) - active 36 C [DISK INVALID]
Disk 1 - WDC_WD20EARS-00MVWB0_WD-WCAZA4336067 (sdc) - standby [OK]
Disk 2 - WDC_WD30EZRX-00DC0B0_WD-WCC1T1078908 (sdd) - active 33 C [OK]
Disk 3 - HGST_HDN724040ALE640_PK1334PCJZXT9S (sdi) - active 36 C [OK]
Disk 4 - WDC_WD30EZRX-00DC0B0_WD-WMC1T2463685 (sdb) - active 32 C [OK]
Disk 5 - WDC_WD20EARS-00MVWB0_WD-WCAZA0765138 (sdf) - standby [OK]
Disk 6 - WDC_WD30EZRX-00D8PB0_WD-WCC4N0899764 (sde) - active 32 C [OK]
Disk 7 - WDC_WD30EZRX-00DC0B0_WD-WCC1T1338318 (sdh) - active 37 C [OK]
Disk 8 - HGST_HDN724040ALE640_PK2334PCJWEV4B (sdl) - active 39 C [OK]
Cache - ST31000528AS_9VP6J2BT (sdg) - standby [OK]

Parity sync / Data rebuild in progress.
Total size: 8 TB
Elapsed time: 7 hours, 45 minutes
Current position: 2.32 TB (29.0 %)
Estimated speed: 63.9 MB/sec
Estimated finish: 1 day, 41 minutes
Sync errors corrected: 0

 

tower-diagnostics-20180817-1016.zip

Link to post
  • 3 weeks later...

I am on the 6.6.0-rc1 build and I cannot seem to acknowledge or ignore the unclean shutdown warning. It acts like it worked until I refresh the page and it is still there. Nothing in the Chrome console when I click the buttons.

 

Edit: I've also tried clearing the cache and all that fun stuff.

Edited by wreave
Link to post

Just a couple of comments on the last couple updates to FCP and unRaid 6.6

 

--cpuset-cpus is deprecated on extra parameters (docker applications) in unRaid 6.6   While the option still works, it is highly recommended to instead utilize the CPU pinning option when editing the application, as unexpected results (both in the GUI and when running the container) may happen if still utilizing --cpuset-cpus, especially if utilizing both the GUI and the extra parameters option.  This is flagged as an error

 

unRaid 6.6 (rc2+) now also allows you to isolate CPUs instead of manually editing the syslinux.cfg file.  FCP will flag as an error if you pin a docker application to multiple isolated CPUs.  Long technical explanation, but this will not give you the results you may be expecting (unless you know exactly what you're doing).  Pinning a docker app to a single isolated core however will give you the expected results.  This is flagged as an error

Link to post
On 9/4/2018 at 6:12 PM, wreave said:

I am on the 6.6.0-rc1 build and I cannot seem to acknowledge or ignore the unclean shutdown warning. It acts like it worked until I refresh the page and it is still there. Nothing in the Chrome console when I click the buttons.

 

Edit: I've also tried clearing the cache and all that fun stuff.

This will happen if for some reason your flash drive dropped offline.  But, you should also have another error regarding that.

Link to post
  • 2 weeks later...

I have a dedicated device for my docker files - docker.img and appdata.  This is auto-mounted by the unassigned devices plugin, as /mnt/docker

 

Fix Common Problems always reports "Invalid folder docker contained within /mnt".  Is there a more acceptable way to configure this, or should I simply "Ignore Error"?

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.