Jump to content
Squid

[Plugin] CA Fix Common Problems

1170 posts in this topic Last Reply

Recommended Posts

Issues that are set to ignored still put entries into the log.  If they are ignored, there should not be any log entries.

I disagree there.  Simply because they are still issues that the user has chosen to ignore for whatever reason.  And if they are not put into the syslog, then any assistance the user is seeking via the forums will not have all of the relevant information.

 

ie: a user is having issues accessing shares, but has chosen to ignore the fact that there is myShare and MyShare coexisting at the same time. 

 

I just don't want people completely turning off notifications simply because they have a valid use case (or completely disagree with) those warnings.

 

If you still think that I'm wrong here, I'll make it optional to log the ignored issues.

 

The choice is yours on how to handle this.  I just thought if I choose to ignore an issue, it should not log any entries.

 

The issue I have is with a Logitech Media Server Docker that was not configured to work properly as a dlna server because it will choose upnp ports based on what is available and I had to set the network to 'Host' to get it to work properly.  I don't see it being fixed because Logitech is dropping their media players and it is not a good use of time to rework the Docker.  I assumed when I asked for it to be ignored, it would not show up in the log.

 

Another issue is that I developed a custom plugin I use for my particular situation that Community Applications would not know about.

 

Maybe classify some issues as not critical and allow only those to be ignored.  You know as well as I do that a person will choose to ignore an issue, not look at their log, and then ask for support.  If you don't allow critical issues to be ignored, they continue to show and maybe then get the attention they deserve.

Share this post


Link to post

Since we can now backup into dated folders, can we get a options to keep the last X number of dated folders and removed the rest?

 

Thanks

Myk

 

Share this post


Link to post

Having a dirty mind makes ordinary conversations much more interesting

 

- Added in improper shutdown checks

- Check user shares for standard LT permissions of 0777

- Added in "Troubleshooting mode"

 

Troubleshooting mode would generally only get used when you're having weird crashing issues, complete lock ups of the server, random reboots, etc

 

What it'll do is

 

  • Run unRaid's diagnostics every 30 minutes - file(s) saved to /config/logs/ on the flash drive
  • Run a subset of this plugin's checks every 10 minutes - Currently just available free space on /var/log and rootfs - also reports in syslog the current used space
  • Runs uptime every 10 minutes - so that the sysload is logged
  • Starts a tail on the syslog (file stored in config/logs/syslog.txt on the flash drive so that in the event of a crash / lockup, a syslog up to the actual crash can be retrieved

In other words, I've made this (with some extra features) into a plugin  http://lime-technology.com/wiki/index.php/Troubleshooting#Capturing_your_syslog

 

- still trying to figure out how to capture (if its even possible) the crash dump messages that get output to the local monitor to a file.  (ie: I want to permanently redirect stderr for a currently running bash instance to a file if anyone wants a challenge) 

 

The point in running multiple diagnostics, the subset of tests, and logging the sysload is so that when asking for help and posting the diagnostics (some or all), a trend leading up to the crash can hopefully be discerned

 

Note that once this mode is entered the only way to abort it is to restart the server.

If you've entered this mode looking for help on the forums, make sure you post at least the last diagnostic file generated, and the syslog.txt file

 

Other changes - a scan for problems is now automatically done with every start of the array

- temporarily removed HPA checks as my secondary server is having a very weird issue with them (disabling a disk when its run), and I don't want to cause anybody any issues til I sort out what's happening.

 

 

Share this post


Link to post

Regarding the new permission check...here's what mine is set to now:

 

Share Misc has non-standard permissions set The permission on the share is currently set to 0770 (standard permissions are 0777). You may have trouble accessing this share locally and/or over the network due to this issue. You should run the

tool to fix this issue

Share MoviesHD has non-standard permissions set The permission on the share is currently set to 0770 (standard permissions are 0777). You may have trouble accessing this share locally and/or over the network due to this issue. You should run the

tool to fix this issue

Share MoviesSD has non-standard permissions set The permission on the share is currently set to 0770 (standard permissions are 0777). You may have trouble accessing this share locally and/or over the network due to this issue. You should run the

tool to fix this issue

Share Music has non-standard permissions set The permission on the share is currently set to 0770 (standard permissions are 0777). You may have trouble accessing this share locally and/or over the network due to this issue. You should run the

tool to fix this issue

Share .PhAzE-Common has non-standard permissions set The permission on the share is currently set to 0755 (standard permissions are 0777). You may have trouble accessing this share locally and/or over the network due to this issue. You should run the

tool to fix this issue

Share Photos has non-standard permissions set The permission on the share is currently set to 0770 (standard permissions are 0777). You may have trouble accessing this share locally and/or over the network due to this issue. You should run the

tool to fix this issue

Share TV_Shows has non-standard permissions set The permission on the share is currently set to 0770 (standard permissions are 0777). You may have trouble accessing this share locally and/or over the network due to this issue. You should run the

tool to fix this issue

 

I don't know what 0770 or 0777 means...I just had it set up to whatever default setup Unraid had....I just want to be sure if I have this plugin change the permissions, that my files and server don't go sideways :P

Share this post


Link to post

The plugin doesn't change anything.  It's a warning that the permissions are not set to what it's set to when you run the newpermissions utility.  Admittedly I never checked to see what the permissions are set to if you create a new share. 

 

Sent from my LG-D852 using Tapatalk

 

 

Share this post


Link to post

Since we can now backup into dated folders, can we get a options to keep the last X number of dated folders and removed the rest?

 

Thanks

Myk

 

No?

Share this post


Link to post

Decided to try the latest, looks good, one issue though - reports "Error: Array is not started" but it IS started.  Want my diagnostics?

 

It also popped up with a notice about an adblocker detected, so I checked and yes, uBlock Origin was running.  However I've never had any display problems, and when I checked uBlock Origin, it indicated nothing blocked on the page, and I never changed any settings.  So I guess not every adblocker is a problem.  I'll leave it as is, until there IS a problem.  (I'm not reporting it as an issue, just a behavioral variation)

Share this post


Link to post

Decided to try the latest, looks good, one issue though - reports "Error: Array is not started" but it IS started.  Want my diagnostics?

 

It also popped up with a notice about an adblocker detected, so I checked and yes, uBlock Origin was running.  However I've never had any display problems, and when I checked uBlock Origin, it indicated nothing blocked on the page, and I never changed any settings.  So I guess not every adblocker is a problem.  I'll leave it as is, until there IS a problem.  (I'm not reporting it as an issue, just a behavioral variation)

Can't check atm but it's probably because you don't run user shares.  I'll fix

 

As far as the adblocker warning is concerned it popped up because it DID change a particular item (non displayed) on this page.  The error Only pops up when going to the page and cannot be detected during background checks.  But net result is your mileage may vary if the blocker does affect your unraid gui.

 

Sent from my LG-D852 using Tapatalk

 

 

Share this post


Link to post

Got this notification last night-

**** The plugin shellinabox-plugin.plg is not known to Community Applications and is possibly incompatible with your server ****   **** Share .fsr has non-standard permissions set ****

Already knew about shell-in-a-box not being recognized. The .fsr share warning is new though. This is not a share that I have created. It must be associated with some other plugin. Is there any way to find out which one? Should I just ignore the warning and assume that whatever plugin uses the share has set it up properly?

Share this post


Link to post

Actually AFAIK you should be removing shell in a box as it has been superseded by Command Line.

 

That share I don't know what made it so I can't give you any advice there.  If everything is ok just add it to the ignore list

 

Sent from my LG-D852 using Tapatalk

 

 

Share this post


Link to post

Actually AFAIK you should be removing shell in a box as it has been superseded by Command Line.

 

That share I don't know what made it so I can't give you any advice there.  If everything is ok just add it to the ignore list

 

Sent from my LG-D852 using Tapatalk

 

 

Thanks. I'll see if I can find a Shell-In-The-Box thread to get info for uninstalling that.

Share this post


Link to post

Share .PhAzE-Common has non-standard permissions set The permission on the share is currently set to 0755 (standard permissions are 0777). You may have trouble accessing this share locally and/or over the network due to this issue. You should run the

tool to fix this issue

Just a little comment regarding permissions

 

If everything else is correct (owner as nobody, group as users), you will not have a problem with permission of 077x

 

However if the owner is root, you will have an issue with any share over the network that is not set to 0xx7 (or 0xx6)

 

The justification for this check is that when creating a share, permissions are set to 0777, and when running the New Permissions tool included with unRaid, permissions are set across the board to 0777.

 

PhAzE-Common has its permissions set to 0755.  No idea what the ownership is with that folder.  But as the suggestion states "You may have problems...over the network".  After seeing this post, I thought about including an exception for phaze common set to 0755, and then decided that since LT has decided that the appropriate permissions for a share is 0777 to let the warning stand.  Its a warning, not an error because there may be specific reasons for differing permissions set, that this plugin is not aware of.

Share this post


Link to post

Awesome plugin!  Two minor suggestions: First, it might be nice to have an option to not automatically perform the scan/tests upon accessing the Plugin.  I know I just wanted to look at what options were available to me, but then it was scanning for a few minutes.  Secondly, when suggested fixes are selected, it takes me to whatever section I chose, but then it has to scan again when I return to the plugin.  Maybe a pop-up with the area to fix?

 

Just some thoughts.

Share this post


Link to post

Awesome plugin!  Two minor suggestions: First, it might be nice to have an option to not automatically perform the scan/tests upon accessing the Plugin.  I know I just wanted to look at what options were available to me, but then it was scanning for a few minutes.  Secondly, when suggested fixes are selected, it takes me to whatever section I chose, but then it has to scan again when I return to the plugin.  Maybe a pop-up with the area to fix?

 

Just some thoughts.

Now that I think about it, that annoy's me also when I'm testing  ;)  too late for today's update, but the next one

 

Share this post


Link to post

Give a man a gun and he can rob a bank.  Give a man a bank and he can rob the world

 

- Should be fixed: False positive on array not started when not using user shares (because RobJ insists on being different)

- Added in to troubleshooting mode: output of free and ps aux (only processes with CPU % > 0)

- Added in hack attempts in progress

 

Hack Attempts:  Checks for invalid login attempts.  Defaults to a grace value of 10 per day allowed.

 

Note:  I only have a single syslog that I could easily find that had a hack attempt (http://lime-technology.com/forum/index.php?topic=49177.msg472096#msg472096) (btw there were 5417 attempts to break into buddy's server within a 15 hour period (one attempt every 10 seconds), and this check looks for those messages which were logged. 

 

The usual protect my a$$ disclaimer:

If this plugin does not catch anything, it does not necessarily mean that you are not being actively hacked, nor that you have not already been hacked.  Also, this is only detecting hacks to log in to your server.  If someone has already hacked their way onto your network and are trying to hack their way into your shares, then those invalid logins are not logged, and at present cannot be detected.

 

If you have (or know of) a syslog somewhere on this forum that shows active hack attempts beyond what these checks find, forward me the appropriate link and detection for it will be added.

Share this post


Link to post

- Should be fixed: False positive on array not started when not using user shares (because RobJ insists on being different)

Been different all my life, why change!  ;)

 

Anyway, it works fine now, on my differentexceptional system.

Share this post


Link to post

Awesome plugin!  Two minor suggestions: First, it might be nice to have an option to not automatically perform the scan/tests upon accessing the Plugin.  I know I just wanted to look at what options were available to me, but then it was scanning for a few minutes.  Secondly, when suggested fixes are selected, it takes me to whatever section I chose, but then it has to scan again when I return to the plugin.  Maybe a pop-up with the area to fix?

 

Just some thoughts.

ok.  This is what I've done for the next release (possibly tonight - depends on how much I enjoy my long weekend  ;)  ) is this:

 

  If there are no errors already logged when entering the plugin, then it will do a scan for errors.

  If there are errors already logged, then it will display the time of the last scan and not rescan anything unless you hit rescan.

 

Note however that even with this, the adBlocker detection (and applicable popup) is always tested, simply because the background checks cannot figure this one out.

Share this post


Link to post

BTW, if anyone knows any quick and dirty checks for VM settings (and ideally willing to give me code fragments - or the checking procedure written out in english if you don't know how to code), feel free to post as I have no fundamental reason to run a VM and therefore don't include any checks against their settings, etc.

Share this post


Link to post

- Should be fixed: False positive on array not started when not using user shares (because RobJ insists on being different)

Been different all my life, why change!  ;)

 

Anyway, it works fine now, on my differentexceptional system.

At least I know that anytime you post a false positive I know where my coding mistake lies  ;D

 

And if anyone ever called me "normal" I'd probably be insulted...

Share this post


Link to post

And if anyone ever called me "normal" I'd probably be insulted...

I don't think that there's anything worse than being ordinary.

Angela Hayes: American Beauty

Share this post


Link to post
8) I have a clean bill of health now. Thanks :)  for the great tool. The changes I made to Plex uncovered one feature I did not even know was broken... theme songs on TV show screens now working.

Share this post


Link to post

Beer.  Because no great story ever begins with "So I was sitting down having a salad..."

 

- Added in checks for Moderated / Blacklisted docker applications

- Added in checks for plugins incompatible with your unRaid version (Note that this check is different than the check for plugins not known to CA, and finds plugins which are KNOWN to CA but are also identified by the author as being incompatible with your version of unRaid.

- Added in checks for changed webUI on docker apps *

- Changed:  Only run scans when entering the UI if no errors are previously logged.  The date and time of the last scan generating errors / warnings is displayed

 

* I actually expect a ton of people to be hit by this warning

 

The way that the webUI entry should be formatted on the add / edit docker container screen should be similar to this:

 

http://[iP]:[PORT:80]/

 

What this does is tell unRaid to substitute the appropriate IP address and host port that is mapped to the container's port 80 and use that as the webUI entry.

 

What many people do is instead change the entry to be something like this:

 

http://[iP]:8080/ or http://192.168.1.181:8080/

 

Both of those examples above (while they may work under your current network setup) are incorrect

 

The first will fail if you ever have to change the host port on the application, whereas the second will fail if your IP address changes (and you also have to change the host port)  (In a nutshell, I am assuming that what the author put into the template is correct and if you've changed it then you're wrong)

 

However, there may be some valid reasons you have to have changed the webUI setting - hence why it's a warning.

 

 

 

 

 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.