Jump to content
Squid

[Plugin] CA Fix Common Problems

1330 posts in this topic Last Reply

Recommended Posts

Of course mover should produce a notification and provide a download link to the error logs or have an error overview, but it hasn't so I think it could be something CA-fix could handle.

Share this post


Link to post
8 hours ago, mgutt said:

Of course mover should produce a notification and provide a download link to the error logs or have an error overview, but it hasn't so I think it could be something CA-fix could handle.

It already tells you if your shares have files on cache/array inconsistent with the settings for the share. Since FCP isn't running when mover runs how could it know if mover didn't do what you wanted.

Share this post


Link to post

Hey,

 

i love your plugin and really appreciate your work with this. 

Can i request a feature to help solving out an issue that a few people had.

 

I would like if you can informate users if their unraid crashes and they are running a ryzen 1xxx or 2xxx Series processor they must disable "C State" in there BIOS. This solves the issue. Hope you can implement this, i have searched so much to get this tip.

Sources:
https://www.reddit.com/r/unRAID/comments/bj0q2o/ryzen_c_states/
https://forums.unraid.net/topic/74894-zenstates-fixing-the-problem-where-gen1-ryzen-wont-boost-in-unraid/

https://forums.unraid.net/topic/67219-problems-with-ryzen-cpu/

 

Share this post


Link to post

Howdy gang,

 

So please tell me this is lurking some mystical place I cant seem to find...

 

UserStory - Why can I not seem to click on the popup notification in the unraid interface, while viewing the list of criticals notifications, and then be taken to the plugin directly? Why must I go thru the pain of acknowledging the alert, then going to plugins tab, wait for that to load, check versions, blah, then display, scroll the way down to find FCP and click it to load the plugin. 

 

Ask - Please include that URL as part of the notification.

 

Observation -Sure the link would not be unusable outside your home network unless you correctly, yet foolishly expose the unraid interface thru Letsencrypt or another reverse proxy. Love the default built in security right there. VPN if you want network level control of your home-network.

 

Be IT smart. 😃

Share this post


Link to post

You dont need to go to the plugins tab.   There is also an icon within the settings tab.   I've never tried to put a direct link within the built in popup alert but will see if it's possible.

Share this post


Link to post
Posted (edited)

Everytime the plugin does its scan, i get the error: "Fix Common Problems: Warning: CPU Overheating" but i'm certain it's a false positive. For example, i just ran it now (by clicking "rescan" on the plugin page) when the CPU temp is 50 deg C and I got the warning. Any ideas on how to fix this?

Edited by loheiman

Share this post


Link to post

That test is done by scanning the syslog and seeing if the cpu has throttled itself down at some point.    It is not a "live" test.   If you have that warning the cpu has throttled down because of temperature since the last reboot.   Up to you if you ignore it or not.  

Share this post


Link to post

@Squid I love your tools, I was wondering if you'd considered the option to run the extended test on a schedule as well.

Share this post


Link to post

Hey,

I am just setting things up while I wait for the final components.

I just got 3 errors and the plugin is not happy with me. :)   I looked in this topic for the last few months of posts without succes.

 

With the opportinity now in 6.9, I wanted to split cache and dockers/VMs/appdata so I first create a pool named local_data and I was planning to add another pool named cache later on. 

I chose not to use any caching for the moment on media and personal shares and set every other one to local_data 

 

image.thumb.png.9c8e3e6cc396410b119f41c5e645f1f8.png

 

Still I got this errors and I am not sure if I did something wrong or if the plugin is only searching for a pool named cache.

Do I have do delete the *.cfg files as suggested from the key ?

 

image.thumb.png.c46f879ad2e956828da7f131c071c413.png

mediahub-diagnostics-20200804-2134.zip

Share this post


Link to post
Posted (edited)
On 8/3/2020 at 11:06 AM, Squid said:

That test is done by scanning the syslog and seeing if the cpu has throttled itself down at some point.    It is not a "live" test.   If you have that warning the cpu has throttled down because of temperature since the last reboot.   Up to you if you ignore it or not.  

Ahh, yes i see that now in the syslogs. Thanks for the clarification!

Edited by loheiman

Share this post


Link to post
11 hours ago, ChatNoir said:

I first create a pool named local_data and I was planning to add another pool named cache later on. 

What is your target by creating a pool named "cache"?

 

The error messages result because you enabled caching for the listed shares:

IMG_20200805_084258.thumb.jpg.ac46b30e21148d2dafc672064c972d79.jpg

 

But you do not have any SSD installed (cache disk).

Share this post


Link to post
Posted (edited)

I'll try to clarify my reasonning.

On 6.8.3 and before you could use cache to:

  1. cache data before transfering it to the array: Yes
  2. store data that you used often and wanted a fast access to: Prefer or Only
  3. for all elements where speed was not important could be set to: No

With 6.9 and the multiple pools, I understood that those different tasks could be splitted on different pools that could be named cache or whatever.

 

The end goal for me is to have two pools :

  • cache : for data transfer cache
  • local_data : for dockers, appdata and the likes

For the moment, I am waiting for more stuff to advance the build. The array is not in its proper config and I did not load all the data I want to on it. 

 

So I am just playing around, trying to set things up, making tests before finalizing everything.

I do have a SSD, but only one available for the moment, so I focused on the dockers to have the test setup running, not the transfer cache.

 

I am not at home to make screenshots of the details of the shares, but as shown on my first screenshot, I selected Only and the only pool available local_data, not cache for the shares in question. All media etc shares are set to No.

 

It is possible that I misunderstood how to setup my pools and/or shares as I only have unRAID running for a few days but it seems to me that the plugin is only looking for a specific pool named cache and does not consider that I do indeed have a pool, but with a different name.

Edited by ChatNoir

Share this post


Link to post
Posted (edited)

No, the plug-in does not search for a pool named "cache". It's only checking if you have enabled caching and not having a SSD as "cache device":

IMG_20200805_104205.jpg.d5be8e5facbd96c36719fb590912c2b1.jpg

 

Having multiple pools is only useful if you want to split your data on different arrays. There could be different reasons for that:

 

1.) If you have a massive amount of disks like >20 and you want to use unraid's TurboWrite but without the downside waking up all >20 disks on write operations (instead it would wake up only one pool of disks).

 

2.) You build a pool of SSDs only and use them as a "cache". But it's nothing used by Unraid automatically. It's used as a usual pool contain one or multiple shares and after you uploaded files to this "cache" share you could manually (or by a script) move the data later to your other pool of HDDs (or you leave them on the SSDs forever). IMHO naming it "cache" is wrong. It contains usual shares and this pool has a parity disk, too. Instead it should be called "fast pool" as you finally have a "fast" (SSDs) and "slow" (HDDs) pool.

Edited by mgutt

Share this post


Link to post

False positives related to FCP and cache-pools will get fixed.  Sorry...  Didn't even think about FCP's test on that one when I started with beta25

  • Thanks 1
  • Haha 1

Share this post


Link to post
33 minutes ago, Squid said:

False positives related to FCP and cache-pools will get fixed.  Sorry...  Didn't even think about FCP's test on that one when I started with beta25

Ok, no problem, I just wanted to be sure I was alright before starting configuring several dockers and stuff.

Thank you Squid. :)

 

Share this post


Link to post

Hello, just installed Jitsi server and i'm getting this warning on CA Fix Problems. I tried to click Apply Fix and gave me an Error: Missing Template. Any thoughts? I tried installing the Jitsi server with encryption but failed so I had to install it without encryption. If that information help. Though if you do know how to install it with working encryption, please let me know as well. I followed Spaceinvader one's video to the tee minus Let's Encrypt as I used Nginx Proxy Manager instead.

 

Thank you in advance for any help!

Screen Shot 2020-08-19 at 7.51.31 PM.png

Screen Shot 2020-08-19 at 7.58.02 PM.png

Share this post


Link to post

Thanks for creating such a useful tool.  I've recently been digging deeper into the tool, but have experienced a problem where everytime I run the Extended Test, it runs for 12 hours and then locks up the Unraid server.  Is there a log or something I can check to see what is happening/causing the issue?

 

Thanks in advance!

Share this post


Link to post
On 9/4/2020 at 9:40 AM, jeffreywhunter said:

Thanks for creating such a useful tool.  I've recently been digging deeper into the tool, but have experienced a problem where everytime I run the Extended Test, it runs for 12 hours and then locks up the Unraid server.  Is there a log or something I can check to see what is happening/causing the issue?

 

Thanks in advance!

What do you mean by locking up? 

Share this post


Link to post
What do you mean by locking up? 
The server crashes and becomes unresponsive, even from the console. Requires hard reboot.

Sent from my SM-G965U using Tapatalk

Share this post


Link to post

The "Status" line in FCP shows what folder it's currently working on.  I would mirror the syslog to the flash and then run a scan.  It *should* hopefully show something when the crash occurs.

Share this post


Link to post
On 7/30/2020 at 5:02 PM, RevAtB said:

Howdy gang,

 

So please tell me this is lurking some mystical place I cant seem to find...

 

UserStory - Why can I not seem to click on the popup notification in the unraid interface, while viewing the list of criticals notifications, and then be taken to the plugin directly? Why must I go thru the pain of acknowledging the alert, then going to plugins tab, wait for that to load, check versions, blah, then display, scroll the way down to find FCP and click it to load the plugin. 

 

Ask - Please include that URL as part of the notification.

 

Observation -Sure the link would not be unusable outside your home network unless you correctly, yet foolishly expose the unraid interface thru Letsencrypt or another reverse proxy. Love the default built in security right there. VPN if you want network level control of your home-network.

 

Be IT smart. 😃

Next rev of Unraid supports clicking on a notification that takes you to where you need to be to handle it.  As I get around to it, I'll be adding the appropriate links to all the possible notifications within Unraid, including FCP

Share this post


Link to post
On 7/30/2020 at 5:02 PM, RevAtB said:

So please tell me this is lurking some mystical place I cant seem to find...

Yes, it's in the magical place called Soon™.

Share this post


Link to post

Great Plugin, love it, awesome work.

 

When I run an extended scan, it scans my /URbackup/ for a rather long time. Last time I gave up, it had been running for 5 days.

The /URbackup contain approximately 2 million files, so yes it is a lot of files.

 

Should I just wait it out, or should I start troubleshooting?

I tried browsing the System Log to see any messages of problems or progress, but found none. Am I looking in the wrong place?

 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.