[Plugin] CA Fix Common Problems


1371 posts in this topic Last Reply

Recommended Posts

  • Replies 1.4k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

This plugin is designed to find and offer up suggestions to a multitude of configuration errors, outright problems, etc for numerous aspects of your unRaid server.   To install this plugin,

Mainly because my keyboard is worn out from replying "Uninstall Advanced Buttons", today's update features an "Update Assistant" which sits on the Tools Menu (next to Update OS)   This perfo

False positives related to FCP and cache-pools will get fixed.  Sorry...  Didn't even think about FCP's test on that one when I started with beta25

Posted Images

Does the plugin check for user shares which have the same name as disk shares?  I couln't see this check in the list of things checked but maybe I am just not looking hard enough.

 

I know a user had this problem a week or so ago when he attempted to copy the contents of one disk to another and accidentally created the directory on the save disk with the name of the original disk.  Then when he rebooted the auto created user share 'hid' the actual disk share.

Link to post

Does the plugin check for user shares which have the same name as disk shares?  I couln't see this check in the list of things checked but maybe I am just not looking hard enough.

 

I know a user had this problem a week or so ago when he attempted to copy the contents of one disk to another and accidentally created the directory on the save disk with the name of the original disk.  Then when he rebooted the auto created user share 'hid' the actual disk share.

It will tonight    ;D
Link to post

Does the plugin check for user shares which have the same name as disk shares?  I couln't see this check in the list of things checked but maybe I am just not looking hard enough.

 

I know a user had this problem a week or so ago when he attempted to copy the contents of one disk to another and accidentally created the directory on the save disk with the name of the original disk.  Then when he rebooted the auto created user share 'hid' the actual disk share.

It will tonight    ;D

 

The webGUI won't allow the creation of a user share with a name of a disk share, but it is always good to make a check, better safe than sorry :)

Link to post

Does the plugin check for user shares which have the same name as disk shares?  I couln't see this check in the list of things checked but maybe I am just not looking hard enough.

 

I know a user had this problem a week or so ago when he attempted to copy the contents of one disk to another and accidentally created the directory on the save disk with the name of the original disk.  Then when he rebooted the auto created user share 'hid' the actual disk share.

It will tonight    ;D

 

The webGUI won't allow the creation of a user share with a name of a disk share, but it is always good to make a check, better safe than sorry :)

In retrospect (as remotevisitor pointed out) it's happened a fair amount with an improperly placed "/" on rsync commands when converting RFS to XFS.

 

The check I've done allows diskX as a share as long as diskX is not present in the system

Link to post

Does the plugin check for user shares which have the same name as disk shares?  I couln't see this check in the list of things checked but maybe I am just not looking hard enough.

 

I know a user had this problem a week or so ago when he attempted to copy the contents of one disk to another and accidentally created the directory on the save disk with the name of the original disk.  Then when he rebooted the auto created user share 'hid' the actual disk share.

It will tonight    ;D

 

The webGUI won't allow the creation of a user share with a name of a disk share, but it is always good to make a check, better safe than sorry :)

In retrospect (as remotevisitor pointed out) it's happened a fair amount with an improperly placed "/" on rsync commands when converting RFS to XFS.

 

Yep, remember the saying there are many ways that lead to Rome...

 

Link to post

I am not getting the crashplan warning anymore after updating today....

 

Thanks!

 

Myk

Today's update did nothing actually.  But at least you're out of the way and only gubnutten to handle...  2016.05.27 was the fix, but since he's on 6.2 it makes absolutely no sense without seeing his xml
Link to post

Just wanted to check on this Other Comments section, do I need to do anything? NVME pool.

 

Q9Ev5eC.png

I don't think of HPA being present on any drive as being an issue unless it's on the parity as it then directly can impact your ability to rebuild or expand your array (you might not be able to)  hence why parity makes an error and any other drive is just an info an won't even notify you

 

Sent from my SM-T560NU using Tapatalk

 

 

Link to post

Thank you

 

I don't really understand what HPA is but I figure it's part of the BTRFS cache pool?

if you can login and give me the output of
hdparm -N /dev/sdX

where X is the identifier of one of those disks.  You can find it on the Main tab.

 

I would actually think its more likely that it's because it's an NVMe

Link to post

Oh and what HPA is is where the motherboard has decided to shrink the size of the hard drive so that it can store BIOS backups on it.  Really bad on the parity drive because at that point the parity drive may not be as large or larger than the data drives and your ability to rebuild is directly affected

 

Sent from my SM-T560NU using Tapatalk

 

 

Link to post

Thanks Squid,

 

hdparm -N /dev/nvme0n1 & / hdparm -N /dev/nvme1n1 returned the following

 

/dev/nvme0n1:
SG_IO: questionable sense data, results may be incorrect
max sectors   = 0/1, HPA is enabled

 

/dev/nvme1n1:
SG_IO: questionable sense data, results may be incorrect
max sectors   = 0/1, HPA is enabled

Link to post

Thanks Squid,

 

hdparm -N /dev/nvme0n1 & / hdparm -N /dev/nvme1n1 returned the following

 

/dev/nvme0n1:
SG_IO: questionable sense data, results may be incorrect
max sectors   = 0/1, HPA is enabled

 

/dev/nvme1n1:
SG_IO: questionable sense data, results may be incorrect
max sectors   = 0/1, HPA is enabled

OK  it's a false positive...  I'll build an exception for it on tomorrow's build

 

Sent from my SM-T560NU using Tapatalk

 

 

Link to post

But at least you're out of the way and only gubnutten to handle...  2016.05.27 was the fix, but since he's on 6.2 it makes absolutely no sense without seeing his xml

 

Sorry Squid, I have Fix Common Problems 2016.05.28a on unRAID 6.1.9 and I'm still seeing the Crashplan warning.

 

The WebUI in my /flash/config/plugins/dockerMan/templates/gfjardim/CrashPlan.xml file is (note the space and the double-escaping):

<WebUI> http://[iP]:[PORT:4280]/vnc.html?autoconnect=true&amp;host=[iP]&amp;port=[PORT:4280]</WebUI>

 

my /boot/config/plugins/dockerMan/templates-user/my-CrashPlan.xml contains this (without the leading space, and not double-escaped):

<WebUI>http://[iP]:[PORT:4280]/vnc.html?autoconnect=true&host=[iP]&port=[PORT:4280]</WebUI>

 

Link to post

I'm getting a time/date warning-

 

Event: Fix Common Problems
Subject: Warnings have been found with your server.
Description: Investigate at Settings / User Utilities / Fix Common Problems
Importance: warning

**** Your server's current time differs from the actual time by more than 5 minutes.  Currently out by approximately 246 minutes ****

 

When I check the time/date in settings it appears to be dead on. Not sure why I've just started getting this warning.

Link to post

I'm getting a time/date warning-

 

Event: Fix Common Problems
Subject: Warnings have been found with your server.
Description: Investigate at Settings / User Utilities / Fix Common Problems
Importance: warning

**** Your server's current time differs from the actual time by more than 5 minutes.  Currently out by approximately 246 minutes ****

 

When I check the time/date in settings it appears to be dead on. Not sure why I've just started getting this warning.

So it just started and hasn't been giving warnings on that previously?

 

Sent from my LG-D852 using Tapatalk

 

 

Link to post

So it just started and hasn't been giving warnings on that previously?

 

Correct. I can't see anything wrong with the settings and their haven't been any recent changes.

 

34fz2iq.jpg

run a scan again and if it fails again, try this from a command prompt:

echo $(expr $(date +%s) / 60)

and compare it to this website: http://currentmillis.com/time/minutes-since-unix-epoch.php

 

They should be within 1 minute of each other (due to rounding errors)

Link to post

Just out if curiosity, why does "Time of last scan" just show an "*"?

Because I screwed up...  It basically means that there was no errors/warnings at all found which is a situation that I don't ever have on my systems because I've got HPA on a drive.  Will fix...
Link to post

Birthdays are good for your health.  Studies have shown that people who have more birthdays live the longest

 

- Fixed (better be) Crashplan webUI

- Check for sharenames same as disknames

- Check for cache only shares, but no cache drive

- Fix NVMe drives showing HPA

- Fix time of last scan aberration if not errors found

 

Incorrect time issue - I think the website that is checked crashed temporarily (and still returned a valid albeit incorrect time) and then was reset some time later.

Link to post

Fixed all the suggested common problems -- down to three and all are the same thing -- enable auto update. When I click on the button I can see it is taking me to http://tower/Settings/AutoUpdate but nothing loads, I also don't have anything called AutoUpdate in Settings.

 

Is autoupdate a plugin that needs to be installed?

 

If yes then it would probably be useful to check for that and generate a problem if it is not installed.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.