Jump to content
RobJ

powernow_k8 not loaded for AMD CPU's

23 posts in this topic Last Reply

Recommended Posts

.

.

.

Edit: Might as well downgrade this one, low priority, as I appear to be the only one so far with the problem!  Plus, there's an easy workaround, by adding the modprobe to the go file.

 

 

unRAID OS Version:  v6.1.9, and all v6 versions that I've checked, since the 6.0 betas (6.2-betas were not checked)

 

Description:  As of v5.0.6 (and many versions before), powernow_k8 was loaded for AMD CPU's, and effected constant CPU stepping, which results in power saving.  For all v6 versions I've checked, it is not loaded, resulting in max CPU speed at all times.

 

How to reproduce:  Dashboard and cat /proc/cpuinfo and cpufreq-info all show CPU staying at 2411MHz.  After running modprobe powernow_k8, CPU stepping is immediately in effect, going down to 1000MHz on my system.

 

Expected results:  CPU speed ranging from 1000MHZ to 2400MHz

 

Actual results:  CPU speed stays at 2411MHz

 

Other information:  I do not know if this is true for all AMD CPU's, but is true for mine (AMD Athlon 64 X2 Dual Core Processor 4600+).  To summarize, powernow_k8 was loaded in v5 and the CPU stepped up and down.  It's not loaded in v6, and there's no speed stepping.

 

I assume this may have been an oversight with the development of v6. Not an oversight, acpi-cpufreq appears to work fine for all of the other AMD CPU's.

 

Edit: fixed in 6.2

Share this post


Link to post

After I posted a notice about this on the 6.1.9 announcement thread, numerous other AMD users indicated they have no issues with their AMD scaling down.  So clearly I'm in the minority, the only one so far!  This does make sense as more would have reported it before now, if it was a wider problem.

 

It would be interesting to know which AMD chips are working, and what drivers they are loading, with the following command -

  cpufreq-info -d

 

Mine reports from the syslog "CPU0: AMD Athlon 64 X2 Dual Core Processor 4600+", with no driver loaded (unless I load powernow_k8 myself).

 

Edit to indicate I'm the only one so far!

Share this post


Link to post

After I posted a notice about this on the 6.1.9 announcement thread, 3 others indicated they have no issues with their AMD scaling down.  So clearly I'm in the minority, the only one of 4 responders.  This does make sense as more would have reported it before now, if it was a wider problem.

 

It would be interesting to know which AMD chips are working, and what drivers they are loading, with the following command -

  cpufreq-info -d

 

Mine reports from the syslog "CPU0: AMD Athlon 64 X2 Dual Core Processor 4600+", with no driver loaded (unless I load powernow_k8 myself).

A8-6600K

root@Server_A:~# cpufreq-info -d
acpi-cpufreq

Sempron 3850

root@Server_B:/boot# cpufreq-info -d
acpi-cpufreq

And my frequencies do change based upon load

Share this post


Link to post

The powernow_k8 scaling driver is for older amd processors.

 

powernow_k8 - "CPUFreq driver for K8/K10 Athlon 64/Opteron/Phenom processors. Since Linux 3.7 'acpi-cpufreq' will automatically be used for more modern CPUs from this family."

Share this post


Link to post

Interesting.  On my system, lsmod shows acpi-cpufreq installed, cpufreq-info does not show it, shows no drivers installed, and it's not working.  Perhaps there's a CPU profile list somewhere that needs updating?

 

My early syslog ACPI table shows a POWERNOW entry, perhaps it could be detected some how?  Perhaps this indicates it's tied to the motherboard, what technologies it supports.

Jun  1 10:09:27 JacoBack kernel: ACPI: RSDP 0x00000000000F80B0 000014 (v00 Nvidia)

Jun  1 10:09:27 JacoBack kernel: ACPI: RSDT 0x00000000BFFF3040 000034 (v01 Nvidia AWRDACPI 42302E31 AWRD 00000000)

Jun  1 10:09:27 JacoBack kernel: ACPI: FACP 0x00000000BFFF30C0 000074 (v01 Nvidia AWRDACPI 42302E31 AWRD 00000000)

Jun  1 10:09:27 JacoBack kernel: ACPI: DSDT 0x00000000BFFF3180 006732 (v01 NVIDIA AWRDACPI 00001000 MSFT 0100000E)

Jun  1 10:09:27 JacoBack kernel: ACPI: FACS 0x00000000BFFF0000 000040

Jun  1 10:09:27 JacoBack kernel: ACPI: SSDT 0x00000000BFFF99C0 000248 (v01 PTLTD  POWERNOW 00000001  LTP 00000001)

Jun  1 10:09:27 JacoBack kernel: ACPI: MCFG 0x00000000BFFF9C80 00003C (v01 Nvidia AWRDACPI 42302E31 AWRD 00000000)

Jun  1 10:09:27 JacoBack kernel: ACPI: APIC 0x00000000BFFF9900 000072 (v01 Nvidia AWRDACPI 42302E31 AWRD 00000000)

Share this post


Link to post

Squid, this does not appear to be a 'common problem', but would it qualify as a candidate for 'Fix Common Problems' (as a warning)?  Check for CPU scaling driver and governor, cpufreq-info -d for driver and cpufreq-info -o for governor.  If none set, then suggest loading powernow_k8 for AMD, unknown for Intel.

Share this post


Link to post

Squid, this does not appear to be a 'common problem', but would it qualify as a candidate for 'Fix Common Problems' (as a warning)?  Check for CPU scaling driver and governor, cpufreq-info -d for driver and cpufreq-info -o for governor.  If none set, then suggest loading powernow_k8 for AMD, unknown for Intel.

Give me the exact output from your command as it's impossible for me to test a fail

 

Sent from my LG-D852 using Tapatalk

 

Share this post


Link to post

Squid, this does not appear to be a 'common problem', but would it qualify as a candidate for 'Fix Common Problems' (as a warning)?  Check for CPU scaling driver and governor, cpufreq-info -d for driver and cpufreq-info -o for governor.  If none set, then suggest loading powernow_k8 for AMD, unknown for Intel.

Give me the exact output from your command as it's impossible for me to test a fail

 

Without powernow_k8 loaded, I get:

root@JacoBack:/boot# cpufreq-info -d

root@JacoBack:/boot# cpufreq-info -o

          minimum CPU frequency  -  maximum CPU frequency  -  governor

 

Once powernow_k8 is loaded, I get:

root@JacoBack:/boot# cpufreq-info -d

powernow-k8

root@JacoBack:/boot# cpufreq-info -o

          minimum CPU frequency  -  maximum CPU frequency  -  governor

CPU  0      1000000 kHz ( 41 %)  -    2400000 kHz (100 %)  -  ondemand

CPU  1      1000000 kHz ( 41 %)  -    2400000 kHz (100 %)  -  ondemand

Share this post


Link to post

Squid, this does not appear to be a 'common problem', but would it qualify as a candidate for 'Fix Common Problems' (as a warning)?  Check for CPU scaling driver and governor, cpufreq-info -d for driver and cpufreq-info -o for governor.  If none set, then suggest loading powernow_k8 for AMD, unknown for Intel.

Give me the exact output from your command as it's impossible for me to test a fail

 

Sent from my LG-D852 using Tapatalk

 

Just check cpufreq -d for a blank string result and that tells you there is no cpu scaling driver loaded.  Nothing more than that.  You don't need to get into the governor that is loaded or not loaded.

Share this post


Link to post

This issue is very easy to fix.  LT just needs to load the powernow_k8 driver with 'modprobe powernow_k8' in the rc.cpufreq script.

Share this post


Link to post

Squid, this does not appear to be a 'common problem', but would it qualify as a candidate for 'Fix Common Problems' (as a warning)?  Check for CPU scaling driver and governor, cpufreq-info -d for driver and cpufreq-info -o for governor.  If none set, then suggest loading powernow_k8 for AMD, unknown for Intel.

Give me the exact output from your command as it's impossible for me to test a fail

 

Sent from my LG-D852 using Tapatalk

 

Just check cpufreq -d for a blank string result and that tells you there is no cpu scaling driver loaded.  Nothing more than that.  You don't need to get into the governor that is loaded or not loaded.

regardless of how easy it is for LT to fix, the check is in for the next release.  Gotta love the one line checks  ;D

Share this post


Link to post

This issue is very easy to fix.  LT just needs to load the powernow_k8 driver with 'modprobe powernow_k8' in the rc.cpufreq script.

 

I suspect it's a little trickier than that, as it needs to be conditional, first on having an AMD processor, and secondly no driver installed or working.  I don't think you would want to load powernow_k8 if acpi-cpufreq is working fine, and it seems to be for most AMD systems.  It may be that you only want to load it when the motherboard has support for powernow (and acpi-cpufreq isn't working).

Share this post


Link to post

Just check cpufreq -d for a blank string result and that tells you there is no cpu scaling driver loaded.  Nothing more than that.  You don't need to get into the governor that is loaded or not loaded.

regardless of how easy it is for LT to fix, the check is in for the next release.  Gotta love the one line checks  ;D

 

Nice!  I'll test it when I can.

Share this post


Link to post

I decided to downgrade this one, a low priority, as I appear to be the only one so far with the problem!  Plus, there's an easy workaround, by adding the modprobe to the go file.

Share this post


Link to post

I decided to downgrade this one, a low priority, as I appear to be the only one so far with the problem!  Plus, there's an easy workaround

 

Another easy workaround is to upgrade to an Intel system.  ;D

Share this post


Link to post

I decided to downgrade this one, a low priority, as I appear to be the only one so far with the problem!  Plus, there's an easy workaround

 

Another easy workaround is to upgrade to an Intel system.  ;D

 

I'll be happy to provide PayPal details by PM to anyone for a FundMe - FundRobJ'sIntel System!    :D

Share this post


Link to post

After upgrading my 6.1.9 system to 6.2-rc4, I discovered that powernow_k8 is now automatically loaded, so I removed the load line from my go file.  (Thanks to whoever made the change!)  Consider this solved and closed.

Share this post


Link to post

Sorry for digging up an old thread.  I just installed recently on my old gaming rig which contains an AMD Phenom II X4 965 and powernow_k8 does not appear to be loading.  Here's what I see when I try the commands on unRAID 6.3.5.

 

root@Tower:~# modprobe powernow_k8
modprobe: ERROR: could not insert 'powernow_k8': No such device
root@Tower:~# cpufreq-info -d
root@Tower:~#
 

Edited by _Shorty

Share this post


Link to post

edit: Aha! So the default unRAID config is working just fine with my CPU.  I had forgotten that this machine was overclocked in the BIOS by manually setting the multiplier for its gaming lifetime, and now that it is an unRAID box and had this issue I remembered about this.  Since I've gone back into the BIOS and set the multiplier back to auto the CPU clock speed behaviour is as expected, throttling down under low load. Doh!

----------

Ah!  Underscores and dashes... :)

 

root@Tower:~# ls -la /lib/modules/$(uname -r)/kernel/drivers/cpufreq/ /lib/modules/$(uname -r)/kernel/arch/*/kernel/cpu/cpufreq/
/bin/ls: cannot access '/lib/modules/4.9.30-unRAID/kernel/arch/*/kernel/cpu/cpufreq/': No such file or directory
/lib/modules/4.9.30-unRAID/kernel/drivers/cpufreq/:
total 24
drwxr-xr-x  2 root root  120 May 26  2017 ./
drwxr-xr-x 29 root root  580 May 26  2017 ../
-rw-r--r--  1 root root 6483 May 26  2017 acpi-cpufreq.ko.gz
-rw-r--r--  1 root root 1880 May 26  2017 amd_freq_sensitivity.ko.gz
-rw-r--r--  1 root root 3288 May 26  2017 pcc-cpufreq.ko.gz
-rw-r--r--  1 root root 7072 May 26  2017 powernow-k8.ko.gz
 

Edited by _Shorty

Share this post


Link to post

Something must be off because mine worked fine until upgrading to 6.4 any ideas on how to manually load drivers for phenom x4

Share this post


Link to post

Ok I got it to load by enabling and cool and quiet stepping in BIOS , but it used to work fine in earlier releases.  Also the GUI isn’t showing the movement like it did before.

Share this post


Link to post
Posted (edited)

Just thought I would address this issue finally and I am running into some problems.

 

tried running these commands and this is what I am getting. Do I need to manually load powernow_k8 somehow?

root@Tower:~# modprobe powernow_k8
modprobe: ERROR: could not insert 'powernow_k8': No such device
root@Tower:~# cpufreq-info -d
root@Tower:~# cpufreq-info -o
          minimum CPU frequency  -  maximum CPU frequency  -  governor

Any help or direction would be greatly appreciated, I cant seem to find anything else on the forums related to this

 

EDIT - should add that I am running dual opteron 2419 processors on a Supermicro - H8DM8-2 motherboard

 

Edited by benyaki

Share this post


Link to post

I'm seeing the same things after getting the warning from fix common problems. I tried the above commands and see the same outputs. I think those are the right commands.

 

Mobo is Supermicro - H8SGL

 AMD Opteron™ 6212 @ 2600

tower-diagnostics-20180930-1841.zip

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now