[Support] Data-Monkey - netdata

Recommended Posts

When I go to the application section it shows the reads and writes by containers but when I click on the individual containers they all show no activity on the disks. Anyone know a fix for this? Is there something I need to change in the install or something I need to configure within the WebGUI? Ive seen some people recommend using cAdvisor (id much prefer to use this if possible) for this purpose but I cant see that info their either.

Link to comment
  • 1 month later...

I just updated netdata and now my graphs are messed up. The values for each datapoint are now on the left side under the graph instead of on the right side beside the graph. Making it virtually impossible to see the actual values of the graphs at a glance.


This is what I have now:




This is what it used to be and should be:




How can I change it back?

Link to comment
1 minute ago, Squid said:

By complaining to https://www.netdata.cloud/

So this is how it is supposed to be now? And no way to change the layout? That is silly.


Anyone know what version this changed in? I had not updated in some time so not sure when the change happened. I guess I will just revert to the older version that has the other graph layout, this new setup is useless by comparison.

Link to comment
  • 1 month later...

newbie query here, where do i put these commands?


-v '/mnt/cache/appdata/netdata/netadata.conf':'/etc/netdata/netadata.conf':'rw'



-v "/var/run/docker.sock":"/var/run/docker.sock":rw

When i put above in CLI i get:


root@Tower:~# -v "/var/run/docker.sock":"/var/run/docker.sock":rw
-bash: -v: command not found


Link to comment

I know it's really stupid, but maybe this typo correction will help someone else. I copy/pasted the config volume instructions from the first post instructions and couldn't figure out why it wouldn't map the file into the container:


-v '/mnt/cache/appdata/netdata/netadata.conf':'/etc/netdata/netadata.conf':'rw'


Edited by mlapaglia
Link to comment
  • 5 weeks later...
On 1/28/2021 at 10:11 PM, TexasUnraid said:

If you go back a page I had to deal with the same issue. I wiped the container and started over and got it working after a few tweaks.

Ah. where is the config file for netdata?

Link to comment
17 hours ago, TexasUnraid said:

I forgot off hand, if it is not listed in one of the posts on the last page then it should be in the manual if you google it.

All folders I have found until now mentioned dont exist or is empty...

Guess I will hope someone else here knows.

Edited by Mihle
Link to comment
11 minutes ago, TexasUnraid said:



You have to use the console of the docker itself to see the folder.


I ended up mapping the folder to appdata and then reinstalling the container, this allowed me to edit the file from appdata using krusader instead of inside the container.

I am a noob, I have no idea how to do that, if I am supposed to just write the -v things in tot the console of the docker or something it does not work. it says that the command -v do not exist.


I have basically zero experience with command stuff


maybe I should just not do this even if I want it to log longer.

Edited by Mihle
Link to comment

Yeah, then this is going to be deeper then what you can learn here. You should watch some videos on how docker works, I think spaceinvaderone has some.


The -v strings are path mappings, in unraid you set them in the template when you are installing/editing the docker.


Although in this case, those strings are secondary, the important part are the paths in the later posts to the config file. You will still need to read up on how to navigate the folders and edit the file from the command line though. If you map the config path to appdata that will make it simpler since you can edit the file in krusader.

Link to comment

This is my netdata template, if you delete the netdata you have now, shut down the server, copy this file to the unraid USB boot drive folder (remove any existing netdata files)




Then start the server again, go to apps and select previous apps. It should list netdata there, simply click the install button and it should have the settings already entered and ready to go.


(you can do all of this without rebooting if you know how to access the USB drive on unraid)


After this, you can see the netconfig file it is using by adding


to your servers ip address.


The file should be located in


if you need to edit it in krusader.


Edited by TexasUnraid
Link to comment
  • 1 month later...

I claimed my unRaid netdata into my netdata cloud to access all data in web.

The config directory of that cloud connection is not mapped into the host so it is lost on every restart.


To repair this you could do the following:

set up a directory under appdata/netddata/cloud.d, then map it to the container path /var/lib/netdata/cloud.d

See the picture for help.


If somebody already mentioned this, nevermind ;-)



Link to comment
  • 2 months later...

Hey Guys,


I'm using netdata since a bit now, what I'm wondering is, is it possible to keep my data and the plugins I installed after an update of the container?

I'm using fping to keep track of my Network latency, and at the moment updating the container will result in a fresh setup of said plugin.

Also, I'm wondering how I can prevent my history to get lost after every update, is it possible to write the data to an external mariaDB Database?


Thank you in advance,


Link to comment
  • 1 month later...
On 5/11/2019 at 3:23 AM, Caldorian said:

Just installed it on a 6.6.7 install, and it's looking good. However, I'm getting an alert in it about my cache drive, saying that the btrfs allocation is 97.3%. However, if I look at my unraid dashboard, it's only around 60% allocated (157GB out of 256GB).

Any clue why this alert is being raised, and how I may clear it?



I just installed Netdata too and it's really great! But within one day I also have this alert. Did you ever find out how to solve or clear it?

Link to comment
12 hours ago, Squid said:

It's probably not referring to free space, but inode allocation.  You need to run a balance    https://forums.unraid.net/topic/62230-out-of-space-errors-on-cache-drive/?tab=comments#comment-610551

Thanks! That fixed it. I ran:

btrfs balance start -dusage=75 /mnt/cache

and the alert was resolved.


While I was waiting I explored the GUI some more and noticed there is also a button to do this:


Link to comment
  • 1 month later...
5 minutes ago, ExXxtr3me said:



just tried to install netdata today but i getting the following error:




Hey all,


Same thing is happening to me. Had Netdata working for a few months until last night's update. Am able to provide additional details if necessary.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.