Jump to content
jbrodriguez

ControlR (Android/iOS app for unRAID)

1061 posts in this topic Last Reply

Recommended Posts

6 hours ago, H2O_King89 said:

any way for this to work with the new rc8 https?

 

Eventually it will (I hope).

 

I haven't installed rc8 (not even rc7).

 

What's your experience ? It doesn't add a server with the new url ?

Share this post


Link to post
9 hours ago, jbrodriguez said:

I haven't installed rc8 (not even rc7).

What's your experience ? It doesn't add a server with the new url ?

 

The app still connects, but the plugin is confused about whether SSL is enabled. Starting with 6.4.0-rc8q, SSL on/off is specified in /boot/config/ident.cfg rather than the go script.

Share this post


Link to post
14 hours ago, ljm42 said:

The app still connects, but the plugin is confused about whether SSL is enabled

 

Thanks for the confirmation ljm42.

 

Yes, the plugin needs some work now.

 

The thing is should it support multiple RCs ?

 

The changes are fairly substantial for an RC, so I'm still thinking how to move forward and whether I should wait for stable.

 

At the very least, I will only support the latest RC.

Share this post


Link to post
1 hour ago, H2O_King89 said:

Still can’t get this to work. Can’t put in https://

 

Just enter the ip (address?) (without https://) and tap on the "Secure ?' switch

Share this post


Link to post

I received two bug reports about not being able to power down a server with v2.10.2 and I was finally able to reproduce it.

 

I've fixed it in my dev environment.

 

The next version is a major internal overhaul (data storage architecture changed completely), which means when it's released you'll need to re-add you server(s) :o

 

Sorry beforehand for the inconvenience, but a migration step would be expensive in terms of resources. O.o

 

Finally, I hope to make it available early next month at the latest.

Share this post


Link to post

v3.0.0 has been published on Apple & Google stores !

 

This release brings a new storage architecture, that makes the app easier to maintain and add features.

 

You need to re-add your servers.

 

These additional changes are included:

- Configurable poke vs ping to check if server is online
- Improved Settings and Add Servers screens
- Used OS native fonts everywhere
- Improved auto refresh behavior
- Fixed power down/reboot issues
- Fixed issue with scrolling marquee after orientation change
- Other bug fixes and improvements
 

Also, swipe to delete server is once again available by default.

 

Just FYI, Poke checks that the port you specify when adding the server is accepting connections. Ping sends an ICMP request to the server.

This should help with people that for some reason doesn't have ping available for their server(s).

 

You need to have the plugin (2.3.0) installed, for optimal operation.

 

Finally, I was going to implement ControlR as a notification agent, but held it back.

 

It's relatively easy to do on iOS, but more difficult on Android, since there are different ways to do it and some providers/libraries haven't caught up yet with the current sanctioned way (FCM).

 

So it will probably be a while. It also needs a new notification agent template that would need to be shipped directly with unRAID, as far as I can tell.

 

I will look now into showing ups stats.

 

Let me know about any issues you may find with this release.

 

Edited by jbrodriguez

Share this post


Link to post

The first time I tried to manually add my server the ControlR app crashed. Crash didn't repeat though. I notice that on my iPhone 7 the password field is hidden behind the keyboard.

Share this post


Link to post

Also, it appears that changing any setting crashs the app. No changes are preserved.

Edited by wgstarks

Share this post


Link to post
36 minutes ago, wgstarks said:

The first time I tried to manually add my server the ControlR app crashed. Crash didn't repeat though. I notice that on my iPhone 7 the password field is hidden behind the keyboard.

 

34 minutes ago, wgstarks said:

Also, it appears that changing any setting crashs the app. No changes are preserved.

Fixed with 2.10.2 update. Don't see the ping/poke option anymore though.

Share this post


Link to post
8 minutes ago, wgstarks said:

Fixed with 2.10.2 update

 

So, did you revert back to 2.10.2 ? Is that what you mean ?

Share this post


Link to post
14 minutes ago, jbrodriguez said:

 

So, did you revert back to 2.10.2 ? Is that what you mean ?

Guess so.o.O Tried deleting and re-installing the app since this often fixes problems. After re-installing the app showed an over the air update so I installed that. Never realized the App Store had reverted me to an earlier version, just thought you were very fast with a fix.?

 

Going to re-install the most recent version (3.0.0).

Share this post


Link to post

Same here on iOS, although third attempt added the server. Any setting change results in the app quitting however the setting is saved.

Share this post


Link to post
4 minutes ago, Ashe said:

Any setting change results in the app quitting however the setting is saved

 

If you refresh the server (pull down), does it work ?

Share this post


Link to post
 
If you refresh the server (pull down), does it work ?


No setting change still results in a forced quit

Share this post


Link to post

Ashe/wgstarks, what iOS version are you on ?

 

I'm testing on 10.3.3 and I can't reproduce the crashes yet

 

41 minutes ago, Ashe said:

No setting change still results in a forced quit

 

I understand you were able to add the server. If you just refresh the server, without changing any setting, does it work ?

Share this post


Link to post
Ashe/wgstarks, what iOS version are you on ?
 
I'm testing on 10.3.3 and I can't reproduce the crashes yet
 
 
I understand you were able to add the server. If you just refresh the server, without changing any setting, does it work ?


11.01 for iOS

Server works absolutely fine apart from docker, logs and VMs so it seems it’s not communicating with the plugin.

There is also a minor visual issue with the rotating banner for the mb/cpu temps that goes right to left then bounces and goes left to right.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.