Jump to content
jbrodriguez

ControlR (Android/iOS app for unRAID)

1011 posts in this topic Last Reply

Recommended Posts

So I tried turning SSL off again, and It worked. I saw in the settings that timeout was set to 1, changed it to 1000. 

Edited by GilbN

Share this post


Link to post

v4.1.1 is available as an over-the-air (OTA) update !

 

4.1.1

 

- Fix issues when adding servers

 

This is small change to address the issue when adding servers.

 

Look for the red badge on the settings icon, go the settings page and follow instructions (restart the app basically).

 

Glad to know it's working GilbN.

 

Please try it normally, and yes timeout 1 was really low (it's in milliseconds).

 

@WonderfulSlipperyThing let me know if this works for you as well.

Share this post


Link to post
2 minutes ago, jbrodriguez said:

v4.1.1 is available as an over-the-air (OTA) update !

 

4.1.1

 

- Fix issues when adding servers

 

This is small change to address the issue when adding servers.

 

Look for the red badge on the settings icon, go the settings page and follow instructions (restart the app basically).

 

Glad to know it's working GilbN.

 

Please try it normally, and yes timeout 1 was really low (it's in milliseconds).

 

@WonderfulSlipperyThing let me know if this works for you as well.

 

Worked adding the server manually with SSL now :)

Share this post


Link to post
59 minutes ago, jbrodriguez said:

v4.1.1 is available as an over-the-air (OTA) update !

 

4.1.1

 

- Fix issues when adding servers

 

This is small change to address the issue when adding servers.

 

Look for the red badge on the settings icon, go the settings page and follow instructions (restart the app basically).

 

Glad to know it's working GilbN.

 

Please try it normally, and yes timeout 1 was really low (it's in milliseconds).

 

@WonderfulSlipperyThing let me know if this works for you as well.

That worked, thanks!

Share this post


Link to post

v4.2.0 is available on App Store / Play Store !

 

This is a maintenance release to fix issues when adding servers.

 

This release just brings to the Play / App Store the fix for the issue when adding servers.


No additional change was made.

 

Thanks for the confirmation WonderfulSlipperyThing.

Share this post


Link to post

I've just updated the ControlR PLUGIN (v2018.07.07, 2.11.0), to modify how it decides which protocol (http/https) to listen on.

 

So, in terms of the ControlR iOS/Android app, note the following:

 

If the SSL setting in your unRAID is set to 

  • 'yes' -> Add the server via ip/hostname, https port, secure switch on
  • 'auto' -> Add the server via ip/hostname, http port, secure switch off
  • 'no' -> Add the server via ip/hostname, http port, secure switch off 

Let me know about any issues.

Share this post


Link to post

I had to change the rules shown in the previous post, now that the PLUGIN 2018-07-14 (2.12.0) is out

 

This is how you should add your server to make sure that the features provided by the plugin work:

 

If the SSL setting in your unRAID is set to 

'yes' -> Add the server via ip/hostname, https port, secure switch on

'auto' -> Add the server via ip/hostname, https port, secure switch on

'no' -> Add the server via ip/hostname, http port, secure switch off 

 

This is reflected in the app's FAQ.

 

In the short term, I'll be adding a padlock to server header section in the app, to show how it was added: padlock open = http, padlock closed = https.

 

Sorry for the inconveniences.

Share this post


Link to post

I recently upgraded to iOS 12 beta and since then any servers I ad disappear and it won't register them now. I know it is a beta but just giving you a heads up :)

Share this post


Link to post

Hi, I'll try to check if iOS 12 has any network changes (permission wise mostly), but I don't think that's the case.

 

Have you made any changes on the unRAID side ? Bumped version? Installed any network docker (reverse proxy for example) ?

Share this post


Link to post

Not that I’m aware of. I do run a reverse proxy but have done for years with no issues. Connection details are just my local ip and port 80.


Sent from my iPhone using Tapatalk

Share this post


Link to post

Can you try the following (to debug the connection) ?

 

- Go to Settings > Credits

- After the react native credits, you’ll find a debug button, hit it once (counter should read 1)

- Now try connecting manually (you should see a ‘debug initialized ‘ message at the bottom)

- It should go back to the main screen

- Go to manual add again

- It should be displaying some debug message

- Take a screenshot and send it over (pm if you prefer)

 

Share this post


Link to post
On 8/26/2018 at 10:47 AM, jbrodriguez said:

Can you try the following (to debug the connection) ?

 

- Go to Settings > Credits

- After the react native credits, you’ll find a debug button, hit it once (counter should read 1)

- Now try connecting manually (you should see a ‘debug initialized ‘ message at the bottom)

- It should go back to the main screen

- Go to manual add again

- It should be displaying some debug message

- Take a screenshot and send it over (pm if you prefer)

 

 

I am a first time user, using the android app and cannot add my server.  I enabled debug and set to 10s timeout, it says "request timed out."

I have tried using SSL on/off, used different ports, and enabled/disabled the app.

 

Any other suggestions?  I haven't rebooted the server (waiting on a parity check to complete) but will try that next.

 

Thanks in advance!

Share this post


Link to post

Hi, the time out means it's not "seeing" unraid's webGui.

 

Are you adding the server from within your LAN ? 

 

Do you have a reverse proxy on the server that redirects the main webGUI ?

 

Try the SSL/port combination described in the following table

 

SSL		Instructions
yes	->	add server via ip/hostname, https port (default is 443), secure switch on
auto	->	add server via ip/hostname, https port (default is 443), secure switch on
no	->	add server via ip/hostname, http port (default is 80), secure switch off

 

Share this post


Link to post
On 8/26/2018 at 3:47 PM, jbrodriguez said:

Can you try the following (to debug the connection) ?

 

- Go to Settings > Credits

- After the react native credits, you’ll find a debug button, hit it once (counter should read 1)

- Now try connecting manually (you should see a ‘debug initialized ‘ message at the bottom)

- It should go back to the main screen

- Go to manual add again

- It should be displaying some debug message

- Take a screenshot and send it over (pm if you prefer)

 

Unfortunately I switched from an iPhone to Android over the weekend and so cannot investigate further!

Share this post


Link to post
3 hours ago, planetwilson said:

Unfortunately I switched from an iPhone to Android over the weekend and so cannot investigate further!

There is an Android version.

Share this post


Link to post
1 minute ago, trurl said:

There is an Android version.

 

Yes sorry I should have been clearer. I have bought it already, seems to work fine but I do get the odd time where it won't show me VMs, dockers etc. Not sure why and can't reproduce it all the time.

Share this post


Link to post

@FreeMan,

 

You're referring to the ControlR plugin, so I'm referencing your post here.

 

The most likely reason you can't see logs is that the app can't connect with the plugin, because of SSL settings (Settings > Identification > SSL)

 

Check if the following table (from the FAQ), solves your issue

SSL		Instructions
yes	->	add server via ip/hostname, https port (default is 443), secure switch on
auto	->	add server via ip/hostname, https port (default is 443), secure switch on
no	->	add server via ip/hostname, http port (default is 80), secure switch off

 

 

Share this post


Link to post
On 9/18/2018 at 7:11 AM, jbrodriguez said:

@FreeMan,

 

You're referring to the ControlR plugin, so I'm referencing your post here.

 

The most likely reason you can't see logs is that the app can't connect with the plugin, because of SSL settings (Settings > Identification > SSL)

 

Check if the following table (from the FAQ), solves your issue


SSL		Instructions
yes	->	add server via ip/hostname, https port (default is 443), secure switch on
auto	->	add server via ip/hostname, https port (default is 443), secure switch on
no	->	add server via ip/hostname, http port (default is 80), secure switch off

 

 

The only way I can get the ControlR app to add my server is to use port 80 and have the secure switch off, despite the fact that the 'Use SSL/TLS' setting on the server is set to "Auto". If I try adding it on port 443 with the secure switch on, it doesn't find the server at all.

 

Any other suggestions?

Share this post


Link to post
8 hours ago, FreeMan said:

is to use port 80 and have the secure switch off, despite the fact that the 'Use SSL/TLS' setting on the server is set to "Auto"

That shouldn't be the case.

 

Since SSL is set to auto, the plugin listens on https, but since you can only add the server via http, the app can't connect to the plugin.

 

I'll look into redirecting the plugin connection, so that this would be a non-issue.

 

In the meantime, can you send me /boot/logs/controlr.log ? (pm if you want)

 

Also, are you running anything other than the webGUI on port 443 ?

 

Maybe you have a reverse proxy or a letsencrypt container listening on the server's 443 port ?

Share this post


Link to post



That shouldn't be the case.
 
 
In the meantime, can you send me /boot/logs/controlr.log ? (pm if you want)
 
Also, are you running anything other than the webGUI on port 443 ?
 
Maybe you have a reverse proxy or a letsencrypt container listening on the server's 443 port ?


I am running LetsEncrypt on my main server, but I was playing /trying to connect to my new backup server which has nothing but a couple of Dynamix plug ins on it right now.

I'll send the log when I get home this evening.

Sent from Tapatalk

Share this post


Link to post

Ok, so I guess the same happens on your backup server ?

 

You can only add it via http/80, not https/443?

 

What's your unRAID version on the backup ?

 

6 hours ago, FreeMan said:

I'll send the log when I get home this evening.

Thanks, I'll check it out.

 

Send me the /boot/logs/controlr.log of the backup too (you installed the plugin there ?)

Share this post


Link to post

1) Nothing of interest (personally) in the log file, so it's attached (from server: Backup)

2) On the Backup server, I am running 6.5.3. I just received the 6.6 update notice, but I won't do that yet (unless you think it'll help) so we've got a consistent platform to test against.

3) I have both my main and backup servers added on port 80. I've not tried reconfiguring the main server for https yet. It hasn't had log access for several months, though it did at one point. I'm not sure what particular build of the app or plugin caused it to stop.

4) I have these plugins installed:

      preclear disks & associated statistics

      CA, CA-Auto Update, CA-Autostart docker manager

      Dynamix-File Integrity, Stop Shell, System Buttons, System Info

      Fix Common Problems

      Nerd Tools with only Python 2.7, tmux & utempter installed (the last 2 for preclear disk)

      Speedtest command line tool

5) I have the Disk Speed docker installed

6) I access the server by hostname

 

Note all those apply to my backup server which is brand new, still running on a trial license with no data on it yet (unless otherwise specified).

 

I'm going to go ahead and update my main server to 6.6. I'll test out ControlR to see if I can attach via 443 after that's done, just for kicks.

 

Hope I covered all the questions. Thanks for a great product and fantastic support!

controlr.log

Edited by FreeMan

Share this post


Link to post

Thanks for the detailed reply and kind words !!!

 

From the log

I: 2018/09/18 19:41:05 api.go:90: Api started listening https on :2382

means the plugin detected a known certificate on /boot/config/ssl/certs and an SSL setting of 'auto' or 'yes'.

 

Try adding the backup server via https.

 

If it doesn't work, can you try adding it by ip address, just to test ?

 

I'll update my test server to 6.6.0 this weekend, so I'll know if the app still works or needs an update :)

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.