Jump to content
SpaceInvaderOne

How to stop .DS_STORE files and ._ files being created in shares (SERVER SIDE)

31 posts in this topic Last Reply

Recommended Posts

(However I personally dont like seeing the files at all. I have my windows machines usually with the show hidden files checked so i see the files anyway with the hide option. I also dont like to see the files when working in krusader docker.)

 

If Samba is set up to hide the dot files but Windows is set to display them, they should appear greyed out. But I find it puzzling that you have Windows set to display hidden files when you don't like seeing them!

 

I use the Krusader docker too and like it because it tells the truth - I don't like files that are present being hidden from me.

 

I'm fundamentally opposed to a file server that is configured to ignore requests to create files with certain names, preferring the option of configuring the clients so they don't make the requests in the first place, but I'm pleased you have found a solution that works for you and maybe other people will find it useful too.

 

Share this post


Link to post
On 6/24/2016 at 8:22 AM, ideaman924 said:

Guess the SMB options only show up on beta versions.

 

BTW, I'm on v6 21. Hope to upgrade to 23... maybe.

In case any new users stumble upon this thread. The option to hide .DS_Store files is available in the GUI.

Settings > Network Settings > SMB > Hide "dot" files

On 6/26/2016 at 8:47 AM, John_M said:

Perhaps a better option for other people might be to configure OS X not to create the ._ files on network volumes in the first place.

 

I ran the terminal command (I don't remember it off the top of my head), rebooted the computer, but the files are still being made on the array.

From my understanding, Apple is slowly phasing out AFP and SAMBA will be the way to go; sticking with SAMBA for now.

Share this post


Link to post
Posted (edited)
19 hours ago, MothyTim said:

Unraid smb set to hide dot files but windows still shows them?

 

On 6/27/2016 at 5:44 PM, John_M said:

If Samba is set up to hide the dot files but Windows is set to display them, they should appear greyed out.

To hide them completely you have to tell Windows not to display them. See the table below:

 

                              Samba hide             Samba show

Windows hide          Invisible                  Invisible

Windows show        Greyed out              Visible

 

I still maintain that I'm fundamentally opposed to the idea of configuring a file server to refuse to store certain files. It's much better to configure Macintosh clients not to create the annoying files on shared network storage in the first place. See here, for example: https://www.tekrevue.com/tip/stop-ds-store-files-mac-network/

defaults write com.apple.desktopservices DSDontWriteNetworkStores -bool TRUE

 

Edited by John_M
Added more info

Share this post


Link to post

Thanks for the explanation. I have done as you suggest and told the Mac not to create them!

Cheers,

Tim

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.