Jump to content
linuxserver.io

[Support] Linuxserver.io - Nextcloud

1915 posts in this topic Last Reply

Recommended Posts

3 hours ago, L0rdRaiden said:

How is the updating process of this docker? will the docker automatically get the 15.0.2 or do I need to do something?

I followed the manual instructions via the link on the first post.  It does state you can use the web interface also, but I couldn't find any proof that was the preferred method after reading this entire thread.  I did have to re-install all of my apps for some reason, not sure why, but I did follow the directions exactly as provided.  Re-adding the apps was very simple, configuration settings relating to those apps appear to have been retained.  So I'm now on 15.0.2.

Edited by jbear
  • Like 1

Share this post


Link to post
On 1/4/2019 at 1:43 PM, BDLR said:

Nextcloud and SABNZBD issue:  Nextcloud missing files after SABNZBD download

 

Hey Guys,

In Nextcloud I created a folder called "Howard Stern" and in SABNZBD I created a path to that folder.   I also added a category in SABNZBD to have those downloads moved to that folder.  SABnazbd is moving the file correctly and I can see it the files in that path but NEXTCLOUD is not showing those files in the WEBUI.    

 

Can any advise on the fix?   (I tried to show hidden files option and that didnt work)

 

 

 

 

Note sure if anyone replied on this, but files can't be added to Nextcloud by copying them directly into the user profile in the file folder.  You must leverage webdav, web interface etc.  Alternatively, iI you do choose to add them in this manner, you would need to invoke the occ tool from the command line, there is a parameter to add them to the database with files:scan.  Not sure if this would make sense or not.

 

Hope this helps.

 

Share this post


Link to post

You can also download the external drive app within next cloud (or whatever it’s called) and map to a share or folder on your system. Or your user path for all shares, if that floats your boat.

Share this post


Link to post
On 1/10/2019 at 7:32 PM, Darksurf said:

having an issue with this docker. I kind of want to blame unraid for this though. All my other dockers are working fine. In fact, this docker is working. The problem is I'm not getting a port mapping from the host to the docker and I can't even specify one completely. You can see in my attachment that I attempt to create a port map, but the options don't give me a place to choose a docker port, only a host port. and if you look in dockers tab, you see there's no mappings meanwhile the other dockers have no issues.

 

 

Screenshot_20190110_192656.png

Screenshot_20190110_192813.png

 OK, I just realized the issue. Evidently UNRAID is not aware that proxynet is a bridge. I had to select the default bridge and it then gave me a container port option! After setting the container port option, I was able to set the network interface back to the proxynet bridge and it worked!

Share this post


Link to post
8 hours ago, jbear said:

I followed the manual instructions via the link on the first post.  It does state you can use the web interface also, but I couldn't find any proof that was the preferred method after reading this entire thread.  I did have to re-install all of my apps for some reason, not sure why, but I did follow the directions exactly as provided.  Re-adding the apps was very simple, configuration settings relating to those apps appear to have been retained.  So I'm now on 15.0.2.

ok, thanks I did it, but if I update nextcloud manually when the docker updates by itself what is updating really?

Share this post


Link to post

After i updatet some Apps, i get an internal Server Error.

Can i disable all apps with one command ?

Share this post


Link to post
On 9/28/2018 at 2:42 PM, Konijntjes said:

When i did enter the docker container with ssh and did run the following command the error message was gone

 

sudo -u abc php /config/www/nextcloud/occ db:add-missing-indices

 

Only the "The "Referrer-Policy" HTTP header is not set to "no-referrer", "no-referrer-when-downgrade", "strict-origin" or "strict-origin-when-cross-origin". This can leak referer information." message to go

 

This help me fix upgrading to ver 15

Share this post


Link to post

Hi

 

I have some issues with autoupload. It does not work.

I have tried the following.

Delete my account, clear nextcloud cache, delete nextcloud, restart Samsung S7, install nextcloud but still does not work.

 

Any ideas and suggestions? Appreciate all help

Share this post


Link to post

Sorry to bother, I did try searching for this and found others with the issue but not a resolution.

 

I had 13.0.0 installed, updated to 14.x and then 15.0.2 after that - all via WebUI and that went very smoothly.

 

I just now have these warnings, before the upgrades I didn't have any warnings or issues here listed, I also still continue to get an A+ rating on the Nextcloud security scan, but I would like to resolve all of these issues listed here for good measure.

 

EDIT - got the tables updated w/ the sudo -u -abc command in the docker shell, but still not sure why the refer-policy is kicking that back, i had thought i had that issue on 13.x originally and fixed it. I'll have to look around some more, but if someone has a link or info handy feel free to send it my way!

 

Any help is appreciated!

 

image.thumb.png.a4ef418c64832179412f0c05a9274bec.png

Edited by CorneliousJD

Share this post


Link to post

Ok, so far I am still really struggling with this error.

 

Quote

The "Referrer-Policy" HTTP header is not set to "no-referrer", "no-referrer-when-downgrade", "strict-origin", "strict-origin-when-cross-origin" or "same-origin". 

I have searched around and found that the setup I followed had me put this in my reverse proxy (LetsEncrypt container) in my nextcloud site-config.

### Add HTTP Strict Transport Security ###
add_header Strict-Transport-Security "max-age=63072000; includeSubdomains";

Reasoning behind this I guess is that Nextcloud's own NGINX will issue those headers now after the update, and having them both cancels them out.

I've tried removing that from my LetsEncrypt site config and restarting both containers and no dice, the error still shows up.

 

Not sure what I'm doing wrong here - the post I initailly followed to set this all up is here: https://blog.linuxserver.io/2017/05/10/installing-nextcloud-on-unraid-with-letsencrypt-reverse-proxy/

Share this post


Link to post

Trying to setup NextCloud with Duckdns, letsencrypt, and MariaDB dockers.  Not sure when setting one of these up I missed something or not.  After setting all dockers up, when going to the WebUI for NextCloud, I am receiving the following message.

 

Welcome to our server

The website is currently being setup under this address.

For help and support, please contact: me@example.com

 

I should mention that I followed SpaceInvator One’s two guides for setting this up.  

 

Any ideas what’s going on? 

Edited by JohnSracic

Share this post


Link to post
10 hours ago, JohnSracic said:

Trying to setup NextCloud with Duckdns, letsencrypt, and MariaDB dockers.  Not sure when setting one of these up I missed something or not.  After setting all dockers up, when going to the WebUI for NextCloud, I am receiving the following message.

 

Welcome to our server

The website is currently being setup under this address.

For help and support, please contact: me@example.com

 

I should mention that I followed SpaceInvator One’s two guides for setting this up.  

 

Any ideas what’s going on? 

Try this URL - check the ending with the Nextcloud config files.

 

https://blog.linuxserver.io/2017/05/10/installing-nextcloud-on-unraid-with-letsencrypt-reverse-proxy/

 

It has to match the domain name you're trying to access from (your public facing DuckDNS domain)

Share this post


Link to post
3 hours ago, CorneliousJD said:

Try this URL - check the ending with the Nextcloud config files.

 

https://blog.linuxserver.io/2017/05/10/installing-nextcloud-on-unraid-with-letsencrypt-reverse-proxy/

 

It has to match the domain name you're trying to access from (your public facing DuckDNS domain)

 

I was for sure missing the nextcloud file in the /config/nginx/site-confs/ directory.  I coped directly from the link you provided and changed the two lines...  Now when I start letsencrypt and look at the logs, i see 'nginx: [emerg] unexpected "{" in /config/nginx/site-confs/nextcloud.rtf:1'.  Looking at the code, there are two open brackets and two closing brackets.  What am I missing?  Here is my nextcloud file...

 

------------------------------------

 

server {

listen 443 ssl;

server_name [name].duckdns.org;

 

root /config/www;

index index.html index.htm index.php;

###SSL Certificates

ssl_certificate /config/keys/letsencrypt/fullchain.pem;

ssl_certificate_key /config/keys/letsencrypt/privkey.pem;

###Diffie–Hellman key exchange ###

ssl_dhparam /config/nginx/dhparams.pem;

###SSL Ciphers

ssl_ciphers 'ECDHE-RSA-AES128-GCM-SHA256:ECDHE-ECDSA-AES128-GCM-SHA256:ECDHE-RSA-AES256-GCM-SHA384:ECDHE-ECDSA-AES256-GCM-SHA384:DHE-RSA-AES128-GCM-SHA256:DHE-DSS-AES128-GCM-SHA256:kEDH+AESGCM:ECDHE-RSA-AES128-SHA256:ECDHE-ECDSA-AES128-SHA256:ECDHE-RSA-AES128-SHA:ECDHE-ECDSA-AES128-SHA:ECDHE-RSA-AES256-SHA384:ECDHE-ECDSA-AES256-SHA384:ECDHE-RSA-AES256-SHA:ECDHE-ECDSA-AES256-SHA:DHE-RSA-AES128-SHA256:DHE-RSA-AES128-SHA:DHE-DSS-AES128-SHA256:DHE-RSA-AES256-SHA256:DHE-DSS-AES256-SHA:DHE-RSA-AES256-SHA:AES128-GCM-SHA256:AES256-GCM-SHA384:AES128-SHA256:AES256-SHA256:AES128-SHA:AES256-SHA:AES:CAMELLIA:DES-CBC3-SHA:!aNULL:!eNULL:!EXPORT:!DES:!RC4:!MD5:!PSK:!aECDH:!EDH-DSS-DES-CBC3-SHA:!EDH-RSA-DES-CBC3-SHA:!KRB5-DES-CBC3-SHA';

###Extra Settings###

ssl_prefer_server_ciphers on;

ssl_session_cache shared:SSL:10m;

 

        ### Add HTTP Strict Transport Security ###

add_header Strict-Transport-Security "max-age=63072000; includeSubdomains";

add_header Front-End-Https on;

 

client_max_body_size 0;

 

location / {

proxy_pass https://xxx.xxx.x.xxx:444/;

        proxy_max_temp_file_size 2048m;

        include /config/nginx/proxy.conf;

}

}

 

 

Share this post


Link to post
22 minutes ago, JohnSracic said:

 

I was for sure missing the nextcloud file in the /config/nginx/site-confs/ directory.  I coped directly from the link you provided and changed the two lines...  Now when I start letsencrypt and look at the logs, i see 'nginx: [emerg] unexpected "{" in /config/nginx/site-confs/nextcloud.rtf:1'.  Looking at the code, there are two open brackets and two closing brackets.  What am I missing?  

Not too sure off hand, it may be something going off with mixing SpaceInvader One's guide with the one I linked. You may want to blow it out and start over with the guide I linked above, that worked well for me with no issues roughly 6/7 months ago when I setup my container. 

Share this post


Link to post
On 1/18/2019 at 8:31 PM, CorneliousJD said:

Ok, so far I am still really struggling with this error.

 

I have searched around and found that the setup I followed had me put this in my reverse proxy (LetsEncrypt container) in my nextcloud site-config.


### Add HTTP Strict Transport Security ###
add_header Strict-Transport-Security "max-age=63072000; includeSubdomains";

Reasoning behind this I guess is that Nextcloud's own NGINX will issue those headers now after the update, and having them both cancels them out.

I've tried removing that from my LetsEncrypt site config and restarting both containers and no dice, the error still shows up.

 

Not sure what I'm doing wrong here - the post I initailly followed to set this all up is here: https://blog.linuxserver.io/2017/05/10/installing-nextcloud-on-unraid-with-letsencrypt-reverse-proxy/

Well I did end up fixing this, but not in a way that I found many answers for, but this works and still gives me an A+ on the NextCloud security and I get the following in Nextcloud too! 

 

All I did to fix this on my end was going into my LetsEncrypt site-conf for nextcloud, and under the ### Add HTTP Strict Transport Security ### section I added this header line.

add_header Referrer-Policy no-referrer;

After saving this and restarting LE and Nextcloud and re-checking, all checks pass and I'm getting an A+ on the security check!

image.png

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now