[Support] Linuxserver.io - Nextcloud

Recommended Posts

9 hours ago, levster said:

I noticed that there is a 17.0.0 release as of 9/30/2019. However, my version is 16.0.5 and is being reported as the latest stable and up to date. Am I missing something?

No. Only fresh installs will pickup v17. Existing issues will get v17 when nextcloud release it to their web updater. They stagger the release for obvious reasons.

Link to comment

When creating a new folder in a Local external storage directory, Nextcloud gives it the permissions drwxr-xr-x. Which isn't in accordance with the unRaid Permission scheme, and prevents me to change it via SMB afterwards. How can I tell unRaid to always create folders with drwxrWxrWx (777) permissions?

Link to comment
2 minutes ago, turnipisum said:

Can't access nextcloud after update anyone have any idea. Tried recreating container but got same issue nothing can connect windows app or web ui.

x.x.x.x is currently unable to handle this request.


Need way more detail.  Logs etc

Link to comment

New to UNRaid along with the deployment of NextCloud, however when deploying and trying to access GUI, I received the following error:

Internal Server Error The server encountered an internal error and was unable to complete your request. Please contact the server administrator if this error reappears multiple times, please include the technical details below in your report. More details can be found in the server log.


Is this a result of the latest version or something else. Looking at the logs, does not show any warnings from the UNRaid interface. Any assistance would be great.


Link to comment
On 10/12/2019 at 1:38 AM, Diggewuff said:

When creating a new folder in a Local external storage directory, Nextcloud gives it the permissions drwxr-xr-x. Which isn't in accordance with the unRaid Permission scheme, and prevents me to change it via SMB afterwards. How can I tell unRaid to always create folders with drwxrWxrWx (777) permissions?


51 minutes ago, Ustrombase said:

Is it better to use SMB or to simply mount the volume via docker?

The external storage is actually mounted via Docker. But every folder created by Nextcloud via web UI or App gets wrong permissions. 

Link to comment

I am getting this error when I try moving "a lot" of pictures (50) into a folder using the webUI

[15-Oct-2019 04:10:14] WARNING: [pool www] server reached pm.max_children setting (5), consider raising it

research has led me to edit /config/php/www2.conf inside my config directory of nextcloud docker.



However, I can't find anywhere what each of these settings are suppose to be. I would like to know what each number means. Also don't know why this happens specifically when I am moving files into another folder.


pm = dynamic
pm.max_children = 40
pm.start_servers = 15
pm.min_spare_servers = 15
pm.max_spare_servers = 25

Does anyone know?

Link to comment

I've got two problems going on. I'm connecting to nextcloud using a reverse proxy provided by NginxProxyManager. The guide by spaceinvaderone didn't work out for me so I didn't go with his reverse proxy suggestion.


Problem nr 1:

whenever I try to upload either a single larger file (test file is 5gb) or multiple files totaling a few Gb I get

error assembling chunks, error 504

The log doesn't show anything for this error. The upload usually goes through, but not if I refresh the page too soon after receiving the error.


Problem nr 2:

When I try to upload a larger number of files (tested with 100+) my log shows the following:

Sabre\DAV\Exception\BadRequest: Expected filesize of 10485760 bytes but read (from Nextcloud client) and wrote (to Nextcloud storage) 7372800 bytes. Could either be a network problem on the sending side or a problem writing to the storage on the server side.

    /config/www/nextcloud/apps/dav/lib/Connector/Sabre/Directory.php - line 156:


    /config/www/nextcloud/apps/dav/lib/Upload/UploadFolder.php - line 45:

    OCA\DAV\Connector\Sabre\Directory->createFile("251658240", null)

    /config/www/nextcloud/3rdparty/sabre/dav/lib/DAV/Server.php - line 1096:

    OCA\DAV\Upload\UploadFolder->createFile("251658240", null)

    /config/www/nextcloud/3rdparty/sabre/dav/lib/DAV/CorePlugin.php - line 525:

    Sabre\DAV\Server->createFile("uploads/sam ... 0", null, null)


    Sabre\DAV\CorePlugin->httpPut(Sabre\HTTP\R ... "}, Sabre\HTTP\Response {})

    /config/www/nextcloud/3rdparty/sabre/event/lib/EventEmitterTrait.php - line 105:

    call_user_func_array([ Sabre\DAV\ ... "], [ Sabre\HTTP ... }])

    /config/www/nextcloud/3rdparty/sabre/dav/lib/DAV/Server.php - line 479:

    Sabre\Event\EventEmitter->emit("method:PUT", [ Sabre\HTTP ... }])

    /config/www/nextcloud/3rdparty/sabre/dav/lib/DAV/Server.php - line 254:

    Sabre\DAV\Server->invokeMethod(Sabre\HTTP\R ... "}, Sabre\HTTP\Response {})

    /config/www/nextcloud/apps/dav/lib/Server.php - line 317:


    /config/www/nextcloud/apps/dav/appinfo/v2/remote.php - line 35:


    /config/www/nextcloud/remote.php - line 163:

    require_once("/config/www ... p")

Googling the error shows others with the same problem on OwnCloud. All solutions however are related to Apache, whereas I'm using nginx and they don't directly apply.


Solutions I've tried:

Modifed nginx.conf (/appdata/nextcloud/nginx/nginx.conf)

- increased client_max_body_size to 16G


Modifed php.ini (/etc/php7/php.ini)

- increased max_input_vars to 1000

- increased memory_limit to 1024M

- changed temp folder

- increased upload_max_filesize to 16G

- increased max_file_uploads to 1000

- increased max_execution_time to 7200

- increased max_input_time 7200

Edited by sampla
additional edits in php.ini
Link to comment
5 minutes ago, sampla said:

Bumping thread. I'm getting really tired of this issue.

No need to bump anything. If no one answers, it's usually because noone have any suggestions.

We supply a working reverse proxy config in our letsencrypt container, so take a look at our config.

This container have no problem uploading huge files, so it's most likely your reverse proxy config that is wrong.

  • Thanks 1
Link to comment

Alright, so I managed to change my reverse proxy to letsencrypt as suggested and I also realized that I'm better off ignoring what Nextcloud's log in the webUI says and look at nginx's error log instead. I'm getting

[error] 322#322: *1832 upstream timed out (110: Operation timed out) while reading response header from upstream, client:, server: _, request: "PUT /remote.php/webdav/Photos/pic.jpg HTTP/HTTP/1.1", upstream: "fastcgi://", host: "nextcloud.mywebsite.com:443"

Some Googling suggests adding

proxy_read_timeout 3600;

to my conf file, but when I do my letsencrypt log tells me

nginx: [emerg] "proxy_read_timeout" directive is duplicate in /config/nginx/proxy-confs/nextcloud.subdomain.conf:28



Edited by sampla
Link to comment
4 minutes ago, amadnei said:

hopefully someone can help me, Im stuck at doing the Letsencrypt reverse proxy.


Seem to be unable to port foward on asus router, wich I suspect why letsencrypt cannot reach my duckdns domain ?


What errors are you getting? Are you following spaceinvaderone's youtube guide?

Link to comment
3 minutes ago, amadnei said:

I did follow spaceinvader, aswell as techcoreduo and linuxserver written guide !



Waiting for verification...
Challenge failed for domain amadnei.duckdns.org.duckdns.org

In letsencrypt docker settings write only "duckdns.org" for domain name. For subdomain write only "amadnei".

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.