Jump to content
linuxserver.io

[Support] Linuxserver.io - Nextcloud

3323 posts in this topic Last Reply

Recommended Posts

Latest now working fine.

Share this post


Link to post
16 hours ago, saarg said:

 

No need to post an issue on github. Github is not used for support questions, but bugs.

 

You have to use the command line to update nextcloud. Webui works for some, but not all. The update is not under our control as that is all nextcloud.

 

There is a link in the first post to a update guide.

I attempted to follow the guide linked in the first post, but it my `occ` is missing

 

root@Tower:~# docker exec -it nextcloud bash
root@7010b1d5296c:/# sudo -u abc php7 /config/www/nextcloud/occ maintenance:mode --on
Could not open input file: /config/www/nextcloud/occ

root@7010b1d5296c:/# ls -l /config/www/nextcloud/
total 16
drwxrwxr-x 1 abc abc  0 Jan 10 17:17 apps
drwxrwxr-x 1 abc abc 38 Jan 10 17:17 config
-rw-rw-r-- 1 abc abc 57 Jan 10 17:16 index.php
-rw-rw-r-- 1 abc abc 57 Jan 10 17:16 public.php
-rw-rw-r-- 1 abc abc 57 Jan 10 17:16 remote.php
-rw-rw-r-- 1 abc abc 57 Jan 10 17:16 status.php
drwxrwxr-x 1 abc abc 42 Jan 10 17:17 themes
drwxrwxr-x 1 abc abc 42 Jul 23  2018 updater

root@7010b1d5296c:/# find . -type f -iname "occ"
find: ./sys/kernel/slab/unraid/md: No such file or directory
./data/updater-ocahy6bwi45i/backups/nextcloud-16.0.5.1/occ
./data/updater-ocahy6bwi45i/backups/nextcloud-17.0.1.1/occ
./data/updater-ocahy6bwi45i/backups/nextcloud-16.0.4.1/occ
./data/updater-ocahy6bwi45i/backups/nextcloud-16.0.3.0/occ
./data/updater-ocahy6bwi45i/downloads/nextcloud/occ
root@7010b1d5296c:/# 

Any advice on how to move forward?

Share this post


Link to post
19 minutes ago, Bob1215 said:

I attempted to follow the guide linked in the first post, but it my `occ` is missing

 


root@Tower:~# docker exec -it nextcloud bash
root@7010b1d5296c:/# sudo -u abc php7 /config/www/nextcloud/occ maintenance:mode --on
Could not open input file: /config/www/nextcloud/occ

root@7010b1d5296c:/# ls -l /config/www/nextcloud/
total 16
drwxrwxr-x 1 abc abc  0 Jan 10 17:17 apps
drwxrwxr-x 1 abc abc 38 Jan 10 17:17 config
-rw-rw-r-- 1 abc abc 57 Jan 10 17:16 index.php
-rw-rw-r-- 1 abc abc 57 Jan 10 17:16 public.php
-rw-rw-r-- 1 abc abc 57 Jan 10 17:16 remote.php
-rw-rw-r-- 1 abc abc 57 Jan 10 17:16 status.php
drwxrwxr-x 1 abc abc 42 Jan 10 17:17 themes
drwxrwxr-x 1 abc abc 42 Jul 23  2018 updater

root@7010b1d5296c:/# find . -type f -iname "occ"
find: ./sys/kernel/slab/unraid/md: No such file or directory
./data/updater-ocahy6bwi45i/backups/nextcloud-16.0.5.1/occ
./data/updater-ocahy6bwi45i/backups/nextcloud-17.0.1.1/occ
./data/updater-ocahy6bwi45i/backups/nextcloud-16.0.4.1/occ
./data/updater-ocahy6bwi45i/backups/nextcloud-16.0.3.0/occ
./data/updater-ocahy6bwi45i/downloads/nextcloud/occ
root@7010b1d5296c:/# 

Any advice on how to move forward?

The updater probably already turned on maintenance mode and made a backup and deleted the current install. So you don't have the occ file.

How far did you get in the update?

Share this post


Link to post
The updater probably already turned on maintenance mode and made a backup and deleted the current install. So you don't have the occ file.

How far did you get in the update?

I kept getting 504 codes at different points in the web updater sequence, and at another time some message about not being able to unzip/zip.

 

But I did just skip that second step regarding turning maintenance mode on (like you said, it was already stuck on). I completed the steps in the guide and it's back up and running. Thanks for taking the time to help out

 

 

Share this post


Link to post
18 hours ago, blaine07 said:

 


Poster above mentioned setting up Redis as well; appears he went at it a entirely different direction.

Which way is right/ wrong here? Or is it both accomplishing same thing? One using app on CA and Nextcloud using something built in?

https://forums.unraid.net/topic/48383-support-linuxserverio-nextcloud/?do=findComment&comment=807040

 

I don't know exactly which post you are referring to but as far as I can tell everyone is doing it the same way as me. You need a Redis instance running as the Nextcloud container doesn't come with one.

EDIT: oops missed your link. That user just says he installed it by modifying the config but doesn't really go into detail about all the steps. You need a Redis instance running which you install via community applications.

Edited by Skylord123

Share this post


Link to post

Did someone already got the update to NC 18 now called "Nextcloud Hub" with a lot of new features. Most interesting are the preconfigured and already implemented office features. No more extra containers like collabora needed.

Share this post


Link to post
Did someone already got the update to NC 18 now called "Nextcloud Hub" with a lot of new features. Most interesting are the preconfigured and already implemented office features. No more extra containers like collabora needed.
A new install will have the features by default, an existing install will not, and you will need to manually add the relevant apps/plugins via the Nextcloud webui.

I have upgraded manually to check everything is working, but not really had time to check it all out yet as spent last night working on something else, which reminds me, I need to upload that.

Sent from my Mi A1 using Tapatalk

Share this post


Link to post
2 minutes ago, CHBMB said:

A new install will have the features by default, an existing install will not, and you will need to manually add the relevant apps/plugins via the Nextcloud webui.

Wait, so I can't update NC 17 to 18 with the internal update routine?

Share this post


Link to post
Wait, so I can't update NC 17 to 18 with the internal update routine?
You can, but they stagger the OTA updates, so you can only do it when it's offered to you. Using the terminal you can update whenever you want.

Whatever method you're using the "hub" features will not automatically be enabled with an upgrade, you still need to enable the relevant plugins, whereas a fresh install they will be enabled out of the box.

Sent from my Mi A1 using Tapatalk

Share this post


Link to post

@CHBMB Thanks for the explanation. I guess same as the most users I already have the mail, calender, photos app etc. already enabled and if I wanna use the new talk and office stuff I only have to install it from the store. Sounds easy. I hope it will work that easy 😉

Share this post


Link to post
@CHBMB Thanks for the explanation. I guess same as the most users I already have the mail, calender, photos app etc. already enabled and if I wanna use the new talk and office stuff I only have to install it from the store. Sounds easy. I hope it will work that easy
I briefly tried the office stuff which didn't work for me, but I already have collabora so I reverted to that.

I'm sure any niggles will get ironed out with time and patience.

Sent from my Mi A1 using Tapatalk

Share this post


Link to post

So, I’m guessing, when we get update to version 18 the OnlyOffice stuff won’t be already enabled and it won’t break my already existing Collabora integration

Share this post


Link to post
12 hours ago, Bob1215 said:

I kept getting 504 codes at different points in the web updater sequence, and at another time some message about not being able to unzip/zip.

 

But I did just skip that second step regarding turning maintenance mode on (like you said, it was already stuck on). I completed the steps in the guide and it's back up and running. Thanks for taking the time to help out emoji4.png

 

 

Good you got it running.

So it made the backup and deleted the files and then failed unpacking it.

I'm not sure why the web update fails for some. Do you reverse proxy using subfolder?

Share this post


Link to post

For ONLYOFFICE.
With Hub (18) you install the ONLYOFFICE connector and after that, search for "Community Document Server" within Nextcloud - Apps and install that.

https://apps.nextcloud.com/apps/documentserver_community

Does not work for me. Only gives me "Community document server is not supported for this instance, please setup and configure an external document server"
Tried chmod for the files mentioned here https://github.com/nextcloud/documentserver_community/issues/10 with no luck.

Guess I have to wait and see how this develops.

Edited by Niklas

Share this post


Link to post
On 1/13/2020 at 7:26 PM, kerpster said:

What is the reason for mariadb and some of the other things that you guys are installing? I installed nextcloud and that's it. 

I believe redis or MariaDB provide quicker downloads of large files or photos to your local NextCloud app. Letsencrypt provides some reverse proxy security. However, I stripped out both just to get to the latest upgrade but, I had to delete the Nextcloud folder in the appdata directory first to resolve my previous issue. I feel like a dumbass but, I managed to upgrade my Nextcloud! I’ll add the redis and Letsencrypt soon.

Share this post


Link to post
My nextcloud is stuck in Maintenance Mode, it was trying to update. 
How do i fix this?
If you still needed to complete the update: Click the link to the update guide in the first post, skip step 2 (putting nextcloud into maintenance mode with occ), complete the steps to update manually and close maintenance mode.

Otherwise just do the last steps in that guide to close maintenance mode.

Sent from my SM-N950U using Tapatalk

Share this post


Link to post

Alright, not trying to beat a dead horse here...apologies in advance. 
 

Today I have been trying to upload a .mov file that is just a LITTLE larger than 2.5gb using the current Nextcloud iOS app. Every time it fails with a 413 error in Nextcloud app. 
 

I’ve searched through thread and edited the few different files, that are usually responsible for this issue, max upload size to 0 as been mentioned in thread 200x. Still no dice. 
 

In my Letsencrypt nextcloud.subdomain.conf would or could “proxy_max_temp_file_size 2048m” have anything to do with my issues? Not sure what else to do, as I said, I’ve changed max upload size everywhere else(mentioned in thread) to “0” on max size. Could it just be a defunct in most recent Nextcloud iOS client app ?

 

suggestions, thoughts, direction or help would be greatly appreciated. 
 

Thanks!!

 

DE6477AA-7916-4690-B432-A7FAA97F50D0.jpeg

Share this post


Link to post

Just adding my experience. Not a huge Nextcloud user and I've had trouble with every update. From past experience I decided to go 16->17->18.

 

16->17 via GUI. Borks several times but with some retries it finally finishes but all I get is Maintenance mode. go to the manual guide, disable it and I get the upgrade screen, again which borks but it's still using CPU so I give it time and once the CPU goes to 0 it lets me log in and I'm at 17

 

17->18 No GUI option so I do the manual route below.  Way more smooth (just use the click->console from the unRaid GUI). Upon restart it takes a long time to finish executing (7-10 min but it's not the fastest processor) but finally finishes and I'm at 18. 

 

Haven't tried any of the new Office stuff but everything seems to working fine so far. 

 

Share this post


Link to post
Alright, not trying to beat a dead horse here...apologies in advance. 
 
Today I have been trying to upload a .mov file that is just a LITTLE larger than 2.5gb using the current Nextcloud iOS app. Every time it fails with a 413 error in Nextcloud app. 
 
I’ve searched through thread and edited the few different files, that are usually responsible for this issue, max upload size to 0 as been mentioned in thread 200x. Still no dice. 
 
In my Letsencrypt nextcloud.subdomain.conf would or could “proxy_max_temp_file_size 2048m” have anything to do with my issues? Not sure what else to do, as I said, I’ve changed max upload size everywhere else(mentioned in thread) to “0” on max size. Could it just be a defunct in most recent Nextcloud iOS client app ?
 
suggestions, thoughts, direction or help would be greatly appreciated. 
 
Thanks!!
 
DE6477AA-7916-4690-B432-A7FAA97F50D0.thumb.jpeg.c591df02c668073a6aa1d2e8a43d4de5.jpeg


Solved my problem, sometimes I’m a real... errrm “genius.”

Forgot I was proxying through Cloudflare... DNS only and such issue evidently doesn’t exist. I’ll flip proxy back on later. Facepalm.

So, for anyone in future... If your uploading large files and using Cloudflare as your CDN you *may* have to turn the CF Proxy off/on to accommodate occasional large file uploads. :-)

Share this post


Link to post
8 hours ago, saarg said:

Good you got it running.

So it made the backup and deleted the files and then failed unpacking it.

I'm not sure why the web update fails for some. Do you reverse proxy using subfolder?

I'm using a subdomain like "subdomain_name.duckdns.org". I originally attempted to update by connecting remotely via a VPN connection to my server and applying the update through the webui. Not sure if that contributed to the 504s. I'll keep a closer eye on the update process and report back if I have any useful information for troubleshooting/debugging.

Share this post


Link to post
16 minutes ago, Bob1215 said:

I'm using a subdomain like "subdomain_name.duckdns.org". I originally attempted to update by connecting remotely via a VPN connection to my server and applying the update through the webui. Not sure if that contributed to the 504s. I'll keep a closer eye on the update process and report back if I have any useful information for troubleshooting/debugging.

It might have been the VPN that triggered the issue then. One of our team members have never been able to update using the webui, while everyone else manages. One theory was that he is using subfolder, while the others use subdomain. So I was just trying to see if there was any difference between subfolder and subdomain.

Share this post


Link to post

I’m far from helpful but FWIW the 3 times I’ve tried GUI updates it’s resulted in failure every single time. Subdomain reverse proxy.

Share this post


Link to post

just may as note, also updated to 18 (always updated through web and always went fine), reverse proxy lsio letsencrypt subdomain config.

 

about the office update inside, also can say its not working here yet ... adding onlyoffice and comunity doc server also resulting in

 

Quote

 

Community document server is not supported for this instance, please setup and configure an external document server

when opening a office file ...

Edited by alturismo

Share this post


Link to post
20 hours ago, blaine07 said:
 

Solved my problem, sometimes I’m a real... errrm “genius.”

 

Forgot I was proxying through Cloudflare... DNS only and such issue evidently doesn’t exist. I’ll flip proxy back on later. Facepalm.

 

So, for anyone in future... If your uploading large files and using Cloudflare as your CDN you *may* have to turn the CF Proxy off/on to accommodate occasional large file uploads. 🙂

 

So I fixed PART of this problem.. still need a little help though. Thought I fixed it 100% as I DID got rid of the 413 error(turning off temporarily the Cloudflare Proxy)...

 

Basically, now, when I upload the 2.5gb file mentioned above the WHOLE file uploads in the iOS Nextcloud app, it sits on screen saying 2.54gb of 2.54 uploaded. Just sits, never says finished. If I look at my Unraid Server.. it fills the NORMALLY 50% docker.img to over 80%(and sends me a panicked email). Almost hangs Unraid server up; everything comes to a crawl. Wouldn’t mind the blip if file would finish but then it just starts uploading all over again without deleting its previous attempt. In essence never finishing though.

 

Been trying to read and figure it out, but afraid to meddle in too much. I suspect it’s a cache/tmp directory problem but I just don’t quite know enough to figure it out.

 

https://docs.nextcloud.com/server/stable/admin_manual/configuration_files/big_file_upload_configuration.html

 

Tried looking where this referenced but with NC on Unraid the file structure must just be different enough that I cant figure out where those specific files are I guess rendering it not a possible solution.

 

Any help would be greatly appreciated. If a Diagnostics upload would be helpful please let me know. With having to restart Nextcloud when this happens not sure what log files would be useful, sorry for the ignorance on my part.

 

Edit: still also not sure if the Proxy Max Temp File Size thing I mention in post above is perhaps a relative culprit

 

e5d93b506e0aa5fd0790e084b9e7ab68.png

 

Edit2: if useful. 

 

Run Command: root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name='nextcloud' --net='proxynet' -e TZ="America/Chicago" -e HOST_OS="Unraid" -e 'PUID'='99' -e 'PGID'='100' -p '444:443/tcp' -v '/mnt/user/nextcloud/':'/data':'rw' -v '/mnt/user/appdata/nextcloud':'/config':'rw' 'linuxserver/nextcloud' 

Edited by blaine07

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.