Jump to content
linuxserver.io

[Support] Linuxserver.io - Nextcloud

3149 posts in this topic Last Reply

Recommended Posts

16 hours ago, Vesko said:

I install yesterday Onlyoffice docker and connect to Nextcloud 18 thru Let'sencrypt reverse proxy.Everything works ok even the Onlyoffice open in the Android Nextcloud app.

Android app Onlyoffice works also.

Finding more problems with my install now... cant get it working with my nextcloud android app. works 100% with the webgui. but with the android app it starts to open the onlyoffice editor but hangs on the loading screen. running it though NPM... not sure if i need some custom command NPM to get it working.  

Share this post


Link to post
6 hours ago, tazire said:

Finding more problems with my install now... cant get it working with my nextcloud android app. works 100% with the webgui. but with the android app it starts to open the onlyoffice editor but hangs on the loading screen. running it though NPM... not sure if i need some custom command NPM to get it working.  

Try from 4G and wifi is is the same?

Can you access your Nextcloud from WAN test with 4G.

I setup myne with Duckdns.org same as Spaceinvader video in youtube .

Did you put the onlyoffice.subdomain.conf. in Let'sencrypt ,Appdata folder.

Did you put Onlyoffice container on Proxynet network?

Edited by Vesko

Share this post


Link to post

Hey guys,

 

loving this nextcloud docker.

Have it working with MariaDB and LetsEncrypt Reverse Proxy.

 

But I have two problems with it.

When I logout of e.g. the admin account to log in with my user account it doesn't redirect me to the login page.

I press logout and nothing happens. If I press F5 it redirects me, but not automatically.

But this is only a minor problem and nothing to serious.

 

Next I am apperantly in an update loop.

I update, check for updates and there is another one ready.

The docker says there is an update but only this happens:

image.png.f5f9fb96ae6f9d122880c8d7b525dc4a.png

 

Sometimes it does a real update and downloads some files, one of it is ~150mb in size.

But I am still on 17.0.2.

Is there no update for v18 in this docker yet?

 

Thanks in advance guys ;)

 

Share this post


Link to post

@arough Nextcloud isn't updated by the docker itself, you have to use the WebUI updater or commandline to update NC.

Share this post


Link to post

I've tried reading through this thread before asking but i cannot seem to find any help. I have previously setup the nextcloud docker and mariadb as per spaceinvaderones video guides but my performance for nextcloud is very slow to the point of timing out. Im hoping my specs are in my signature but i do know my machine is more than capable of running this container i'm just wondering if there is anything else i can install/configure to increase the performance of this container? I really want to use this container but installing it as "default" is basically unusable.

Share this post


Link to post
On 1/24/2020 at 5:15 PM, Iceman24 said:

Is this the redirect line and how it would look if I commented it?

 


/**'overwrite.cli.url' => 'https://nextcloud.server.com', *\/

 

Yes that is it and also I think there is one more called overwritehost

You close a comment section with */ I don't think it works with that \ in there.

Edited by andreidelait

Share this post


Link to post

Wondering if someone can help. I just setup a new clean install of MariaDB and NextCloud with LetsEncrypt.

 

I've got this in the Settings -> Overview tab, I tried to look and ran out of pages to search.

I did manage to find out how to do the BigINT conversion which I did.

 

There are some warnings regarding your setup.

The reverse proxy header configuration is incorrect, or you are accessing Nextcloud from a trusted proxy. If not, this is a security issue and can allow an attacker to spoof their IP address as visible to the Nextcloud. Further information can be found in the documentation.

The "Strict-Transport-Security" HTTP header is not set to at least "15552000" seconds. For enhanced security, it is recommended to enable HSTS as described in the security tips ↗.

The database is missing some indexes. Due to the fact that adding indexes on big tables could take some time they were not added automatically. By running "occ db:add-missing-indices" those missing indexes could be added manually while the instance keeps running. Once the indexes are added queries to those tables are usually much faster.

Missing index "calendarobject_calid_index" in table "oc_calendarobjects_props".

Missing index "schedulobj_principuri_index" in table "oc_schedulingobjects".

 

Sorry to be a noob but can someone walk me through how to fix the above?

Share this post


Link to post
On 1/25/2020 at 5:51 PM, Vesko said:

Try from 4G and wifi is is the same?

Can you access your Nextcloud from WAN test with 4G.

I setup myne with Duckdns.org same as Spaceinvader video in youtube .

Did you put the onlyoffice.subdomain.conf. in Let'sencrypt ,Appdata folder.

Did you put Onlyoffice container on Proxynet network?

when using nextcloud webui everything works exactly as it should. onlyoffice opens files as normal. Its only an issue with the android app. Regardless of network i get the same issue when trying to edit a file. it will open the onlyoffice connector and then sit on the loading screen and never actually loads. 

Share this post


Link to post
@arough Nextcloud isn't updated by the docker itself, you have to use the WebUI updater or commandline to update NC.
I thought updating apps through their built-in updater was a no-no on Docker apps, that you're only supposed to update them via Docker. Is it different for Nextcloud?

Share this post


Link to post

@Iceman24 Nextcloud is the only exception I stumbled accross so far. If you wanna update NC, check under settings >>> overview which version and release chanel you're on. From there you can update NC. But like with other software you might have to recheck after a couple days of release of a new version, because they rolling out the updates in waves.

Share this post


Link to post
42 minutes ago, bastl said:

@Iceman24 Nextcloud is the only exception I stumbled accross so far. If you wanna update NC, check under settings >>> overview which version and release chanel you're on. From there you can update NC. But like with other software you might have to recheck after a couple days of release of a new version, because they rolling out the updates in waves.

Can confirm, Nextcloud is a special case for us. Main thing is to make sure your image is up to date then proceed with the webui update.

Share this post


Link to post
2 hours ago, SavellM said:

Wondering if someone can help. I just setup a new clean install of MariaDB and NextCloud with LetsEncrypt.

 

I've got this in the Settings -> Overview tab, I tried to look and ran out of pages to search.

I did manage to find out how to do the BigINT conversion which I did.

 

There are some warnings regarding your setup.

The reverse proxy header configuration is incorrect, or you are accessing Nextcloud from a trusted proxy. If not, this is a security issue and can allow an attacker to spoof their IP address as visible to the Nextcloud. Further information can be found in the documentation.

The "Strict-Transport-Security" HTTP header is not set to at least "15552000" seconds. For enhanced security, it is recommended to enable HSTS as described in the security tips ↗.

The database is missing some indexes. Due to the fact that adding indexes on big tables could take some time they were not added automatically. By running "occ db:add-missing-indices" those missing indexes could be added manually while the instance keeps running. Once the indexes are added queries to those tables are usually much faster.

Missing index "calendarobject_calid_index" in table "oc_calendarobjects_props".

Missing index "schedulobj_principuri_index" in table "oc_schedulingobjects".

 

Sorry to be a noob but can someone walk me through how to fix the above?

I had issues with the same was able to eventually figure it out. You need to console into the Nextcloud docker and run the below command, changing the end of it which perhaps you already did to get the BigINT conversion done. So "db:add-missing-indices" after the "occ" instead of what I have here. For the HSTS, add the line "add_header Strict-Transport-Security "max-age=15768000; includeSubDomains; preload;";" in the "default" file in the "\nextcloud\nginx\site-confs" folder. I put it above the line that has "SAMEORIGIN" in it, not all that far from the top of the file.

 

image.png.5e9fe7a285aa3e36790ac4efec348e7a.png

  • Like 2
  • Thanks 1

Share this post


Link to post

Hi,

 

new to unraid and nextcloud and I want to share a fix for a problem I had a couple of days ago.

I looked for a fix in the forums but only 2 people reported it and one of them moved to owncloud after giving up on it, I hope this will help other people who had the same issue.

After I setup nextcloud (followed SpaceinvaderOne's video) I had a problem each time I tried to upload a large file (11.2 GB).

After the upload, while processing, an error message showed up - "Error when assembling chunks, status code 504".

If I refresh the page the file is there and its ok (compared checksum to source). Tested it a couple of times and only one time the file didn't show up (can't really explain it). The message is pretty annoying so I had to look it up.

Found the following issue:

https://github.com/nextcloud/server/issues/17992

 

To fix I had to open the nginx config - appdata/nextcloud/nginx/site-confs/default

Searched for 'fastcgi' and inside the brackets I added these lines:

fastcgi_connect_timeout 60;

fastcgi_send_timeout 1800;

fastcgi_read_timeout 1800;

 

That fixed those error messages and I hope it will help you.

For more info you can check the issue on nextcloud's github.

 

Have a good day :)

Share this post


Link to post
5 hours ago, andreidelait said:

Yes that is it and also I think there is one more called overwritehost

You close a comment section with */ I don't think it works with that \ in there.

Thanks, that did work. Odd thing though is that when I did so, it removed the ovewritehost from the file entirely and moved the overwrite.cli.url all the way to the bottom, but kept it. So it seems the overwritehost was the only one needing commenting or removal, as it was removed upon reboot and the other one was kept, but moved to bottom of file.

Share this post


Link to post
1 hour ago, Iceman24 said:

I had issues with the same was able to eventually figure it out. You need to console into the Nextcloud docker and run the below command, changing the end of it which perhaps you already did to get the BigINT conversion done. So "db:add-missing-indices" after the "occ" instead of what I have here. For the HSTS, add the line "add_header Strict-Transport-Security "max-age=15768000; includeSubDomains; preload;";" in the "default" file in the "\nextcloud\nginx\site-confs" folder. I put it above the line that has "SAMEORIGIN" in it, not all that far from the top of the file.

 

image.png.5e9fe7a285aa3e36790ac4efec348e7a.png

When i try this i get error

 

sudo: /config/www/nextcloud/occ: command not found

 

i dont know what is wrong.

Screenshot from 2020-01-26 23-41-17.png

Screenshot from 2020-01-26 23-44-37.png

Edited by Vesko

Share this post


Link to post
1 minute ago, Vesko said:

When i try this i get error

 

sudo: /config/www/nextcloud/occ: command not found

 

i dont know what is wrong.

How exactly did you type it?

Share this post


Link to post
7 minutes ago, Vesko said:

When i try this i get error

 

sudo: /config/www/nextcloud/occ: command not found

 

i dont know what is wrong.

 

"php7" missing in the command.

 

sudo -u abc php7 /config/www/nextcloud/occ db:convert-filecache-bigint

Edited by Niklas

Share this post


Link to post
5 minutes ago, Niklas said:

 

"php7" missing in the command.

 

sudo -u abc php7 /config/www/nextcloud/occ.......

 

 

Great !!!

Thank you now works.

Screenshot from 2020-01-26 23-47-47.png

Share this post


Link to post
9 minutes ago, Iceman24 said:

How exactly did you type it?

Missing Php7 in the command.

Screenshot from 2020-01-26 23-41-17.png

Share this post


Link to post
8 minutes ago, Niklas said:

 

"php7" missing in the command.

 

sudo -u abc php7 /config/www/nextcloud/occ db:convert-filecache-bigint

Interesting. I never knew anyone included "php7" in the command and it worked for me without it.

Share this post


Link to post
20 minutes ago, Iceman24 said:

Interesting. I never knew anyone included "php7" in the command and it worked for me without it.

Today we learned something new .

Thanks to Niklas and Iceman24.

 

Now i have to fix only this:

The reverse proxy header configuration is incorrect, or you are accessing Nextcloud from a trusted proxy. If not, this is a security issue and can allow an attacker to spoof their IP address as visible to the Nextcloud. Further information can be found in the documentation.

 

The "Strict-Transport-Security" HTTP header is not set to at least "15552000" seconds. For enhanced security, it is recommended to enable HSTS as described in the security tips ↗

Edited by Vesko

Share this post


Link to post
Today we learned something new . Thanks to Iceman24.

 

Now i have to fix only this:

The reverse proxy header configuration is incorrect, or you are accessing Nextcloud from a trusted proxy. If not, this is a security issue and can allow an attacker to spoof their IP address as visible to the Nextcloud. Further information can be found in the documentation.

 

The "Strict-Transport-Security" HTTP header is not set to at least "15552000" seconds. For enhanced security, it is recommended to enable HSTS as described in the security tips

 

I'm not in a position to do anything other than say check my post about 10 back with how to fix this. Have to add line in "default" to file.  

 

 

Share this post


Link to post
Hi,
 
new to unraid and nextcloud and I want to share a fix for a problem I had a couple of days ago.
I looked for a fix in the forums but only 2 people reported it and one of them moved to owncloud after giving up on it, I hope this will help other people who had the same issue.
After I setup nextcloud (followed SpaceinvaderOne's video) I had a problem each time I tried to upload a large file (11.2 GB).
After the upload, while processing, an error message showed up - "Error when assembling chunks, status code 504".
If I refresh the page the file is there and its ok (compared checksum to source). Tested it a couple of times and only one time the file didn't show up (can't really explain it). The message is pretty annoying so I had to look it up.
Found the following issue:
https://github.com/nextcloud/server/issues/17992
 
To fix I had to open the nginx config - appdata/nextcloud/nginx/site-confs/default
Searched for 'fastcgi' and inside the brackets I added these lines:
fastcgi_connect_timeout 60;
fastcgi_send_timeout 1800;
fastcgi_read_timeout 1800;
 
That fixed those error messages and I hope it will help you.
For more info you can check the issue on nextcloud's github.
 
Have a good day

Have you tried making large uploads in the iOS Nextcloud app?

Share this post


Link to post
13 minutes ago, Iceman24 said:

I'm not in a position to do anything other than say check my post about 10 back with how to fix this. Have to add line in "default" to file.  

 

 

Yes !!!

Fixed .

Thank you very much Iceman24 .

Now only this stays but maybe is normal.

 

The reverse proxy header configuration is incorrect, or you are accessing Nextcloud from a trusted proxy. If not, this is a security issue and can allow an attacker to spoof their IP address as visible to the Nextcloud. Further information can be found in the documentation.

Share this post


Link to post
Yes !!!
Fixed .
Thank you very much Iceman24 .
Now only this stays but maybe is normal.
 
The reverse proxy header configuration is incorrect, or you are accessing Nextcloud from a trusted proxy. If not, this is a security issue and can allow an attacker to spoof their IP address as visible to the Nextcloud. Further information can be found in the documentation.
You're welcome. Make sure this area of your config.php looks like this.

'trusted_domains' =>
array (
0 => 'unRAIDIP:NextcloudPort',
1 => 'nextcloud.server.com',
),
'trusted_proxies' => array('unRAIDIP'),
'forwarded_for_headers' => array('HTTP_X_FORWARDED_FOR'),
'dbtype' => 'mysql',
'version' => '18.0.0.10',
'overwrite.cli.url' => 'https://nextcloud.server.com',
'overwritehost' => 'nextcloud.server.com',
'overwriteprotocol' => 'https',
  • Like 1
  • Thanks 2

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.