Jump to content
linuxserver.io

[Support] Linuxserver.io - Nextcloud

3915 posts in this topic Last Reply

Recommended Posts

15 minutes ago, saarg said:

You can access it via the IP, but you will be redirected to the domain when the page loads.

My question to this would be, would it then use the internet for viewing etc... or would it work over the local LAN. Right now it appears to be utilizing the internet and not the local LAN when accessing it from a local machine.

Share this post


Link to post
14 hours ago, live4soccer7 said:

I'm not sure what to say. I put everything back to the way it downloaded (unchanged) with the exception of commenting out the subfolder aspect in the default conf file within letsencrypt. At that point everything worked as expected and I have also set up to other dockers on subdomains without issues and without having to edit any files other than changing servername to match my subdomain.

i have the same problem with other dockers to access like "bitwarden" it works locally but not with letenrypt.

i am trying to find out what to comment out in "appdata\letsencrypt\nginx\site-confs" i don't see what you see could you share the config default. 

Share this post


Link to post

Also i forget to mention that when i use "bitwarden.mydomain.com"  it redirect me to my Nextcould why is that??

 

 

Share this post


Link to post
6 minutes ago, ssinseeme said:

i have the same problem with other dockers to access like "bitwarden" it works locally but not with letenrypt.

i am trying to find out what to comment out in "appdata\letsencrypt\nginx\site-confs" i don't see what you see could you share the config default. 

You don't have to uncomment anything in the default file to get it working.

Share this post


Link to post
3 minutes ago, ssinseeme said:

Also i forget to mention that when i use "bitwarden.mydomain.com"  it redirect me to my Nextcould why is that??

 

 

You have configured something wrong.

Share this post


Link to post
39 minutes ago, saarg said:

You have configured something wrong.

something wrong in Nextoud docker or the other docker "bitwaerden"

Share this post


Link to post
9 hours ago, ssinseeme said:

something wrong in Nextoud docker or the other docker "bitwaerden"

Letsencrypt I would say.

If you follow the readme in the proxy-confs folder and the info at the top of the proxy-conf file you use it's not hard to get it to work.

You have followed some guide you found on the internet and then copy/pasted it in the various config files?

Share this post


Link to post
3 hours ago, saarg said:

Letsencrypt I would say.

If you follow the readme in the proxy-confs folder and the info at the top of the proxy-conf file you use it's not hard to get it to work.

You have followed some guide you found on the internet and then copy/pasted it in the various config files?

Yes, I did follow Spaceinvador YT Video to set up Letencrypt and Nextcloud. He redirected port 443 to 1443 and port 80 to 180. i did the same but I see that you mentioned above that we should leave everything set us  as default. I tried that but because port 80 and 443 is been used then the installation failed. However I have my Nextcloud working but none of the other dockers work, all subdomain.mydomain redirect me to Nextcloud.

 

Share this post


Link to post
Posted (edited)

Hi people! Hope everyone is staying safe during the pandemic. 

 

I posted a problem in the nextcloud forum figured would be better if I post the question here as well, as it's annoying as hell.

 

Server replied "413 Request Entity Too Large" to "PUT xxxxfile"

The file is basically larger than 110Mbs 

 

They recommended to adjust client_max_body_size in the nginx.conf (Which I did) and the post_max_size and upload_max_filesize in php.ini (Which I don't know where is that)

 

I'm sure this happened to someone else in the forum. I'm using the latest nextcloud client. 

 

 

Edited by gacpac

Share this post


Link to post
2 hours ago, ssinseeme said:

Yes, I did follow Spaceinvador YT Video to set up Letencrypt and Nextcloud. He redirected port 443 to 1443 and port 80 to 180. i did the same but I see that you mentioned above that we should leave everything set us  as default. I tried that but because port 80 and 443 is been used then the installation failed. However I have my Nextcloud working but none of the other dockers work, all subdomain.mydomain redirect me to Nextcloud.

 

I'm talking about the settings in letsencrypt and not port forwarding.

 

I don't know how spaceinvader tells you to set it up, so you should go back and make sure you did it correctly.

Share this post


Link to post

Need some help correcting some errors, fresh install following Space Invader Video.

Untitled.thumb.png.04838c35b080fbc2b812a766374e2a0a.png

Share this post


Link to post

I followed his instructions able to get every error out except for the first one regarding "SAMEORIGIN".

Share this post


Link to post
5 minutes ago, deaerator said:

I followed his instructions able to get every error out except for the first one regarding "SAMEORIGIN".

Fresh install, so the appdata folder was never used before?

If that is the case, then you might need to update your reverse proxy conf. Delete the nextcloud sample and restart letsencrypt. That will restore the newest sample. Then edit the sample as instructed at the top of the file, save it and delete the old proxy conf file. Then remove the sample part from the filename and restart letsencrypt.

Share this post


Link to post

Did that and still getting the SAMEORIGINS error.

# make sure that your dns has a cname set for nextcloud
# assuming this container is called "letsencrypt", edit your nextcloud container's config
# located at /config/www/nextcloud/config/config.php and add the following lines before the ");":
#  'trusted_proxies' => ['letsencrypt'],
#  'overwrite.cli.url' => 'https://nextcloud.your-domain.com/',
#  'overwritehost' => 'nextcloud.your-domain.com',
#  'overwriteprotocol' => 'https',
#
# Also don't forget to add your domain name to the trusted domains array. It should look somewhat like this:
#  array (
#    0 => '192.168.0.1:444', # This line may look different on your setup, don't modify it.
#    1 => 'nextcloud.your-domain.com',
#  ),

server {
    listen 443 ssl;
    listen [::]:443 ssl;

    server_name nextcloud.*;

    include /config/nginx/ssl.conf;
	add_header X-Frame-Options "SAMEORIGIN" always;
	add_header Strict-Transport-Security "max-age=15768000; includeSubDomains; preload;";

    client_max_body_size 0;

    location / {
        include /config/nginx/proxy.conf;
        resolver 127.0.0.11 valid=30s;
        set $upstream_app nextcloud;
        set $upstream_port 443;
        set $upstream_proto https;
        proxy_pass $upstream_proto://$upstream_app:$upstream_port;

        proxy_max_temp_file_size 2048m;
    }
}

 

Share this post


Link to post
10 hours ago, deaerator said:

Did that and still getting the SAMEORIGINS error.


# make sure that your dns has a cname set for nextcloud
# assuming this container is called "letsencrypt", edit your nextcloud container's config
# located at /config/www/nextcloud/config/config.php and add the following lines before the ");":
#  'trusted_proxies' => ['letsencrypt'],
#  'overwrite.cli.url' => 'https://nextcloud.your-domain.com/',
#  'overwritehost' => 'nextcloud.your-domain.com',
#  'overwriteprotocol' => 'https',
#
# Also don't forget to add your domain name to the trusted domains array. It should look somewhat like this:
#  array (
#    0 => '192.168.0.1:444', # This line may look different on your setup, don't modify it.
#    1 => 'nextcloud.your-domain.com',
#  ),

server {
    listen 443 ssl;
    listen [::]:443 ssl;

    server_name nextcloud.*;

    include /config/nginx/ssl.conf;
	add_header X-Frame-Options "SAMEORIGIN" always;
	add_header Strict-Transport-Security "max-age=15768000; includeSubDomains; preload;";

    client_max_body_size 0;

    location / {
        include /config/nginx/proxy.conf;
        resolver 127.0.0.11 valid=30s;
        set $upstream_app nextcloud;
        set $upstream_port 443;
        set $upstream_proto https;
        proxy_pass $upstream_proto://$upstream_app:$upstream_port;

        proxy_max_temp_file_size 2048m;
    }
}

 

It might be the ssl.conf or the proxy.conf that needs updating. Check the date at the top with the one on GitHub. If they are different, delete them and restart the container.

Share this post


Link to post
22 minutes ago, saarg said:

It might be the ssl.conf or the proxy.conf that needs updating. Check the date at the top with the one on GitHub. If they are different, delete them and restart the container.

I deleted both and the error still appears. 

Share this post


Link to post
1 hour ago, deaerator said:

I deleted both and the error still appears. 

Delete this file appdata/nginx/site-confs/default in nextcloud appdata and restart the nextcloud container.

 

The solution was found as the first hit on google if you would have googled sameorigin nextcloud linuxserver.

Share this post


Link to post

Tried that also and is not working, still this stupid error shows up. 

I too googled a bunch of solutions that didn't work also and that's why I'm asking help here. 

Share this post


Link to post
Hi people! Hope everyone is staying safe during the pandemic. 
 
I posted a problem in the nextcloud forum figured would be better if I post the question here as well, as it's annoying as hell.
 
Server replied "413 Request Entity Too Large" to "PUT xxxxfile"
The file is basically larger than 110Mbs 
 
They recommended to adjust client_max_body_size in the nginx.conf (Which I did) and the post_max_size and upload_max_filesize in php.ini (Which I don't know where is that)
 
I'm sure this happened to someone else in the forum. I'm using the latest nextcloud client. 
 
 
Hello?

Sent from my Pixel 2 XL using Tapatalk

Share this post


Link to post
2 hours ago, deaerator said:

Tried that also and is not working, still this stupid error shows up. 

I too googled a bunch of solutions that didn't work also and that's why I'm asking help here. 

I just did a new installation of Nextcloud here and do not have that error message.

 

I can see from the proxy-conf you posted above that you have edited it. Do not do that. Do only what is mentioned in the top of that file.

How does your default file in nextcloud look like?

Share this post


Link to post

I'm sure this has been answered before but for the life of me I can't figure it out.  

 

Heres my PHP info from the admin screen:

Version: 7.3.17

Memory Limit: 2 GB

Max Execution Time: 3600

Upload max size: 3 GB

 

I was able to set memory limit and upload max size without issue, but that max execution time I can't find a way to change it.  I need that bumped up but I haven't been able to find any configuration file setting to make it stick.  Can anyone assist?  I'm running into issues because of it.

 

Share this post


Link to post

what happened to my Nextcloud? I have been running nextcloud for 3 weeks with no problems. Today suddenly on my phone i kept getting 

"Error the certificate for this server is invalid" . at home I tried to open the web UI from the docker and it was trying to acess my local IP nextclpoud instead of Https. any idea. I have not change anything to the settings.

Share this post


Link to post

I found a workaround for the 504 Error while setting up Nextcloud with MariaDB.

 

Maybee this will help you guys, as I saw you had the same problems as I did: 

@Curious_George @daveo132

 

Steps:

  1. Install Nextcloud without external DB (on SQLite)
  2. Migrate DB from SQLite to MariaDB

 

--------------------------------------------

 

Install Nextcloud and MariaDB as described in the tutorials

(Like: https://blog.linuxserver.io/2017/05/10/installing-nextcloud-on-unraid-with-letsencrypt-reverse-proxy/ or in the Spaceinvader One Video)

  • Setup MariaDB Docker
  • Create DB User, Database and grant rights
  • Setup Nextcloud Docker
  • Choose the SQLite selected as standard instead of the MariaDB you just initiated
  • Nextcloud should now work (even if the error comes up)

Now we have a functional Nextcloud on SQLite, thanks to the buildin occ tool we can now migrate to MariaDB.

 

Migrate DB to MariaDB

(See also Nextcloud Documentation: https://docs.nextcloud.com/server/18/admin_manual/configuration_database/db_conversion.html)

 

  • Open Unraid Terminal
  • Open Nextcloud Docker Terminal signing in as user "abc" (technical nextcloud user): 
    docker exec -it -u abc nextcloud sh

     

  • Navigate to Nextcloud directory: 
    cd /config/www/nextcloud/

     

  • Run OCC DB:Convert-Type Tool filling in the MariaDB (type mysql is correct in this case) credentials: (Schema: db:convert-type [--port PORT] <type> <username> <hostname> <database>)
    php occ db:convert-type --port="3306" mysql your_mariadb_user <Docker/Unraid IP> your_database_name

     

  • You will be prompted for the MariaDB User password, and the tool will migrate the DB.

  • Create missing indexes executing: 

    php occ db:add-missing-indices

     

  • Migrate some column types to bigint

    php occ db:convert-filecache-bigint

     

  • Check everything worked in the WebGui under Settings - > Administration -> Overview 

 

This should do the trick. ;)

 

I hope this also works for you!

 

Greetings

Findus

Share this post


Link to post
Posted (edited)

Hello,

 

I am trying to install Nextcloud for the first time.

I already installed MariaDB. So to setup Nextcloud I enter a user name and a password, then drop down the toggle menu to enter my MariaDB user and password, enter myip:thenextcloudport

Then I uncheck the "install recommended apps" and click enter and after about 15 seconds I get a 504 : Gateway Time-out error message. If I go back to the same URL, it takes me to the exact same setup page, as if I hadn't done anything.

 

The MariaDB user and password seem to be correct since I can log into MariaDB using

mysql -uusername -p

How do I get Nextcloud to take what I typed in into account?

 

Edit : I was doing it wrong. In the MariaDB toggle menu, in localhost, I was typing my server's localip : the port of the nextcloud container, but the right port was the one of the MariaDB container. I had to restart the container after I entered everything correctly and now I can log into the admin account.

Edited by CiaoCiao

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.