[Support] Linuxserver.io - Nextcloud


4997 posts in this topic Last Reply

Recommended Posts

1 hour ago, Tolete said:

Still no joy on nextcloud 21

waiting on update.

-anyone got the repository "linuxserver/nextcloud tag ?"

 

It doesn't help to use the tag as you have to update nextcloud inside the container.  Updating the container doesn't update nextcloud.

Link to post
  • Replies 5k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Application Name: Nextcloud Application Site: https://nextcloud.com/ Docker Hub: https://hub.docker.com/r/linuxserver/nextcloud/ Github: https://github.com/linuxserver/docker-nextcl

Here's my list of instructions....    Use them at your own risk.....   If upgrading to v12 please see here:   ##Turn on maintenance mode docker exec -it nextcloud occ m

Thanks, fixed for me as well, and I also added this line add_header Referrer-Policy no-referrer always; to appdata/nextcloud/nginx/site-confs/default   And now I have a green

Posted Images

42 minutes ago, saarg said:

It doesn't help to use the tag as you have to update nextcloud inside the container.  Updating the container doesn't update nextcloud.

 

I always thought you had to update containers from within unRAID. So how specifically do we update to Nextcloud 21? Thanks.

Link to post
Just now, adminmat said:

 

I always thought you had to update containers from within unRAID. So how specifically do we update to Nextcloud 21? Thanks.

Start by reading first post, then wait until it's available as nextcloud decide when you get.

Link to post
4 hours ago, skois said:

Could you please be more specific? What exactly to add?
Also I guess you mean to put "that" in the "/appdata/nextcloud/ngiong/site-confs/default"

Yea apologies - we just need to add the additional nginx bits to the site config file. Though if you've done it manually, all good 👍

Link to post
Yea apologies - we just need to add the additional nginx bits to the site config file. Though if you've done it manually, all good
Because I'm not any good with nginx, do you have the bits on hand? Or do you know if the docker will be updated soon to include them?
Thanks!

Sent from my Mi 10 Pro using Tapatalk

Link to post
4 hours ago, j0nnymoe said:

Yea apologies - we just need to add the additional nginx bits to the site config file. Though if you've done it manually, all good 👍

thank you, what are the correct parameters to add it manually?

Link to post
5 hours ago, Tolete said:

thank you, what are the correct parameters to add it manually?

 

I replaced these lines in the '/mnt/cache/appdata/nextcloud/nginx/site-confs/default' file. (Adjust path to your appdata path, if it's different)

 

location = /.well-known/carddav {
  return 301 $scheme://$host:$server_port/remote.php/dav;
}
location = /.well-known/caldav {
  return 301 $scheme://$host:$server_port/remote.php/dav;
}
location = /.well-known/webfinger {
  return 301 $scheme://$host:$server_port/public.php?service=webfinger;
}
location = /.well-known/host-meta {
  return 301 $scheme://$host:$server_port/public.php?service=host-meta;
}
location = /.well-known/host-meta.json {
  return 301 $scheme://$host:$server_port/public.php?service=host-meta-json;
}

with these lines

# Make a regex exception for `/.well-known` so that clients can still
# access it despite the existence of the regex rule
# `location ~ /(\.|autotest|...)` which would otherwise handle requests
# for `/.well-known`.
location ^~ /.well-known {
    # The following 6 rules are borrowed from `.htaccess`

    location = /.well-known/carddav     { return 301 /remote.php/dav/; }
    location = /.well-known/caldav      { return 301 /remote.php/dav/; }
    # Anything else is dynamically handled by Nextcloud
    location ^~ /.well-known            { return 301 /index.php$uri; }

    try_files $uri $uri/ =404;
}

Then I restarted the Nextcloud docker and the error was gone.

Link to post

I implemented the changes as outlined by "ICDeadPpl" (thank you) and it worked to remove the "carddav/caldav" errors, but the "/.well-known/webfinger" error is still present. 

I've tried adding

"location = /.well-known/webfinger   { return 301 /public.php?service=webfinger; }"

but that didn't work at all

Any ideas?

Link to post
2 hours ago, Dovy6 said:

Interestingly, the '21' version of the documentation doesn't mention 'webfinger' at all - https://docs.nextcloud.com/server/21/admin_manual/installation/nginx.html

You can watch the issues / pr on github about this

#Nextcloud Documentation
https://github.com/nextcloud/documentation/issues/6157 
https://github.com/nextcloud/documentation/pull/6221
#LSIO Docker 
https://github.com/linuxserver/docker-nextcloud/issues/185

https://github.com/linuxserver/docker-nextcloud/pull/186

Edited by skois
Link to post
On 2/23/2021 at 4:57 PM, j0nnymoe said:

Yea apologies - we just need to add the additional nginx bits to the site config file. Though if you've done it manually, all good 👍

Question, your last post mentioned "We plan to add this soon." -

Forgive me, but are we to take this to mean that you are one of the LS.io dev's, and that this change will come in an update/by-default sometime soon?

As if so, then i'm just gonna leave it be, and it can fix itself whenever that update rolls around.

Link to post
6 hours ago, boomam said:

Question, your last post mentioned "We plan to add this soon." -

Forgive me, but are we to take this to mean that you are one of the LS.io dev's, and that this change will come in an update/by-default sometime soon?

As if so, then i'm just gonna leave it be, and it can fix itself whenever that update rolls around.

Even if we update the default file, you will have to delete it and restart the container to get the updated one.

Link to post

Got some trouble while upgrade via web-gui.
Tried the updater.phar in docker instead. it says

[✔] Check for expected files
[✔] Check for write permissions
[✔] Create backup
[✔] Downloading
[✔] Verify integrity

[   ] Extracting ...PHP Warning:  require(/config/www/nextcloud/updater/../version.php): failed to open stream: No such file or directory in phar:///config/www/nextcloud/updater/updater.phar/lib/Updater.php on line 658
PHP Fatal error:  require(): Failed opening required '/config/www/nextcloud/updater/../version.php' (include_path='.:/usr/share/php7') in phar:///config/www/nextcloud/updater/updater.phar/lib/Updater.php on line 658
root@c3af26c4f37e:/data# cd /config/www/nextcloud/updater/

Im stuck.

Link to post
13 hours ago, saarg said:

Even if we update the default file, you will have to delete it and restart the container to get the updated one.

That's fine, its a small price to pay to ensure that the container/built files, are otherwise 'standard'.

I'll keep an eye out for the next update, and delete the file then.

Link to post

For those who don't know, they just pushed out an update with the new default config for nextcloud v21. You will need to delete your old default config and restart container.

Has fixed:

/.well-known/carddav

/.well-known/caldav

But still getting errors:

/.well-known/webfinger

/.well-known/nodeinfo

Link to post
18 minutes ago, Astroaero said:

For those who don't know, they just pushed out an update with the new default config for nextcloud v21. You will need to delete your old default config and restart container.

Has fixed:

/.well-known/carddav

/.well-known/caldav

But still getting errors:

/.well-known/webfinger

/.well-known/nodeinfo

Yup.

Confirmed myself too.

 

To help anyone, assuming standard paths - 

1. ssh to server/use web interface for shell (ssh user@IP)

rm /mnt/user/appdata/nextcloud/nginx/site-confs/default

 

Then restart the container.

Link to post

I updated via the GUI and now i get gateway 504 error. Anyone know how to fix...it was a 20.x version to a higher 20.x version. It seemed to fail during upgrade but let me continue when i refreshed it. Guessing that was a bad idea. 

Link to post

I want to use the PreviewGenerator addon to speed up the previews for the Smartphone applications.

 

The app comes with instructions which imply you're supposed to use the terminal:

 

https://github.com/rullzer/previewgenerator#how-to-use-the-app

"Run ./occ preview:generate-all once after installation."

"Add a (system) cron job for ./occ preview:pre-generate"

 

How am I supposed to do this? Entering the console from the Docker page and inputting those commands does not work.

Link to post

Thanks for the updated config files, worked perfectly for me.

 

Where am I supposed to add the default phone region though?

I've created a "phone.config.php" file in "/config" next to the other files, but I still get the error.

The content is:

<?php
$CONFIG = array (
  'default_phone_region' => 'DE',
);

 

What am I doing wrong?

 

Cheers

Stefan

Link to post
2 hours ago, blaine07 said:

Right now this link is dead. I'll check it later. 
here is the new issue i created. If you want you can do a comment there with your steps. and if you have the error still.
https://github.com/linuxserver/docker-nextcloud/issues/189

 

Edit* Check the issue for the solution.
TL?DR? Update docker, delete /config/nginx/site-confs/default, restart docker, Go to Settings > Overview, (for chrome) Press F12 and while having dev tools open right click refresh button and click emtpy cache and hard reload.

Edited by skois
  • Like 2
  • Thanks 1
Link to post
1 hour ago, skois said:

Right now this link is dead. I'll check it later. 
here is the new issue i created. If you want you can do a comment there with your steps. and if you have the error still.
https://github.com/linuxserver/docker-nextcloud/issues/189

 

Edit* Check the issue for the solution.
TL?DR? Update docker, delete /config/nginx/site-confs/default, restart docker, Go to Settings > Overview, (for chrome) Press F12 and while having dev tools open right click refresh button and click emtpy cache and hard reload.

Thanks skois!! Was looking over config files and all it took was a cache empty.

Link to post

i am getting the following error and am not able to use nextcloud anymore.  Here is the log file as well.

 

Internal Server Error

The server was unable to complete your request.

If this happens again, please send the technical details below to the server administrator.

More details can be found in the server log.

 

2021/02/21 08:06:04 [error] 407#407: *10720 recv() failed (104: Connection reset by peer) while reading response header from upstream, client: 172.18.0.2, server: _, request: "PROPFIND /remote.php/webdav/ HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: "nextcloud.mgranger.com"
2021/02/21 08:06:04 [error] 407#407: *10719 recv() failed (104: Connection reset by peer) while reading response header from upstream, client: 172.18.0.2, server: _, request: "GET /ocs/v2.php/core/navigation/apps?absolute=true&format=json HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: "nextcloud.mgranger.com"
2021/02/21 14:50:50 [error] 392#392: *12791 access forbidden by rule, client: 172.18.0.2, server: _, request: "GET /.git/HEAD HTTP/1.1", host: "nextcloud.mgranger.com"
2021/02/21 18:24:22 [error] 392#392: *19607 access forbidden by rule, client: 172.18.0.2, server: _, request: "GET /.git/HEAD HTTP/1.1", host: "nextcloud.mgranger.com"
2021/02/22 04:22:20 [error] 392#392: *38785 access forbidden by rule, client: 172.18.0.2, server: _, request: "GET /.git/HEAD HTTP/1.1", host: "nextcloud.mgranger.com"
2021/02/22 07:59:33 [error] 392#392: *45881 access forbidden by rule, client: 172.18.0.2, server: _, request: "GET /.git/HEAD HTTP/1.1", host: "nextcloud.mgranger.com"
2021/02/22 09:47:45 [error] 392#392: *50249 access forbidden by rule, client: 172.18.0.2, server: _, request: "GET /.git/HEAD HTTP/1.1", host: "nextcloud.mgranger.com"
2021/02/22 22:03:58 [error] 393#393: *10231 access forbidden by rule, client: 172.18.0.2, server: _, request: "GET /.git/HEAD HTTP/1.1", host: "nextcloud.mgranger.com"
2021/02/25 01:14:04 [error] 393#393: *129115 FastCGI sent in stderr: "Primary script unknown" while reading response header from upstream, client: 172.18.0.2, server: _, request: "GET /wp-login.php HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: "nextcloud.mgranger.com"
2021/02/25 01:14:06 [error] 393#393: *129118 FastCGI sent in stderr: "Primary script unknown" while reading response header from upstream, client: 172.18.0.2, server: _, request: "GET /wordpress/wp-login.php HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: "nextcloud.mgranger.com"
2021/02/25 01:14:07 [error] 393#393: *129121 FastCGI sent in stderr: "Primary script unknown" while reading response header from upstream, client: 172.18.0.2, server: _, request: "GET /blog/wp-login.php HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: "nextcloud.mgranger.com"
2021/02/25 01:14:09 [error] 393#393: *129124 FastCGI sent in stderr: "Primary script unknown" while reading response header from upstream, client: 172.18.0.2, server: _, request: "GET /wp/wp-login.php HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: "nextcloud.mgranger.com"
2021/02/26 07:22:54 [error] 393#393: *191405 FastCGI sent in stderr: "PHP message: PHP Fatal error:  Allowed memory size of 536870912 bytes exhausted (tried to allocate 36864 bytes) in /config/www/nextcloud/lib/private/legacy/OC_Image.php on line 498" while reading response header from upstream, client: 172.18.0.2, server: _, request: "GET /index.php/apps/files/api/v1/thumbnail/256/256/InstantUpload/Camera/2021/01/20210103_111032.jpg HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: "nextcloud.mgranger.com"
2021/02/26 07:22:55 [error] 393#393: *191411 FastCGI sent in stderr: "PHP message: PHP Fatal error:  Allowed memory size of 536870912 bytes exhausted (tried to allocate 36864 bytes) in /config/www/nextcloud/lib/private/legacy/OC_Image.php on line 498" while reading response header from upstream, client: 172.18.0.2, server: _, request: "GET /index.php/apps/files/api/v1/thumbnail/256/256/InstantUpload/Camera/2021/01/20210103_111038.jpg HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: "nextcloud.mgranger.com"
2021/02/26 07:22:57 [error] 393#393: *191415 FastCGI sent in stderr: "PHP message: PHP Fatal error:  Allowed memory size of 536870912 bytes exhausted (tried to allocate 36864 bytes) in /config/www/nextcloud/lib/private/legacy/OC_Image.php on line 498" while reading response header from upstream, client: 172.18.0.2, server: _, request: "GET /index.php/apps/files/api/v1/thumbnail/256/256/InstantUpload/Camera/2021/01/20210103_111044.jpg HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: "nextcloud.mgranger.com"
2021/02/26 07:22:59 [error] 393#393: *191421 FastCGI sent in stderr: "PHP message: PHP Fatal error:  Allowed memory size of 536870912 bytes exhausted (tried to allocate 36864 bytes) in /config/www/nextcloud/lib/private/legacy/OC_Image.php on line 498" while reading response header from upstream, client: 172.18.0.2, server: _, request: "GET /index.php/apps/files/api/v1/thumbnail/256/256/InstantUpload/Camera/2021/01/20210103_111619.jpg HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: "nextcloud.mgranger.com"
2021/02/26 07:23:02 [error] 393#393: *191425 FastCGI sent in stderr: "PHP message: PHP Fatal error:  Allowed memory size of 536870912 bytes exhausted (tried to allocate 36864 bytes) in /config/www/nextcloud/lib/private/legacy/OC_Image.php on line 498" while reading response header from upstream, client: 172.18.0.2, server: _, request: "GET /index.php/apps/files/api/v1/thumbnail/256/256/InstantUpload/Camera/2021/01/20210103_112101.jpg HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: "nextcloud.mgranger.com"
2021/02/26 07:23:04 [error] 393#393: *191431 FastCGI sent in stderr: "PHP message: PHP Fatal error:  Allowed memory size of 536870912 bytes exhausted (tried to allocate 36864 bytes) in /config/www/nextcloud/lib/private/legacy/OC_Image.php on line 498" while reading response header from upstream, client: 172.18.0.2, server: _, request: "GET /index.php/apps/files/api/v1/thumbnail/256/256/InstantUpload/Camera/2021/01/20210103_112203.jpg HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: "nextcloud.mgranger.com"
2021/02/26 07:23:06 [error] 393#393: *191439 FastCGI sent in stderr: "PHP message: PHP Fatal error:  Allowed memory size of 536870912 bytes exhausted (tried to allocate 36864 bytes) in /config/www/nextcloud/lib/private/legacy/OC_Image.php on line 498" while reading response header from upstream, client: 172.18.0.2, server: _, request: "GET /index.php/apps/files/api/v1/thumbnail/256/256/InstantUpload/Camera/2021/01/20210103_112209.jpg HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: "nextcloud.mgranger.com"
2021/02/26 07:23:08 [error] 393#393: *191441 FastCGI sent in stderr: "PHP message: PHP Fatal error:  Allowed memory size of 536870912 bytes exhausted (tried to allocate 36864 bytes) in /config/www/nextcloud/lib/private/legacy/OC_Image.php on line 498" while reading response header from upstream, client: 172.18.0.2, server: _, request: "GET /index.php/apps/files/api/v1/thumbnail/256/256/InstantUpload/Camera/2021/01/20210104_204440.jpg HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: "nextcloud.mgranger.com"
2021/02/26 07:23:10 [error] 393#393: *191449 FastCGI sent in stderr: "PHP message: PHP Fatal error:  Allowed memory size of 536870912 bytes exhausted (tried to allocate 36864 bytes) in /config/www/nextcloud/lib/private/legacy/OC_Image.php on line 498" while reading response header from upstream, client: 172.18.0.2, server: _, request: "GET /index.php/apps/files/api/v1/thumbnail/256/256/InstantUpload/Camera/2021/01/20210104_204444.jpg HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: "nextcloud.mgranger.com"
2021/02/26 07:23:12 [error] 393#393: *191453 FastCGI sent in stderr: "PHP message: PHP Fatal error:  Allowed memory size of 536870912 bytes exhausted (tried to allocate 36864 bytes) in /config/www/nextcloud/lib/private/legacy/OC_Image.php on line 498" while reading response header from upstream, client: 172.18.0.2, server: _, request: "GET /index.php/apps/files/api/v1/thumbnail/256/256/InstantUpload/Camera/2021/01/20210108_173936.jpg HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: "nextcloud.mgranger.com"
2021/02/26 07:23:33 [error] 393#393: *191487 FastCGI sent in stderr: "PHP message: PHP Fatal error:  Allowed memory size of 536870912 bytes exhausted (tried to allocate 36864 bytes) in /config/www/nextcloud/lib/private/legacy/OC_Image.php on line 498" while reading response header from upstream, client: 172.18.0.2, server: _, request: "GET /index.php/apps/files/api/v1/thumbnail/256/256/InstantUpload/Camera/2021/01/20210108_173941.jpg HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: "nextcloud.mgranger.com"
2021/02/26 07:23:35 [error] 393#393: *191489 FastCGI sent in stderr: "PHP message: PHP Fatal error:  Allowed memory size of 536870912 bytes exhausted (tried to allocate 49152 bytes) in /config/www/nextcloud/lib/private/legacy/OC_Image.php on line 498" while reading response header from upstream, client: 172.18.0.2, server: _, request: "GET /index.php/apps/files/api/v1/thumbnail/256/256/InstantUpload/Camera/2021/01/20210108_205709.jpg HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: "nextcloud.mgranger.com"
2021/02/26 07:23:37 [error] 393#393: *191493 FastCGI sent in stderr: "PHP message: PHP Fatal error:  Allowed memory size of 536870912 bytes exhausted (tried to allocate 49152 bytes) in /config/www/nextcloud/lib/private/legacy/OC_Image.php on line 498" while reading response header from upstream, client: 172.18.0.2, server: _, request: "GET /index.php/apps/files/api/v1/thumbnail/256/256/InstantUpload/Camera/2021/01/20210108_205713.jpg HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: "nextcloud.mgranger.com"
2021/02/26 07:23:39 [error] 393#393: *191495 FastCGI sent in stderr: "PHP message: PHP Fatal error:  Allowed memory size of 536870912 bytes exhausted (tried to allocate 49152 bytes) in /config/www/nextcloud/lib/private/legacy/OC_Image.php on line 498" while reading response header from upstream, client: 172.18.0.2, server: _, request: "GET /index.php/apps/files/api/v1/thumbnail/256/256/InstantUpload/Camera/2021/01/20210108_205715.jpg HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: "nextcloud.mgranger.com"
2021/02/26 09:01:12 [error] 392#392: *5 connect() failed (111: Connection refused) while connecting to upstream, client: 192.168.1.192, server: _, request: "GET / HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: "192.168.1.190:448"
2021/02/26 09:01:12 [error] 392#392: *5 open() "/config/www/nextcloud/favicon.ico" failed (2: No such file or directory), client: 192.168.1.192, server: _, request: "GET /favicon.ico HTTP/1.1", host: "192.168.1.190:448", referrer: "https://192.168.1.190:448/"
2021/02/26 10:43:31 [error] 386#386: *1754 FastCGI sent in stderr: "Primary script unknown" while reading response header from upstream, client: 172.18.0.2, server: _, request: "GET /wp-login.php HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host:

 

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.