[Support] Linuxserver.io - Nextcloud


Recommended Posts

I've got my domain registered with my domain provider and then a CNAME record that points the nextcloud subdomain to a duckdns address, the duckdns address is currently updated with my current IP address.

 

Ports are forwarded correctly also, I was able to connect to nextcloud using my subdomain for a good amount of time, as was a friend of mine who I provide storage to, nothings changed on my router since then, but just to be sure:

 

image.png.246a08d3832808d62c047931458324a1.png

Link to comment
6 minutes ago, Myleslewis said:

I've got my domain registered with my domain provider and then a CNAME record that points the nextcloud subdomain to a duckdns address, the duckdns address is currently updated with my current IP address.

 

Ports are forwarded correctly also, I was able to connect to nextcloud using my subdomain for a good amount of time, as was a friend of mine who I provide storage to, nothings changed on my router since then, but just to be sure:

 

image.png.246a08d3832808d62c047931458324a1.png

can you ping your subdomain? ping nextcloud.***.net ?
If you can't probably something is off with the whole domain-duckdns thhing.
Check also on your registaar if the he currently have is correct.

Do you remeber what happened when it stopped working?


Just to make sure its the whole domain thing the problem.

Go to /mnt/user/appdata/nextcloud/www/nextcloud/config/config.php

Change 'overwrite.cli.url' to ->                   'overwrite.cli.url' => 'https://192.168.1.139:444', 

comment out using a # infront. the lines overwritehost and overwriteprotocol


Change network from proxynet to bridge
Restart docker and try to access it with local ip:port
 

Edited by skois
Link to comment
6 minutes ago, skois said:

can you ping your subdomain? ping nextcloud.***.net ?
If you can't probably something is off with the whole domain-duckdns thhing.
Check also on your registaar if the he currently have is correct.

Do you remeber what happened when it stopped working?


Just to make sure its the whole domain thing the problem.

Go to /mnt/user/appdata/nextcloud/www/nextcloud/config/config.php

Change 'overwrite.cli.url' to ->                   'overwrite.cli.url' => 'https://192.168.1.139:444', 

comment out using a # infront. the lines overwritehost and overwriteprotocol


Change network from proxynet to bridge
Restart docker and try to access it with local ip:port
 

I can ping nextcloud.***.net and get a response with my public ip, all okay here.

 

Not sure what you mean by "checking on my registrar if the he currently have is correct", sorry. The CNAME is still as it was previously, nothings changed there.

 

I completed the next steps and still cannot connect using localip:port :(

Link to comment
14 minutes ago, Myleslewis said:

I can ping nextcloud.***.net and get a response with my public ip, all okay here.

 

Not sure what you mean by "checking on my registrar if the he currently have is correct", sorry. The CNAME is still as it was previously, nothings changed there.

 

I completed the next steps and still cannot connect using localip:port :(

Sorry meant if registar have the correct ip***

 

Ah also change database to bridge network!

 

Hmmm :/ Please once again post the config.php file and the docker edit of nextcloud (this time click the advanced on top right corner)

Edited by skois
Link to comment
16 minutes ago, skois said:

Sorry meant if registar have the correct ip***

 

Hmmm :/ Please once again post the config.php file and the docker edit of nextcloud (this time click the advanced on top right corner)

Ah right, yeah it definitely gives the correct IP when pinging it.

 

Here is my docker template in advance view:

image.thumb.png.c7c371d003b9c85d9ef5136cd196245b.png

 

Here is my config.php:

 

<?php
$CONFIG = array (
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'datadirectory' => '/data',
  'instanceid' => '************',
  'passwordsalt' => '*****************************************',
  'secret' => '*************************************************',
  'trusted_domains' =>
  array (
    0 => '192.168.1.139:444',
    1 => 'nextcloud.*********.net',
  ),
  'dbtype' => 'mysql',
  'version' => '20.0.7.1',
  'overwrite.cli.url' => 'https://192.168.1.139:444',
#  'overwritehost' => 'nextcloud.********.net',
#  'overwriteprotocol' => 'https',
  'dbname' => 'nextcloud',
  'dbhost' => '192.168.1.139:3306',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'nextcloud',
  'dbpassword' => '*********',
  'installed' => true,
  'trusted_proxies' => ['swag'],
);

 

I did change the webui port to 444 as I noticed it was 443 in the advance mode, but still same issue, cant access via localip:port

Edited by Myleslewis
Link to comment
1 minute ago, Myleslewis said:

Ah right, yeah it definitely gives the correct IP when pinging it.

 

Here is my docker template in advance view:

image.thumb.png.c7c371d003b9c85d9ef5136cd196245b.png

 

Here is my config.php:

 

<?php
$CONFIG = array (
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'datadirectory' => '/data',
  'instanceid' => '************',
  'passwordsalt' => '*****************************************',
  'secret' => '*************************************************',
  'trusted_domains' =>
  array (
    0 => '192.168.1.139:444',
    1 => 'nextcloud.*********.net',
  ),
  'dbtype' => 'mysql',
  'version' => '20.0.7.1',
  'overwrite.cli.url' => 'https://192.168.1.139:444',
#  'overwritehost' => 'nextcloud.********.net',
#  'overwriteprotocol' => 'https',
  'dbname' => 'nextcloud',
  'dbhost' => '192.168.1.139:3306',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'nextcloud',
  'dbpassword' => '*********',
  'installed' => true,
  'trusted_proxies' => ['swag'],
);

Change database also to bridge from proxynet.

Check if it works.
If not, go to nextcloud docker and click console. do "ping 1.1.1.1 -c4" and "ping 192.168.1.139 -c4" change the local ip to your ip of your pc not your server.
To see if the docker can access internal network and external.

Link to comment
6 minutes ago, skois said:

Change database also to bridge from proxynet.

Check if it works.
If not, go to nextcloud docker and click console. do "ping 1.1.1.1 -c4" and "ping 192.168.1.139 -c4" change the local ip to your ip of your pc not your server.
To see if the docker can access internal network and external.

database is on bridge already when I originally changed nextcloud to bridge, and both pings were successful

 

Link to comment
Just now, Myleslewis said:

database is on bridge already when I originally changed nextcloud to bridge, and both pings were successful

 

If you still can't access nextcloud with 192.168.1.139:444 .
Then i really don't know whats going on there. Sorry

  • Thanks 1
Link to comment
4 minutes ago, skois said:

If you still can't access nextcloud with 192.168.1.139:444 .
Then i really don't know whats going on there. Sorry

I think at this point, all I can do is do a complete removal of nextcloud and reinstall it all from scratch.

 

I would like to say thank you so much for taking so much time in helping me troubleshoot what's happening and why I can't access my nextcloud.

 

You're a credit to the forum !

Link to comment
3 minutes ago, Myleslewis said:

I think at this point, all I can do is do a complete removal of nextcloud and reinstall it all from scratch.

 

I would like to say thank you so much for taking so much time in helping me troubleshoot what's happening and why I can't access my nextcloud.

 

You're a credit to the forum !

I hope you don't have any problems with your new installation! Instead of swag you can also check the nginxproxymanager which is a gui alternative. I like it better cause is easier for certificates and proxies!

Link to comment
1 minute ago, skois said:

I hope you don't have any problems with your new installation! Instead of swag you can also check the nginxproxymanager which is a gui alternative. I like it better cause is easier for certificates and proxies!

 

Thank you, I'm going to take a break from it for a couple of days and come back to it I think.

 

I did try installing nginxproxymanager and use that instead of swag to see if that would fix it but I couldn't get it working, though that's going to me purely user error. Will have another crack it at over the weekend perhaps :)

  • Like 1
Link to comment

First time installing NextCloud w/ Mariadb and phphmyadmin. 

 

I am able to install all the above and I configured passwords/users ok. However, I am getting ONE persistent error. If troubleshooting is extensive on this one, I can start from scratch and wipe out everything. This is a first time install.

 

Has anyone seen this error before and how to address it?

image.thumb.png.5f20187458e8271f4fe1f30bc0ae9d1a.png

Link to comment
1 hour ago, Huge Yeti said:

First time installing NextCloud w/ Mariadb and phphmyadmin. 

 

I am able to install all the above and I configured passwords/users ok. However, I am getting ONE persistent error. If troubleshooting is extensive on this one, I can start from scratch and wipe out everything. This is a first time install.

 

Has anyone seen this error before and how to address it?

image.thumb.png.5f20187458e8271f4fe1f30bc0ae9d1a.png

I see in nextcloud forum couple people with the same problem, but i see nextcloud have addressed it.
Try again from scratch following this video. If it doesn't work you could try in a couple of days again, maybe need some time for the patch to be included in the nextcloud image.

 

Link to comment
4 hours ago, skois said:

I see in nextcloud forum couple people with the same problem, but i see nextcloud have addressed it.
Try again from scratch following this video. If it doesn't work you could try in a couple of days again, maybe need some time for the patch to be included in the nextcloud image.

 

This worked perfect. Up and running and configuring. Thank you.

  • Like 1
Link to comment

 

7 hours ago, ToTesFeuer said:

Hello I have a big problem and can not get any further....

I have updated the apps on my Nextcloud and now my Nextcloud does not start anymore.

In the changelog it shows me as an error:

 

PHP Fatal error: require(): Failed opening required '/config/www/nextcloud/apps/mail/vendor/composer/../rubix/tensor/src/constants.php' (include_path='/config/www/nextcloud/apps/mail/vendor/pear-pear.horde.org/Horde_Crypt_Blowfish:/config/www/nextcloud/apps/mail/vendor/pear-pear.horde.org/Horde_Date:/config/www/nextcloud/apps/mail/vendor/pear-pear.horde.org/Horde_Exception:/config/www/nextcloud/apps/mail/vendor/pear-pear.horde.org/Horde_Idna:/config/www/nextcloud/apps/mail/vendor/pear-pear.horde.org/Horde_Imap_Client:/config/www/nextcloud/apps/mail/vendor/pear-pear.horde.org/Horde_ListHeaders:/config/www/nextcloud/apps/mail/vendor/pear-pear.horde.org/Horde_Mail:/config/www/nextcloud/apps/mail/vendor/pear-pear.horde.org/Horde_ManageSieve:/config/www/nextcloud/apps/mail/vendor/pear-pear.horde.org/Horde_Mime:/config/www/nextcloud/apps/mail/vendor/pear-pear.horde.org/Horde_Nls:/config/www/nextcloud/apps/mail/vendor/pear-pear.horde.org/Horde_Secret:/config/www/nextcloud/apps/mail/vendor/pear-pear.horde.org/Horde_Smtp:/config/www/n in /config/www/nextcloud/apps/mail/vendor/composer/autoload_real.php on line 73

 

 

 

Thanks for any help!

 

 

Where exactly do you get this error? This error shounldn't stop nextcloud from working.

 

Fill this template so we have more info what's happening. And someone here might hop in to help

On 3/23/2021 at 2:36 PM, skois said:

I created a template to fill when someone have a problem, so we get as much info as we can and also avoid multiple posts asking to post this and that.

If you have anything else in mind to add to template or change, please tell me.

Because this forum don't render markdown, here is the link of the template.

 

https://github.com/stavros-k/unraid_issue_templates/blob/55eea02eef3d80eb7d5a87f2bb6fbc4f6bda6940/Issue Template.md

Link to comment
55 minutes ago, skois said:

So you think someone will just open a screenshot with hundreds of lines in which CANT use search function. And is also cropped out and most of the info is not in the picture? 
Also nextcloud log also missing. (nextcloud.log).

 

 

I can't find the log file.

I don't feel like looking for it any more. I will delete Nextcloud. Far too many problems.

Thanks for your help anyway

Link to comment

Getting an error message on nextcloud instances using mysql docker about support for version 21 of nextcloud.  Does anyone know how to deal with this?  I presume a merge to Mariadb would be the answer but I don't know how to do that.  Any hints?  Better still, a procedure to take away the guesswork.

 

Link to comment
21 hours ago, ToTesFeuer said:

 

I can't find the log file.

I don't feel like looking for it any more. I will delete Nextcloud. Far too many problems.

Thanks for your help anyway

It appears the issue is with the mail app.  It is possible to log into a terminal and uninstall it.  Then you do a repair and it will probably start.  Once you get it started you can deal with the mail app.  The issue with the mail app will probably be in the database engine.  I'll offer to help if you want to persist with it.

Link to comment

I installed nextcloud a few weeks ago and all was going well. I then tried installing OnlyOffice which I believe is the culprit of the issue.

When starting the docker container I am now getting the following error: "It looks like you are trying to reinstall your Nextcloud. However the file CAN_INSTALL is missing from your config directory. Please create the file CAN_INSTALL in your config folder to continue."
I am not sure of exactly what I need to be doing to fix this. I could start all over again, but there is some data I would like to salvage if possible.

Link to comment
On 4/22/2019 at 10:01 PM, Maldar said:

I'm tryin to add an SMTP account and I keep getting an error I'm not sure what to do with:

 

A problem occurred while sending the email. Please revise your settings. (Error: Expected response code 250 but got code "501", with message "501 Syntactically invalid HELO argument(s)
 " Log data: ++ Starting Swift_SmtpTransport << 220 xxx.mail01.xxxxx.net ESMTP Exim 4.90_1 Mon, 22 Apr 2019 16:51:28 -0400
 >> EHLO _

 

I've verified the server and login information are correct.  I can't seem to find anything about this specific error.

 

I know this is quite an old post, but I've had this same error myself and I couldn't find a solution after a lot of Googling. I also couldn't see a response in this thread which helped. I have found a solution though, so in case anyone else ends up down a rabbit hole, here's what I've discovered. Keep in mind I'm not sure if I'm taking a hammer to crack a nut.

In `\nginx\site-confs\default` the server_name is set to '_' which gets passed through to swiftmailer, causing it to send '_' as part of the EHLO. Some SMTP servers will reject this as it's not a valid domain name.
 

You can edit 'server_name' to the name or host of your server (or anything really) and that will filter through to swiftmailer.

 

This seems to be a configuration specific to the LinuxServer.io image for nextcloud. What I don't understand is why this isn't causing more issues - are people just not using smtp, or are they using smtp servers that are more forgiving about hostnames? That's why I'm a little unsure of my "fix", I feel like I've missed something in the docs around configuration but I can't find mention of it anywhere.

Link to comment

I have an issue, not sure if this is common.

 

I was using the openoffice docker to edit my nextcloud documents within nextcloud.  It has not stopped, saying the docker 30day licenses has expired.

 

How to I resolve this issue please?  I stopped the docker and now i get this issues.

 

Is there a new method to setup only office or any other way to edit documents within nextcloud?

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.