[Support] Linuxserver.io - Nextcloud


Recommended Posts

Just now, skois said:

You must be logged in as dehein in this share, to be able to delete/edit files, are you logged in?

 

 

yes, dehein is my Windows username. I tried to rename a file in a differnet share

image.png.cdcdd77bd36ca14e3cf4d777c853c3fa.png

which worked

Link to comment
2 minutes ago, dehein2 said:

 

yes, dehein is my Windows username. I tried to rename a file in a differnet share

image.png.cdcdd77bd36ca14e3cf4d777c853c3fa.png

which worked

Do also an ls -l on /mnt/user, Check what is the owner of Public
If its still nobody:users, I can't understand what is the problem there.


You can try Tools > New Permissions and select public share to fix all perms.

 

Link to comment
2 minutes ago, skois said:

Do also an ls -l on /mnt/user, Check what is the owner of Public
If its still nobody:users, I can't understand what is the problem there.


You can try Tools > New Permissions and select public share to fix all perms.

 

drwxrwxrwx 1 nobody users   34 May 25 15:15 Public/

just as all other shares... ;(

Link to comment
Just now, dehein2 said:

drwxrwxrwx 1 nobody users   34 May 25 15:15 Public/

just as all other shares... ;(

Try the tools, and also try to logout of the share from your computer and re-log 
Maybe (windows ?) is fckng up?

Link to comment

I just tried a brand new install of the image, pointed it to my mariadb and a new database instance, pointed to a new folder so a pretty clean install. It's now giving me a 502 gateway timeout when i go to the webui and i can't restart my docker service. I'm pretty sure if i try to restart my server it'll just spin on trying to stop the docker service.

 

I was able to login and see nextcloud UI and go through it.  About an hour or so later I can't access it. I didn't install any apps and just wanted to see if a clean install would do the same thing. I wonder if my phone hitting it is causing it to time out. Either way, I'l try a different nextcloud docker image to see if I get the same issues.

Link to comment

HI,

 

now i've got another issue - i guess coincidental ;)

Nextcloud just stopped working. I saw it because the sync icon turned grey. IM also unable to reach the web interface. I restartet the container - but no luck. How can i find out what's going on? I dind't change anything really...

 

Link to comment
Just now, dehein2 said:

HI,

 

now i've got another issue - i guess coincidental ;)

Nextcloud just stopped working. I saw it because the sync icon turned grey. IM also unable to reach the web interface. I restartet the container - but no luck. How can i find out what's going on? I dind't change anything really...

 

somehow as I'm writing this it's working again - can i still check a log file?

Link to comment

does anyone have OnlyOffice Document Server running on 21.0.2?

 

OnlyOfficeDocumentServer...

https://documentserver.mydomain.com/healthcheck = true


Nextcloud...

Error when trying to connect (Server error: `GET https://documentserver.mydomain.com/healthcheck` resulted in a `503 Service Temporarily Unavailable` response:


please send help!

 

 

Link to comment
Posted (edited)

Hi all,

 

I setup nextcloud with letsencrypt ssl certificate (via Nginx Proxy Manager) and runnung on my own subdomain. It is working fine but I have some issues with web-gui.

I delete a file, it's loading and loading and loading only after I hit F5 then the file is gone. Same with creating files.

What could be the issue?

 

Thank you and Regards,

Luk

Edited by luk
Link to comment
Posted (edited)

Hey Everyone,

 

My Nextcloud is currently stuck in an update stating only "update in progress" and I can't get it out. I saw in a post someone just used the backup made by the updater to restore their Nextcloud to the previous version. Could someone tell/link me how to do that? I know the location up the backup just not how to use it.

 

Thanks,

 

Edit: NVM I figured it out

Edited by TrueImpulse
Link to comment

I'm having some trouble updating.  I previously was on version 17.0.2.  I wanted to update to the latest version since the Windows client informed me that server version 17 is no longer supported.  I updated the docker container to 21.0.2, and then intended to open the web client to perform the update.  However, I got the "This version of Nextcloud is not compatible with > PHP 7.3. You are currently running 7.4.19." message.  So, I opened the console for the container and tried running the CLI updater.  However, when I do this it tells me it will download version 17.0.10.  I went ahead and updated, thinking that I needed to be on the latest version of 17 to be presented with the next version.  However, after that process, it still presents me with version 17.0.10.

 

So, how can I go about getting the latest version?  Thanks for any help you can provide!

Link to comment
I'm having some trouble updating.  I previously was on version 17.0.2.  I wanted to update to the latest version since the Windows client informed me that server version 17 is no longer supported.  I updated the docker container to 21.0.2, and then intended to open the web client to perform the update.  However, I got the "This version of Nextcloud is not compatible with > PHP 7.3. You are currently running 7.4.19." message.  So, I opened the console for the container and tried running the CLI updater.  However, when I do this it tells me it will download version 17.0.10.  I went ahead and updated, thinking that I needed to be on the latest version of 17 to be presented with the next version.  However, after that process, it still presents me with version 17.0.10.
 
So, how can I go about getting the latest version?  Thanks for any help you can provide!
Tldr, you need to use an older docker tag,
For more info search this forum, it have been answered multiple times recently.

Sent from my Mi 10 Pro using Tapatalk

  • Like 1
Link to comment
14 hours ago, luk said:

Hi all,

 

I setup nextcloud with letsencrypt ssl certificate (via Nginx Proxy Manager) and runnung on my own subdomain. It is working fine but I have some issues with web-gui.

I delete a file, it's loading and loading and loading only after I hit F5 then the file is gone. Same with creating files.

What could be the issue?

 

Thank you and Regards,

Luk

anyone any idea here?

Link to comment

Hi,

 

I tried to use this container but I have an error when I try to get my browser to it :

 

Quote

Composer autoloader not found, unable to continue. Check the folder "3rdparty". Running "git submodule update --init" will initialize the git submodule that handles the subfolder "3rdparty".

 

To you have an idea of what happens ?

Link to comment
Posted (edited)

did an update to the latest version today and im not locked out of nextcloud both windowsapp (says offline) and webgui. I cannot reset the passwords through the gui either i get an error "could not send reset email please contact administrator"
I tried resetting the password and created a new user through occ. I got an email about an admin resetting my password but i cannot login on my admin account or the new account i created.
I run redis and mariadb im also usin nginxproxymanager
/config/www/nextcloud/config/config.php looks like this anonymized ofc
 

<?php
$CONFIG = array (
  'memcache.local' => '\\OC\\Memcache\\Redis',
  'datadirectory' => '/data',
  'instanceid' => 'occ0pyg1e73h',
  'passwordsalt' => 'pass',
  'secret' => 'secret',
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'redis' => 
  array (
    'host' => '192.168.10.38',
    'port' => 6379,
  ),
  'trusted_domains' => 
  array (
    0 => '192.168.10.38:444',
    1 => 'server',
  ),
  'dbtype' => 'mysql',
  'version' => '21.0.0.18',
  'overwrite.cli.url' => 'serverurl',
  'overwritehsot' => 'serverurl',
  'overwriteprotocol' => 'https',
  'dbname' => 'nextcloud',
  'dbhost' => '192.168.10.38',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'nextcloud',
  'dbpassword' => 'pass',
  'installed' => true,
  'mail_smtpmode' => 'smtp',
  'mail_sendmailmode' => 'pipe',
  'mail_from_address' => 'server',
  'mail_domain' => 'domain',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_smtpauth' => 1,
  'mail_smtphost' => 'send.one.com',
  'mail_smtpname' => 'server',
  'mail_smtppassword' => 'pass',
  'mail_smtpport' => '465',
  'mail_smtpsecure' => 'ssl',
  'filesystem_check_changes' => 1,
  'maintenance' => false,
);

 

The only error i can see is from /nginx/error.log and s over an hour old and hasnt repeated after a full server restart so i dont think its related

2021/05/31 14:15:25 [error] 394#394: *1452 access forbidden by rule, client: 192.168.10.1, server: _, request: "GET /.well-known/assetlinks.json HTTP/1.1", host: "nextcloud.jarvinen.se"
2021/05/31 14:23:00 [error] 402#402: *171 FastCGI sent in stderr: "PHP message: PHP Fatal error:  Uncaught Error: Class 'OCA\DAV\Connector\Sabre\ExceptionLoggerPlugin' not found in /config/www/nextcloud/remote.php:61
Stack trace:
#0 /config/www/nextcloud/remote.php(169): handleException()
#1 {main}
  thrown in /config/www/nextcloud/remote.php on line 61" while reading response header from upstream, client: 192.168.10.1, server: _, request: "PROPFIND /remote.php/dav/files/ovifla/ HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: "nextcloud.jarvinen.se"


any ideas on what i can do to fix this? Am i missing something?
 

EDIT:

 found some more errors which does not make much sense to me.

{"reqId":"GdMWKqNqERxV0OWVPYZ1","level":3,"time":"2021-05-31T13:10:03+00:00","remoteAddr":"","user":"--","app":"PHP","method":"","url":"--","message":{"Exception":"Error","Message":"Trying to access array offset on value of type null at /config/www/nextcloud/apps/dav/lib/CalDAV/BirthdayService.php#305","Code":0,"Trace":[{"file":"/config/www/nextcloud/apps/dav/lib/CalDAV/BirthdayService.php","line":305,"function":"onError","class":"OC\\Log\\ErrorHandler","type":"::"},{"file":"/config/www/nextcloud/apps/dav/lib/BackgroundJob/GenerateBirthdayCalendarBackgroundJob.php","line":71,"function":"resetForUser","class":"OCA\\DAV\\CalDAV\\BirthdayService","type":"->"},{"file":"/config/www/nextcloud/lib/private/BackgroundJob/Job.php","line":52,"function":"run","class":"OCA\\DAV\\BackgroundJob\\GenerateBirthdayCalendarBackgroundJob","type":"->"},{"file":"/config/www/nextcloud/lib/private/BackgroundJob/QueuedJob.php","line":46,"function":"execute","class":"OC\\BackgroundJob\\Job","type":"->"},{"file":"/config/www/nextcloud/cron.php","line":128,"function":"execute","class":"OC\\BackgroundJob\\QueuedJob","type":"->"}],"File":"/config/www/nextcloud/lib/private/Log/ErrorHandler.php","Line":92,"CustomMessage":"--"},"userAgent":"--","version":"21.0.0.18"}

 

Edited by Jamorro
Link to comment

My nextcloud instance completely stopped working recently. I tried using CA appdata backup to do a restore of two different dates and neither worked. I did it for both nextcloud and my mariadb docker. I then completely removed both dockers renamed the existing appdata and did a clean install of both. Still no joy. Neither container shows errors in the log but I still can't access the UI, all I get is site can't be reached.

Link to comment
On 6/3/2021 at 5:12 PM, shiftylilbastrd said:

My nextcloud instance completely stopped working recently. I tried using CA appdata backup to do a restore of two different dates and neither worked. I did it for both nextcloud and my mariadb docker. I then completely removed both dockers renamed the existing appdata and did a clean install of both. Still no joy. Neither container shows errors in the log but I still can't access the UI, all I get is site can't be reached.

 

Similar issues. I've been using this container for a while. Docker page says .....

 

Quote

25.02.21: - Nginx default site config updated for v21 (existing users should delete /config/nginx/site-confs/default and restart the container).

 

so I tried that. Seems better. Time will tell though. Maybe give it a shot?

 

https://hub.docker.com/r/linuxserver/nextcloud

Link to comment

I'm using Nextcloud v20 with Android  3.16.0 app.  Can anyone explain how sync works?  Is it one way sync? Two way?  Server to device or device to server?  Etc..

 

I created a test folder and setup auto upload.  New files are uploaded as expected.  If I delete files in the test folder on the server, they are not deleted from the device.  If I delete test files from the device, they are not deleted from the server.  If I manually exec a sync, the files receive a green checkmark in the app, but it's not obvious what that means and I see no evidence of a sync.

Link to comment
9 minutes ago, Gragorg said:

Has there been any headway to get the built in Only Office to work or is everyone using the Only Office docker in addition to nextcloud?

I'm using collabora, only office is faster, but missing some very basic features. like cell lock

Link to comment
On 6/6/2021 at 6:23 AM, dboonthego said:

I'm using Nextcloud v20 with Android  3.16.0 app.  Can anyone explain how sync works?  Is it one way sync? Two way?  Server to device or device to server?  Etc..

 

I created a test folder and setup auto upload.  New files are uploaded as expected.  If I delete files in the test folder on the server, they are not deleted from the device.  If I delete test files from the device, they are not deleted from the server.  If I manually exec a sync, the files receive a green checkmark in the app, but it's not obvious what that means and I see no evidence of a sync.

How did you configure auto upload, did you configure it to move the files to app folder? 
or leave them where they are.

In general, when you upload from your phone, files on your phone are not touched, (unless you configure it to do so).
Nextcloud app on android does not work like the desktop's one.
 

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.