[Support] Linuxserver.io - Nextcloud


Recommended Posts

On 3/30/2019 at 7:17 PM, Niklas said:

Yes. In several different containers. Check my earlier post about it and the one I use now. 

 

Edit: I got it from Docker hub. No container with unraid template available. 

Add container button
Name: ClamAV
Repository: mk0x/docker-clamav:alpine
Icon URL: http://www.clamav.net/assets/clamav-trademark.png
Extra Parameters: -p 3310:3310 --hostname=clamavsrv --restart=unless-stopped
Network Type: "Custom : Br0" (change to fit your network and environment)
Fixed IP address (optional): 192.168.1.24 (change to fit your network and environment)
Added extra path for logs, want easy access: Container Path: /var/log/clamav. Host path: /mnt/user/appdata/clamav/logs/

See screenshots in earlier post.

Edit 2: Added my template.

Edit 3: Switched to the smaller alpine based image.

 

 

my-ClamAV.xmlUnavailable

Hi! I saw your post and did it myself. In the Nextcloud configuration I get the error "The ClamAv module is not in daemon mode". After searching online I couldn't find a fitting solution. So I'm asking you... Do you still have this setup running? If so, do you know what I have to change? 

Best wishes.

Link to comment
On 11/30/2021 at 2:26 PM, dbs179 said:

I'm having an issue upgrading from 21.0.7 to 22.2.3.  I'm using the Web Updater and it gets all the way to the last step of turning Maintenance Mode off and starting the update process and then I get an "Internal Server Error".  I'm not quite sure where to go from here.  Any suggestions?  Upgrades up until now, including upgrading from 21.0.5 to 21.0.7 worked just fine.

For anyone having issues upgrading to 22.2.3 or higher that is using ReDis, the linked thread below helped me get everything sorted out and upgraded using the manual upgrade method. You will have a security and setup warning that files have not passed the integrity check until the issue is fixed, which is supposed to be corrected in 22.2.4

 

https://help.nextcloud.com/t/redis-cluster-error-without-having-a-cluster/121589/21

Link to comment

Hi guys,

 

Been having this error after updating some nextcloud settings with the recent video SIO released (Great followup video), all was working well till I clicked 'Update all apps', then NC was using a ton of CPU resources and I restarted the container, I kept getting a 'Internal Server Error' ever since and have scoured the forums for a solution, which mostly said changing the repo to another version like this which seemed to have helped many others. I even restoring my server through Backup/Restore Appdata but all did not work for me. Is there any way I could resolve this? Or should I re-install NC and MariaDB from a freshstart?

 

Have checked through Adminer that the db is still intact and the weird thing is, Nextcloud is still accessible through my phone and pc's file browser, but the web browser constantly shows this error. Has anyone ever experienced something like this and what can I do to solve this? Thank you! 

nc server error.PNG

Edited by jvlarc
Link to comment

Having an issue with upgrading following the instructions in post 1. It may have to do with the fact that I reinstalled Nextcloud, so there is an existing user & files. I restored from backup, but if seems unsuccessfully. When I run `docker exec -it nextcloud occ upgrade`, the step `Updating database schema` gives an error message

Doctrine\DBAL\Schema\SchemaException: The table with name `nextcloud.oc_authorized_groups` already exists. Update failed

 

I get the same message when I go to the WebUI

 

image.png.bc5790e64d3439c3b2f7b1386bad4c04.png

Link to comment

Hey Fellas, 

 

I am hoping someone can help me out here. I wanted to share some large files with my brother using my NextCloud. I figured that since these files were sitting in the same array I would just copy them over to my NextCloud folder. After I copied them over with Krusader I noticed that they are not appearing on my web client. I can see them in the NextCloud folder on the server side of things but on the client side I can't see so I can't share them. Do I have to do something special here to get these files to appear?

Link to comment
5 hours ago, SiRMarlon said:

Hey Fellas, 

 

I am hoping someone can help me out here. I wanted to share some large files with my brother using my NextCloud. I figured that since these files were sitting in the same array I would just copy them over to my NextCloud folder. After I copied them over with Krusader I noticed that they are not appearing on my web client. I can see them in the NextCloud folder on the server side of things but on the client side I can't see so I can't share them. Do I have to do something special here to get these files to appear?

In order to show up you will need to do the following command in the container console.

 

sudo -u abc php config/www/nextcloud/occ files:scan -all

or

sudo -u abc php config/www/nextcloud/occ files:scan <Username You Want To Scan> 

 

Make sure you take the brackets off and just place the username you want to scan so the items moved with Kruzader show up. Spaceinvander also did a video on this not to long ago if you want to follow a video.

Edited by Tucubanito07
Link to comment

Hi all, I am trying to install Nextcloud here and I am getting the following error when connecting to the mariaDB container:

 

SQLSTATE[HY000] [2002] Operation timed out

image.thumb.png.e46163f91c147e4574d27c7eebf5d3dc.png

 

The error occurs whether I want to use the root user or the nextcloud user. 

 

Here are my Docker configurations ...

Nextcloud:

image.thumb.png.22fd0033c40cbf26cc44a86d97a53738.png

 

mariaDB:

image.thumb.png.8c858bf9c71aaaa86beac13ea495ed83.png


It is important to me that I can reach nextcloud from a different IP address than the one from the server (server IP: 192.168.2.100 / nextcloud IP: 192.168.2.102 -> via br0)

 

Does anyone have an idea why the error occurs?

Link to comment
On 1/3/2022 at 11:29 AM, H2O_King89 said:


Is there anything more? Now when I try I get a time out error when it’s over a 1GB


Sent from my iPhone using Tapatalk Pro

I really don't have anything else. I do remember, but you probably have to search in the forum because it happened to me that one of the default files from swag had a limitation and after looking over at github the file was updated, so again my solution was to rename the file or move it somewhere else to have a new one downloaded with the error fix. 

Link to comment
3 hours ago, dxniel7402 said:

Hi all, I am trying to install Nextcloud here and I am getting the following error when connecting to the mariaDB container:

 

SQLSTATE[HY000] [2002] Operation timed out

image.thumb.png.e46163f91c147e4574d27c7eebf5d3dc.png

 

The error occurs whether I want to use the root user or the nextcloud user. 

 

Here are my Docker configurations ...

Nextcloud:

image.thumb.png.22fd0033c40cbf26cc44a86d97a53738.png

 

mariaDB:

image.thumb.png.8c858bf9c71aaaa86beac13ea495ed83.png


It is important to me that I can reach nextcloud from a different IP address than the one from the server (server IP: 192.168.2.100 / nextcloud IP: 192.168.2.102 -> via br0)

 

Does anyone have an idea why the error occurs?

 

when you mess with br0 it's part of unraid way of working. the best way to do that is having to nic cards one use it for management and the other one use it for the other networks. Someone can explain better than me, but long story short the docker won't be able to reach that 192.168.2.102. 

 

I suggest you look the tutorial from spaceinvaderone in youtube to get a better understanding of why you should use a docker network instead of br0

 

Link to comment
On 1/6/2022 at 4:44 PM, gacpac said:

 

when you mess with br0 it's part of unraid way of working. the best way to do that is having to nic cards one use it for management and the other one use it for the other networks. Someone can explain better than me, but long story short the docker won't be able to reach that 192.168.2.102. 

 

I suggest you look the tutorial from spaceinvaderone in youtube to get a better understanding of why you should use a docker network instead of br0

 

Hi @gacpac, 
thanks for your answer.

I had watched the video before, but it didn't quite solve my problem. I could now unfortunately not actually set the desired IP, but should not be further problematic.

I had found the following solution for me after trying several times:

Mariadb container I have now set to "host" and the nextcloud container to "bridged". Only then I could continue the installation. 

Link to comment
2 hours ago, dxniel7402 said:

Hi @gacpac, 
thanks for your answer.

I had watched the video before, but it didn't quite solve my problem. I could now unfortunately not actually set the desired IP, but should not be further problematic.

I had found the following solution for me after trying several times:

Mariadb container I have now set to "host" and the nextcloud container to "bridged". Only then I could continue the installation. 

Hi together,

I have here again a short update, because: I got it to work the way I want it to! :)

I have now been able to solve it by running both containers under "br0" each with their own IP addresses.

However, I had the problem that under br0 I could only reach Nextcloud within a VM, conversely if I set it to bridged, I could only reach it from a local PC or the like. (e.g. iPhone) and in a VM it did not work. 
Since I have two network interfaces, the solution was to add another route.

 

In Nextcloud during the installation I entered the IP of the mariadb container... well and now everything works as I wanted :)


I think I'm the only one with this problem... so if somehow questions arise I try to answer them ;)

Link to comment
24 minutes ago, dxniel7402 said:

Hi together,

I have here again a short update, because: I got it to work the way I want it to! :)

I have now been able to solve it by running both containers under "br0" each with their own IP addresses.

However, I had the problem that under br0 I could only reach Nextcloud within a VM, conversely if I set it to bridged, I could only reach it from a local PC or the like. (e.g. iPhone) and in a VM it did not work. 
Since I have two network interfaces, the solution was to add another route.

 

In Nextcloud during the installation I entered the IP of the mariadb container... well and now everything works as I wanted :)


I think I'm the only one with this problem... so if somehow questions arise I try to answer them ;)

I'm curious to know your use case, for using dedicated IP Adresses for both nextcloud and mariadb. I just remember there's a setting that might allow you to access host networks using br0 inside docker settings, but it's not perfect, i still rather have 2 physical nics and go from there. 

image.png.713ff208305a4c624336652cd5efcc23.png

Edited by gacpac
Link to comment

I have a problem too.

I got the 400 ssl error, so my question is as following:

 

How do I get a ssl-cert for my nextcould, so that I can access it via my domain name with CNAME forwarder (and use it with NginxProxyManager)?

 

I can get a ssl certificate via my NginxProxyManager, but how to access that nextcloud instance?
Because I forwarded everything properly but getting the common ssl error:

400 Bad Request

The plain HTTP request was sent to HTTPS port

 

Link to comment
4 minutes ago, rikdegraaff said:

I have a problem too.

I got the 400 ssl error, so my question is as following:

 

How do I get a ssl-cert for my nextcould, so that I can access it via my domain name with CNAME forwarder (and use it with NginxProxyManager)?

 

I can get a ssl certificate via my NginxProxyManager, but how to access that nextcloud instance?
Because I forwarded everything properly but getting the common ssl error:

400 Bad Request

The plain HTTP request was sent to HTTPS port

 

Activate this ins NginxProxyManager

image.png.a012b11a2f47bf1f95a45ca3573a91b2.png

Link to comment
2 hours ago, Vitor Ventura said:
Activate this ins NginxProxyManager
image.png.a012b11a2f47bf1f95a45ca3573a91b2.png

Thanks that was already activated. I needed to set the domain to https instead of http at the NginxProxyManager.

 

Sent from my POCO F1 using Tapatalk
 

Edited by rikdegraaff
Link to comment
59 minutes ago, Vitor Ventura said:
Have you edited the file?

Sent from my HD1913 using Tapatalk

 

Yea I encircled the option and blacked out some of the details. Why? Is there something wrong about the image?

Sent from my POCO F1 using Tapatalk

 

Edited by rikdegraaff
Link to comment
24 minutes ago, Vitor Ventura said:
No, no, no...

Have you edited file config.php?

minute 22.28

Sent from my HD1913 using Tapatalk
 

Sorry, my bad.
Yes I added a trusted domain to the config.php so that I can get in via the reverse proxy.
Can you tell me what is wrong with that?
I'm a little worried about it, right now...

Thanks in advance.

Sent from my POCO F1 using Tapatalk

 

EDIT: I am now following the video and will edit the files as necessary. 
EDIT2: I followed the video until 24:12 minute and cannot proceed, as I cannot find the proxy-confs folder in my NginxProxyManager appdata folder... I assume it is safe now, right @Vitor Ventura?

Edited by rikdegraaff
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.