[Support] Linuxserver.io - Nextcloud


4930 posts in this topic Last Reply

Recommended Posts

2 hours ago, CHBMB said:

I've been updating using the instructions I posted and recently by using the webui, both successfully.

 

I tried to update yesterday and it got to the point of deleting the old version and stopped while leaving me just the web page of 'system updating' webpage.

 

Left it for a good while with no progress.

 

Had to pick up the manual copy of the config and download the new version to recover the situation.

 

Running 11.0.2 fine now.

Link to post
  • Replies 4.9k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Application Name: Nextcloud Application Site: https://nextcloud.com/ Docker Hub: https://hub.docker.com/r/linuxserver/nextcloud/ Github: https://github.com/linuxserver/docker-nextcl

Here's my list of instructions....    Use them at your own risk.....   If upgrading to v12 please see here:   ##Turn on maintenance mode docker exec -it nextcloud occ m

I replaced these lines in the '/mnt/cache/appdata/nextcloud/nginx/site-confs/default' file. (Adjust path to your appdata path, if it's different)   location = /.well-known/carddav { return

Posted Images

13 minutes ago, dome said:

I just updated to the latest version in the unraid docker tab and am since then unable to connect to nextcloud.

The desktop application told me there was an unknown error. I tried to access the webui, which showed only a blank page.

I then reinstalled the docker to a new appdata folder, now the webui works but says "internal server error".

Is there a way to downgrade to the previous version or fix this error?

 

just fixt it by rolling back latest tag to the previous version, a reupdate should fix it.

Link to post

Hi All,

I followed Aptalca's Nginx-Letsencrypt to Reverse Proxy LSIO's Nextcloud - guide for my setup. Now I'm not able to upload files via a web browser. I get the error

Error uploading file "xxx.yyy": Not enough free space, you are uploading 8.5 MB but only 0 B is left

It doesn't matter which size the file has, it fails. Uploads via WEBDAV are working fine. In addition I'm not able to set any quotas for my users. I did the setup alreaydy a couple of times following the guide by the letter. There are no entries in the log

Edit: I can upload files again locally if I

  • disable Letsencrypt

  • set root /config/www/; back to root /config/www/nextcloud/; in nextcloud/config/nginx/site-confs/defaults

  • outcomment the overwritexxx parameter in the config.php

So I assume there might be an issue with the proxy

Edited by thalex
Link to post
On 2/28/2017 at 7:34 AM, sparklyballs said:

just fixt it by rolling back latest tag to the previous version, a reupdate should fix it.

I would like to update but am afraid of breaking the delicate installation. Could you please elaborate on what you meant by your statement?

Link to post
8 minutes ago, levster said:

I would like to update but am afraid of breaking the delicate installation. Could you please elaborate on what you meant by your statement?

 

it was a one time fix because our upstream images had been rebased to alpine 3.5 and php7

 

this image is currently using an older version and there was a clash of dependencies which caused containers to not work properly.

so I manually pulled the last known working version, tagged it latest and pushed it back to the hub.

Link to post
2 minutes ago, sparklyballs said:

 

it was a one time fix because our upstream images had been rebased to alpine 3.5 and php7

 

this image is currently using an older version and there was a clash of dependencies which caused containers to not work properly.

so I manually pulled the last known working version, tagged it latest and pushed it back to the hub.

So, just to be clear, can I update from the Nextcloud app itself, or do I reinstall from the apps page?

Link to post
On 14.2.2017 at 9:32 AM, EdgarWallace said:

I saw that my disk3 isn't spinning down. This is what the File Activity is showing:

 


Disk 3 2017-02-14 09:15 => /mnt/disk3/Cloud_Data/nextcloud.log
 

 

 

Is the nextcloud log preventing disk3 from spinning down?

 

Is there any way to avoid that nextcloud.log is accessing one of the disks but rather writing to the cache drive? Appdata would be great.

Link to post
3 hours ago, EdgarWallace said:

 

Is there any way to avoid that nextcloud.log is accessing one of the disks but rather writing to the cache drive? Appdata would be great.

 

A quick search of the Nextcloud Admin manual.....

 

Add this line to your config.php

 

  'logfile' => '/config/nextcloud.log',

Save and restart docker container.

Link to post
1 minute ago, EdgarWallace said:

 

Oh, that easy .... Thank you very much .

 

Yeah, Nextcloud has great documentation for admin of a server.  Worth referring to for any issues, always found it accurate and succinct.

Link to post
1 hour ago, sparklyballs said:

Image has now been moved from our lsiodev repository and into our main linuxserver repo.

 

Please update your unraid template accordingly.

 

Not finding it.... getting a 404 error.

 

EDIT: found it by putting linuxserver/nextcloud in my template...... the link to the web is what gives the 404. 

Edited by ridewithjoe
Link to post
1 hour ago, sparklyballs said:

Image has now been moved from our lsiodev repository and into our main linuxserver repo.

 

Please update your unraid template accordingly.

 

3 minutes ago, peter_sm said:

I got this error when trying to update

 


Pulling image: lsiodev/nextcloud:latest

TOTAL DATA PULLED: 0 B

Error: Error: image lsiodev/nextcloud:latest not found

 

 

Link to post
11 minutes ago, ridewithjoe said:

 

Not finding it.... getting a 404 error.

 

EDIT: found it by putting linuxserver/nextcloud in my template...... the link to the web is what gives the 404. 

 

Fixed the link.  We have a no-blame culture in linuxserver.io, but it was @sparklyballs that screwed up.... :P

Link to post
2 hours ago, local.bin said:

Same here :) what about your ssl rating? They're not bullet proof of course, these tests, but help to get things setup right.

 

I run a tight ship. All different sites have given me perfect marks. But you're right, nothing is bullet proof.

Link to post
got a A+ but were not on the latest patch level. is that something we have to wait for Linux|Server to update or can it be done thru the application. 


Check the first page. Couple of ways to update...
Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.