Jump to content
linuxserver.io

[Support] Linuxserver.io - Nextcloud

2700 posts in this topic Last Reply

Recommended Posts

10 minutes ago, CHBMB said:

Ok, well if it's not smb permissions then try ssh in to your box then cd /mnt/user/files/$USERNAME/files

Then touch newfile

I'm guessing as the permissions are ok then a new file should be created.

Which proves it's possible to write locally.

FWIW I've tested mine via smb and it's working.

Which would help narrow the problem

Sent from my LG-H815 using Tapatalk
 

Yeah, I can write locally in /mnt/user/files/$USERNAME/files

 

Like I said, I can write everywhere in that smb share except in the nextcloud folder... I am doing this through Windows (and I'm actually quite new to Windows, the last time I really used Windows was XP!!) Are there some smb permissions on the Windows side I can look at?

Share this post


Link to post

Yeah, I'm sure there are but I'm not the person to ask...

Not a windows user either...

Sent from my LG-H815 using Tapatalk

Share this post


Link to post

OK, so with that issue still outstanding I have a second issue...

 

How can I connect to my nextcloud install with webdav in Windows 10? The first time I tried it worked like a charm. But after a reboot, I get an error saying the network name cannot be found and can no longer connect using webdav.

Share this post


Link to post

I was finally able to get my domain to be visible from the outside world, but it takes almost 4 minutes to load the login page. Previously on my laptop, I had LetsEncrypt + Nextcloud + DuckDNS working much faster, but it looks like something (possibly with my default Nextcloud config in unRAID) is causing slowness.

 

Does anyone have any experience with slowness when using DuckDNS + Nextcloud + LetsEncrypt in unRAID?

slow_loading.PNG

Share this post


Link to post
On 7/24/2017 at 5:32 PM, huladaddy said:

OK, so with that issue still outstanding I have a second issue...

 

How can I connect to my nextcloud install with webdav in Windows 10? The first time I tried it worked like a charm. But after a reboot, I get an error saying the network name cannot be found and can no longer connect using webdav.

Here is the solution. Hope it helps others...

 

  • Go to the nextcloud appdata folder
  • Edit appdata/nextcloud/www/nextcloud/.htaccess
  • Add these lines to the end of the file:
RewriteCond %{HTTP_USER_AGENT} DavClnt
RewriteRule ^$ /remote.php/webdav/ [L,R=302]
  • Restart nextcloud

You will now be able to use Windows Explorer to connect to your nextcloud with webdav using "Map network drive" and the following folder:

 

https://nextcloud.yourdomain.com/remote.php/webdav

Edit: Ignore the above!

 

I did further testing. While the above did seem to help in some circumstances, I narrowed the problem down to the WebClient service not automatically starting on my machine. The fix was to go to services.msc and make sure WebClient Startup type was set to Automatic, not Manual.

 

Hope that helps!

Edited by huladaddy

Share this post


Link to post

Is there a safe way to move my data directory? I originally put it into an SMB share, which I thought would be useful, but now I am wanting to isolate my nextcloud data.

 

If there is not a safe way to do this, how can I reinstall nextcloud? Do I have to also reinstall mariadb? I would imagine letsencrypt should be unaffected by a reinstall?

Share this post


Link to post
18 minutes ago, huladaddy said:

Is there a safe way to move my data directory? I originally put it into an SMB share, which I thought would be useful, but now I am wanting to isolate my nextcloud data.

 

If there is not a safe way to do this, how can I reinstall nextcloud? Do I have to also reinstall mariadb? I would imagine letsencrypt should be unaffected by a reinstall?

Sorry for answering my own questions...

 

Using docker containers makes this trivial. I just moved everything to the new location and told the container where /data now lives.

 

But I do have a question. Are the directories called "appdata_xxxxxxxxxxxx" and "files_external" nextcloud directories? Also, there are files called .ocdata and index.html, both with size 0. Do those also belong to nextcloud? 

Share this post


Link to post

I'm still having slow logon issues getting into nextcloud.

I've just discovered if I use edge to logon, it logs straight in.  Everything is fast.

 

If I use firefox, it takes 10 minutes just to get to the login screen.

 

What's going on??

 

Share this post


Link to post
2 hours ago, Jessie said:

I'm still having slow logon issues getting into nextcloud.

I've just discovered if I use edge to logon, it logs straight in.  Everything is fast.

 

If I use firefox, it takes 10 minutes just to get to the login screen.

 

What's going on??

 

 

Take a look at the logs /mnt/user/appdata/nextcloud/log/nginx/error.log and /mnt/user/appdata/nextcloud/log/php/error.log

Share this post


Link to post

Whenever I install this image I get the following in the browser:

 

Quote

apps directory not found! Please put the Nextcloud apps folder in the Nextcloud folder or the folder above. You can also configure the location in the config.php file.

 

Did I do something wrong?

EDIT: After re-creating the container it seems to be working now. Not sure what happened though.

Edited by firrae

Share this post


Link to post

LinuxServer.IO I love your dockers.  Thanks so much for your work.

 

How was the /nextcloud URL base so elegantly taken out in the docker config?

 

I just reverted to installing NextCloud on Ubuntu Server because of the lack of LDAP support in this docker.

 

I am trying to achieve 2 things and I am hoping you all can help:

 

1) I have a permanent redirect on my nextcloud apache server to forward from / to /nextcloud  I accomplished this by adding the following line to my default-ssl.conf fil:

RedirectMatch ^/$ /nextcloud/

Now I can access my instance at cloud.mydomain.com which ultimately redirects to https://cloud.mydomain.com/nextcloud

 

When I was using your docker, I could authenticate in the app by simply entering "https://cloud.mydomain.com" but with my above config I must enter the url base in order to log into the app.  Not a big deal.... but I am more curious than anything how to configure it the way you did.

 

2) My current data folder is located at /var/www/nextcloud/data on the local filesystem of the VM.  I want to create a symlink in that directory and point to a share on my unraid... but I haven't the slightest idea the best way to accomplish that in Linux.

 

Any assistance with this would be much appreciated.

 

Current config.php, where 192.168.0.205 is the nextcloud ubuntu VM on hyperv and 192.168.0.31 is the mariadb docker on my unraid

 

<?php
$CONFIG = array (
  'instanceid' => 'xxxxxxxxxxxx',
  'passwordsalt' => 'xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx',
  'secret' => 'xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx',
  'trusted_domains' =>
  array (
    0 => '192.168.0.205',
    1 => 'cloud.mydomain.com',
  ),
  'datadirectory' => '/var/www/nextcloud/data',
  'overwrite.cli.url' => 'https://cloud.mydomain.com',
  'overwritehost' => 'cloud.mydomain.com',
  'overwriteprotocol' => 'https',
  'dbtype' => 'mysql',
  'version' => '12.0.0.29',
  'dbname' => 'nextcloud',
  'dbhost' => '192.168.0.31:3306',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'dbuser' => 'admin',
  'dbpassword' => 'xxxxxxxxxxxxxx',
  'installed' => true,
);

 

Also my nginx redirect is identical to yours in the tutorial.

Edited by napalmyourmom

Share this post


Link to post

This is a nextcloud setup question rather than a support issue for this container, but in answer to your question it's far more simple than you think and you're definitely overcomplicating things.  

 

Just take a look at the nginx file on line 30.

 

As regards the symlink, best bet is to mount the smb share locally on your Ubuntu machine and then use that as your data folder.  Look into modifying /etc/fstab/ I use this on my machine to mount my Unraid shares to a local directory.  For instance to mount my shares locally.  I don't use Ubuntu but I recall the need to have cifs-utils installed.

sudo apt-get install cifs-utils
sudo mkdir -p /unraid/{backups,cache,nextcloud,usr,virtualisation}
sudo nano /etc/fstab

Use this line in fstab to add the shares

//192.168.0.1/backups /unraid/backups cifs noperm,guest,uid=99,gid=100,dir_mode=0777,file_mode=0755,rw 0 0
//192.168.0.1/cache /unraid/cache cifs noperm,guest,uid=99,gid=100,dir_mode=0777,file_mode=0755,rw 0 0
//192.168.0.1/nextcloud /unraid/nextcloud cifs noperm,guest,uid=99,gid=100,dir_mode=0777,file_mode=0755,rw 0 0
//192.168.0.1/usr /unraid/usr cifs noperm,guest,uid=99,gid=100,dir_mode=0777,file_mode=0755,rw 0 0
//192.168.0.1/virtualisation /unraid/virtualisation cifs noperm,guest,uid=99,gid=100,dir_mode=0777,file_mode=0755,rw 0 0

then mount with

sudo mount -a

Took me frigging ages to work out the fstab stuff... :$

Edited by CHBMB

Share this post


Link to post

Trying to run the updater from the nextcloud web interface but it fails telling me.

Quote

The following extra files have been found:

  • .rnd

Anyone know what would cause this?

Share this post


Link to post
17 hours ago, cofree918 said:

Trying to run the updater from the nextcloud web interface but it fails telling me.

Anyone know what would cause this?

 

Searching on google reveals a few people have had similar issues with this error.  Tried updating via cmd line, link is in the first post.  FWIW I always update via terminal rather than the webui as I've found it a bit flaky in the past, although it has got better with successive versions.  Advantage of the terminal is you can pinpoint exactly where it goes wrong and also know exactly where there's a backup to restore if necessary,

Share this post


Link to post

I'm not sure if this is the correct place to ask this or not, but...

 

I updated the Nextcloud from the WebUI admin page, as I've done in the past to the latest stable release and am now stuck at the "the Nextcloud instance is currently in maintenance mode, which may take a while", and has been there for nearly 12 hours. Is it normal for it to do so for so long and if not what are the troubleshooting steps that I need to take at this time?

 

Thank you,

 

Lev

 

I changed the config.php to maintenance - false, and it seemed to immediately fix the issue. Strange.

Edited by levster
Fixed?

Share this post


Link to post

Just started playing with this container and it's nice. However I am running into issues authenticating it against a windows server 2016 ldap. Users never actually populate even tho all nextcloud's connection test/queries against the ldap are valid.

 

Has anyone noticed this or know of a fix?

 

aZXaySl.png

Share this post


Link to post

IIRC correctly there's some PHP error that precludes LDAP at the moment,

Share this post


Link to post

Thanks CHBMB.

 

I might hang tight then until that gets ironed out. LDAP authentication is something new for me to play with in the home anyways and not a deal breaker. Nextcloud seems like a good fit for my household/homelab.

 

PHP is not the path I have the capability to research. Here I was thinking it might have something to do with the lack of unix ldap attributes in server 2016 and specifically the uid attribute lol Glad I didn't spend any more time looking into that.

Edited by sirkuz

Share this post


Link to post

Hey,

im currently having an issue while downloading larger files.

I have configured my Nextcloud with LS lets encrypt docker, and when I'm downloading a large file or folder which then is put into a tar container the download is aborting at 1 GB.

Could that be a configuration error? At witch points could download size limits be configured? Via local network Downloads are not aborting! 

I suppose it's the reverse proxy.

#***.***********.de

server {
    listen 443 ssl http2;
    server_name ***.***********.de;

    root /config/www;
        index index.html index.htm index.php;

    ###SSL Certificates
    ssl_certificate /config/keys/letsencrypt/fullchain.pem;
        ssl_certificate_key /config/keys/letsencrypt/privkey.pem;

    ###Diffie–Hellman key exchange ###
    ssl_dhparam /config/nginx/dhparams.pem;

    ###SSL Ciphers
    ssl_ciphers 'ECDHE-RSA-AES128-GCM-SHA256:**********************';

        ###Extra Settings###
    ssl_prefer_server_ciphers on;
    ssl_session_cache shared:SSL:10m;

    ### Add HTTP Strict Transport Security ###
    #add_header Strict-Transport-Security "max-age=63072000; includeSubdomains";
    add_header Front-End-Https on;

    client_max_body_size 0;

        location / {
                proxy_pass https://192.168.1.5:443;
        }
}

 

Edited by Diggewuff

Share this post


Link to post
48 minutes ago, Diggewuff said:

Hey,

im currently having an issue while downloading larger files.

I have configured my Nextcloud with LS lets encrypt docker, and when I'm downloading a large file or folder which then is put into a tar container the download is aborting at 1 GB.

Could that be a configuration error? At witch points could download size limits be configured? Via local network Downloads are not aborting! 

I suppose it's the reverse proxy.


#***.***********.de

server {
    listen 443 ssl http2;
    server_name ***.***********.de;

    root /config/www;
        index index.html index.htm index.php;

    ###SSL Certificates
    ssl_certificate /config/keys/letsencrypt/fullchain.pem;
        ssl_certificate_key /config/keys/letsencrypt/privkey.pem;

    ###Diffie–Hellman key exchange ###
    ssl_dhparam /config/nginx/dhparams.pem;

    ###SSL Ciphers
    ssl_ciphers 'ECDHE-RSA-AES128-GCM-SHA256:**********************';

        ###Extra Settings###
    ssl_prefer_server_ciphers on;
    ssl_session_cache shared:SSL:10m;

    ### Add HTTP Strict Transport Security ###
    #add_header Strict-Transport-Security "max-age=63072000; includeSubdomains";
    add_header Front-End-Https on;

    client_max_body_size 0;

        location / {
                proxy_pass https://192.168.1.5:443;
        }
}

 

 

I found the solution!

 

see link or:

Quote

Yesterday I faced a strange issue, I realize that nginx was not serving files larger than 1GB. After investigation I found that it was due to the proxy_max_temp_file_size variable, that is configured by default to serve up to 1024 MB max.

This variable indicates the max size of a temporary file when the data served is bigger than the proxy buffer. If it is indeed bigger than the buffer, it will be served synchronously from the upstream server, avoiding the disk buffering.
If you configure proxy_max_temp_file_size to 0, then your temporary files will be disabled.

In this fix it was enough to locate this variable inside the location block, although you can use it inside server and httpd blocks. With this configuration you will optimize nginx for serving more than 1GB of data.


location / {
...
proxy_max_temp_file_size 1924m;
...
}

 

 

Share this post


Link to post

Hi

 

Can not log in to Nextcloud anymore.

 

Just getting this message:

Internal Server Error

The server encountered an internal error and was unable to complete your request.

Please contact the server administrator if this error reappears multiple times, please include the technical details below in your report.

More details can be found in the server log.

 

Technical details

Remote Address: 192.168.0.105

Request ID: /oW7TUnkRq5LLoXBgf8i

 

Any help would be appreciated! I have no idea what could be wrong. I have not changed anything. 

 

Latest error message in log seems to be:

 

2017/08/21 21:06:56 [error] 306#306: *17 FastCGI sent in stderr: "PHP message: PHP Fatal error:  Uncaught Doctrine\DBAL\DBALException: Failed to connect to the database: An exception occured in driver: SQLSTATE[HY000] [2002] Connection refused in /config/www/nextcloud/lib/private/DB/Connection.php:60
Stack trace:
#0 /config/www/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(429): OC\DB\Connection->connect()
#1 /config/www/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(389): Doctrine\DBAL\Connection->getDatabasePlatformVersion()
#2 /config/www/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(328): Doctrine\DBAL\Connection->detectDatabasePlatform()
#3 /config/www/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(621): Doctrine\DBAL\Connection->getDatabasePlatform()
#4 /config/www/nextcloud/lib/private/DB/Connection.php(147): Doctrine\DBAL\Connection->setTransactionIsolation(2)
#5 /config/www/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/DriverManager.php(172): OC\DB\Connection->__construct(Array, ...
PHP message: PHP Fatal error:  Uncaught Doctrine\DBAL\DBALException: Failed to connect to the database: An exception occured in driver: SQLSTATE[HY000] [2002] Connection refused in /config/www/nextcloud/lib/private/DB/Connection.php:60
Stack trace:
#0 /config/www/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(429): OC\DB\Connection->connect()
#1 /config/www/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(389): Doctrine\DBAL\Connection->getDatabasePlatformVersion()
#2 /config/www/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(328): Doctrine\DBAL\Connection->detectDatabasePlatform()
#3 /config/www/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(621): Doctrine\DBAL\Connection->getDatabasePlatform()
#4 /config/www/nextcloud/lib/private/DB/Connection.php(147): Doctrine\DBAL\Connection->setTransactionIsolation(2)
#5 /config/www/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBA

Edited by mrvilla

Share this post


Link to post

Looks like a database error, but other than that I got no idea. What version nextcloud were you running?

Sent from my LG-H815 using Tapatalk

Share this post


Link to post
45 minutes ago, mrvilla said:

Hi

 

Can not log in to Nextcloud anymore.

 

Just getting this message:

Internal Server Error

The server encountered an internal error and was unable to complete your request.

Please contact the server administrator if this error reappears multiple times, please include the technical details below in your report.

More details can be found in the server log.

 

Technical details

Remote Address: 192.168.0.105

Request ID: /oW7TUnkRq5LLoXBgf8i

 

 

Hello,

 

same problem for me. Last change on Sytem was update the letsencrypt container. Nextcloud Container is up to date (12.0.2.0)

Here is the log:

 

Quote

{"reqId":"E4nIAgnWNGsYNMWHQHDK","level":4,"time":"2017-08-21T20:47:44+00:00","remoteAddr":"172.17.0.1","user":"Florian","app":"remote","method":"GET","url":"\/status.php","message":"An exception occurred while executing 'DELETE FROM `oc_authtoken` WHERE `token` = ?' with params [\"f57be92a9c0c1127e1dbf27d4909e0483d63979c9b9aefe412305e3e55c54244447f947f3a7f5bde5fbe3f35cdef81fb7a3dcd7ff936aff3adce8c9de6142a85\"]:\n\nSQLSTATE[HY000]: General error: 1665 Cannot execute statement: impossible to write to binary log since BINLOG_FORMAT = STATEMENT and at least one table uses a storage engine limited to row-based logging. InnoDB is limited to row-logging when transaction isolation level is READ COMMITTED or READ UNCOMMITTED.","userAgent":"Mozilla\/5.0 (Windows) mirall\/2.3.2 (build 1) (Nextcloud)","version":"12.0.2.0"}
{"reqId":"SRhr0yOFzQbbQ4oJO3GC","level":3,"time":"2017-08-21T20:48:02+00:00","remoteAddr":"172.17.0.1","user":"Florian","app":"index","method":"GET","url":"\/index.php\/login","message":"Exception: {\"Exception\":\"Doctrine\\\\DBAL\\\\Exception\\\\DriverException\",\"Message\":\"An exception occurred while executing 'DELETE FROM `oc_authtoken` WHERE `token` = ?' with params [\\\"7cdfea70818533eb9106e05ebc00fd7d3ae93a8ff471beaae74a62f41b9ad54cfd9ec801f9c8d361d05924751c5ad9bfd5fa62bfe8e60af66dae0b49cc2f929b\\\"]:\\n\\nSQLSTATE[HY000]: General error: 1665 Cannot execute statement: impossible to write to binary log since BINLOG_FORMAT = STATEMENT and at least one table uses a storage engine limited to row-based logging. InnoDB is limited to row-logging when transaction isolation level is READ COMMITTED or READ UNCOMMITTED.\",\"Code\":0,\"Trace\":\"#0 \\\/config\\\/www\\\/nextcloud\\\/3rdparty\\\/doctrine\\\/dbal\\\/lib\\\/Doctrine\\\/DBAL\\\/DBALException.php(128): Doctrine\\\\DBAL\\\\Driver\\\\AbstractMySQLDriver->convertException('An exception oc...', Object(Doctrine\\\\DBAL\\\\Driver\\\\PDOException))\\n#1 \\\/config\\\/www\\\/nextcloud\\\/3rdparty\\\/doctrine\\\/dbal\\\/lib\\\/Doctrine\\\/DBAL\\\/Connection.php(1015): Doctrine\\\\DBAL\\\\DBALException::driverExceptionDuringQuery(Object(Doctrine\\\\DBAL\\\\Driver\\\\PDOMySql\\\\Driver), Object(Doctrine\\\\DBAL\\\\Driver\\\\PDOException), 'DELETE FROM `oc...', Array)\\n#2 \\\/config\\\/www\\\/nextcloud\\\/lib\\\/private\\\/DB\\\/Connection.php(213): Doctrine\\\\DBAL\\\\Connection->executeUpdate('DELETE FROM `oc...', Array, Array)\\n#3 \\\/config\\\/www\\\/nextcloud\\\/3rdparty\\\/doctrine\\\/dbal\\\/lib\\\/Doctrine\\\/DBAL\\\/Query\\\/QueryBuilder.php(208): OC\\\\DB\\\\Connection->executeUpdate('DELETE FROM `oc...', Array, Array)\\n#4 \\\/config\\\/www\\\/nextcloud\\\/lib\\\/private\\\/DB\\\/QueryBuilder\\\/QueryBuilder.php(213): Doctrine\\\\DBAL\\\\Query\\\\QueryBuilder->execute()\\n#5 \\\/config\\\/www\\\/nextcloud\\\/lib\\\/private\\\/Authentication\\\/Token\\\/DefaultTokenMapper.php(48): OC\\\\DB\\\\QueryBuilder\\\\QueryBuilder->execute()\\n#6 \\\/config\\\/www\\\/nextcloud\\\/lib\\\/private\\\/Authentication\\\/Token\\\/DefaultTokenProvider.php(238): OC\\\\Authentication\\\\Token\\\\DefaultTokenMapper->invalidate('7cdfea70818533e...')\\n#7 \\\/config\\\/www\\\/nextcloud\\\/lib\\\/private\\\/User\\\/Session.php(822): OC\\\\Authentication\\\\Token\\\\DefaultTokenProvider->invalidateToken(*** sensitive parameters replaced ***)\\n#8 \\\/config\\\/www\\\/nextcloud\\\/lib\\\/private\\\/User\\\/Session.php(250): OC\\\\User\\\\Session->logout()\\n#9 \\\/config\\\/www\\\/nextcloud\\\/lib\\\/private\\\/User\\\/Session.php(223): OC\\\\User\\\\Session->validateSession()\\n#10 \\\/config\\\/www\\\/nextcloud\\\/lib\\\/private\\\/legacy\\\/app.php(319): OC\\\\User\\\\Session->getUser()\\n#11 \\\/config\\\/www\\\/nextcloud\\\/lib\\\/private\\\/legacy\\\/app.php(110): OC_App::getEnabledApps()\\n#12 \\\/config\\\/www\\\/nextcloud\\\/lib\\\/private\\\/legacy\\\/user.php(128): OC_App::loadApps(Array)\\n#13 \\\/config\\\/www\\\/nextcloud\\\/lib\\\/base.php(743): OC_User::setupBackends()\\n#14 \\\/config\\\/www\\\/nextcloud\\\/lib\\\/base.php(1086): OC::init()\\n#15 \\\/config\\\/www\\\/nextcloud\\\/index.php(46): require_once('\\\/config\\\/www\\\/nex...')\\n#16 {main}\",\"File\":\"\\\/config\\\/www\\\/nextcloud\\\/3rdparty\\\/doctrine\\\/dbal\\\/lib\\\/Doctrine\\\/DBAL\\\/Driver\\\/AbstractMySQLDriver.php\",\"Line\":116}","userAgent":"Mozilla\/5.0 (Windows NT 10.0; WOW64; rv:55.0) Gecko\/20100101 Firefox\/55.0","version":"12.0.2.0"}
{"reqId":"bRxTqInRQlf8CDDAQO8F","level":3,"time":"2017-08-21T20:48:03+00:00","remoteAddr":"172.17.0.1","user":"Florian","app":"index","method":"GET","url":"\/index.php\/js\/core\/merged-template-prepend.js?v=79c1107e6d1e292a320b71b45bbabbd2-0","message":"Exception: {\"Exception\":\"Doctrine\\\\DBAL\\\\Exception\\\\DriverException\",\"Message\":\"An exception occurred while executing 'DELETE FROM `oc_authtoken` WHERE `token` = ?' with params [\\\"7cdfea70818533eb9106e05ebc00fd7d3ae93a8ff471beaae74a62f41b9ad54cfd9ec801f9c8d361d05924751c5ad9bfd5fa62bfe8e60af66dae0b49cc2f929b\\\"]:\\n\\nSQLSTATE[HY000]: General error: 1665 Cannot execute statement: impossible to write to binary log since BINLOG_FORMAT = STATEMENT and at least one table uses a storage engine limited to row-based logging. InnoDB is limited to row-logging when transaction isolation level is READ COMMITTED or READ UNCOMMITTED.\",\"Code\":0,\"Trace\":\"#0 \\\/config\\\/www\\\/nextcloud\\\/3rdparty\\\/doctrine\\\/dbal\\\/lib\\\/Doctrine\\\/DBAL\\\/DBALException.php(128): Doctrine\\\\DBAL\\\\Driver\\\\AbstractMySQLDriver->convertException('An exception oc...', Object(Doctrine\\\\DBAL\\\\Driver\\\\PDOException))\\n#1 \\\/config\\\/www\\\/nextcloud\\\/3rdparty\\\/doctrine\\\/dbal\\\/lib\\\/Doctrine\\\/DBAL\\\/Connection.php(1015): Doctrine\\\\DBAL\\\\DBALException::driverExceptionDuringQuery(Object(Doctrine\\\\DBAL\\\\Driver\\\\PDOMySql\\\\Driver), Object(Doctrine\\\\DBAL\\\\Driver\\\\PDOException), 'DELETE FROM `oc...', Array)\\n#2 \\\/config\\\/www\\\/nextcloud\\\/lib\\\/private\\\/DB\\\/Connection.php(213): Doctrine\\\\DBAL\\\\Connection->executeUpdate('DELETE FROM `oc...', Array, Array)\\n#3 \\\/config\\\/www\\\/nextcloud\\\/3rdparty\\\/doctrine\\\/dbal\\\/lib\\\/Doctrine\\\/DBAL\\\/Query\\\/QueryBuilder.php(208): OC\\\\DB\\\\Connection->executeUpdate('DELETE FROM `oc...', Array, Array)\\n#4 \\\/config\\\/www\\\/nextcloud\\\/lib\\\/private\\\/DB\\\/QueryBuilder\\\/QueryBuilder.php(213): Doctrine\\\\DBAL\\\\Query\\\\QueryBuilder->execute()\\n#5 \\\/config\\\/www\\\/nextcloud\\\/lib\\\/private\\\/Authentication\\\/Token\\\/DefaultTokenMapper.php(48): OC\\\\DB\\\\QueryBuilder\\\\QueryBuilder->execute()\\n#6 \\\/config\\\/www\\\/nextcloud\\\/lib\\\/private\\\/Authentication\\\/Token\\\/DefaultTokenProvider.php(238): OC\\\\Authentication\\\\Token\\\\DefaultTokenMapper->invalidate('7cdfea70818533e...')\\n#7 \\\/config\\\/www\\\/nextcloud\\\/lib\\\/private\\\/User\\\/Session.php(822): OC\\\\Authentication\\\\Token\\\\DefaultTokenProvider->invalidateToken(*** sensitive parameters replaced ***)\\n#8 \\\/config\\\/www\\\/nextcloud\\\/lib\\\/private\\\/User\\\/Session.php(250): OC\\\\User\\\\Session->logout()\\n#9 \\\/config\\\/www\\\/nextcloud\\\/lib\\\/private\\\/User\\\/Session.php(223): OC\\\\User\\\\Session->validateSession()\\n#10 \\\/config\\\/www\\\/nextcloud\\\/lib\\\/private\\\/legacy\\\/app.php(319): OC\\\\User\\\\Session->getUser()\\n#11 \\\/config\\\/www\\\/nextcloud\\\/lib\\\/private\\\/legacy\\\/app.php(110): OC_App::getEnabledApps()\\n#12 \\\/config\\\/www\\\/nextcloud\\\/lib\\\/private\\\/legacy\\\/user.php(128): OC_App::loadApps(Array)\\n#13 \\\/config\\\/www\\\/nextcloud\\\/lib\\\/base.php(743): OC_User::setupBackends()\\n#14 \\\/config\\\/www\\\/nextcloud\\\/lib\\\/base.php(1086): OC::init()\\n#15 \\\/config\\\/www\\\/nextcloud\\\/index.php(46): require_once('\\\/config\\\/www\\\/nex...')\\n#16 {main}\",\"File\":\"\\\/config\\\/www\\\/nextcloud\\\/3rdparty\\\/doctrine\\\/dbal\\\/lib\\\/Doctrine\\\/DBAL\\\/Driver\\\/AbstractMySQLDriver.php\",\"Line\":116}","userAgent":"Mozilla\/5.0 (Windows NT 10.0; WOW64; rv:55.0) Gecko\/20100101 Firefox\/55.0","version":"12.0.2.0"}

 

 

 

Edited by Gorosch
correction

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.