Jump to content
linuxserver.io

[Support] Linuxserver.io - Nextcloud

2779 posts in this topic Last Reply

Recommended Posts

exactly, I placed a password that's very familiar to me, and it didn't work when I execute mysql -uroot -p.  I then tried to change the password on the mariadb docker container, then restarted mariadb docker container, and used the new password with mysql -uroot -p, still, it doesn't work.  

 

Will there be a problem if I delete the mariadb docker container totally, and recreated it, and assign a new password instead?  

Share this post


Link to post
22 minutes ago, jang430 said:

exactly, I placed a password that's very familiar to me, and it didn't work when I execute mysql -uroot -p.  I then tried to change the password on the mariadb docker container, then restarted mariadb docker container, and used the new password with mysql -uroot -p, still, it doesn't work.  

 

Will there be a problem if I delete the mariadb docker container totally, and recreated it, and assign a new password instead?  

 

I think deleting and setting up from scratch is best. I think you can only set the password at first boot of the container if I remember correctly. Be sure to use /mnt/cache for the appdata. 

Share this post


Link to post

I newly created a mariadb container, leaving the default root password at 0.  Tried to execute mysql -uroot -p, and entering the password 0 gives me ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)

 

image.png.fa93822e52166d01501ca2dea2180200.png

Edited by jang430

Share this post


Link to post
1 hour ago, jang430 said:

I newly created a mariadb container, leaving the default root password at 0.  Tried to execute mysql -uroot -p, and entering the password 0 gives me ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)

 

image.png.fa93822e52166d01501ca2dea2180200.png

 

Post the docker run command as I requested earlier. 

Share this post


Link to post
2 hours ago, jang430 said:

I newly created a mariadb container, leaving the default root password at 0.  Tried to execute mysql -uroot -p, and entering the password 0 gives me ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)

 

image.png.fa93822e52166d01501ca2dea2180200.png

 

if the password is less than 4 characters it defaults to no password as per the docker logs on 1st startup

 

use

mysql -uroot

 

i strongly suggest setting a password 

you can't do it by changing the variable in an existing container use the mysqladmin tool as per the readme and the logs

 

https://github.com/linuxserver/docker-mariadb#setting-up-the-application

 

i also suggest you read the logs and the readme for any container as a matter of course and save yourself a lot of needless troubles

 

 

Share this post


Link to post

@sparklyballs, thanks for pointing me to the log file, and pointing out that any password less than 4 characters is considered none.  

 

@saarg, thanks for the patience.  So to change the password, mysqladmin is the way to go.  Furthermore, after changing the password, mariadb docker container has to be restarted once again.  I overlooked this.

 

Thanks to you!  Will setup the next few steps ?

 

Share this post


Link to post

Good evening

 

Can I suggest you update https://blog.linuxserver.io/2017/05/10/installing-nextcloud-on-unraid-with-letsencrypt-reverse-proxy/ to add the mariaDB binlog_format=mixed setting in the custom.cnf change and switch to using /letsencrypt/nginx/proxy-confs/nextcloud.subdomain.conf instead of copying the whole domain definition?

 

There is one thing that I'm not sure I understand about the config.  In nextcloud.subdomain.conf, I need to leave

set $upstream_nextcloud nextcloud;
proxy_pass https://$upstream_nextcloud:443;

even though my container is configured on port 44333 (443 is letsencrypt)

 

image.png.bd5c1e3a71002132afdbc0c6f355f3e2.png

 

Is it the result of using the "private" docker network, reproxy0?  It's resolving nextcloud:443 as 172.19.0.7:443, connecting through reproxy0?  What is different about the network I defined versus the other docker network that are already defined?  That would not work using the bridge network?

 

Share this post


Link to post

Ok looking for a little bit of help. I started trying to get this all working again using the directions. I started from scratch with it all and got nextcloud and the db up and running without a problem. I had my letsencrypt up and running before hand as i was using it for other containers like ombi etc. I then put in the suggested file with my updated server info and now im getting the following error in the logs

 

Requested domain is not a FQDN because it contains an empty label.
ERROR: Cert does not exist! Please see the validation error above. The issue may be due to incorrect dns or port forwarding settings. Please fix your settings and recreate the container

 

I can send my config files if required.

Share this post


Link to post
54 minutes ago, tazire said:

Ok looking for a little bit of help. I started trying to get this all working again using the directions. I started from scratch with it all and got nextcloud and the db up and running without a problem. I had my letsencrypt up and running before hand as i was using it for other containers like ombi etc. I then put in the suggested file with my updated server info and now im getting the following error in the logs

 

Requested domain is not a FQDN because it contains an empty label.
ERROR: Cert does not exist! Please see the validation error above. The issue may be due to incorrect dns or port forwarding settings. Please fix your settings and recreate the container

 

I can send my config files if required.

 

Share your nextcloud custom.cnf and the letsencrypt file

Share this post


Link to post
3 minutes ago, tazire said:

 

Is that the correct nextcloud file? 

config.php

nextcloud.txt

 

Yes!  config.php is the nextcloud file, custom.cnf is mariaDB, my bad.

 

Assuming you replaced nextcloud.server.com in all the files by nextcloud.yourRealDomain.com and that port 4433 is forwarded to 443 in your nextcloud container, it looks good.

192.168.0.1 is your unraid's IP?

nextcloud.txt should just be nextcloud though, no extension

Share this post


Link to post

ah... funny how you just don't see whats right in front of your face... duh.... no my unraids ip isn't that! thanks. 

 

I sorted out the extension also.

 

but im still getting the same error as above!

 

EDIT

 

Just one other thing that might be the issue. I have one domain with sub-folders for all my other dockers ie. sample.duckdns.org/ombi

 

Where as i have nextcloud.duckdns.org as my nextcloud domain. Could this be the cause of this issue? I tried nextcloud.sample.duckdns.org before and just couldnt get it working. so i updated the letsencrypt perams as shown

pic.png

Edited by tazire

Share this post


Link to post

 

I own my domain so not a pro with duckdns but I think the "Domain name" should be "tazire.duckdns.org" and "Subdomain(s)" should be "www,nextcloud"

Share this post


Link to post
1 minute ago, Gog said:

 

I own my domain so not a pro with duckdns but I think the "Domain name" should be "tazire.duckdns.org" and "Subdomain(s)" should be "www,nextcloud"

 

Yea it seems not matter which way i try im getting that error atm.

Share this post


Link to post

to access nextcloud, are you trying to use mynextcloud.duckdns.org or nextcloud.tazire.duckdns.org ?

 

nextcloud.tazire.duckdns.org would be a subdomain.

mynextcloud.duckdns.org would be a different domain and I think you need a separate letsencrypt instance for that.

Edited by Gog

Share this post


Link to post

i tried it both ways. ideally i wanted mynextcloud.duckdns.org but i also want to use tazire.duckdns.org/container for my other dockers

Share this post


Link to post
6 minutes ago, tazire said:

i tried it both ways. ideally i wanted mynextcloud.duckdns.org but i also want to use tazire.duckdns.org/container for my other dockers

 

Pick one :)

I suggest nextcloud.tazire.duckdns.org because I don't know how to setup two letsencrypt on the same unraid :P

you'll need to doublecheck config.php and nextcloud to make sure the domain is correct everwhere.

I think the error ERROR: Cert does not exist! Please see the validation error above. The issue may be due to incorrect dns or port forwarding settings. Please fix your settings and recreate the container

is because you are using a domain letsencrypt is not able to generate a key for but with the subdomain settings in letsncrypt, that should go away.

Share this post


Link to post
22 minutes ago, Gog said:

 

Pick one :)

I suggest nextcloud.tazire.duckdns.org because I don't know how to setup two letsencrypt on the same unraid :P

you'll need to doublecheck config.php and nextcloud to make sure the domain is correct everwhere.

I think the error ERROR: Cert does not exist! Please see the validation error above. The issue may be due to incorrect dns or port forwarding settings. Please fix your settings and recreate the container

is because you are using a domain letsencrypt is not able to generate a key for but with the subdomain settings in letsncrypt, that should go away.

 

Ok well i guess the issue has to be in the nextcloud file because it was running fine without it. So ill just go back and start from scratch with that..

 

EDIT

 

Just went back to all the settings that up until i started trying to get nextcloud to work had worked just fine.... broken... same issue as mentioned above. No idea whats going on now

 

2nd EDIT..

 

Completely baffled now. I just did a fresh install of letsencrypt with no new config files what so ever and i am getting the above error. no idea whats going on atm... 

Edited by tazire

Share this post


Link to post

i have an issue where some of the jpegs uploaded to nextcloud from my mobile device are not viewable, tells me file format is not supported yet the file size looks correct.

 

Did anyone experience this?

Share this post


Link to post

Not sure if this is question for the nextcloud docker or nginx, but here goes.  (On a side note, a "search this thread" function on this website would help tremendously.)

 

I am getting "error 413" on some larger file uploads from an ipad.  After research, I think its due to the "client_max_body_size" which I edited in "nginx/site-confs/nextcloud" to 16384m (and I also tried 0 to disable checking) and I still get the error.  There's nothing related in the nginx or nextcloud logs.  I also tried changing "proxy_max_temp_file_size" in the same file to 16384m to no avail.

 

Any ideas?

 

Share this post


Link to post

Hi I have put together a video guide for setting up nextcloud that maybe helpful for some users.

Following this video there will be one (in a few days)  on setting up the linuxserver letsencrypt container for use as a reverse proxy.

Hope its useful...

Share this post


Link to post
6 hours ago, gridrunner said:

Hi I have put together a video guide for setting up nextcloud that maybe helpful for some users.

Following this video there will be one (in a few days)  on setting up the linuxserver letsencrypt container for use as a reverse proxy.

Hope its useful...

 

Great! Now we can just send them your way if they can't set it up following your guide ?

Share this post


Link to post

Been using for a while now and was wondering if there is anyway of setting up Lets Encrypt on this docker?

Share this post


Link to post
35 minutes ago, mattmill said:

Been using for a while now and was wondering if there is anyway of setting up Lets Encrypt on this docker?

Easier to follow the tutorial and reverse proxy it through the LSIO LE docker. Everything is laid out for you, and since you keep the pieces in separate containers it's easier to troubleshoot.

Share this post


Link to post
21 hours ago, saarg said:

 

Great! Now we can just send them your way if they can't set it up following your guide ?

lol thats fine. Just tell them to pm me on my other contact address here, this one,  " @saarg " ...I will respond straight away to any messages !!!  ?

Edited by gridrunner

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.